1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Zyxel P660r-d1 (half bridge) + Wrt54gl tomato

Discussion in 'Tomato Firmware' started by Cronogr, May 6, 2012.

  1. Cronogr

    Cronogr Serious Server Member

    Hi, the past days i'm trying to configure my zyxel p660 into half bridge mode and use my tomato linksys as a router to pass internet through the house, my connection type is pppoa so that's why i'm using half bridge mode.
    Anyway i'm able to put the zyxel into half bridge and get the public ip, when i connect it on my pc, everything is fine internet is fine.
    When i connect the zyxel on the linksys i get the public ip, dns, gateway, etc to show inside tomato but none of the connected devices can access the internet
    Sorry but my knowledge is limited i dont know what i'm doing wrong please someone can guide me through ?

    The configuration as is:
    Nat off
    the commands i run onto zyxel are as this
    wan node index 1
    wan node nat none
    wan node save
    poe bridge switch on
    ip dhcp enif0 server lease 120

    Basically i changed only the ip to
    Dhcp is on for wan

    Thanks in advance !
  2. mstombs

    mstombs Network Guru Member

    Exactly what Tomato version? There used to be an issue with half-bridge with unusual/ spoofed IP settings - specifically when the Gateway IP was not in the network defined by the IP address and netmask. Tomatousb fixed this a while ago, before that I had a firewall script which patched the Tomato routing.
  3. Cronogr

    Cronogr Serious Server Member

    i'm using the 1.28 i can upload images etc if it will be of any help ! Anyway i'm confused as of what to do
  4. mstombs

    mstombs Network Guru Member

  5. Cronogr

    Cronogr Serious Server Member

    Thank you very much i flashed with tomatousb problem solved, the only problem i encounter now is really slow p2p but i hope i will find a solution. Thanks again

Share This Page