¿New firmware for WAG54G V2?

Discussion in 'Other Linksys Equipment' started by djbill, Jun 27, 2005.

  1. djbill

    djbill Network Guru Member

    Hi, i'm finding new firmware than "WAG54GV2-EU_AnnexA_ETSI_1_00_19.zip"; anyone know other firmware for V2-EU version.(Official or unofficial)

  2. hijglander

    hijglander Network Guru Member

    just check the download section on this site....
  3. Tveer

    Tveer Network Guru Member

    I was also looking for new firmware. That's why I downloaded
    Version: v1.00.47
    Compatibility: WAG54G v2
    Filesize: 3.46 MB
    Added on: May-29-2005
    from this site and upgraded (wired) using the tffp (?) program. Because the tffp-progr. gave a green light-icon and said the upgrade was succesful, i was happy. But right after that the wag54g v2 doesn't work anymore. The computer can't connect to it. Above all that I tried to reset it but the power light keeps blinking green. That's all the wag54g does, nothing more. I can't reset it, can't approach it or get into it so i'm not able to change any settings of whatever.
    I'm afraid I used the wrong firmware and that because of this, the wag54g v2 is broken now.
    What to do? Can i fix this myself? How to get to the setup again?
  4. HiSpeed

    HiSpeed Network Guru Member

  5. Tveer

    Tveer Network Guru Member

    Thanx but it doesn't help me out. First trying to ping, gives an error message about "time out" and that 4 packages were send, 0 received meaning 100% error (sorry, i have to translate this from Dutch to English).

    Next when trying to use the tftp.exe gives me 3 times an error saying that the server does not repsond. I can't get any connection to my wireless network.
    I've tried to do it wired but same problem.

    I think i've secured the gateway too good. I made it accept only one MAC-address and that is the MAC=address of my wireless network card (i hope you know what i mean).So trying to access it with my LAN-card (i mean "wired") fails because my LAN-card has an different MAC=address. This worked fine but now it seems to be stuck in between the default settings and the previous (working) setting. And I can't get in between!!

    The green power light is still blinking............but that's all. Any more advice?
  6. DavidC

    DavidC Network Guru Member


    I think the TFFP utility you used has a 3MB file size limit - the WAGV2 is over this so you may have only sent a portion of the firmware. It is best to stick with the router interface upgrade utility only over a wired link!

    I would ask Linksys if there is a means of resetting the WAG and loading a clean firmware. If they can provide a load utility then you may get it done.

    The firmware you have tried to load is an unofficialy released beta and as such not supported by Linksys. If you were not provided with this directly by Linksys they could say it is your fault and expect you to pay for repairing the WAG.

    I it was my WAG from what you describe I would expect it to be stuffed.

    All else fails try to hunt down Wickus (he posts on this site) and see if the openWRT port development people know how to reset the router - I would expect they sometimes get into your type of problem if the port firmware is not 100%.
  7. Tveer

    Tveer Network Guru Member

    Thanx David for your time. I hunted down Wickus and told him about the problem with my wag. I also asked Linksys Holland (yes, it exists!!) if there'is another way of restoring the default factory settings other than by resetting the device.

    I'n not very positive about the solution. I think the only thing to do would be to buy properly working hardware (it all started out of frustration about constant disconnects, especially when downloading large files).

    But i better wait a while. Maybe someone knows how to deal with this problem.

  8. u9689

    u9689 Guest

  9. Tveer

    Tveer Network Guru Member

    nice site .............but useless to me right now because i cannot get a connection with the wag54g. And if i'm wright this site doesn't help me out on that...

    anyone a better idea?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice