1.23 VOIP Problems

Discussion in 'Tomato Firmware' started by gregg098, Dec 19, 2008.

  1. gregg098

    gregg098 LI Guru Member

    I previously had 1.20 Victek mod installed and everything was working great. I just reflashed to 1.23 w/ VPN GUI mod. I dont need all the extra feature so I just went with the VPN version. Anyways, I kept all of my settings the exact same, but now, my SPA 2102 VOIP device fails to register following router reboots. I have followed the advice of the post here, but still get the same results. That post is also what I used to fix my problems with 1.20 and earlier. Is there something new in 1.23 that is preventing my VOIP device from reconnecting after a router reboot?

    EDIT: I forgot to mention that the VOIP device registers fine on a power cycle and I did in fact clear the NVRAM after flashing.
  2. schweinc

    schweinc Network Guru Member

    Same Thing With Viatalk

    Acutally the same happened with 1.22. Viatalk was upgrading their serveres and after 3 weeks of no VoIP the manufacturer of my ATA, Zoom, advised using the IP address vice the named server and it worked. So insted of xxxxx.vtnoc.net I use the IP address according to Tomato's trace. Hope you get it solved. Pig
  3. gregg098

    gregg098 LI Guru Member

    I actually already do use the IP address for the server (Vitelity). I just reverted to 1.22 with the same results. Maybe Ill just go back to 1.20 since I know it works.
    Ive been going over all my settings except for the fact that its 1.23 VPN vs 1.20 Vicktek (and Id used just plain old Tomato prior to that with no problems) nothing is different.
  4. gregg098

    gregg098 LI Guru Member

    So I went back to Victek 1.20 and inputting my settings from scratch again and everything works great. Anyone know what could have changed from 1.20 to 1.23 (and 1.22 for that matter) that would cause this issue?
  5. esaym

    esaym LI Guru Member

    I run my own asterisk server. Every issue that I have had with registration problems were because of firewall issues. Make sure you are not dropping packets on the wan and that all the proper ports are forwarded. Usually I only have to forward SIP and not RTP.
  6. gregg098

    gregg098 LI Guru Member

    I forwarded 5060-5061 and 16384-16482 for my adapter. This has worked for the past few years. I have narrowed it down to somthing in Tomato, I just dont know what.
  7. Sarvatt

    Sarvatt Guest

    I believe they fixed a problem with iptables NAT loopback around that time, try changing your NAT Loopback setting in 1.23 to something else. It really should be on forwarded only, but you might have it set to enabled or disabled. If it's on forwarded only, try enabled even though thats not an optimal setting. Manually forwarding the ports might interfere with upnp if it uses that, just something else to watch out for because I've screwed things up manually forwarding ports then the device still requesting a forward via upnp and I assume it was causing a loop somewhere and not working right. If anything, you might need to reset your NVRAM also, I wouldnt be surprised if there was some interference between those two modded tomato releases.
  8. gregg098

    gregg098 LI Guru Member

    Ill give it a shot tonight or tomorrow. Also, I did reset the NVRAM and I always leave upnp disabled. On my 1.20 working version, NAT loopback is set to forwarded only. I have no idea what it was at on 1.23, so hopefully that is the problem.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice