1 week with Tomato and already bricked my router...

Discussion in 'Tomato Firmware' started by mobrien118, Apr 29, 2009.

  1. mobrien118

    mobrien118 Addicted to LI Member

    Hi all,

    I'm new to this forum, have been using DD-WRT for years now and wanted to try Tomato as a client bridge that I use in my network.

    Had it working just fine, and really liked it, in fact, but I just couldn't leave well enough alone. With DD-WRT I have needed to overclock my main router because I have so many QoS rules and other config settings, so I wanted to make sure that Tomato could do the same thing.

    I tried to set the clkfreq NVRAM setting a few times (to 240 and 233) and whenever I rebooted the router, it came back with the frequency returned to 216 again. (I realize the 233 setting is invalid for my WRT54g v.3 - BCM3302 V0.7, but it didn't take anyway, so OK)

    What finally killed it was that I set it to 228 using this method, which should be a perfectly valid setting for my CPU, and now I am getting the green flashing power light of death. Tried to TFTP it, but am not getting a ping, but I haven't exhausted this possibility yet, since I didn't set the computer to a static IP.

    Anyone have any ideas?

    I previously had this router running at 240MHz using DD-WRT for the past few years with no problems, so I don't think 228 would have overloaded the processor. I'd like to assume that this is too big of a coincidence for the chip or other hardware to go bad at the exact time I am trying to do this.

    Anyone have any suggestions/comments that might help me out of this mess? I already ordered a new router since I need this working ASAP and NewEgg has GLs for $60 shipped, but I wouldn't mind resurrecting this guy, either.


  2. The Doctor

    The Doctor LI Guru Member

    1- Try the long reset.

    2- Get a JTAG cable, and follow the directions at the DD-WRT to use it.

    3- Don't buy the GL model, for $60-$65 including shipping, you can get the WRT54G-TM on eBay. It has 8 MB of flash, and 32 MB of RAM, which means you can run just about any firmware on it. I have had several through my hands recently, every one of them has overclocked to 250 MHz without a problem, YMMV.

    Be sure to buy a new one, listed as being in the sealed box. Buy only from a seller with an excellent rating. Do not buy any that are tested/working. And do not buy any open boxes on eBay, one joker was try to sell a new one for over $50 "may be missing parts". The picture clearly showed everything there, but if you read his packing list, there was only one minor piece missing. That minor piece was the router :eek:


    Oh, yeah, almost forgot to mention. It is very doubtful the tomato was the cause of your problem, probably just a glitch. With any luck, the router can be restored to operation by one of the first two things I listed. I have never used a JTAG cable myself, although I do have one just in case, so I can't help you on that one.
  3. mobrien118

    mobrien118 Addicted to LI Member

    Thanks, Ed, for your quick and helpful response. I want to avoid making/buying a JTAG for the time being just because I don't really have the time or patience, currently, to solder the board. Same reason for not wanting the TM, because from what i understand, you need JTAG to do the initial flash.

    I did try the long reset (holding down the reset button for a really long time during a reboot, or just while on, right?), but the power light starts blinking as soon as DC is applied and doesn't change.

    What I'm most interested in finding out from this thread is what I did to cause the failure in the first pace. (Although suggestions on how to bring my current one back to life are both welcome and appreciated!)

    Thanks again for the suggestions,

  4. mstombs

    mstombs Network Guru Member

    You are not the first to brick playing with clock speed, you now need to clear the NVRAM. Personally I prefer the JTAG method, others recommend flash chip pin shorting - but that sounds dangerous.

    No WRT54G-TM can now be flashed with dd-wrt without JTAG


    but I got mine before that so also have a heatsink fitted...
  5. landa

    landa LI Guru Member

    Boot router into failsafe mode. What you need to do here is to change the IP of a working machine to (because in failsafe, the router will default to and make sure that it is on the same network as the router.
  6. mobrien118

    mobrien118 Addicted to LI Member

    LOL. I tried that (jump pins 15-16 with a multimeter probe) but there is no change in the status of the router.
    Dang! I wish I knew that before I bought the GL, but I did order it before this post. from now on I will get TMs if I need another one. Thanks for the info!

    How do you do that? does anyone have a link to failsafe instructions?

    Thanks for all the excellent feedback and suggestions. I am new to this forum but you all have made me feel very welcome already!

  7. az2008

    az2008 Addicted to LI Member

    I haven't had to unbrick my wrt54gl yet. But, I spent some time googling for how to do it, making notes, just in case.

    One of the things I found is http://millerstechtips.blogspot.com/2008/03/how-to-un-brick-wrt54gl-with-openwrt.html

    Also: http://www.linksysinfo.org/forums/showthread.php?t=52914

    I couldn't find a coherent how-to. Just bits and pieces.

    The basic gist of it seemed to be that you need to connect to the router without using DHCP (a hardcoded IP address), use tftp to upload the firmware image, and that you have a very short amount of time to do this as the router boots. The suggestions were to run a continuous ping in one DOS window, and be prepared in another DOS window to press enter on the tftp command as soon as the ping starts to acknowledge.

    There was also something here: http://blog.rim3y.net/zero/?p=942 (it refers to with and without vxworks. This seems to have something to do with newer Linksys routers. The GL doesn't have vxworks.).

    In all cases, the firmware you tftp to the router can be anything. You could use DD-WRT's mini firmware. Or, Linksys's factory default. Or, load Tomato again.

    I don't know if there are other things to deal with. For example, there's something about DD-WRT's password messing things up for Tomato.

  8. gawd0wns

    gawd0wns Network Guru Member

    To set your local ip address to, if you are using windows, go to control panel --> network connections --> select your local area network connection --> enter the TCP/IP properties --> Change the option "Obtain an IP address automatically" to "Use the following IP address" --> Enter the ip address, and as your router address, and the subne netmask as

    Hit ok... Now try re-flashing with tftp
    Edit: Remember to clear NVRAM and do a full hard reset (60-60-60) after you get the firmware loaded.
  9. phuque99

    phuque99 LI Guru Member

    Tomato requires 60s for reset?
  10. gawd0wns

    gawd0wns Network Guru Member

    I can't recall if a hard reset is 30-30-30 or 60-60-60. To be on the safe side, do 60-60-60.
  11. landa

    landa LI Guru Member

    To enter in filesafe you have to press SES button right after turning on the router. You will see the DMZ led blinking... Now is in filesafe. Next step is to telnet the router and erase the nvram.
  12. GreenThumb

    GreenThumb Addicted to LI Member

    Correct this thread's title to:

    "One Week with With Tomato and I have Bricked My Router By Trying to Overclock it Without Knowing What I was Doing."
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice