12/03/2005 V23 Build

Discussion in 'DD-WRT Firmware' started by dellsweig, Dec 2, 2005.

  1. dellsweig

    dellsweig Network Guru Member


    - new wireless client/ap/wds table for info and wireless status

    0000309 BrainSlayer is currently sick, so bug fixing is a little bit delayed
    0000318 Can't setup static ISP settings on dd-wrt v23b 24.11
    0000048 Blocked Services on Access Restrictions Not Working
    0000308 /usr/sbin/rflow missing from v23b2 2005/11/24 vpn build
    0000306 No access to configure SNMP agent in GUI
    0000288 Static IP Internet Connection Type Cannot Save Settings
    0000281 DHCP-Relay: dhcp-fwd not starting => error
    0000279 Formatting in status:wireless
    0000297 wrong netmask in /tmp/dnsmasq.conf
  2. Tomchu

    Tomchu Network Guru Member

    Can someone outline the "official" steps for upgrading DD-WRT? Currently I have v23b2 11/24/05 mini generic installed on my V4s. Do I do a complete NVRAM cleaning, then upgrade through the web interface, or is the NVRAM cleaning not necessary when going from DD-WRT mini generic --> DD-WRT mini generic?
  3. BrainSlayer

    BrainSlayer Network Guru Member

    nvram cleaning is always the best way but not always needed. between v23 versions its not needed at all, only one some dev steps i changed important things in the nvram structure.

    additional generic steps can be found in hwsupport.txt
  4. bigjohns

    bigjohns Network Guru Member

    I'm sure that this applies to moving from v22final-r2 to v23, right?

    Looks like the bug list is growing shorter! Hope that you're feeling better, oh wise BrainSlayer.
  5. sded

    sded Network Guru Member

    For 11/24 generic mini to 12/2 generic mini I just flashed the firmware. All of the settings were retained and there were no issues. Sounds like there are no problems doing this within a version unless there is a warning to the contrary.
  6. Tomchu

    Tomchu Network Guru Member

    I flashed the router that I have doing NAT/DNS/DHCP for my house to this build, and virtually everything stopped working. :-( Neither external nor internal DNS worked, it wouldn't give DHCP out to wired clients, and I could only get to the router's interface by setting my IP manually.

    I tried the "erase nvram; reboot" procedure, and that didn't fix it either. I flashed back to last month's, and it works perfectly once again.

    I'll have another go at it when I'm home after the weekend. I'm sure it's probably user error on my part, but all I did was an update through the web interface to mini generic. :-/
  7. dellsweig

    dellsweig Network Guru Member

    I think there is an open 9or just resolved) issues with dnsMasq.

    If you use the udhcd instead (dont check the dnsmasq box in setup) this should work until the fix is released.

    I had the same issue
  8. dellsweig

    dellsweig Network Guru Member

    0000344 Clients MACs not shown in full (Status->Wireless)
    0000346 12/02/05 - Can't remove static DNS entries
    0000345 02/12 build: DHCP server broken, DNSMasq not running ?
    0000348 udhcpd does not respect LAN domain setting
    0000342 Reopen: 0000328: httpd hangs in QOS Page (qos disabled) when i press a "Add" button.
    0000343 Info Page - Java Script Errors
    0000350 Change "Status Site" to "Sys-Info Site"
    0000110 Wireless Security page contains errors
    0000333 Wireless Status Page - Encryption Info Out of Place
    0000334 Java Script Error on Port Services Page
    0000331 Java Script Error on Administration Page
    0000111 Access Restrictions page contains errors
  9. dellsweig

    dellsweig Network Guru Member

    Upgraded working 12/02 Std WRT54G build to 12/03 build

    1) Flash completed - IP logging stopped (kernel logging continued)

    2) telnet to router - iptables --list showed empty list

    3) hard reset router

    4) restore config backup from 12/02

    5) all functions ok - IP logging still not working

    6) Hard reset router

    7) hand configure router - same settings as 12/02 backup - IP logging works

    8) Save config

    9) hard reset router

    10) restore config from step 8. IP logging no longer works
  10. bigjohns

    bigjohns Network Guru Member

    UGG. This is a nasty persistant issue, is it not?
  11. dellsweig

    dellsweig Network Guru Member

    It looks like the problem has been found

    Certain L7 filters cause problems in iptables
  12. bigjohns

    bigjohns Network Guru Member


    So how do they fix that? I need full L7 support (latest filters too! - it would be cool if there was a way in DDWRT to upgrade them from the web interface...) for access restriction control and QOS...

    I need logging too...

  13. dellsweig

    dellsweig Network Guru Member

    It looks like the problem I saw (IP Logging) and other L7 problems only effect certain L7 filters. The 2 identified so far are MSN and BearShare. I am using other L7 filters with no problem.

    I removed my MSN filter and IP Logging is working fine

    As soon as I hear of a fix for these 2 filters I will post it. Otherwise, I am sure it will be fixed in a future build.

    Other than this issue - the 12/3 build of V23 looks REAL good. I have it on a client bridge, a WDS node and my main AP gateway router.
  14. bigjohns

    bigjohns Network Guru Member

    I think I can get by without the "bearshare" and MSN filters... at least to start off.

    So you can save and restore your config now and logging still works?
  15. dellsweig

    dellsweig Network Guru Member


    It looks like that was the issue I had with logging. It also explains why it could not be widely re-produced.

    I am VERY happy with this build
  16. juanker

    juanker Network Guru Member

    Me too!. The only thing that bugs me is that a while after turning off the cisco light, it comes back to orange.
    Funny, since that did not happen with my previous build (24.11.2005).
    Anything got changed?
  17. 4Access

    4Access Network Guru Member

    Looks like I'm a little late... I spent an hour testing logging yesterday like I said I would but could never reproduce your symptoms. I was convinced the problem was somehow related to specific iptables rules you were using but was too tired last night to make a post detailing it. Oh well, I'm glad you figured out what the problem was!! Lets hope for a quick fix! :)
  18. DoC_DaR

    DoC_DaR Network Guru Member

    DHCP Table

    Tried factory reset, re-flash, factory reset. Set up config manuel. Still DHCP Table empty. Also, internal clock not self adjusting now. Using WRT54GS v2.0 with DD-WRT v23b 12/03. Am using DNSMasq on this build.
  19. daenigma

    daenigma Network Guru Member

    I upgraded to the December 3rd build and the DHCP assinments are not showing up (status screen and LAN IP listing) although they are given out.

    This is what I placed into dnsmasq:
    please let me know if I have the settings incorrect...
    This is using a WRT54GS V3 and DD-WRT v23 mini
  20. Couledouce

    Couledouce Network Guru Member

    Mini works fine with WRT54G v2.0 WEP WDS
  21. DoC_DaR

    DoC_DaR Network Guru Member

    Build 12_3

    Turned DNSMasq of, using standard DHCP, DHCP Clients Table works. Still incorrect clock. Using 12/2 and clock works again. 12/3 and 12/2 seem to respond to changes quicker than previous versions. Top Notch firmware. Any planes on SRX400 as it also runs Linux?
  22. dellsweig

    dellsweig Network Guru Member

    Access restrictions do not appear to be working in the 12/3 build

    defined a tcp/upd filter for a service (port block). This filter was applied to an enabled access restriction set to a range of PC (which included my static defined PC). The filter was set to deny and set for 24 hours 7 days.

    I then opened a 'dos' window and started a telnet session to a host on that specific port. The traffic passed through the router un-effected by the filter

    I opened 0000388 on bugtrak. This may be related to the current L7 filter issues
  23. Silas

    Silas Network Guru Member

    With this version I have problems with Upnp and azureus on WRT54GS 1.1. Azureus is showing windows that Upnp connection has been lost....and this is known problem in DD-WRT v23 (1203). :sad:

    But this is my first try anything than official firmware. :thumbup:

    Any suggestion of using P2P (torrent), ftp and games (bf2, ....) on same network with good pings....
    I'm using 3 WRT54GS one has ADSL connection and other two are for me and my friend.... And my friend is using p2p and ftp a lot....and I have very high pings... :sad:
  24. DoC_DaR

    DoC_DaR Network Guru Member

    I would try using DD-WRT v23b 12/02 as this is working better for me than 12/03. As things get fixed, others are affected. You are looking for a specific function that trying different builds may help. I, myself, have also found that the builds seem to work better if I do a reset button factory reset before and after changing builds. Good Luck.
  25. vincentfox

    vincentfox Network Guru Member

    gsv4 std 3-12-2005 not working

    I upgraded a GSv4 to 3-12-2005-mini fine.

    Hard-reset, rebooted.

    Attempt to upgrade to GSv4 3-12-2005-std getting
    "upgrade are failed"

    Downloaded zip again to see if corrupt d/l, same result.

    Router seems to work fine, firmware not.

    Should I try one of the other ones like just plain GS file?

    EDIT: oops reading some threacs now to use "generic" version when doing web upgrades. Tried that, seems work. Sorry for post!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice