2.4 wireless stuck at channel 1

Discussion in 'Tomato Firmware' started by Timusius, Jun 26, 2014.

  1. Timusius

    Timusius Networkin' Nut Member

    I recently installed Shibbys 117 on an Asus RT-AC66U and started using it as one of my two wireless routers in the house. I configured the 2.4 wireless to run on channel 11, since my other router is running on channel 1. (And there are also a couple of neighbours running a lot of stuff on channel 1.)

    Soon I noticed that when using wireless computers in one end of the house (near this router) the connection was bad. So I investigated.

    It turns out that no matter what I set the 2.4 wifi channel to.... it stays on channel 1.
    The setting is saved alright, and on the Basic/Network page I see it as whatever I set it to.

    But on the Status/Overview page it's always listed as using channel 1.
    (Also using a wifi scanner, shows that this router sticks to channel 1.)

    I have now upgraded to Shibby 120, but the problem persists. (I didn't reset NVRam though, because I have quite a lot of settings set up for the router.)

    Have anyone else experienced this?
    Anyone know how to fix it? (Perhaps some commands to set the channel via the console, or something.)
  2. mpegmaster

    mpegmaster Addicted to LI Member

    DO THE... NVRam Reset... All will be good for the karma of the Asus RT-AC66U ;)
  3. kthaddock

    kthaddock Network Guru Member

    Try first to use fixed channel and not AUTO !!!!
  4. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    Tried on 3 AC66U units and I can set the channel on all of them. The posts above are good advice, though I suspect that you're not using Auto channel selection.
  5. Timusius

    Timusius Networkin' Nut Member

    Hmm.. I just spent 2 hours working on it... still no luck.

    Resetting the NVRAM did not work.

    I even installed 120 again with clear NVRAM ticked off. Still not working.

    Then I reinstalled the original ASUS firmware. Using that I was able to switch channels just fine.

    Then I installed tomato 120 again. This time using the ASUS recovery tool. (The new asus firmware complains when trying to upgrade directly.)

    Now everything was even worse. After a complete reset, and reboot to make the 5Ghz show up, the channels looked like this:

    2.4 Ghz is at channel 6 on the settings page but was really transmitting on channel 1.
    5Ghz is set to channel 40 on the settings page but was really transmitting on channel 36.

    None of them were changeable using the settingspage. Yes, I remember to click save ;-)
    All of these experiments were done with nothing but clean NVRAM, I didn't bother to set anything else up.

    I then uploaded my old configuration, that I had saved before. Now the problem is only back at 2.4 being stuck. 5Ghz is changeable.

    I can only assume that this problem must relate to the Tomato firmware :-(

    I need VLANS, so I don't really want to use the ASUS or Merlin firmware. Also I'm a big fan of Tomato :-D

    More data on my router:
    Chipset is Broadcom BCM5300 chip rev 1
    It was bought in March 2013, so perhaps I have an early revision?
    I'm using the AIO version of the firmware.
    Last edited: Jun 27, 2014
  6. Timusius

    Timusius Networkin' Nut Member

    This morning I spent a lot of time on this problem. There surely is some sort of funny thing going on with the interface.

    This is a compilation of screen captures, all done at the same time. Just after flashing(with clear NVRAM).

    Apparently the status page must get it's input from somewhere else than the NVRAM.

    Well.. I had Tomato running on this router half a year ago, when the support for the AC66U was brand new. I didn't notice any problems back then... so I decided to test with some other, and older versions. These are my results:

    I've tried the following firmwares and got these results:
    Shibby 120 AIO, Shibby 120 VPN and VICtecs 9014v1.3build - Not working
    Shibby 117 AIO - Not working
    Shibby 116 AIO - Not working
    Shibby 115 AIO - Working both 2.4 and 5Ghz

    I then flashed 120 again, and the channel stayed at 11 where I had put it using 115.. but I was unable to change it.
    I then flashed 115 again to make sure that this was just some freak random occurence. And this time it was not working so well. But I was able to change it. It seemed to work, but it would only change the channel if I also changed some other settings at the same time.(For example setting the network mode to N-only.) I did not manage to find any logic to this behavior, even though I messed around with the GUI buttons a lot.

    So the current result is:
    116 and later seem to not be able to change the channel.
    115 seems to be working better, but not perfect.

    The problem is the same for 5Ghz, but it does seem to be a little better. THe 5Hgz has the same problem with the Status page. Especially right after an NVRAM clear, the 5Hgz may be at channel 36 for real, but the GUI will report it on channel 40. (And having 36 not even selectable in the GUI.)
  7. kthaddock

    kthaddock Network Guru Member

    Channel 6 upper use channel 1+8 on 40 Mhz. You only se channel 1 on your phone, it's only 20Mhz width.
    Use inSSIDer on your computer to show your used channels.

    Channel 6 lower you can use channel 1 to 9 with upper 5 to 13

    Attached Files:

  8. Timusius

    Timusius Networkin' Nut Member

    I don't think the app shows the actual with of the channel. But if it does you're right. Then even more is wrong with the settings.

    However the problem is not the width of the channel, the problem is that I can not even set it. No matter what I set it to, it stays on the same channel. Only using the 115 version of Tomato, or the official Asus firmware, am I able to change it.
  9. ntest7

    ntest7 Network Guru Member

    Please clear your browser cache & cookies, or try a different browser.
  10. Monk E. Boy

    Monk E. Boy Network Guru Member

    The fundamental problem you're having is you're using 40Mhz channel widths. If you want to use channel 6, then you need to use 20Mhz channel widths and set it to channel 6. With 40Mhz it's going to use channel 6 and either channel 1 or channel 11, depending on the options you choose. Unless you're living in a farm house in the middle of a few acres, you're really not going to be able to use 40Mhz on 2.4Ghz.

    Every other problem you're having sounds like the results I get when I long erase NVRAM and immediately go in and start adjusting settings. I have to let the router sit there for a few minutes in order to fully populate the NVRAM values. This is a blatantly repeatable thing, if I do an NVRAM export/dump from an SSH session, the exported file is smaller and contains different information than the times when I let I'm patient and let it sit. These aren't desktop systems with near-instantaneous response times, they're penny pinched systems with slow flash, slow RAM, slow CPUs, etc. and something that sounds simple like completely clearing NVRAM takes far longer than you'd think it should.

    One other thing to note, when you restore the configuration file, you're effectively restoring a dump of the NVRAM at the time you make the configuration backup. If the NVRAM contained a configuration problem, restoring it is going to return you to the exact same state you were in.
    Last edited: Jul 11, 2014
    Marcel Tunks likes this.
  11. Malitiacurt

    Malitiacurt Networkin' Nut Member

    FYI that app is unreliable for 40 (and 80MHz) wide signals.

    The Wifi Analyzer app does not show 40Mhz channels, only the control channel. I confirmed this with the Android app and an older version of inSSIDer on my laptop.
  12. droidd

    droidd Network Newbie Member

    I have version 1.28.0000 -125 K26ARM USB AIO-64K installed and I am also having the same issue. No matter what channel is selected is seems to be "locked" on channel 1.
  13. AaronCompNetSys

    AaronCompNetSys LI Guru Member

    This is still a top google result for this problem, and I just encountered it on Shibby Tomato 132.

    It appears that the webui for the config gets cached and its not compatible across versions. Clear cache, or shift+click reload. Do this any time you see weirdness in the settings.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice