2 little problems (wan, wifi)

Discussion in 'Tomato Firmware' started by hadede, Aug 19, 2009.

  1. hadede

    hadede Addicted to LI Member

    Hi all,

    I hope I didn't miss out anything already written about my problems mentioned below. If so, please provide the links and close my thread. That said, here are the 2 issues which I'm facing.

    1) Changing the type of encryption of my wifi strangely makes my WAN dead... I have cable internet, so I simply plug in my linksys router and choose DHCP mode on WAN port. I also have to spoof my computer's mac-address to get access...
    If I change the wifi encryption, wifi will be restarted and the computer is on it back again. But then, I have no internet. The status overview tells me that it is renewing... But neither waiting, nor disconnect and again renew worked... Same for unplugging the cable and connect it again... even reboot does not work... If I pull the power plug of router AND modem afterwards it will work again... This is reproducable (with v1.23 and after upgrading v1.25)

    2) I have issues with one of my computers and wifi encryption. I already searched for linux (i have installed ubuntu) related hints, but didn't find any. I'm not sure what causes the problem:
    As I said, I installed Ubuntu, which comes with default drivers for my card (Cisco Aironet 350). The card itself is WPA capable (not WPA2), but the driver does not support WPA. So I use ndiswrapper to include the windows drivers, which works quite good.
    If I set tomato to use WPA Personal and TKIP it usually works (perhaps not always stable, but I can't tell after a few days). But if I tell tomato to use WPA / WPA2 Personal there is no chance to connect.
    I thought, it should use the highest encryption possible, what would be WPA, but somehow it does not connect...

    Hints or solutions are welcome!
    Thank you all in advance,
  2. fyellin

    fyellin LI Guru Member

    It is not uncommon to need to reboot the cable modem after making a change to the router. Try unplugging it and then plugging it back in. I'd never heard of it happening before just by changing the encryption algorithm, but it's certainly possible.

    I can't help you with the second problem. If your driver supports WPA/AES, I suggest you use it instead of WPA/TKIP, as it is more secure.
  3. hadede

    hadede Addicted to LI Member


    thanks for your answer...
    I never experienced a broken WAN connection ever since I use tomato (about 1 year) and I'm sure, I did a lot of settings changes. This is new to me and did only happen the last days. I noticed that the modem does some strange blinking uncommon for normal operation which I never saw before. So my first suggestions would be that the router either sends something which confuses the modem, or something regarding WAN is restarted too during WIFI changes and it doesn't reapply the spoofed MAC address to the WAN port... But in the last case, at least router reboot should help (which is not the case here). Usually if I connect another computer, the modem refuses the connection rather than doing a "freakout"...

    Regarding the second problem, it's simply unclear to me why Ubuntu in the described configuration would not be able to do a WPA connection although both WPA and WPA2 is allowed. But I really don't know where to start with my investigation

    Any hints appreciated!
  4. gawd0wns

    gawd0wns Network Guru Member

    Try using WPA-AES or WPA2-AES, perhaps you will get better results... TKIP is no longer perferible anyway.

    The only time I ever have to reboot my cable modem is after a change to my router's MAC address.
  5. hadede

    hadede Addicted to LI Member

    unfortunately this is not supported by the quite old wifi card (afaik)... Its a Cisco Aironet 350 802.11b card and I'm glad it supports at least WPA.
    I have a spare usb-wifi card which supports more, but I simply tried to keep the setup as lean as possible, so you can simply close the lid, take it with you, and open the lid and connect somewhere else...
    (BTW: If sth is officially supported and doesn't want to work it usually bugs me until I solve it ;-))

    Regarding the WAN port: This would be such a case... But why should tomato change the WAN MAC address on changing wifi encryption? Afaik there is only the wifi module restarted...
    But perhaps it reboots sth and restores the original MAC address and then it spoofs it again... If the modem notices it, it would refuse connection until a reboot... I could imagine that sth happens...
    Does anyone know, if I can see these things happening somewhere in a tomato logfile?

    best regards,
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice