54g v2.2 with HyperWRT 2.1b1 fails to upgrade FW

Discussion in 'HyperWRT Firmware' started by NolanWNET, Mar 27, 2006.

  1. NolanWNET

    NolanWNET Network Guru Member

    I loaded my wrt54g v2.2 with HyperWRT 2.1b1 a few days ago and everything worked fine until today I tried to go back to 4.20.7 linksys firmware. If I use the web interface it comes up saying "UPGRADE FAILED", I also tried the linksys ftp utility with no lock. I also tried other 3rd party FW, cleared the NVRAM.

    Any help with this will be appreciated...
  2. Thibor

    Thibor Super Moderator Staff Member Member

    which begs the question: if everything went fine, why would you ever wish to go back to a less stable, lower featured firmware?
    oh, and you have to reboot if a flash attempt fails before trying again
  3. NolanWNET

    NolanWNET Network Guru Member

    I was going to mail the router to my parents, I don't think they need all the features.....
  4. zachariah

    zachariah Network Guru Member

    maybe having no problems is too boring, so he must create some to keep himself busy, just a hunch.
  5. Toxic

    Toxic Administrator Staff Member

    have you tried flashing with the tftp utility as soon as you turn on the routers power?
  6. NolanWNET

    NolanWNET Network Guru Member

    I tried that a cople of times and still didn't work. But I noticed that the HyperWRT FW that I had loaded on the router was the one for the 54GS(I think)??? , so I installed the linksys wrt54gs FW with no problems and then used the ftp utility at boot up to load the 54g FW. Now everything is back to normal.

    Thanks for the help...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice