aborted SSH and SCP connections with WRT54G v5

Discussion in 'Cisco/Linksys Wireless Routers' started by DTinAZ, Aug 31, 2006.

  1. DTinAZ

    DTinAZ LI Guru Member

    I just recently replaced my old cable modem and home router with Linksys equipment. The router is a WRT54G v5 Firmware Version: v1.00.9. The problem I'm seeing is with SSH (PuTTY) and SCP (WinSCP) session windows losing their connections after 30 minutes of inactivity with errors like this:

    Network error: software caused connection abort

    This didn't happen when using my old hardware, and nothing has changed on the host servers in terms of timeout configuration (other users are still able to maintain idle connections indefinitely). Therefore, I'm looking at the router as a likely source of the disconnections.

    I've not yet found other descriptions of this kind of problem here, but I might have missed it. A Google search (ssh "30 minutes" disconnect) resulted in a hit to this forum topic:


    where, if you scroll all the way to the bottom, you'll see this seemingly related verbage:

    but wait...I just went back to my Google results and found this hit, which is much more on target:


    and then a followup to that:


    This is *exactly* what I'm talking about. But is there any hope that this can be resolved? I didn't see any settings in my router admin interface that would address this. Should I take the router back to Fry's Electronics and exchange it for a different model?

  2. Cesideem

    Cesideem LI Guru Member

    I have quite the same problem with my WRT54GS v5.1 Firmware v1.50.5 :(
  3. Toxic

    Toxic Administrator Staff Member

  4. Cesideem

    Cesideem LI Guru Member

    K, but that doesn´t help solving the current problem... :(
  5. Toxic

    Toxic Administrator Staff Member

    it has been reported in these forums before it just doesn't work. and to solve the problem, well. i told you what I would do:)
  6. DTinAZ

    DTinAZ LI Guru Member

    I tried giving the Linksys folks a chance so I had an online tech support chat this morning. The solution the tech came up with was to change the MTU setting on the router's setup page, changing it from "Auto" to 1372. I thanked him, changed the setting, rebooted stuff and tried an SSH connection, which died exactly 30 minutes later. Then this afternoon, I tried an SCP connection, which also died after 30 minutes.

    I'm about to unplug the thing, box it up, and take it back to Fry's Electronics and exchange it for an WRT54GL.

    Thanks for the responses. I'll be back, but hopefully without any problems. :)

  7. DTinAZ

    DTinAZ LI Guru Member

    Fry's took back the WRT54G v.5 and sold me a WRT54GL v1.1, for a bit more than it should have cost ($79.99) but I was in a hurry and convenience won out over thriftiness. :)

    The (not unexpected) good news is that it works just fine and I don't have any issues maintaining those idle SSH or SCP connections as long as I want to. The setup went fairly well, although the last stage, when the router trys to connect to the Internet, didn't go well with either this or the previous router. I had to repeat that over and over again until it finally worked. Also, when I logged into the admin GUI of the WRT54GL, there were some really odd upper-ASCII strings in the "Host Name" and "Domain Name" boxes on the setup page. I hadn't entered anything for those values during the install, so that was a bit odd. The GUI complained at me about bad ASCII values in those boxes, and I was eventually able to clear them out.

    The firmware version that was already on the router is v4.30.7, Jun. 20, 2006. I searched the Linksys website and the only firmware they have for a GL there is for a v1.0 and is 4.30.2. Wonder why they don't even mention the v1.1?

    I know that I have some third-party firmware choices that would bring extra features to the router, such as the DD-WRT version, but I'm not sure I need them. I'm not a gamer and only make minimal use of the wireless access point on the router, so I'm not sure what the advantages would be for me, but I'll keep reading these forum messages and try to get a little up-to-speed.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice