AC66U with Shibby can't connect as WiFi Client with encryption enabled

Discussion in 'Tomato Firmware' started by nmalinoski, Aug 23, 2013.

  1. nmalinoski

    nmalinoski Networkin' Nut Member

    I got Shibby's 112 firmware flashed to my brand-new AC66U last night, but I had difficulty getting it to connect as a wireless client to my existing network (E3000, downstairs) from an upstairs room. When I looked at the signal quality, it was typically 0, but would spike to between ~4 and ~13. I compared that to my WRT54GL, also configured as a wireless client of the same network and sitting in nearly the same spot, which was getting a solid/steady 20 to 21.

    I tried, with no luck:
    - Re-aiming the antennae
    - Boosting the transmit power
    - Switching the Wireless Mode to G-only (As is for my 54GL)
    - Moving the AC66U to another upstairs room

    I'm currently testing it at work with one of the lab access points. It connects just fine, but even 25ft away, in the same room, the quality hovers around 32-38. I left it alone with the faceplate towards the host AP for a few minutes, and the quality somehow ended up crawling up to 97 (RSSI=17dBm, Noise=-78dBm). Then I moved it and the signal dropped back down to the previous levels.

    I'm convinced I'm doing something wrong, but I'm not sure what. Is it me? Is there some configuration that I'm missing? Are the antennae crap compared to the 54GLs'?
  2. koitsu

    koitsu Network Guru Member

  3. nmalinoski

    nmalinoski Networkin' Nut Member

    I attempted various 90deg permutations as suggested in that other thread with no improvement. I attempted one better by placing the AC66U within 2ft of the host router; although the signal went up to 40-50, it still exhibited the same behavior.

    I decided to try using the AC66U as a client of one of my routers (I don't have full control over the other); a WRT54GL also running Tomato. I configured the AC66U with the name, encryption type, and password of the network, and specified G-only for the mode.

    The signal quality fluctuates between ~23 and 39, with an acceptable interference level, -31 to -37dBm RSSI, and -60 to -75 Noise; then, after 10-15s, signal quality drops to 0. When that happens, I see the Channel Width switches from 20MHz to 40MHz, the channel switches from 4 to 6, and interference reads as Severe. On the host AP end, it sees the client router in the Devices list with a signal quality of 99 for a bit, and then it drops off the list and reappears a second or so later.

    Edit: It does connect when I disable encryption.
    Last edited: Aug 24, 2013
  4. koitsu

    koitsu Network Guru Member

    It sounds like there are devices (either other APs or things like baby monitors, microwaves, toys, etc.) taking up portions of the spectrum. This is outside of your control, and usually a bigger problem in the 2.4GHz range. It would benefit everyone if you posted a screenshot of your Basic / Network screen. You can edit out the MAC address and SSID if you want.

    The RSSI ratings don't mean much to me unless you've calculated your noise floor already.

    The "signal level" dropping to 0 is also pointless -- what you're not aware of is devices which use power saving operations. Many portable devices (phones, laptops, etc.) save power by throwing their chips/radios/receivers into a "low power" mode -- this is done at the software (OS), driver, firmware, *and* hardware level -- where the signal will diminish. Staring at these numbers is just going to make you OCD, I'm sorry to say. You really need to test with a device that you know doesn't do this.


    1. Use 5GHz exclusively. Usually the 2.4GHz range is the one with issues due to unregulated spectrum and other devices (see above). If you have devices on your network which need 2.4GHz then obviously this isn't an option for you.

    2. My opinion is that you should use 20MHz exclusively. There are other discussions about why this is on this forum. Yes, it limits the available bandwidth (thus possible throughput) you can get, but welcome to the unreliability of wireless.

    3. Regardless of the above: make sure the correct country is selected under Advanced / Wireless / Country/Region (otherwise the below scanning may not be applicable to you, since different countries use different frequency ranges, and sometimes devices made for your country cannot communicate outside of those regions). You should pick a channel statically (and not use "Auto") by going to Basic / Network and under the Wireless section, click the Scan button next to Channel. Let this run for a bit. This will look for other APs around you (it cannot detect other devices like baby monitors, etc.) and give you a count of how many are using what channels. Do this procedure 5 or 6 times, waiting maybe 10-15 seconds between each Scan, and take note of which channels are least used (a pad of paper helps here, so you can average the results). What you're looking for is a channel that is least used by other people. Then, pick that channel (instead of Auto) and Save.

    4. If none of this works, then there is always the possibility you have a bad AC66U unit and should do an RMA. Your antennas might be bad, but even more common is the internal wiring (yes, physical wires are used, not traces) relating to connecting the wireless ICs to the actual antenna posts -- those sometimes are faulty or come loose or a bad quality connection is there. Do not open your router unless you want to risk voiding your warranty.

    I should finally note that I do not have familiarity with the 5GHz stuff or dual-band devices. My advice comes from 2.4GHz experience.
  5. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    Basic settings from both routers would be ideal, not just the AC66U.
  6. nmalinoski

    nmalinoski Networkin' Nut Member

    Last edited: Aug 25, 2013
  7. Malitiacurt

    Malitiacurt Networkin' Nut Member

    IIRC WPA2 + AES wireless client is broken on all tomato builds.
    Last edited: Mar 20, 2014
  8. nmalinoski

    nmalinoski Networkin' Nut Member

    I'll give this a shot. For what it's worth, Toastman 1.28.7634 for the WRT54G/GL can handle being a wireless client with WPA2+AES just fine. I'm not sure when it broke.

    Edit: Sadly, neither WPA+AES nor WPA+TKIP worked. :<
    Last edited: Aug 27, 2013
  9. mercurio_

    mercurio_ Reformed Router Member

    i have the same problem on a ac66u for me the client mode only works with no encryption / wep encryption. the bridged mode works also for WPA/WPA2 + AES. maybe it's the same error

    CHRISTOS ZAPITIS Reformed Router Member

    Here goes my 2 cents:
    Tested on Linksys E3200 and ASUS RT-AC66U
    Wireless Client Mode does not work with WPA-AES or WPA2-AES (WAN side does not obtain IP through DHCP / connection uplink is not stable or does not occur at all).

    This is definitely something to do with the encryption as when primary wireless rooter is set with no security then Wireless Client Mode works fine.

    Note: Wireless Client Bridge works fine under WPA-AES and WPA2-AES.

    I justed tested the Wireless Client Mode with MIPSR1-116 K26 Mini, on a Linksys WRT54GS v1.1 and it works fine with stable throughput.

    Could this point to an interface issue on shibby builds? A driver issue? I wish I could troubleshoot some more.
  11. csaba

    csaba Reformed Router Member

    Cisco E4200 with tomato-E4200USB-NVRAM60K-1.28.RT-N5x-MIPSR2-116-AIO.bin.

    I have the same issue. WPA2 + AES wireless client doesn't work. I did manage to get wireless bridge mode working but I would like to use wireless client mode. Is there any firmware for E4200 that has a working wireless client mode?

    CHRISTOS ZAPITIS Reformed Router Member

    Until this is fixed, you can use dd-wrt for this purpose
  13. Xavier Soares

    Xavier Soares Network Newbie Member

    Good day,

    Anyone know when it is scheduled to be solved the problem of wireless client with encryption?
    I really need and can not use with the RT-AC66U with the old RT-N12 works great!
    Thank you for your attention.
    best regards.
  14. Xavier Soares

    Xavier Soares Network Newbie Member

    Anyone have news on this subject?
    Really needed to solve this BUG
    Thank you.
    best regards
  15. Kent_Diego

    Kent_Diego LI Guru Member

    The stock Asus firmware is based on Tomato. I wonder if the either Merlin or or stock has same problem.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice