Access restrictions not working

Discussion in 'HyperWRT Firmware' started by dog-man, May 31, 2006.

  1. dog-man

    dog-man Network Guru Member

    I have a WRT54GS V1.1 here in the UK.

    I have the following firmware on it. - Firmware Version: v4.71.1, Hyperwrt 2.1b1 + Thibor15c.

    I have two children with computers on my network. I want to restrict the times they can access the net, as I have always done.

    With this latest s/w, the access restrictions don't work.

    Any advice gratefully received.

  2. Toxic

    Toxic Administrator Staff Member

    please tell us what proceedures you have taken to try and setup access restrictions.

    I take it the feature was working before the upgrade?

    did you hard reset your router after the upgrade?
  3. Thibor

    Thibor Super Moderator Staff Member Member

    since i've thoroughly tested the access restrictions in this version and have approved them as being FULLY functional, i will need you to tell me exactly what i need to do to reproduce your problem. i need ALL details pertaining to the access restrictions AND the firewall. also i need to know if you have set the correct time zone and if it's working correctly(the router status page will tell you)
  4. Seuss

    Seuss Network Guru Member


    I also have a WRT54GS with similar requirements. I found the perfect solution in Linksys firmware ver 4.50.6.

    There are 10 rules you can set up. The router logic tests each rule in sequence from #1 - #10. Here's how I set it up.

    #10 is the blanket DENY (which means any PC that is not specifically ALLOWed will not have access). I specify IP addresses from - That shd cover everything in your network.

    #1 is for my laptop. I specify the laptop MAC address, and ALLOW access Everyday 24hrs.

    #2 is for kid's PC. I specify PC MAC address, and ALLOW access from 7pm - 9pm Mon - Fri.

    #3 is an adhoc profile. As and when I decide to let kids have access, I will Enable this rule. Specify PC MAC address, and specific day and specific time period.

    I found that subsequent releases of the Linksys firmware (up to 4.71.1) does not allow me to set up the same rules, and after much frustration, have decided to remain on ver 4.50.6.

    Let me know if this helped.

  5. dog-man

    dog-man Network Guru Member

    Before upgrading to Hyperwrt and Thibor, I was on the latest Linksys firmware. 4.71.1 or whatever it is.

    Access restrictions worked fine for me. They also worked on previous versions of Hyprwrt. I think I am on my third.

    I did not do a hard reset after upgrading to the latest Hyprwrt firmware.

    I will reinstall the firmware and do a hard reset followed by a test of the access restrictions.

    I will report back later in the day.

  6. dog-man

    dog-man Network Guru Member

    Can you confirm that this >>> v4.71.1, Hyperwrt 2.1b1 + Thibor15c. <<<<<

    is the latest firmware for the wrtg4s v1.1?

    I did a hardware reset after installing firmware and access restrictions are still not working.

    I am going to check my childrens computers to make sure I have configured them correctly before giving you a blow by blow list of my settings etc.

  7. lwf-

    lwf- Network Guru Member

    Indeed that is the latest version of hyperwrt you can get.
  8. Thibor

    Thibor Super Moderator Staff Member Member

    dog-man, you have still not provided the information i requested when i responded to your initial post. Access Restrictions are working, unless you tell me EXACTLY what you are doing, i can't help.
  9. dog-man

    dog-man Network Guru Member

    Sorry for the delay in communicating.

    I am on nights at the moment, so don't get up till the afternoon and even then am like a zombie.

    I want to give you the true facts if I have to pursue this.

    Last night, my daughter told me that she could not get on the Internet, I changed the access restrictions to allow her access but then had to leave for work. I wil speak to her when she returns home from a shopping trip.

    At the moment, it seems that it may now be working due to me carrying out a hard reset of the router.

    I will get back to you and let you know.

    I am grateful that you are interested in my problem, which may (hopefully) no longer exist.


  10. dog-man

    dog-man Network Guru Member

    Ok, have now spoken to my daughter and access restrictions DO WORK!

    It must have been down to me not doing a hard reset after upgrading to the latest firmware.

    Thanks for a great firmware! :thumbup:

  11. Thibor

    Thibor Super Moderator Staff Member Member

    i know they work. as i said at the start of this thread, i had confirmed that it fully worked before i released it. good to hear that you have it functioning.
  12. Wolfie8881

    Wolfie8881 Network Guru Member

    Im having problems too, im trying to block a website using the url and keyword block on a laptop with a static IP, firewall set to enable

    keyword habbo

    rule is set to enable on static ip

    i tried a hard reset, reflashing the router, and erasing the nvram, and it still wont block the website,

    running the latest thibor 15c on a WRT54GS V1

    any help or suggestions will be apreciated.
  13. kennyw76

    kennyw76 Network Guru Member

    access restrictions


    i am having the same problem this is how mine is set up
    edit list of pc's is to
    deny access from 8:30 to 11:55 pm

    heres the funny thing will work in policy box number 1 but wont work in 3 through 20 with same settings

    website blocking is setup on policy 2 and it blocks the websites
    hope this helps
  14. mstombs

    mstombs Network Guru Member

    No problem here:-
    with Thibor 15c on a wrt4GS V1.1 I tested a 'rule 3' and internet access to that site was blocked on my static dhcp assigned PC with either the site,keyword or both entered. Make sure you Save the IP list then save the whole pae settings before testing!
  15. tempralflux

    tempralflux Network Guru Member

    if i use policy 20 as a blanket block for all pc`s that works fine all blocked but say if enter in rule 1 allow all for this removes the block all rule for lets say, key word blocking still works fine. checked /tmp/.ipt file and the rules are there

    -A grp_20 -s -j logdrop
    -A grp_20 -s -j logdrop
    -A grp_20 -s -j logdrop
    -A grp_20 -s -j logdrop
    -A grp_20 -s -j logdrop

    just tested that if i use any IP with in range with a allow all rule it removes the block all restriction on the other IPs

    even tried a iptables-restore /tmp/.ipt but with no luck

    does some else have this problem
  16. seper

    seper LI Guru Member

    using v4.71.1, Hyperwrt 2.1b1 + Thibor15c the URL Blocking feature does not work for HTTPS URLs.
  17. tempralflux

    tempralflux Network Guru Member

    myself had trouble with blocking internet access with certain IP`s but just tested HTTPS and it works fine.
    Quote from Seuss "The router logic tests each rule in sequence from #1 - #10."
    so what i did was

    i kept all the IP`s in order and now access restriction works
    originally was on policy 1 but when i tried on policy 2 access restriction didn`t work
  18. mgnewman

    mgnewman LI Guru Member

    Never mind....
  19. DeepHunter

    DeepHunter LI Guru Member

    Can I turn off the radio at night from like 9 pm to 7 am on a wrt54g 1.1 runnin Thibdor's latest?
  20. Thibor

    Thibor Super Moderator Staff Member Member

    DeepHunter: only by using a cron job to do it. search this subforum for the correct commands to do it
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice