Access Restrictions with QoS (not DNS problem)

Discussion in 'HyperWRT Firmware' started by TerminatorHTK, May 10, 2006.

  1. TerminatorHTK

    TerminatorHTK LI Guru Member

    I've installed Thibor 15b3 on my WRT54G v3 last night, and started having dropped connections on various computers. I cleared NVRAM and reset to defaults and reconfigured, but after about 5-10 minutes again I had dropped connections.

    After further investigation, I discovered that these computers could ping IP addresses with no problems, but could not ping IP names.

    I tried the same clearing and reconfiguring again, and got the same results. It appears that I lose the connection to the DNS server in the router after 5-10 mins.

    I reloaded version 14, and cleared NVRAM and reconfigured. Everything was stable the rest of the night.

    Anyone else experienced this? Any helpful ideas?

    Thanks much in advance.
  2. Thibor

    Thibor Super Moderator Staff Member Member

    i've not changed anything about or to do with dnsmasq, if i hear of another having dns issues i'll look into it. if not, i fully intend to ignore it :)
    if you do see it stop pinging by www address, do "ps | grep dnsmasq" on the command line to see if dnsmasq has crashed(it ought to be there)
  3. prowler1968

    prowler1968 Network Guru Member

    I think another user that had a different issue after the upgrade to Thibor15 was able to correct their problem by clearing the NVRAM and ALSO by pressing the reset button on the router for 30 seconds to fully clear the router of any bad info.

    My upgrade path from 14 to 15 was - Clear NVRAM on 14, flash to 15, clear NVRAM on 15, re-key my setup information.

    I have had flawless performance (other than the issues that were addressed while going from b1, b2 and b3) without the need to hard reset the router.
  4. TerminatorHTK

    TerminatorHTK LI Guru Member

    I'll try the 30 second reset...I haven't done that yet.
  5. TerminatorHTK

    TerminatorHTK LI Guru Member

    Problem Found :cheer:

    I tried the 30 second reset, clearing NVRAM, everything I could think of. Then I started watching the other PCs as I made configuration changes.

    To make a long story short, everytime I enabled the access restrictions with QoS active, I had problems with the machines that were on the access restrictions list. Some connections would stay on these machines, but no new connections could be created (including DNS lookups).

    I've tried this a number of times, and it's repeatable. I've shut off access restrictions for the time being, and everything is working great! :D

    If anyone else is using QoS, port forwarding, and access restrictions, please let me know if you are having any issues. I guess I can live without the access time restrictions for now...but they would be nice to have...

    Otherwise it's working great...thanks for all the hard work.
  6. JeFFJuH

    JeFFJuH Network Guru Member

    Well I can confirm that there are some problems with dnsmasq.
    I entered 3 static DNS entries, and enabled "Use ISP served DNS in addition to static entries" and "Use Dnsmasq for DNS".

    The DNS server works for a while (say 7 to 8 hours) and after that time, all DNS queries get a reply such as "Query refused". dnsmasq seems to be still running. When I disable "Use Dnsmasq for DNS", and renewing the DHCP lease at all client sides, the problem seems to be solved.
  7. mstombs

    mstombs Network Guru Member

    I've had a problem with QOS active and access restrictions, but need to clear nvram and start from scratch before retesting ( couldn't last night as my cable was down!). But sounds suspiciously similar - internet access blocked on certain machines when it shouldn't be, like you I deleted the access restrictions (timebased on MAC address) and all was well! No port forwarding and QOS configured by application in my case.
  8. JeFFJuH

    JeFFJuH Network Guru Member

    Well my problem is really strange. My DNS drops out at some times, and even my internet connection drops out. Releasing the WAN DHCP lease at the router's side and renewing it, results in getting as IP address.

    After I reboot the router (power cycle or from the router's web interface) everything is back up again.

    When I connect my laptop directly to the cable modem when the connection has dropped out, everything seems to work fine, so I think nothing is wrong with the modem itself.

    I used to had this problem before with the original Linksys firmware, but after upgrading to WRT54G 4.20.8, the problem was solved.
  9. prowler1968

    prowler1968 Network Guru Member

    @ Terminator -

    Have not had any problems with DNS on a small office network of about 1 dozen active users. I do have Port Forwarding and Port Redirection set up for a number of machines. NO QOS or NO Access Restrictions (at this time). It does not seem as if any port forwards/redirects are causing an issue.

    @ Jeff -

    I have dnsmasq enabled but no check in ISP Served DNS. (I have a static IP and DNS, not dynamically served by the ISP). Seems to be very stable here.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice