Adding WRT54GS to network with BEFSR41 acting as router

Discussion in 'Cisco/Linksys Wireless Routers' started by Kilrathi17, Jul 7, 2006.

  1. Kilrathi17

    Kilrathi17 LI Guru Member

    Hi --

    I just bought a WRT54GS router and would like to use it to add wireless capability to a network that already has a BEFSR41 acting as the router. The network currently works fine (and, I know, I should save myself the hassle and just buy an access point, but I'm living at home for only a few months, and when I move out, I'll need the router, so I'm hoping to make it work in the meantime so I can have wireless access here).

    To start, I set up the wireless router as indicated in the following link (which is Answer 358 on Linksys' "Easy Answer" page -- for "How to connect a wireless router to a regular ethernet Linksys router):

    Essentially, that told me to use the Setup screen on the WRT to turn its DHCP feature off and then to assign the wireless router to Ok, so far, so good.

    The "link" light on the BEFSR router is on for the port where I'd plugged in a straight-through cable to the WRT wireless router. Similarly, the lights on the WRT are on, for both "Internet" and "WLAN".

    I tried connecting to the wireless network then, but couldn't get it to pull up an IP number when I had my "Network Connections/TCPIP Properties" control panel set to automatically obtain an IP number. So I switched to assign a static IP number to the wireless connection -- which I'd already done with the same computer's wired ethernet connection and to another computer that had a wired connection. So, while unplugged, I was able to get the wireless connection to connect with said static IP -- excellent signal strength, IP number as assigned, everything looking good.

    Only problem is I can't connect to the Internet using any program I tried. I tried "ping" and that worked. Tried "ping" (the wireless router) and that worked. But try "ping" (the BEFSR router) and no luck. Similarly, no luck when pinging (or trying to pull up with Firefox)

    However, the desktop that I had sitting there that was plugged into the BEFSR works fine and is able to connect to the 'net, no problem.

    Anyone have any ideas what's happening? It seems like something weird's going on between the wireless and wired routers (since I can't ping from my computer to the wired router -- and, also, because even when I plug an Ethernet cable into the back of the WRT router, it doesn't work, so it seems like the problem isn't the wireless but rather something about traffic going out/coming in through the WRT) but I can't figure out why. I'm sort of a novice at all this; able to find instructions and follow directions but I'm at the limit of what I've figured out and can't figure out why there'd be a problem in between the WRT and the BEFSR when it looks (from the solid green lights on both of them) like the connection is working just fine.

    Any tips would be greatly appreciated!

  2. Kilrathi17

    Kilrathi17 LI Guru Member

    Alright, think I figured it out. After all that verbosity, it looks like the solution was simply to go from port 1 on the first router to port 1 on the second router -- I'd plugged it into the "Internet" jack on router 2.
    Switched that up, and, voila! I'm wireless. Cool. Wish I'd tried that before spending hours playing the IP configs, but I can't complain.

    Can anyone out there explain, in newbie terms, why it works to go from what I'd assumed was an "outgoing" port to another "outgoing" port instead of plugging into the "Internet" port?
  3. Toxic

    Toxic Administrator Staff Member

    that was your first mistake. the BEFSR41 was a gateway. pluging in a new router using the WAN makes the next router think its the gateway (which is not, it should now be a "router") and you have now added an additional NAT/Firewall.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice