Adsl2mue firmware recovery

Discussion in 'Other Linksys Equipment' started by R0ut3r, Jul 10, 2006.

  1. R0ut3r

    R0ut3r Network Guru Member

    just tryed to flash one (... ) adsl2mue for the disconnection problem with other brand firmware (pretty SIMILAR electronic layout, and i have another 2 to try) but the adsl2mue die ..
    no prob at all: all the adsl2mue i have, have big stability prob and are inusable (working or die)
    at this time 3 devices tested and ALL have the same prob !!!!
    (disconnect every 1/2 days and must be turned of for a reconnection, after the 4.22 the disconnection time drop to 2/20 minutes and even with older firmwares the disconnection rate desn't change!!)
    i think that is useless send back these "modem" ....
    and obviously i have no prob with an old (not mine) wag54: so isn't the telephone line

    the 4.22 is a bug not a firm.... i know that is a beta.. but a beta can have some problem.. not DESTROY the wan port
    (i suggest to remove the beta from the site)

    and now the question: is there a chance to re-flash an adsl2mue (the one with the bad firm try is already opened) using the internal console port and/or the other unsoldered ports on the electronic board?
    i found some interesting info but doesn't talk about a "Normal" (with a gui) firmware and for sure is possible

    thx to all for any suggestion, i hope in some help (in the meantime i have ordered other brand modem,but i'd like to see two indentical devices (are connected with a wrt54gs) and so i hope to use this .... of hardware)

    i think that this kind of solution is positive for the linksys:
    1) some user open the devices and byebye warranty ;)
    2) if opening the devices and solving this issue solve the problem there are less hw return to linksys :thumb:
    3) the advanced used can talk "with good words" for the brand, at today really impossible (wag54 was excellent, wrt54 is awesome, and surely there are many other good hw) for the people that use this adsl2mue
  2. R0ut3r

    R0ut3r Network Guru Member

    building jtag... up
    i need help to put the firm in the adsl2mue.. :)
  3. R0ut3r

    R0ut3r Network Guru Member

    i hope in some help: the new modem (other brand..) seems to work flawlessy
    no 1 can help me, and so , i think, many other adsl2mue users?

    in few words: disconnection problem with the need of a reboot (on 3 different adsl2mue)
    with newest firmware the disconnection rate is worst and not reversible with older firm (on 3 different adsl2mue)
    i need some help for repair (software) an adsl2mue and try other brands firmware (with console or ejtag too)

    (if some developper read.. the wag54g v2.. with the newest firm i have (the same?) big problem with the pppoe protocol, no prob at all with pppoa or with older firmware, but this time is reversible)
  4. R0ut3r

    R0ut3r Network Guru Member

  5. HiSpeed

    HiSpeed Network Guru Member

    Dreamer ! ;-)
  6. R0ut3r

    R0ut3r Network Guru Member

    ehehe.. funny..

    .. a question: i read many post around the web for the same problem
    linksys say again to me to send back the modem(s) again..
    ok i can send back the 3 modems.. ok only 2 (one die trying other brand firm), but they return in the same state, with an old firmware (a bit more stable, but not more: 2 days and the need to turn off/on, and i don't talk about a massive connection: is enough turn on the connection without any client connected and the conn keep alive)
    is it possible that there's not a solution??? is this hw so bad?

    [like reported before: no prob with an old linksys router and with another brand modem!]
  7. mrgamer

    mrgamer Network Guru Member

    a question

    i'm a formerly user of a dlink 300T that was an AR7 modem too (like the ADSL2MUE) and for update/flash it i always used the ADAM2 bootloader!
    i've read that the ADSL2MUE has a PSPBOOT bootloader that is used also on some dlink 300T, and it works fine for update firmware

    then is my question: does the bootloader works to you?
    it should be on different partitions, so pspboot should work as expected: those AR7 modems have 4 partitions like described on linux-mips

    ps: my adsl2mue will come home in 2 days at max, but i will not test it without the chance to flash it back to 4.12 EU
  8. HiSpeed

    HiSpeed Network Guru Member

    Yes, send them back and ask an other product for replacement...
    They have sent an AG241 sometime, but now with the new products AM200, etc., may be an other choice is possible... :wink:
  9. R0ut3r

    R0ut3r Network Guru Member

    if the product is replaced with other hw i can try this chance ty hispeed
    if not is a nonsense

    ok, but one is opened and bricked :p
  10. Toxic

    Toxic Administrator Staff Member

    excuse me.....the solution is

    1. Do not upgrade the firmware unless you have the correct version for your hardware, and you know what you are doing.

    end of lesson tbh.

    why not just get the units replaced.
  11. R0ut3r

    R0ut3r Network Guru Member

    sry toxic
    ok i tryed another firm, a wrong one, but only because 3!!! of these hw doesn't work @ my home, so a new one adsl2m replaced with an identical hw for sure can't help

    for the other two i have read a nice answer, i hope in a similar solution

    but for one.. is it possible that no1 can suggest me an (heavy) rescue method (only for a try.. if it doesn't work no prob at all)?
    well accepted via private message too
  12. mrgamer

    mrgamer Network Guru Member

    by the way i'm using my adsl2mue with a wrt54gl in bridge connection, that goes smooth: really good latency and no disconnection (seems also to get adsl line details with a bit more SNR margin)

    just for let you know that not all are broken :p
  13. R0ut3r

    R0ut3r Network Guru Member

    perhaps i'm a bit unluck with this device ...
  14. tuannd

    tuannd Network Guru Member

    I am LINKSYS Reseller in Vietnam
    I just sale arround 100 ADSL2MUE, and we have now arround 30 Unit defected.

    The Power Led RED all the time, and device was died.

    ADSL2MUE in my country just able to work with some DSLAM (such Siement), some other DSLAM (such from Zyxel, Alcatel) didn't work

    We have tried many firmware such 4.12, 4.19, 4.22 and TI firmware. But problem still the same, very high failure rate

    I was very sad with this kind of LINKSYS quality !
  15. R0ut3r

    R0ut3r Network Guru Member

    with the mrgamer help i'm up (48+ hours without a drop/hang!) with a just de-bricked adsl2mue :)
    i haven't hard-tested the other 2 but i think that the prob is solved in all.. (with a fast test the connection is up for more than 15min, more than before)
  16. R0ut3r

    R0ut3r Network Guru Member

    i want to say that with the clean partition and the default firmware 4.12, one adsl2mue (the bricked one... :D ) is connected since the 08/20/2006 :D
    some days ago loose the adsl line, but there was a thunderstorm and in that situation can happen i think ;)
    again many thx to mrgamer,don't forget that his help save linksys from many hw return/working time/reshipment and allow to every user to try to repair their units
    only for me linksys have saved 3 return + 3 working time + 3 shipment
    all this with a simply thread :D
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice