ADSL2MUE go back to 4.12 firmware

Discussion in 'Other Linksys Equipment' started by mrgamer, Aug 7, 2006.

  1. mrgamer

    mrgamer Network Guru Member

    i'm making this thread for everyone that wants flash the modem back to the original firmware
    want to specify that i NOT tried if that works, since i never changed my firmware yet (i don't need routing/NAT capabilities) but i've read that few people wants to flash it back

    first thing: access your modem, via telnet if you have the newer firmwares or via SSH if you have old ones

    accessing via SSH, you will get into a CLI enviroinment; you can use it for configure your modem or go straight to the shell like this:

    cli> shell
    Starting /bin/sh
    Type exit to return to the CLI
    BusyBox v0.61.pre (2004.10.19-18:15+0000) Built-in shell (ash)
    Enter 'help' for a list of built-in commands.
    at that point most interesting thing to do is
    cat proc/ticfg/env
    that will print something like
    # cat proc/ticfg/env 
    ProductID       AR7RD
    HWRevision      Unknown
    SerialNumber    none
    MEMSZ           0x01000000
    FLASHSZ         0x00400000
    CPUFREQ         150000000
    SYSFREQ         125000000
    MODETTY0        38400,n,8,1,hw
    MODETTY1        38400,n,8,1,hw
    MAC_PORT        0
    mtd0            0x900a0000,0x90400000
    mtd1            0x90020000,0x900a0000
    mtd2            0x90000000,0x90010000
    mtd3            0x90010000,0x90020000
    autoload        1
    BOOTCFG         m:f:"mtd1"
    USB_VID         0x0451
    USB_PID         0x6060
    HWA_RNDIS       00:E0:A6:66:41:EB
    HWA_HRNDIS      00:E0:A6:66:41:E1
    usb_vid         0x13b1
    usb_pid         0x000f
    usb_prod        Linksys RNDIS Network Adapter
    connection0     0
    HWA_0           00:12:17:79:8C:D8
    PROMPT          (psbl)
    important lines are

    IPA - the ip address for flash your modem via the bootloader (PSPboot)
    mtd0...1...2 - your partition allocation, probably changing firmware, changes also those variables

    for save your current filesystem/kernel you can do:

    # dd if=/dev/mtdblock/0 of=/var/filesystem.img
    # dd if=/dev/mtdblock/1 of=/var/kernel.img
    # /usr/sbin/thttpd -g -d /var -u root -p 88
    that will open an http service on port 88 that will let you download your firmware

    okey, for flash your modem back you should:
    1) prepare a commandline
    2) write "ftp IPA" (ex: ftp not pressing enter yet
    3) turn off/reboot your modem
    4) after 5 seconds alike push enter and access your bootloader

    should be like this:
    Connected to
    220 ADAM2 FTP Server ready.
    User (
    password/username are both "adam2"
    at this point we will resize our partitions with the 4.12 firmware sizes:
    quote SETENV mtd0,0x900a0000,0x90400000
    quote SETENV mtd1,0x90020000,0x900a0000
    ( mtd2 contains the bootloader and should NEVER be touched, mtd3 contains the config of your modem, and usually is always 64kb.. so no need to be modified)
    now reboot your modem with new partitions sizes
    quote REBOOT
    you have to wait another 5-6 seconds and then re-access your PSPboot enviroinment
    ok now let's flash it:
    - prepare your kernel/filesystem files where u like it (ex: c:\ )
    quote MEDIA FLSH
    put filesystem.img "fs mtd0"
    put kernel.img "krn mtd1"
    at this point let's reboot and cross your fingers that your new flashed modem will work :)
    quote REBOOT
    OK now, if you are lucky you should get back to 4.12-EU version of the firmware
    still that's a "prototipe" guide, i just saved my kernel/filesystem files but i've not tried to flash it back
    in any case until your bootloader will start you can debrick your modem without any JTAG, but just with a couple of working kernel/filesystem

    get files from
  2. R0ut3r

    R0ut3r Network Guru Member

    luckly some dev read :)
  3. R0ut3r

    R0ut3r Network Guru Member

    i'm trying just now to re-put the old firm on a adsl2mue
    tryed first with telnet but there's not a connection, so i have downloaded putty and opened an ssh connection to
    but i cannot login!

    this in the putty windows:
    login as: admin
    admin@'s password:
    Access denied
    admin@'s password:

    this in the adsl2mue log panel:
    login attempt for nonexistant user 'admin' from (null)

    i have tryed to reset the hw but nothing change
    any further suggestion?

    Edit: the ssh connection doesn't work, but, with your help i have just debricked one adsl2mue: THX!!
    as soon as possible i will test they with the telephone line
  4. cm048

    cm048 LI Guru Member

    Please try
    ID -> root
    PASS -> admin

    For me, it is valid for both ftp / ssh.
  5. R0ut3r

    R0ut3r Network Guru Member

    on one adsl2mue is up a connection test (behind a wrt) and at the moment is 16 hour up (fingers crossed)
    tested the ssh login on another, and YES, usr/pwd are root/admin
  6. mrgamer

    mrgamer Network Guru Member

    nice to hear, that was a "test" guide :) since was all theory and no practice (i've not updated my adsl2mue to 4.22 version)

    so, seems it works :thumbup: !
  7. cm048

    cm048 LI Guru Member

    Hi Mrgamer,

    Are there any point that specify the version number in the env ?

    What I have and list below is version 4.23-TH specially developed for Thai market after disaster in the original version.

  8. R0ut3r

    R0ut3r Network Guru Member

    the advantage of this recover procedure is that you can try any adsl2mue firm that doesn't modify the pspboot (bootloader)
    if yours adsl2mue had from factory a different firm (mrgamer dump the "european 4.12 eu"), you can always dump one from a fully working unit like reported in the begin of the thread, since the partition size are the same ;)
    and use that dump for a try with a defective unit
  9. mrgamer

    mrgamer Network Guru Member

    sorry but no, that env file contains informations about bootloader
  10. R0ut3r

    R0ut3r Network Guru Member

    it works it works :thumbup:
  11. daniels2007

    daniels2007 LI Guru Member

    ADSL2MUE Problem to upgrade 4.22EU to 4.12EU

    After a big error in files'order flashing an ADSL2MUE during
    the upgrade of 4.12EU to 4.22EU (with a model serial n°MGY05E910325)
    My modem is dead because no ADSL synchro is possible, but i can access
    to the modem via telnet, ssh et http.
    But it is impossible to acces at the boot sequence via ADAM2.

    My modem has a PsBoot loader, is ADAM2 running yet on my modem ?

    I want to flash the modem back to the original firmware 4.12EU
    I thing the mtdx bloc are wrong.

    I order a RS232 TTL cable to acess in the boot sequence via the
    serial solder port, is a correct way ?

    Thanks to explain me if there is another methode with PSPBoot
    command line who is very different from ADAM2.

    Here is my modem's info.
    PS: my english is bad....(i am french)

  12. mrgamer

    mrgamer Network Guru Member

    all the adsl2mue modems have pspboot bootloaders
    dunno why exactly, but pspboot emulates ADAM2 prompts (prolly for compatibility)... the main difference between them are firmwares that you can flash in the modem (some particular firmwares are compatible with both the loaders, but don't ask me why.. i'm not a firmware coder/modder)

    anyway in order to boot the modem clearly HAS the bootloader ;) so you can access it in a way or another
    this means: the cable is not needed
    just try harder and login to the bootloader :redface:

    PS: for everyone, i've never built a rs232 cable... so don't ask me stuff about that in private
  13. daniels2007

    daniels2007 LI Guru Member

    thank you for the blow of hand, but the bootloader access problem comes that the time of 3 second di boot is exceeded when the connection in USBnet or Ethernet is active (I am under linux xunbuntu)
  14. daniels2007

    daniels2007 LI Guru Member

    ADSL2MUE back to 4.12 works

    At the end, I found the idea and that I walk reloaded the firmware 4.12E successfully, my modem is ressucited with the remarks above:

    Yes but you must use the ethernet cable with active DHCP,
    with the USBnet no connection at boot is possible....:cool:

    see the article :
    Normally ADAM2 uses or but it may have DHCPOFFER
    which means that it will request an IP address from the network DHCP server,
    obviously if you don't have a DHCP server on your network you won't be able
    to access ADAM2 via FTP/Telnet.

    I think the rs232 cable is usefull when the bootloader is dead.

    better greetings
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice