ADSL2MUE in Bridge Mode - Not Accepting PPPoE

Discussion in 'Networking Issues' started by neil.sunerton, Aug 29, 2006.

  1. I have a Linksys ADSL2MUE (formware version 4.12-UK) (the "modem") connected
    between my router (a Linksys WRT54GL v1.1 running OpenWRT) by Ethernet and
    my ADSL line (Easynet's LLUStream service). I have set the modem in Bridge
    Mode Only and the router is set to connect to the Internet using PPPoE.
    The router cannot bring the PPP up. The modem's DSL light is on.

    My intended result is to have my router connect to the Internet using the modem
    purely as a modem and have the router route my static IP address range to
    my LAN.

    I have tested the modem by having it connect to the Internet using PPPoA and
    performing NAT. That works fine. (Easynet's setting are VPI=0, VCI=38 and Mux=VC)

    I have tried the modem in Bridge Mode Only and connecting it's Ethernet port
    directly to a Windows XP machine and having the Windows machine connect to the
    Internet using PPPoE. This does not work.

    I have connected a packet sniffer to the Ethernet between the router's WAN port and
    the modem while attepting to start PPPoE. The trace reveals PPPoE Active Discovery
    Initiation packets being sent by the router but no response from the modem:

    Ethernet II, Src: (00:16:b6:da:6e:74), Dst: Broadcast (ff:ff:ff:ff:ff:ff)
    Destination: Broadcast (ff:ff:ff:ff:ff:ff)
    Source: (00:16:b6:da:6e:74)
    Type: PPPoE Discovery (0x8863)
    PPP-over-Ethernet Discovery
    Version: 1
    Type: 1
    Code: Active Discovery Initiation (PADI)
    Session ID: 0000
    Payload Length: 12
    PPPoE Tags
    Tag: Service-Name
    Tag: Host-Uniq
    Binary Data: (4 bytes)

    I have tried power cycling and performing factory resets on the modem.
    I've looked through the Linksys support resources, used Google
    and have read RFC2516. I've followed the instructions at I'm having a lengthy and increasing
    pointless support conversation with Linksys.

    My current thoughts are:

    1) that the modem requires a specific value for the Service-Name field
    (I've asked Linksys about this with no answer).

    2) that the modem is faulty (doubtful) or there is a bug in its firmware.

    Thanks for your attention,

    Neil Sunerton
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice