AdvancedTomato - Flat/Material designed web GUI (Shibby base)

Discussion in 'Tomato Firmware' started by Jacky444, Jul 23, 2014.

  1. Jacky444

    Jacky444 LI Guru Member

    My builds went through now too! Though I'm worried to release them officially not to brick routers :/.

    Anyone dare to try? I have builds for:
    - Asus RT-AC66U
    - Asus RT-N66U (AC Wireless drivers)
    - Tenda W1800R
  2. Tim.LSR

    Tim.LSR Networkin' Nut Member

    I will try the N66U, where do I get the image?

    Sent from my SM-N910W8 using Tapatalk
  3. Jacky444

    Jacky444 LI Guru Member

  4. Tony Arnold

    Tony Arnold Serious Server Member

    Looks like there's something pretty wrong with QoS in @shibby20's latest release (and subsequently AdvancedTomato). The `fq_codel` QoS scheduler is missing, and QoS isn't working at all outside of that.

    I've disabled it for now, but if you need QoS maybe wait until 135 is out.
  5. flauchhaus

    flauchhaus New Member Member

    It seems I'm not able to activate any IPv6 Settings - it wont apply when clicking on the save button. (RT-AC68U, Advanced Tomato 3.1-134 AIO, NVRAM reset was done on upgrading)
  6. TronixA

    TronixA Reformed Router Member

    Hi Tony, I can confirm that QOS is dead on my router as well. I'll be going back to 3.1-132 until this is fixed.
  7. mihalski

    mihalski New Member Member

    I just upgraded to the latest build on my Asus RT-AC68U and my WAN PPPoE settings vanished and even if configured I could not connect.. I downgraded back to the last build and the settings came back and I was able to connect.

    Anyone else experience this?
  8. DjonniDK

    DjonniDK Reformed Router Member

    I'm all new to custom firmware on routers, but due to great experience in performance on custom ROMs on phones/tablets I gave it go.

    Got v132 on my R7000. Everything went well and I'm already loving all the features... especially ARP binding.

    Unfortunately the WiFi performance dropped from 433 Mbit on 1 band 5 ghz to 200 Mbit.

    Is this normal/too be expected?

    Sent from my Oneplus 2
  9. vincom

    vincom LI Guru Member

    installed on ac66u v133 shibby.
    installed v3.1-134 fine but had to reset to have working internet connection

    edit: its not stable, lost internet connection when adding some port forward rules, would not reconnect once rules removed even though status states connected.
    imo not ready for primetime, maybe thats why shibby has not released v34 yet.
    Last edited: Mar 19, 2016
  10. srwal

    srwal Serious Server Member

    I have 2 questions? Any AC drivers for the ASUS RT-68U, and did anyone flash the Linksys E900?

    I'm willing to test the E900 if no one has a yet.
  11. Tony Arnold

    Tony Arnold Serious Server Member

    Looks like @shibby20 has released v135 to address the issues introduced in the last couple of versions.

    Looking forward to an update to AT when you have the time, @Jacky444.
    eris23 likes this.
  12. chchia

    chchia Network Guru Member

    I confirm that 134, IPV6 setting cannot be saved.
  13. Jacky444

    Jacky444 LI Guru Member

    There is nothing on GIT yet but as usually when Shibby pushes to git and I have time update will come.
    Tony Arnold likes this.
  14. chchia

    chchia Network Guru Member

    Jacky can you also look into issues where IPv6 page cannot perform save.

    Wow, i saw you fixed it, tq!
    Last edited: Mar 22, 2016
  15. kupony

    kupony New Member Member

    I'm using advanced tomato v132 on my r7000. I am running a vpn on the router - that only selectively routes certain ip's and websites. I also use the installed transmission client to download torrents to a usb stick on the router.

    If the vpn client is turned on (running) does the transmission torrent download go through the vpn or not? I haven't specified any other IPs except my two phones to go through the vpn, so my computer goes through the router and uses the regular isp connection.

    Not sure how the transmission behaves in this scenario (the reason I ask is that on a highly popular torrent it barely connects to seeds... once it does find a good seed, it will download just fine, but it takes a long time for it to find a good seed (sometimes hours)). I don't necessarily need transmission to go through vpn.
  16. InsaneNutter

    InsaneNutter Addicted to LI Member

    Is that the reason no download's appear to work on

    Just tried to download Tomato for the Asus RT-N16, however all downloads on the site appear to give a 404 error.
  17. srwal

    srwal Serious Server Member

    @flachhaus, are you getting AC wireless on the RT-AC68U?

  18. Jacky444

    Jacky444 LI Guru Member

    This was fixed few hours ago.
  19. Tony Arnold

    Tony Arnold Serious Server Member

    I've updated to v135, tested for a few hours, and promptly gone back to v132. QoS just doesn't seem to be working properly post the MultiWAN changes — I realise this isn't your doing, @Jacky444. QoS is categorising traffic incorrectly, and is restricting speeds to well below what is configured and working under v132.

    I've found a few bugs in the AT web UI (specifically on the QoS graphs screen — it hasn't been updated to use the new MultiWAN nvram variables) — I'll try to submit a PR for that in the next few days.

    Thanks for your hard work on AT, Jacky!
  20. Jacky444

    Jacky444 LI Guru Member

    I did go through every change on QOS pages so that's rather weird! MultiWAN brings lots of changes and new things so its not so strange that things go wrong :)
  21. Tony Arnold

    Tony Arnold Serious Server Member

    Try toggling the "Zoom Graphs" button. That's where I saw the issue.
  22. DracoMilesX

    DracoMilesX Networkin' Nut Member

    Just wondering do you need to do a NVRAM reset when coming from 132 to 135?
  23. Jacky444

    Jacky444 LI Guru Member

    I didn't notice any issues, though I don't use QOS (its disabled) and since I have no traffic on the testing router its really not showing up anything. I will check it though and compare sources

    Yes, same terms apply as from any version to next version.
  24. flauchhaus

    flauchhaus New Member Member

    Thank you for fixing the IPv6 bug so quickly!

    Testing with a 2015 Mac which has 1300 802.11ac it seems to connect with AC speeds, however the actual bandwidth seems to be just half as I'm getting 38-50MiB/s on the Asus with Adv. Tomato vs 84-90MiB/s on an Apple TimeCapsule with ac (copy from SSD to SSD over SMB)
    [​IMG] [​IMG]
  25. PANiCnz

    PANiCnz New Member Member

    Same issue on a N60 with 135, have downgraded back to 132 and everything is now working as it should.
  26. chchia

    chchia Network Guru Member

    Hi Jacky,

    I trying to compile your latest AT, but i am stuck with this error which i have no idea how to fixed it at all, can you help?

    checking whether pthread_cond_timedwait is posix like... checking whether pthread_cond_timedwait is posix like... (cached) yes
    ./configure: line 15898: syntax error near unexpected token `mutex_has_default,'
    ./configure: line 15898: `GLIB_IF_VAR_EQ(mutex_has_default, yes,'
    Makefile:421: recipe for target 'config.status' failed
    make[5]: *** [config.status] Error 2
    make[5]: Leaving directory '/home/chchia/advancedtomato-arm/release/src-rt-6.x.4708/router/glib'
    Makefile:1881: recipe for target 'glib-install' failed
    make[4]: *** [glib-install] Error 2
    make[4]: Leaving directory '/home/chchia/advancedtomato-arm/release/src-rt-6.x.4708/router'
    Makefile:122: recipe for target 'all' failed
    make[3]: *** [all] Error 2
    make[3]: Leaving directory '/home/chchia/advancedtomato-arm/release/src-rt-6.x.4708'
    Makefile:927: recipe for target 'bin' failed
    make[2]: *** [bin] Error 2
    make[2]: Leaving directory '/home/chchia/advancedtomato-arm/release/src-rt-6.x.4708'
  27. RobertYamazaki

    RobertYamazaki Network Newbie Member

    @Jacky444 the option administration > debugging > clear cookies give a error 0
  28. AndreDVJ

    AndreDVJ LI Guru Member

    Try installing libglib2.0-dev
  29. chchia

    chchia Network Guru Member

    i do have the libglib2.0-dev, but compilation still fail.

    by the way, what could be the reason why i cannot see the ethernet portstate in my router?

  30. bonds1972

    bonds1972 New Member Member

    I've upgraded my RT-AC66U from 132 to 135, but right now I cannot add any downloads to the Transmission 2.92 application. I've tried using torrent file as well as magnet url, but nothing works. I also looked at the debug level transmission.log, but no error messages was shown.

    Anybody have the same problem?
  31. Jose C

    Jose C Serious Server Member

    I have kind kind of the same issue, if I add a torrent from my phone to transmission it will not work, but if I add the exact same torrent from a pc will work with no issues at all

    Sent from my iPhone using Tapatalk
  32. AndreDVJ

    AndreDVJ LI Guru Member

    Transmission works for me on an R7000 unit. However it doesn't work very well.
    For some reason, file name can't be that long or must have a dash to separate two strings (#clearcookies.asp should have been #clear-cookies.asp).

    With these changes, Clear Cookies works as intended now:
    Cleared Cookies
    Cleared Cookies
    No cookie found!
  33. Thomas Evensen

    Thomas Evensen New Member Member


    Please let me know it this post is more suited elsewhere.

    I downloaded version 3.1-132 of the initial-64K.chk and the VPN-64k.trx from the R7000-page on the AdvancedTomato homepage

    I then followed the instructions from the linked youtube-clip.

    After the initial factory reset in Genie (where it changed the SSID and WEP-password to the router default), I uploaded and flashed with the initial-64K.chk-image. After the R7000 rebooted, I wasn't able to log into the SSID-wlan (NETGEAR17) with the default password.

    I tried to connect by ethernet but only get a 169.254.x.x-ip.

    I've also rebooted the router several times and tried a hard reset.

    Any ideas on where I went wrong and how I can connect to my router so i can either continue the process or revert back to the stock Netgear-FW?

    Any help is appreciated.
    Last edited: Apr 10, 2016
  34. AndreDVJ

    AndreDVJ LI Guru Member

    You need to manually set an IP address to your Ethernet interface. It's advised to do that by 0:20 in the video.
  35. Thomas Evensen

    Thomas Evensen New Member Member

    Doh. Used laptop without ethernet and thought it would work with wlan. My bad.

    Found an older laptop with ethernet and it looks good nok.

  36. Tony Ramirez

    Tony Ramirez Reformed Router Member

    Want to thank the author for this firmware. At first when I got my R7000 I used the stock firmware which is so ugly and limited that I tried Kong DD-WRT. It worked okay but every few days there was a update that will always break something from slow Wifi speeds that will be fixed in the next update just to break again.

    I used Kong DD-WRT for about 4 months but then I decided to try Advanced Tomato. I read the instructions to first flash form DD-WRT back to stock. Then reset using the pin and then to flash the *.chk file first then the main firmware next. At first I tried the newest build v3.1-135 but after reading issues here I went to v3.1-132 doing a full NVRAM reset. Well my 5ghz Wifi is stronger and has better through-port. Meaning that in the bathroom which is the weakest room I still get 2 out of 4 bars on my Nexus 6 but I am able to browse sites when with DD-WRT they will stall and time out.
    Last edited: Apr 12, 2016
    pegasus123 likes this.
  37. DarKHawK

    DarKHawK Reformed Router Member

    Hello Jacky,

    Any ETA on v136?

  38. Jacky444

    Jacky444 LI Guru Member

    Shibby didn't even update git yet and u already want an update lolz :D why people just don't understand we're not working on this full time nor getting paid to do the job. This is free, open source project and we do it when we have time for it. As soon as GIT is updated when I have time I'll look into it.
  39. Tony Arnold

    Tony Arnold Serious Server Member

    > Shibby didn't even update git yet and u already want an update

    I don't think for a minute that people don't appreciate you're doing this off your own back, in your own time for no money (I certainly do!). In the past when I've asked the same question, it's been because I didn't understand that @shibby20 doesn't work in the open (he pushes his code to Git after releasing the binaries), so I didn't know that there was always a delay before you got access to the code.

    I assume that people may also be unaware of how far AT's UI code has diverged from "standard" Tomato, so it's not just a matter of merging/rebasing Shibby's changes into your repo.

    Maybe (when you have time) a couple of lines in the FAQ on might help alleviate questions like this in future?

    Thanks again for your hard work, @Jacky444.
    DarKHawK likes this.
  40. Tony Arnold

    Tony Arnold Serious Server Member

    Oh right, it's there already. RTFM, I guess — my bad.
  41. shibby20

    shibby20 Network Guru Member

    because first i need to prepare all commits before push to git. And this is why i need sometimes to make a delay between release and push sources to git :)

    @Jacky444 - arm sources updated. Have fun :)
  42. JTD121

    JTD121 Addicted to LI Member

    So every couple months, I check to see if there is an update; usually logging into my router and there's an infobox at the top.

    I went to the download site today, and it says
    I'm currently running 3.1-132 AIO-64K, should I be able to upgrade alright? Made a config backup just in case, though! ;)

    Also, there look to be two downloads for 3.1-135; one is 20.43MB, the other 7.98MB. I don't see an explanation of the differences....?
  43. AndreDVJ

    AndreDVJ LI Guru Member

    The 20MB Download is the "AIO" image, and the other one is the "VPN" one.

    The chart attached is rather old but can give you an idea of what features is built-in.

    For further details you need to look into the Makefile.

    Attached Files:

  44. Jacky444

    Jacky444 LI Guru Member

    Thanks Shibby! I'm waiting for RT-AC as well but take your time =).

    Ah its all ok guys, just don't be inpatient, it frustrates me :)
  45. Dibbles

    Dibbles Connected Client Member

    Just thought that I would check out a "tomato" firmware for my R7000 and then discover the possibility to have that with a shiny GUI :)
    Is the AdvancedTomato website down for everyone or is it just me...?

    If I did go and test out the 136 release of Tomato would it be easy enough to go from that to the advanced one when prepared...?

  46. AndreDVJ

    AndreDVJ LI Guru Member

    Yes, just flash AT on top of Shibby's build. AT is a GUI for Shibby's mod. There's no difference under the hood.

    Are you still on Genie? If so you need to follow few instructions before flashing AT or any other firmware here.
  47. Dibbles

    Dibbles Connected Client Member

    Thanks for that. I am on a Genie build.
    Now that the Advanced Tomato website is working for me I could then read the FAQ's etc. I also download the YT videos on how to flash as well as all the files needed to go to and from the Tomato builds, as required.. Understanding that the AT build is a different UI to the Shibby build will make the transition easier, in terms of flashing, when it arrives.
  48. Sean Rhodes

    Sean Rhodes Networkin' Nut Member

    Hi Jacky,

    I noticed you have builds for the 7000, so what's the chance in the future of an ASUS RT-AC3200 build, or is there one already?

    I see in some of the changelogs, you mention adding fixes for the RT-AC3200, but I can't find it on your website, so I don't know if there is a build or not.

    I looked through the previous threads, shibby's makefiles are under:
    Last edited: Apr 18, 2016
  49. babhishek

    babhishek LI Guru Member

    @Tony Ramirez : bathroom browser man!!
  50. Jacky444

    Jacky444 LI Guru Member

    For what is worth, I'd like to ask people (this goes to all who will read this) to stop sending me emails "when will you release 136" and so on because I will not release updates until all the images/code edits are ready!

    When Shibby updates GIT for ARM, I modify my work to fit his and then wait for RT-AC repository. Once all is done and my work is done I compile ALL the images and upload them to the web server. Now Shibby shares every thing sooner than I get my hands on (I totally understand why because the feeling of sharing latest updates with users is <3 awesome) so there is a delay up to 14 days. Not to mention I'm not always available or have time.

    People are so inpatient hah :p big companies like Sony, Huawei, Samsung, HTC, etc... take months to release Android updates (not to mention that usually they must also only merge newest android changes) and they have PAID TEAMS working on it. We are solo developers giving out our FREE time to work on Tomato and each with his own FORK. Its just unfair.

    Note: This post is not for members of Linksysinfo forums because I know most of them understand us. I just hope to show this to people who are new to this and who email me. I get daily 10+ emails...
  51. Nazgulled

    Nazgulled Serious Server Member

    I'm sorry if this has been asked to death but I don't want to ruin a perfectly working router...

    I'm currently on AT 3.0-132 and I've noticed a couple of versions were released in the meantime. I read all changelogs and there's something nice things that I'd like to get my hands on. One of the changelogs stated "Attention: You have to erase nvram after upgrade!!".

    So, what's the recommended procedure to install the latest version (at the time of writing 3.1-135) but keep all my settings? I don't want to have to reconfigure everything manually again, if it's avoidable.

    Thanks for understanding.
  52. AndreDVJ

    AndreDVJ LI Guru Member

    Upgrading from 132, erasing nvram is mandatory. There are new nvram variables, and sometimes people are already running at the limit. If you upgrade a router under this circumstances, you risk bricking your router.

    You have to note down your settings and reconfigure everything. What can help you is to save a dump of your nvram. You cannot import it back in (not possible as-is) but will certainly help with many settings such as port forwarding, bandwidth limiter rules, DHCP reservation, etc.

    So after you noted down your settings, all you have to do is to upgrade the firmware, and remember to tick the checkbox After flashing, erase all data in NVRAM memory in order to restore Tomato defaults.
    Nazgulled likes this.
  53. Jacky444

    Jacky444 LI Guru Member

    I can't compile newest version haha this is just awesome ^^ every 2nd version something goes wrong and I can't figure out what. I hate this fragile compilation process!

    g -DBCMWPA2 -DBCMARM -marm  -DTCONFIG_NVRAM_64K -DLINUX_KERNEL_VERSION=132644 -ffunction-sections -fdata-sections  -DVERSION='"2.73"'          -c auth.c
    arm-brcm-linux-uclibcgnueabi-gcc -Wall -W -O2 -I/home/jacky/advancedtomato-arm/release/src-rt-6.x.4708/router/nettle/include -I/home/jacky/advancedtomato-arm/release/src-rt-6.x.4708/router/gmp -DHAVE_DNSSEC -DHAVE_DNSSEC_STATIC     -DUSE_IPV6     -DUSE_IPSET     -DHAVE_BROKEN_RTC -DHAVE_TOMATO -DLINUX26 -DCONFIG_BCMWL5 -DCONFIG_BCMWL6 -DCONFIG_BCMWL6A -DPART_JFFS2_GAP=0UL -pipe -fno-strict-aliasing -DBCMWPA2 -DBCMARM -marm  -DTCONFIG_NVRAM_64K -DLINUX_KERNEL_VERSION=132644 -ffunction-sections -fdata-sections  -DVERSION='"2.73"'          -c ipset.c
    arm-brcm-linux-uclibcgnueabi-gcc -Wall -W -O2 -I/home/jacky/advancedtomato-arm/release/src-rt-6.x.4708/router/nettle/include -I/home/jacky/advancedtomato-arm/release/src-rt-6.x.4708/router/gmp -DHAVE_DNSSEC -DHAVE_DNSSEC_STATIC     -DUSE_IPV6     -DUSE_IPSET     -DHAVE_BROKEN_RTC -DHAVE_TOMATO -DLINUX26 -DCONFIG_BCMWL5 -DCONFIG_BCMWL6 -DCONFIG_BCMWL6A -DPART_JFFS2_GAP=0UL -pipe -fno-strict-aliasing -DBCMWPA2 -DBCMARM -marm  -DTCONFIG_NVRAM_64K -DLINUX_KERNEL_VERSION=132644 -ffunction-sections -fdata-sections  -DVERSION='"2.73"'          -c domain.c
    arm-brcm-linux-uclibcgnueabi-gcc -Wall -W -O2 -I/home/jacky/advancedtomato-arm/release/src-rt-6.x.4708/router/nettle/include -I/home/jacky/advancedtomato-arm/release/src-rt-6.x.4708/router/gmp -DHAVE_DNSSEC -DHAVE_DNSSEC_STATIC     -DUSE_IPV6     -DUSE_IPSET     -DHAVE_BROKEN_RTC -DHAVE_TOMATO -DLINUX26 -DCONFIG_BCMWL5 -DCONFIG_BCMWL6 -DCONFIG_BCMWL6A -DPART_JFFS2_GAP=0UL -pipe -fno-strict-aliasing -DBCMWPA2 -DBCMARM -marm  -DTCONFIG_NVRAM_64K -DLINUX_KERNEL_VERSION=132644 -ffunction-sections -fdata-sections  -DVERSION='"2.73"'          -c dnssec.c
    arm-brcm-linux-uclibcgnueabi-gcc -Wall -W -O2 -I/home/jacky/advancedtomato-arm/release/src-rt-6.x.4708/router/nettle/include -I/home/jacky/advancedtomato-arm/release/src-rt-6.x.4708/router/gmp -DHAVE_DNSSEC -DHAVE_DNSSEC_STATIC     -DUSE_IPV6     -DUSE_IPSET     -DHAVE_BROKEN_RTC -DHAVE_TOMATO -DLINUX26 -DCONFIG_BCMWL5 -DCONFIG_BCMWL6 -DCONFIG_BCMWL6A -DPART_JFFS2_GAP=0UL -pipe -fno-strict-aliasing -DBCMWPA2 -DBCMARM -marm  -DTCONFIG_NVRAM_64K -DLINUX_KERNEL_VERSION=132644 -ffunction-sections -fdata-sections  -DVERSION='"2.73"'          -c blockdata.c
    dnssec.c:22:24: fatal error: nettle/rsa.h: No such file or directory
    compilation terminated.
    /home/jacky/advancedtomato-arm/release/src-rt-6.x.4708/router/dnsmasq/Makefile:156: recipe for target 'dnssec.o' failed
    make[6]: *** [dnssec.o] Error 1
    make[6]: *** Waiting for unfinished jobs....
    make[6]: Leaving directory '/home/jacky/advancedtomato-arm/release/src-rt-6.x.4708/router/dnsmasq/src'
    Makefile:82: recipe for target 'all' failed
    make[5]: *** [all] Error 2
    make[5]: Leaving directory '/home/jacky/advancedtomato-arm/release/src-rt-6.x.4708/router/dnsmasq'
    Makefile:942: recipe for target 'dnsmasq' failed
    make[4]: *** [dnsmasq] Error 2
    make[4]: Leaving directory '/home/jacky/advancedtomato-arm/release/src-rt-6.x.4708/router'
    Makefile:122: recipe for target 'all' failed
    make[3]: *** [all] Error 2
    make[3]: Leaving directory '/home/jacky/advancedtomato-arm/release/src-rt-6.x.4708'
    Makefile:929: recipe for target 'bin' failed
    make[2]: *** [bin] Error 2
    make[2]: Leaving directory '/home/jacky/advancedtomato-arm/release/src-rt-6.x.4708'
    Makefile:948: recipe for target 'z' failed
    make[1]: *** [z] Error 2
    make[1]: Leaving directory '/home/jacky/advancedtomato-arm/release/src-rt-6.x.4708'
    Makefile:969: recipe for target 'r7000z' failed
    make: *** [r7000z] Error 2
    Tony Arnold likes this.
  54. AndreDVJ

    AndreDVJ LI Guru Member

    I hate this build system too (and probably everyone hates). For some reason /release/src-rt-6.x.4708/router/nettle/rsa.h could not be located. I've seen this error a couple of times.

    What I would do is to refresh the sources of what's inside nettle directory. It may be a permission issue. I've seen it messing up for no reason.

    Try downloading the tarball:

    1) Delete nettle directory contents (rm -r ~/tomato-arm/release/src-rt-6.x.4708/router/nettle/*)
    2) Extract tarball contents inside the directory.

    I hope this helps.
  55. Jacky444

    Jacky444 LI Guru Member

    I will try out and let u know, thanks Andre you're awesome! :)

    P.S.. Tried every thing even changing permissions to 777 and nothing worked =( gosh
    Last edited: Apr 23, 2016
  56. AndreDVJ

    AndreDVJ LI Guru Member

    That's odd. No open-source components have been updated in a while.

    I recall having more problems when I had both MIPS and ARM repos. I dedicated a virtual machine for ARM only.

    I use Debian Jessie x64. My $PATH variable looks like this:
    My ~/.profile:
    # ~/.profile: executed by the command interpreter for login shells.
    # This file is not read by bash(1), if ~/.bash_profile or ~/.bash_login
    # exists.
    # see /usr/share/doc/bash/examples/startup-files for examples.
    # the files are located in the bash-doc package.
    # the default umask is set in /etc/profile; for setting the umask
    # for ssh logins, install and configure the libpam-umask package.
    #umask 022
    # if running bash
    if [ -n "$BASH_VERSION" ]; then
        # include .bashrc if it exists
        if [ -f "$HOME/.bashrc" ]; then
            . "$HOME/.bashrc"
    # set PATH so it includes user's private bin if it exists
    if [ -d "$HOME/bin" ] ; then
    # set PATH if /opt/hndtools-arm-linux-2.6.36-uclibc-4.5.3 exists
    if [ -d "/opt/hndtools-arm-linux-2.6.36-uclibc-4.5.3" ] ; then
        export PATH=/usr/local/bin:/usr/bin:/bin:/sbin:/opt/hndtools-arm-linux-2.6.36-uclibc-4.5.3/bin
    I will try to build Tomato from Shibby's repo and see how it goes.

    EDIT: I built, but encountered one issue. It fails at ~/tomato-arm/release/src-rt-6.x.4708/router/dnscrypt/src/libevent-modified because it requires Automake 1.15. Debian Jessie has 1.14 as default.

    All I had to do is to get in that directory and issue command autoreconf --force
    andre@debian:~/tomato-arm/release/src-rt-6.x.4708/router/dnscrypt/src/libevent-modified$ autoreconf --force
    And firmware got built.

    I'd suggest to backup your modifications and start over. If you need, push changes to git, and I will compile the images for you.
    Last edited: Apr 24, 2016
  57. Jacky444

    Jacky444 LI Guru Member

    I use this vbox for building only too so I don't even start the machine unless there is firmware to be built. Before 136 so, 135 I had every thing working just fine. Then 136 came and I re-based history yesterday (basically cleaning up ALL my changes and resetting ARM repo to Shibby and adding my changes) so there should be no problem at all...

    Now I'm unable to build ARM (RT-AC repo works fine) with that error. I don't remember upgrading system or installing/removing any packages. I also verified that file is actually there and it is.

    I'm confused

    P.S.: My build command is similar but I run it differently through a PHP script (long story but it allows me really easy builds across various repos, firmwares and images including arranging them into proper folders after completion), I just link tool chains directly without opt symlink (which worked just fine through all versions)
  58. AndreDVJ

    AndreDVJ LI Guru Member

    I upgraded my Debian Jessie today (even kernel got updated).

    andre@debian:~$ uname -a
    Linux debian 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt25-2 (2016-04-08) x86_64 GNU/Linux
    However bison gets upgraded too, and build fails because of that:
    checking for bison... bison -y
    checking for bison version... invalid
    configure: WARNING: bison versions supported for regeneration of the Zend/PHP parsers: 2.4 2.4.1 2.4.2 2.4.3 2.5 2.5.1 2.6 2.6.1 2.6.2 2.6.3 2.6.4 2.6.5 2.7 (found: 3.0).
    checking for re2c... re2c
    checking for re2c version... 0.13.5 (ok)
    configure: error: bison is required to build PHP/Zend when building a GIT checkout!
    Makefile:1995: recipe for target 'php/stamp-h1' failed
    make[4]: *** [php/stamp-h1] Error 1
    make[4]: Leaving directory '/home/andre/advancedtomato-arm/release/src-rt-6.x.4708/router'
    Makefile:122: recipe for target 'all' failed
    make[3]: *** [all] Error 2
    make[3]: Leaving directory '/home/andre/advancedtomato-arm/release/src-rt-6.x.4708'
    Makefile:929: recipe for target 'bin' failed
    make[2]: *** [bin] Error 2
    make[2]: Leaving directory '/home/andre/advancedtomato-arm/release/src-rt-6.x.4708'
    Makefile:948: recipe for target 'z' failed
    make[1]: *** [z] Error 2
    make[1]: Leaving directory '/home/andre/advancedtomato-arm/release/src-rt-6.x.4708'
    Makefile:969: recipe for target 'r7000z' failed
    make: *** [r7000z] Error 2
    After getting bison downgraded, I could get R7000 firmware built just fine.
  59. Jacky444

    Jacky444 LI Guru Member

    Might be something with Kubuntu updates then, meh well no firmware then :D i don't have time to figure out what the hell is wrong, I'm busy. Thanks for helping out!
  60. oneleft

    oneleft New Member Member

    @Jacky444 Im trying to access your bitbutcket repo to pull down and compile using my xubuntu 16.04 guide but it says I do not have permission. Did you make your repo private?
  61. Jacky444

    Jacky444 LI Guru Member

    Sorry, yes it was set to private. I changed back to public!
  62. polandj

    polandj New Member Member

    Jacky, saw your blurb about working on 136, the people emailing you for estimated dates, and the broken ARM build. Just wanted to reach out and say Thanks for working on this. Your effort is appreciated, don't let em get you down. It's unfortunate that popular open source projects don't get more love.

    I do share your hate of the brittle build process, though. :)
    Jacky444 likes this.
  63. AndreDVJ

    AndreDVJ LI Guru Member

  64. Jacky444

    Jacky444 LI Guru Member

    PR would be awesome because I keep forgetting :p. What do you mean with "offer a compilation service"? I'd really appropriate any help I can get. Thing is I'd love to fix the problem on my system but I have no idea where to look.
  65. Frequenzy

    Frequenzy Networkin' Nut Member

    is there an instruction how to load advance tomato on a new e6900 router? i checked the site and there was no guid.
  66. AndreDVJ

    AndreDVJ LI Guru Member

    I'd get your repo on my system, compile all ARM images and share with you via OneDrive or sort of, while you figure out your compilation issues (or get rid of your current Linux distro). Of course I'm doing for free :D (what's the point charging for an open-source project where anyone could do it?).

    The Distro of choice to compile Tomato-ARM should be Debian Jessie in my opinion. Wheezy and Ubuntu gave me hell for a long time.

    The only show-stoppers in Jessie are
    router/dnscrypt/src/libevent-modified and router/pcre. Autoreconf these guys or add a compile directive in Makefile to have them Autoreconf'ed and it's all good. Also remember to downgrade bison as described, hold those packages, and all good.

    I have not compiled mipsel for six months already. I still have my old WNR3500Lv2 unit, but what's the point running two routers in your house :D
  67. Jacky444

    Jacky444 LI Guru Member

    Sorry for soooo long delay in response. I have hell house with few clients servers and its really busy busy busy time... I'd appreciate help with compilation. However I need all images at once to be able to push the update officially. I can provide the list if you really wish to help me that much!

    I'm fan of Kubuntu and so far i had no issues, but well... Guess it has to come once in a while!
  68. Sean Rhodes

    Sean Rhodes Networkin' Nut Member

    Hi Jacky,

    Not sure if you are aware or not, but on some routers with the new -135 Shibby or your build, there's an issue with the Vlan page where an Unknown Port Mapping error comes up. There is a fix for Shibby's Gui, but I doubt this will work on your builds.

    I don't use the VLan myself, but I figured someone will bring it up at some point, so may as well be me.:)
  69. AndreDVJ

    AndreDVJ LI Guru Member

    You can PM me a list of images (a shell script if you use one would be even better).
  70. tvlz

    tvlz LI Guru Member

    The warning message is Router Specific, it you are seeing it, you need to Follow the "How to fix Vlan Port Order:" section of that link to get it corrected for the next firmware version, everybody with that router will say thank you. :)
  71. poldim

    poldim Reformed Router Member

    @Jacky444 Any ideas how some of the users here show running AdvanceTomatoe even though it's unsupported?
  72. Sean Rhodes

    Sean Rhodes Networkin' Nut Member

    Hi tvlz, you stated its fixed here

    Let me know if that's not the case, and I will send you all the information that you asked for in your link.
  73. AndreDVJ

    AndreDVJ LI Guru Member

    Open-source project. You can compile by yourself. AT is a GUI to Shibby's builds, so all the user had to do is to take AT GUI specific bits into the sources, and strip out features until you get a firmware that fits into its 8MB Flash memory.
  74. anpak

    anpak Networkin' Nut Member

    Hi everybody..Is advanced tomato GUI available even for Linksys E3000?

    Thank you
  75. Nite

    Nite LI Guru Member

    Had a very unusual thing happen with my router and was hoping you guys might be able to help me out.

    I logged in today after not logging in for awhile to try and figure out why a bridged router was no longer serving connections and found the UI reverted to standard Tomato shibby UI. I was previously running Advanced Tomato version 1.28.0000 MIPSR2-3.1-132 K26AC USB AIO-64K. The UI now claims it is running 1.28.0000 MIPSR2-114 K26AC USB AIO-64K.

    Again, I have not logged into this router for months. It has a very long, completely random password and is physically secure. It still has all my settings/configuration stored.

    How is it possible that it appears to have a different firmware version on it now? Did the Advanced Tomato UI files somehow get corrupted?

    I'm worried about some sort of security compromise at this point. Thanks for your thoughts!
    Last edited: May 18, 2016
  76. AndreDVJ

    AndreDVJ LI Guru Member

    /www directory is completely replaced by Advanced Tomato GUI. The router must have been flashed. Version is read from nvram value os_version.
    root@R7000:/tmp/home/root# nvram get os_version
    1.28.0000 -3.1-136 K26ARM USB AIO-64K
  77. Jacky444

    Jacky444 LI Guru Member

    Agreed with @AndreDVJ. Its impossible to overwrite AdvancedTomato once its flashed because its "readonly" system. Unless the firmware is flashed again (standard shibby in your case).
  78. Nite

    Nite LI Guru Member

    Thanks for the replies Andre and Jacky! Any thoughts on how this could be possible? Is it possible the device is compromised in some way and was flashed remotely?

    Real question is, what would you do if you woke up and found your router flashed with something else?

    Is factory reset and reflash enough?
    Last edited: May 19, 2016
  79. alexo

    alexo Network Guru Member

    I am having issues with 136 and was advised to revert to 132 and do an thorough nvram reset.

    It turns out that the fancy GUI prevents printing the configuration pages (only a part of each page gets printed).
    How am I supposed to restore my settings?
  80. jerrm

    jerrm Network Guru Member

    Flash Shibby 136 and print, or use a backup script to get individual settings out and restore later.

    Or try another browser. Chrome's printing is awful, really pitifully bad for an otherwise good browser. IE is probably best at printing in general. Screen prints are always an option.
  81. alexo

    alexo Network Guru Member

    Good idea. But is it backwards compatible? That is, are you sure that installing the same version of Shibby over A.T. will not mess things up even more?

    Unfortunately, not familiar with those.

    I use Firefox, but I tried chrome and IE. It's the fancy UI that does it.
  82. jerrm

    jerrm Network Guru Member

    AT is Shibby, with updated GUI and httpd tweaks. It should be fine. I went back and forth several times with earlier versions before deciding Shibby was the better interface for my tastes.
    If you're wiping it anyway it can't hurt to try.
  83. DomFel

    DomFel Network Newbie Member

  84. Jacky444

    Jacky444 LI Guru Member

    That looks like lots of work ^^ awesome
  85. AndreDVJ

    AndreDVJ LI Guru Member

    Well I sent a PM to Shibby. He's been absent from the forum for a while. Let's wait what he has to say.
    DomFel and eris23 like this.
  86. Jacky444

    Jacky444 LI Guru Member

    Update 3.2-136 has just been released. This update is a GUI update and not firmware it self.

    Change log:
    Update 3.2-136 (GUI):
    - Fixed VLAN order for RT-N16
    - Fixed issue with Tinc service "START" button, it did not work
    - Fixed LAN information on status overview (home in advancedtomato) page, since 3.1-135 but wasn't noted
    - Fixed IE problem with Ethernet Status icons where they did not always properly fit
    - Possible fix with IP and BW Graphs showing weird line when the bandwidth line reaches the end of graphs
    - Heavily improved responsive design (collapsed navigation mode is ignored in responsive mode bellow 768px)
    - Many new icons, updated old ones and removed other than WOFF file extensions (saving space!)
    - Added missing QOS options which Shibby removed from 134 or some patch and I forgot to add it back
    - Added preloader to the initial interface loading screen, previously nothing was shown so it was confusing
    Elfew, jungu234, Tony Ramirez and 4 others like this.
  87. Mark Barabus

    Mark Barabus Serious Server Member

    Anyone know if the QoS settings are stable in 136 now or is it still best to stay with 132?
  88. Tony Ramirez

    Tony Ramirez Reformed Router Member

    136 is very stable. Way better than 132. It runs faster and I no longer have to restart my computer when I turn on IPv6 tunnel.
  89. Mark Barabus

    Mark Barabus Serious Server Member

    Ok i tried 136 and QoS failed to work on the N66U but worked fine on the AC68U so Arm based routers should be fine. Not sure if the QoS issue is specific to the N66U or broadcom in general but if anyone relies on QoS like me its probably best to stick with 132 until Shibby fixes it.
  90. DomFel

    DomFel Network Newbie Member

    @AndreDVJ hey man any chance to have an updated build with the fixes maybe?
    Does anybody know of any good guide for building from Andre's sources? Don't want to bother this guy too much!
  91. AndreDVJ

    AndreDVJ LI Guru Member

    I have been sync'ing with Jacky's GUI for some time, though not uploading anything.

    I uploaded Netgear and Asus images in my repo.

    If you wanna build. First of all get Debian Jessie x64. This distro has been the most hassle-free while building Tomato so far.

    I attached my own notes. They're not really step-by-step instructions but should help you get your own builds out of the door.

    Attached Files:

  92. DanieleIT

    DanieleIT New Member Member

    Hello everyone, I'm new to this community so forgive me if I ask questions already answered.
    First of all, I'm very thankful for the work done for this project, thanks to shibby, jacky444 and andreDVJ, and other contributors too!
    The question is this: I saw a few post above that andreDVJ's buils of advanced tomato are said to be faster than the original ones (I have a r7000). I'm a curious guy, so I was wondering what were the changes that improved the firmware. Has it anything to do with new broadcom drivers?
    Last edited: Jun 19, 2016
  93. AndreDVJ

    AndreDVJ LI Guru Member

    No... I can't update Broadcom drivers. I tried already (knowing that wouldn't work because of the DPI engine stuff) and bricked the router.

    I upgraded/updated many open-source components, and few other changes... Please read my commits from the last three months.
  94. The Master

    The Master Network Guru Member

    Thanks Jacky, Andre, and Shibby for the GREAT FW :)..

    On my R7000 i testet alle 3 FW Versions now i Stick with Andre´s Version. (Hopefully all is working)
  95. DanieleIT

    DanieleIT New Member Member

    Ok thanks for the informations. I'm installing it next week!
  96. DomFel

    DomFel Network Newbie Member

    Thanks for the builds and for the instructions, I'll try to do that as soon as I can!
  97. jungu234

    jungu234 Network Newbie Member

    codel and fq_codel may be showing in non ARM routers, atleast on my n66u ^^, that's 3.2-136. Responsive design looking fantastic on the Android!
  98. Elfew

    Elfew Network Guru Member

    @AndreDVJ - so will shibby incorporate these changes into his builds? 137 ?
  99. AndreDVJ

    AndreDVJ LI Guru Member

    No answer so far. At least the source code is out there for everyone, so all I did so far aren't lost.
  100. Elfew

    Elfew Network Guru Member

    Ok, thank you
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice