AdvancedTomato - new GUI based on Shibby's mods

Discussion in 'Tomato Firmware' started by Jacky444, Mar 20, 2013.

  1. Kim K

    Kim K Serious Server Member

    Haven't done this, but seen it on these forums somewhere.

    Someone correct me if I'm wrong, but you can add items to the dnsmasq custom field (advanced - dhcp), but this still requires the device to have a static ip number as well.

    E.g. address=/nickname/
  2. ginson

    ginson Addicted to LI Member


    Might be a bug on the UPS Monitor page, some of the text are jumbled when a UPS is connected to the router.

    Im using
    RT-N16 running Tomato Firmware 1.28.0000 MIPSR2-1.21.16 K26 USB AIO
    APC Back-UPS CS 500 connected to the USB port of the router.
  3. Taurus_G4

    Taurus_G4 Serious Server Member

    works pretty great for me so far 4 updates all worked charm though one thing I couldn't get right with any Tomato firmware is restoring "IP Traffic" backup not sure what's the workaround for this but doesn't matter.

    btw upgrade works just fine don't think you need fresh install unless it's mentioned there in release note.
  4. Kim K

    Kim K Serious Server Member

    Yeah, I've never managed to import iptraffic backups either, which is a pity.
  5. uboot

    uboot Serious Server Member

    On Firefox 27 Windows 7 x64, qos filters of 1.20.16 are bad rendered:

  6. Jacky444

    Jacky444 LI Guru Member

    There is no harm in upgrading AdvancedTomato or Shibby's firmware without NVRAM reset. But only if you're upgrading from Shibby to Shibby. AdvancedTomato counts as Shibby's mod since its just a GUI make over.

    That is actually not bad idea. I can add X on the popover it self or just add X to a link when you click it ("System" icon changes to X)

    I'm now waiting for R7000 support since I've just received amazing donation from one of users (A NETGEAR R7000 Router) once that is out I'll be able to provide more frequent also better updates because I will be able to test every thing without any downtime to my network. I'm also going to setup donations, since I'm not expecting much I wasn't really going to do it at all. But I see some people are really thankful and that is why I will setup a PayPal account for those who wish to show their gratitude by donations.

    I would also like to thank every one for testing & risking their routers once again. Also thanks for using AdvancedTomato at all!
  7. Jacky444

    Jacky444 LI Guru Member

    Wow Sorry for double post first of all.
    I didn't notice entire new page =/.

    Might be a bug in Shibby's builds or its something I caused, I will give it a look as soon as I have time.

    Refreshers gave me a lot of trouble to get to work with AJAX based GUI (New 1.20+) since each page you change it doesn't quit the javascript running in background (faster loading for browser and less CPU usage on your router) but new issues came with that. And one of them is what you've mentioned. I'm working hard to fix this bug. Really I tried a lot of things to get it work and its still troubling. But I can promise I'll get to bottom of it.

    I don't have UPS so didn't have chance to test it. I'll try to fix this in next release.

    If you get such page it means it wasn't loaded through AJAX but it went directly to the page. I fixed all these issues in the new 1.21 release. You can workaround this issue by adding "/#" before the "/#qos-detailed.asp?class=5". Temporary till you upgrade of course.

    I have the same issue. Trying multiple times worked for me but from different browsers. Its weird issue that is connected to handler on router it self. (Not GUI) I will try to fix it but I can't make promises. Its written in C++ which isn't on list of my expertise. But I'm Annoyed as well!
  8. uboot

    uboot Serious Server Member

    Thanks. Only the AC release available for RT-N66?
  9. Jacky444

    Jacky444 LI Guru Member

    uboot likes this.
  10. uboot

    uboot Serious Server Member

    Updated to 1.21 and issues still here. :(
    And updater forced nvram cleaning... luckily I always save configuration before.
  11. Jacky444

    Jacky444 LI Guru Member

    Hey, you will have to tell me where you get the issue so I can give it a look =). I mean what did you click to get redirected to non-ajax page?
  12. uboot

    uboot Serious Server Member

    By clicking on qos graphs.
    Last edited: Feb 24, 2014
  13. Jacky444

    Jacky444 LI Guru Member

    I'm sorry for delay, just noticed message. Yeah I checked and you're right! I'll fix it ;)

    Edit: Fixed most issues posted in last few posts, check GIT for more details. You can also compile fixes because new version won't be released just yet, not enough big change log sorry ;)

    Edit 2: I have finnally added donation page, its available here:
    Last edited: Feb 26, 2014
  14. Careless

    Careless Reformed Router Member

    Hi Jacky,

    I emailed you regarding the Port Forwarding pages. I was wondering if you were able to recreate the same bug in your testing.

    Anyone who can test quickly and report back:

    Version: 1.28.0000 MIPSR2-1.21.16 K26 USB Big-VPN installed on Linksys E3000
    >> Port Forwarding Page.
    >> Basic.

    Try adding a range of ports to Ext Ports column (i.e. "80,81" or "5000-5005"), the Int Ports column becomes uneditable, and thus, you cannot forward more than one port per line.

    >> UPnP enabled
    >> NAT-PnP disabled

    not sure if that makes a difference. there are some UPnP ports declared in the separate UPnP Ports list from my brother's computer. I don't think it's related.

    Can someone else verify/test before I reflash? I checked hash before flashing and it seemed fine, and the router has been running great since update.
  15. Jacky444

    Jacky444 LI Guru Member

    I checked this and from what I can see in code its been limited to this functionality. I mean its intended to disable int ports because iptables probably doesn't support range on both ext & int ports. Not sure maybe Shibby could advise?
  16. fredz

    fredz Reformed Router Member

    Does anyone know to configure Tomato so that it uses a proxy (as a squid client) for all outgoing traffic (or for all outgoing traffic from 1 specified local computer)?
  17. phat_cow

    phat_cow Networkin' Nut Member

    How would I go about limiting an Ip's upload spead to bare minimum and download with no limit? Can someone give me an example on how to do that please?
  18. uboot

    uboot Serious Server Member

    Other issues spotted:

    2) Trying to open Tools, Bandwidth or IP Traffic in a new window causes non-ajax page load.
  19. maddie

    maddie Reformed Router Member

    The "PPTP Online" button in "VPN -> PPTP Server" links to the wrong place.

    This is the 1.22.16 build for E4200v1

  20. maxexcloo

    maxexcloo Reformed Router Member

    Issues I've noticed:
    • Some expandable sections (usually the notes section) are closed by default. As only some are this is inconsistant with the rest of the open sections.
    • Restoring IP Traffic doesn't work on the E2000.
    • After restoring Bandwidth Traffic backups there is a redirect to a broken page (I suspect an AJAX loaded page).
    • Opening links in new tabs does not work at all.
    • Other issues I'll post as I find them...
  21. Jacky444

    Jacky444 LI Guru Member

    Thanks for reports. I'll give it a look see what I can do to fix reported issues.
    IPTraffic & Bandwidth Traffic are giving me issues for long time so I postponed fixing those. But they will be fixed in future.
    uboot likes this.
  22. Jacan

    Jacan Reformed Router Member

    Congrats Jacky, the interface is awesome, im using a E3000 and i think im going to upgrate to RT-AC66 because of your mod!!!!!
    Keep up the good work
  23. uboot

    uboot Serious Server Member

    Hi Jacky, I spot another issue today: "Message level" setting under "BitTorrent Client" is broken, because even if I choose "Info", it stay on "Error" (the value restored by the configuration backup launched after upgrading from previous AT - that erase all nvram without asking -).
    Last edited: Mar 18, 2014
  24. CardinS2U

    CardinS2U Network Guru Member

    good job! I just found this! I love it!
  25. maxexcloo

    maxexcloo Reformed Router Member

    I've been having issues with very slow performance, are there any common options I may have enabled that could cause the issue? I'm using JFFS and an AdBlock script.
  26. Jacky444

    Jacky444 LI Guru Member

    Thanks for report, fixed all issues with BitTorrent page now =)

    I really wouldn't know, I have no performance issues however.

    Glad you do!
  27. Charles Phillips

    Charles Phillips Reformed Router Member

    Looks great on Chrome on Linux and Chrome on Mac. Nice work with the flat design.
  28. Jacky444

    Jacky444 LI Guru Member

    Thank you!

    I'm working on a new skin that will look awesome =) also flat but more colors because current design is not really that colorful
  29. Charles Phillips

    Charles Phillips Reformed Router Member

    A small bug -- In Administration -> Configuration, changing the name of the Backup Configuration and clicking outside of the text field causes the text field to recreate itself with the default value. I am unable to download the backup configuration with any name besides the default value.

    Screenshot attached.


    Attached Files:

  30. Jacky444

    Jacky444 LI Guru Member

    Today 23.3.2014 I'm rolling out update 1.23.16.
    This update fixes some issues and adds an amazing built-in skin called Metro.
    Downloads will be available soon. Note that last fix was added after compilation of K26 and RT-N images.
    I'm also going to fix issue with backup file name as reported above so if anyone wants to compile custom image for their router you will be able to do so with that fix as well (This week!).

    Change Log:
    Update (1.23.16):
    - Fixed issue with PPTP Online button (link is now correct)
    - Fixed issue with TOP navigation (right) that didn't load pages properly when opening new tab/browser window
    - Fixed style and href for a lot of other links & buttons (too many to list all)
    - Fixed issue with Advanced-TOR page where you couldn't save settings
    - Fixed issues with BitTorrent Page
    - TomatoAnon: English Localization fixes (Thanks GotMilk!)
    - Added new built-in skin called Metro (Inspired by PHPMyAdmin Metro skin)
    - Fixed issue with "E() is null" on status-overview caused by hidding eth ports state (Late fix only in AC releases)

    Thanks for report! Its a epic funny issue haha :D I will look into it once I get time.
    uboot and Riddlah like this.
  31. railgrinder

    railgrinder Network Guru Member

    First off great work on the improving the GUI. I've been using the Shibby builds but felt that the stock UI was lacking.

    Here's three issues I've noticed in Chrome that I'm not sure have been reported yet:

    1 - The System link (on the upper right-hand corner) needs to be clicked again in order to hide the system panel/flyout. I was expecting that clicking outside the div area would automatically hide/close it, but it remains visible/open even when you click on other links and navigate to other pages.

    2 - Clicking the restore buttons on the Bandwidth Monitoring and IP Traffic Monitoring pages without selecting a file or leaving the file path blank appears to proceed with the restore using a null value. This results in an erroneous bandwidth monitoring page and an "500 Unknown; Read error" message under IP Traffic Monitoring. The Restore button under the configuration page appears to work fine when the path is left blank.

    3 - Under Basic > DHCP/ARP/BW, when adding a new record, the Bound To checkbox remains grayed out and unclickable. It will only become available after a MAC address is entered and you click outside of the text field. If you click on the checkbox immediately after a MAC address is entered, it will remain grayed out.

    4 - Under Basic > DHCP/ARP/BW, when editing an existing record, the second MAC address field is grayed out and uneditable. You'll need to delete the record and recreate it to do so.

    I'm using the latest version of Chrome (33.0.1750.154) and the latest build on an RT-N16 (1.28.0000 MIPSR2-1.23.16 K26 USB AIO)
  32. Jacky444

    Jacky444 LI Guru Member

    Thanks for report!

    1.) Wasn't issue, was coded that way. In new version I changed that and bound and event to close system UI box once you click somewhere else.

    2.) Fixed :) will be working as it should in next release.

    3.) I'm not sure if this is an issue, I'll give it a look once I have more time.
  33. maddie

    maddie Reformed Router Member

    The 3rd issue seems to behave like this always, because a static entry requires a MAC and IP to bind together.

    The the 4th issue, you'll need to uncheck "Bound" before editing the MAC entries.
  34. AndreDVJ

    AndreDVJ LI Guru Member

    I should have tried and reported this ages ago. When you grab a theme for AT and limit the interface width from fluid to some value, the background reverts to light grey and messes up everything.

    Attached Files:

  35. Jacky444

    Jacky444 LI Guru Member

    Glad you decided to report! I didn't notice this issue at all :(. I already changed the way fluid works because of something else and this issue was fixed (sort of by mistake! heh) so in next release it will work fine.
  36. w4rh4wk

    w4rh4wk Networkin' Nut Member

    hey jacky i just upgraded to 23.16 k26AC USB AIO-64k on my rt-n66U (without selecting "after flashing, erase all data in NVRAM memory"). The one at home when i goto VPN>PPTP online i get "Error occured! TypeError: Cannot call methon 'indexOf' of undefined". The funny part is, when i upgraded the same router at work (without selecting "after flashing, erase all data in NVRAM memory") VPN>PPTP online shows up correctly. Maybe a complete nvram wipe is in order?
    Last edited: Mar 24, 2014
  37. Jacky444

    Jacky444 LI Guru Member

    Hey! I really don't know what that could be, there shouldn't be issue like that since AT is based on Shibby and I don't think his compiles have such issue. I will try it on my RT-N66U in few hours and let you know what happens.
    (Might respond tomorrow, bit busy today, mothers day and all)
  38. w4rh4wk

    w4rh4wk Networkin' Nut Member

    no worries, what is interesting is... it only shows that error when a PTPP user is connected to the VPN. When no one is connected, it displays properly.
  39. Qvark

    Qvark Network Newbie Member

    Sorry in advance since this is a beginners question: I'm currently running Shibbys mod and want to try out AdvancedTomato, how do change between the two, is it the same procedure as between stock and Tomato or is there an easier way?

    e: I have a RT-N66U if it makes any difference.
    e2: Oh, sorry, I saw you just recently answered exactly this question. I flashed without deleting NVRAM and it works flawlessly. Thanks for the beautiful GUI!
    Last edited: Mar 25, 2014
  40. sgtbug

    sgtbug Network Newbie Member

    Hi Jacky,

    This is a small issue, nothing serious. In the old version of your firmware, when I used an apostrophe (') in the router name, it showed properly in the titlebar but since the GUI redesign, it shows as '

    Apart from this, the firmware works well. Thanks for the awesome GUI!

    My router: Asus N16
    AT version and Build: 1.28.0000 MIPSR2-1.23.16 K26 USB AIO


  41. Jacky444

    Jacky444 LI Guru Member

    Glad to hear that ;)!
    Its the same as Shibby's firmware yeah!

    Not sure what that could be, I haven't done any changes in that direction. Weird!
  42. bonuspojken

    bonuspojken Networkin' Nut Member

    First of all, and like many other before me stated, I really love the GUI - and it is a perfect layer over the already great firmware Shibby and all the other developers contribute. My praises to all of you.

    However, I do have a small opinion (not an error, not a complaint - just a suggestion perhaps) regarding the spaces between some headings. To better explain I've attached two small images, one for the menu-heading on the left board (for me) and one to illustrate the status-overview.

    My feeling is that the spaces between the different headings is rather big, for example, between "Status" -> "Overview" (however, the spaces is the same for all the other options as well). At the same time, the "Overvew"-page has also rather big spaces. From the "System"-information, the jump down to "WAN" seems to me a little unnecessary big. This leads to a very long page in total.

    Maybe it is just me, :), but my opinion is that if the spaces just became a little bit smaller - the GUI would look even more great.

    How do you feel? :)

    Attached Files:

  43. lepa71

    lepa71 Networkin' Nut Member

    First, thank you for all of your hard work on this. It looks awsome.

    how do I change theme on the latest fw?
    I'm using this on E2500 wioth bridge mode on 5 band.
    Does anybody know how to setup 2.4 as AP and brindge it into 5 band bridge?

  44. Jacky444

    Jacky444 LI Guru Member

    Will take in consideration. Problem at this idea is at the moment on big screens as 1920x1080 these empty spaces make it look clean and nice. Though this could easily be archived by custom styling!

    Theme can be changed the same as before. "nvram set web_css" or at admin-access page "Interface Theme".
    I don't know how to setup bridge, I never really tried :p sorry
  45. lepa71

    lepa71 Networkin' Nut Member

    Thanks. I found it. I don't know how I missed it. Now I'm trying to use theme #8, so I switched to "on-line from ATTD" and entered 8 then saved it, rebooted the router and nothing changed. Any idea?
  46. Jacky444

    Jacky444 LI Guru Member

    Hmm not sure, did you check logs for details? That's strange it works for me :O
  47. lepa71

    lepa71 Networkin' Nut Member

    I tried again and no change. Do I have to download the theme?

    ps my E2500 i in bridge mode.
  48. Jacky444

    Jacky444 LI Guru Member

    mm, no if you have access to internet on router it should download automatically. But if you have issues you can try and download it yeah. Using custom ext/css it should work.
  49. lepa71

    lepa71 Networkin' Nut Member

    I made it to work. I had to set Static dns and Default Gateway to my main router IP. Thanks
  50. Jacky444

    Jacky444 LI Guru Member

    No problem, Happy to help!
  51. Mangix

    Mangix Networkin' Nut Member

    Advanced Settings > Routing is broken with the current git version. Error is:

    TypeError: Cannot set property 'disabled' of null

    I'm running the git version because I have a 4MB flash device and needed to edit the Makefile so that the image would be small enough.
  52. Jacky444

    Jacky444 LI Guru Member

    I need to look into that, I will also push new changes to GIT soon.

    P.S.: Problem is this error is more general than I thought. I'm unable to determine which part of script causes it. Were you able to compile previous versions without the same issue?
    Last edited: Apr 8, 2014
  53. penkwin

    penkwin Network Newbie Member

  54. silverjim

    silverjim Network Guru Member

    Hi. I'm currently running version 0.8 of EasyTomato, which includes the AdvancedTomato. When I go to the Basic/Network and attempt to set the channel to 1, I can't. The options are Auto, 5, 6, 7, 8, 9, 10, 11, 12, 13. I've hit the scan button to see if that would reset the options. It doesn't. It runs through several scans, but the options don't change. Any help out there? Thanks in advance.

    Asus RT-N16
    Firefox 28
    Last edited: Apr 8, 2014
  55. Jacky444

    Jacky444 LI Guru Member

    I'm aware of the issue, I already compiled 24 builds with the same OpenSSL except for AC but I'm not sure I have knowledge to upgrade OpenSSL module without Shibby's help.

    I don't think EasyTomato includes my version of AdvancedTomato. They based their GUI on first releases of AdvancedTomato which were started by another forum member fougner
  56. Jacky444

    Jacky444 LI Guru Member

    New update 1.24.16 has been released. It does not fix OpenSSL bug but it brings new UI function that allows you to customize navigation.

    Change Log:
    - Changed the way interface width changes, now its based on CSS instead of JS (Allows easier control)
    - Changed Navigation spacing (slightly less empty space now)
    - Added behavior that hides System UI by clicking anywhere on the page
    - Added Option to add custom navigation links (nvram set web_nav = '{ "Custom Category" : { "Link 1": "admin-access.asp", "Link 2": "admin-iptraffic.asp" }}')
    - Added Interface option to add extra links to navigation (admin-access.asp)
    - Removed CSS based preloader while loading page (Mouse cursor changes to "wait" state instead)
    - Fixed issue on admin-config page that duplicated fields when changing backup name
    - Fixed issue with restore IP Traffic & Bandwidth pages (I wasn't able to test properly)
    - Fixed issues with links in notes section of "basic-static.asp" page.

  57. silverjim

    silverjim Network Guru Member

  58. railgrinder

    railgrinder Network Guru Member

    I just upgraded my RT-N66U to v1.24.16 from v1.23.16 and noticed the incorrect RX rate on some of my wireless devices. It displays 4294967 for some reason as per the attachment. Power cycling the router and wireless devices doesn't do anything either.

    Note that I just did an update without clearing NVRAM. I updated to v1.23.16 two days ago from the stock firmware and set all my custom settings and I'm a little discouraged at the moment to reapply them manually again to check if it will clear this. Would backing up and restoring the configuration save time or will it restore the NVRAM back to its original state?

    rx rate.PNG
  59. er fudd

    er fudd Serious Server Member

    its not just you
  60. Mangix

    Mangix Networkin' Nut Member

    can you also add a build for the E1200v2?
  61. Jacky444

    Jacky444 LI Guru Member

    I reconfigured router WLAN because of other issues I was having and tried to recompile using new OpenSSL. I forgot to include single config for WIFI antenas so it might be issue because of that. I'm very sorry. I believe you are using AC version since that is the only firmware I configured?

    Its not there? I will look into it.
  62. Theo16

    Theo16 Reformed Router Member

    This problem exist also in shibby's release.
  63. Theo16

    Theo16 Reformed Router Member

  64. Mangix

    Mangix Networkin' Nut Member

    I just did the manual search and found a build for the E1200v2 which is AIO. This unit only has 8MB flash with no USB port. shibby normally just builds the Max profile for this unit.
  65. subzero79

    subzero79 Reformed Router Member

    There is and problem with dynamic dns section. It exposes the password and locks the fields it does not let you change anything.
    I am using the version 24 (latest) in Safari. Chrome in mac doesn't reproduce the error.
    Last edited: Apr 11, 2014
  66. juggie

    juggie Addicted to LI Member

    Everything I can find on google indicates shibby supports 6rd for IPV6 which Advanced Tomato is based on, however I don't see it within advanced tomato on the ipv6 screen? Am I missing something?
  67. Amuro

    Amuro LI Guru Member

  68. Jacky444

    Jacky444 LI Guru Member

    It takes few days up to a week for Shibby to update his GIT sources. Once that is done, I can update AdvancedTomato base.
  69. Jacky444

    Jacky444 LI Guru Member

    New Update 1.24.17 released.
    The only change from previous mod is heartbleed Exploit fix.

    Download here
    Riddlah likes this.
  70. Spyros

    Spyros LI Guru Member

    can't find the e2000 file :S
  71. yudouxie

    yudouxie Reformed Router Member

    Updated from...well, I don't remember the exact edition number but sure there are months passed. Honestly, it's took me quite some time to accept the new skin. Finally and luckly, it's ok.
  72. Jacky444

    Jacky444 LI Guru Member
    I forgot to upload images, sorry for that! :)

    Glad you did on the end. If you have any recommendations be my guest, let me know.

    I have issue finding a build command for MAX on this unit. I will ask Shibby for more info and build as soon as I get response.
    Last edited: Apr 22, 2014
  73. railgrinder

    railgrinder Network Guru Member

    Does this mean we can update without clearing NVRAM?
  74. Jacky444

    Jacky444 LI Guru Member

    Upgrading from Tomato to latest Tomato never requires clearing the NVRAM!
  75. shibby20

    shibby20 Network Guru Member

    Jacky444 - upgrading from tomato to the latest tomato version (even the same mod) always requires clearing nvram! This is the right rule that people should know. It`s a good rule when you made some changes in nvram values (some are changed, some of them are unused). If someone has any of problem with tomato, then he should first of all erase nvram.

    But sometimes changes are not big and developer did not make any changes in nvram. Then erasing nvram is not neccesary.
  76. Dr.Pat

    Dr.Pat Network Newbie Member

    Great mod!

    Some things about the QoS section GUI:
    1. It's very cumbersome to change the order of the rows in the "Classification" menu; could you leave the "#" field editable, or have the rows drag&droppable, so you don't have to press Up/Down 100 times to move them around?
    2. I don't think the "http://ip/#qos-detailed.asp?class=x" links work; they always show the "Unclassified" (0) class. You reach those pages from the links in the class names of "View Graphs" page.
    3. In the "Classification" page, when you add a row, text fields are unnamed/empty and a bit confusing if you are unexperienced about the layout of the form. Also other fields may be obscure without an hint or help. BTW, there's a lot of unused space in the whole form.
    4. "Zoom Graphs" in the the "View Graphs" page is more "Show unused bandwidth"
    5. In the "#qos-detailed.asp" page, it would be useful to add a "Rule" filter
  77. Jacky444

    Jacky444 LI Guru Member

    I agree, but isn't it the same if you clear nvram -> restore configuration afterwards? I mean the changes developer done are still overwritten so on the end its same as not clearing nvram. I do agree that having issues erasing NVRAM is best option to repair them. I'm lazy person and I usually don't want to reconfigure all my port forwards and settings each time I upgrade firmware.

    I will look into these =) thanks for report!
  78. Amuro

    Amuro LI Guru Member

    Hi Jacky44, I installed Advanced tomato without issues in a RT-N16. Looks very nice.

    I noticed an issue in the listing of the available networks: the SSIDs having a letter with a tilde are incorrectly displayed. Please see the attached image for details. The word is 'réseau' (network).

    Hoping you can do something to fix. Thanks!

    Attached Files:

  79. Spyros

    Spyros LI Guru Member

    You must use only ASCII characters for SSID
  80. Amuro

    Amuro LI Guru Member

    I don't recall seeing that SSIDs should only be ASCII in any of the 802.11 standards. Also, i don't recall seeing that when using the Shibby version, hence my mentioning it to Jacky444

    Applle devices don't seem to have a problem in the router or client end using non-English characters.
    Last edited: Apr 26, 2014
  81. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    People have had problems with special characters (eg. punctuation marks) in SSID's with Tomato specifically. It would be considered a very low priority bug since it has no impact on function of the device.
  82. Spyros

    Spyros LI Guru Member

    "A Service Set Identifier (SSID) is essentially the "name" that you give to a wireless network. Any wireless device that you want to connect to the wireless network must know the SSID for that network. The SSID is controlled by the wireless access point (WAP) for the network. An SSID may be any combination of ASCII characters (i.e., any combination of letters, numbers, punctuation marks, etc.)."

    combined with ASCII definition

    "The American Standard Code for Information Interchange (ASCII /ˈæski/ ASS-kee)[1] is a character-encoding scheme originally based on the English alphabet that encodes 128 specified characters - the numbers 0-9, the letters a-z and A-Z, some basic punctuation symbols, some control codes that originated with Teletype machines, and a blank space - into the 7-bit binary integers.[2]"

    which means that you can use numbers 0-9, letters a-z and A-Z and puntctuation symbols. Personally i've encountered problems with illegal SSID characters with Android devices unable to connect and with Symbian OS in the past. DD-WRT has the same limitation and my home modem can't accept greek letters, only ASCII. Punctuation symbols work fine, i have one SSID "E2000 2.4Ghz" and works fine.
  83. Hi, I just installed AdvancedTomato, it looks really good :)
    I went with the usual "format NVRAM, resetup everything", so I had the opportunity of testing a bunch of stuff. This is what I found:

    - Can't change tab between Init/Shutdown/Firewall/Wan Up in the Scripts section. The error console of my browser says "TypeError: E(...) is null". Actually you can change tab, but you have to do it very quickly, as soon as the page load.
    - Bandwidth Limiter is under QoS, but can be used without it enabled. So the big yellow box that say "QoS is disabled" should not be showed here, I think.
    - Under the FTP page, there is a red warning that says "Note: Avoid using this option when FTP server is enabled for WAN. IT PROVIDES FULL ACCESS TO THE ROUTER FILE SYSTEM!". It's not exactly clear what it's referring to.
    - Under the UPnP/NAT-PMP page, "Enable UPnP" and "Enable NAT-PMP" should be at the top, as that page is useless without one of those enabled.
    - If you press system and then reboot/shutdown, but then press cancel, the page will refresh for no particular reason
    - Restoring bandwidth stats will redirect to, which is broken. Should redirect to instead.
    - I can't restore IP Traffic stats. I'm not sure if this is a problem on my end, but I tried two different backups and both were refused.
    - Copyright at the bottom of the page says 2013, should be 2014 :p

    That's pretty much it. Otherwise it has been a smooth sailing!
    Here's a bunch of ideas/improvements I'd live to see:
    - I feel that both the default theme and the Metro theme don't have enough contrast in lists and textboxs. This is more of a problem on crappy monitors.
    - In the scripts page, It would be nice to have colored syntax. I'm not sure if it would be a problem for file size.
    - The tools > System Commands is pretty limited, having something like shellinabox instead would be amazing (
    - More tooltips, please! Like the one you have in the admin access page, those are much better than a separate FAQ/informations section.
    - When you have lists, you can press on one item to edit it. But to edit another item, you first have to press one of the "save/cancel/remove" button. Since those changes aren't actually saved anyway until you press the "save" button at the end of the page, I think it would be nicer to automatically save any changes when one press on a different item.
    Last edited by a moderator: Apr 27, 2014
  84. Jacky444

    Jacky444 LI Guru Member

    First of, I appreciate you effort to write this down!
    I will look into the issues and ideas for improvements. As soon as I find enough free time!

    I don't think there is need for special characters in SSID names really. I don't think there is much I can do about it though. As stated before this isn't high priority bug/issue. I might look into it when I have lots of free time though :p

    P.S.: It might be issue due to font as well. AT uses OpenSans which is a stripped as possible to save space on the router and I'm pretty sure that is why the special characters don't work properly. You can try fixing that by adding custom CSS and write this in it:

    body {
          font-family: Verdana;
  85. Do you accept pull requests over Github? Because some of those looks easy to fix, so I might as well give it a shot (no promise tho!)
    octra likes this.
  86. Jacky444

    Jacky444 LI Guru Member

    Yeah I do! That would be awesome =)
  87. Now, if only Github wasn't so slow for me... I've been cloning your repo at ~50kb/s for the last 2 hours, 71% done.

    Anyway, another bug: In the device list, when you press on "BW Limiter", you get redirected to #qos-qoslimit.asp but the form is not filled with the mac address or the ip. It works correctly for the other buttons (Static and Wifi filter).

    Also a question, when adding a new device to the BW limiter, a wan-up is triggered. I can't remember if this was the behavior in shibby's build as well. It's slightly annoying because I have a script that trigger on wan-up and configure my modem, which mean that every time I add a device to the BW Limiter my connection get resetted.
  88. Spittie

    Spittie Network Newbie Member

    Also got myself an account instead of using one from bugmenot :)

    As in the commit message, those are untested (at least in the firmware, I did test what I could by editing the files in my browser on the fly).
    Couldn't compile because I'm not sure which make flag I should use for my router (e3200), n60z is good? There is a complete list beside make help?
    Forget about that, found out about the advancedtomato-ac repository. Pull request here too (you maintain two separate repository for those?) and I'm building it right now for testing.

    EDIT: compiled, flashed, all ok :)
    Last edited: Apr 28, 2014
  89. Jacky444

    Jacky444 LI Guru Member

    Great news :D Thanks!
    The only fix I need to modify is the removal of "hred="#"" there is better solution to it, adding return false on the functions for shutdown/reboot/logout in case user clicks cancel. Its better than removing href which is standard html format :D

    But thank you! I will merge pull.

    Yeah I'm real noob with Git I didn't really know how to make branch instead of repo :D I will try to merge them when AC builds come out :)

    Will look into triggers :)
  90. Spittie

    Spittie Network Newbie Member

    I've tried this, but couldn't get it to stop refreshing the page. I figured that you were styling those buttons with their class, so removing the href wouldn't hurt.
    But "return false;" is a better/cleaner solution, if it works :) (probably, I was editing the .js from Chromium so that could be a possible cause. Who knows).
  91. Jacky444

    Jacky444 LI Guru Member

    Oh, its cleaner yeah. For editing AT best way is to have source files from www folder on USB or CIFS mount and than you just access router via SSH and CD to that folder than write:
    service httpd stop && httpd start
    That starts the HTTPD inside the current folder. The only issue with using this is when you save some preferences it resets and you can't test compiles (changes to httpd handler)
  92. Spittie

    Spittie Network Newbie Member

    Okay, thanks!
    Talking about httpd, I think that I got why I can't restore the IP traffic stats.
    In bmw.c at line #144 there is a check for file size (
    if ((len < 64) || (len > 10240)) {
    ), but the problem is that my archive ends up bigger than that (and without much uptime/devices as well). I can press on the "Backup" button, then try to restore that backup and get an error.
    I'm not sure if it is safe to increase the limit? Same for the Bandwidth stats, but the file here ends up being much smaller, so I never experienced it.
  93. Jacky444

    Jacky444 LI Guru Member

    Honestly I have no idea aether. You could ask Shibby about that or just try increasing it and see what happens. I do believe this limit is set depending on available storage on the router. With router that has more then 8MB Flash size I don't think there could be issue.
  94. Spittie

    Spittie Network Newbie Member

    I checked, Shibby has it to 102400 (
    So I pushed that to my pull request as well :)
  95. JTD121

    JTD121 Addicted to LI Member

    Really basic question. I know AT is based on Shibby, so does that mean the compatibility between the two is the same? I ask because I am planning to buy a bunch of Asus RT-N12s, and AT lists only the B1 revision, while Shibby's own list has the A1, and the B1/C1/D1 listed.

    On Newegg, I can only really see the D1 available. There are refurbs of the white (different revision?) ones, but they don't seem to list the hardware revision.
  96. 0x4d4e

    0x4d4e Reformed Router Member

    I think I found an error: when trying to upgrade with JFFS enabled the warning appears with the 'disable' link to the admin-jffs2 page. If I click this link the page to disable JFFS has no header and menu and some styles are wrong/missing. If I go back and enter admin-jffs using the menu everything is ok.
    Maybe an error with the link/redirect?

  97. Jacky444

    Jacky444 LI Guru Member

    I would love if someone can confirm this, but I believe these revisions all work from the same image. The only non working factor would be v2 or v3 with very different hardware like NETGEAR WNRL3500L V1/V2.
  98. BabyPro Kelvin

    BabyPro Kelvin Network Newbie Member

    Hi Jacky
    nice themes
    Any builds for K24 Mips1 for wrt54gl? please i await your response
  99. Jacky444

    Jacky444 LI Guru Member

    I'm not compiling MIPS1 routers because of the specific Linux required to do that. Sorry =(.

    I know this project has been a little behind in development, I'm busy and summer is coming up (workout!) but I will do my best to release a new update soon. I'm already working on a new theme (add-on) and patiently waiting ARM sources and firmware =)
  100. JTD121

    JTD121 Addicted to LI Member

    Just ordered the RT-N12 D1. Five of them. Will test with Shibby's build; in the meantime, can you see if there is any firmware difference between what you provide with AT, and Shibby's build for the B1/C1/D1 hardware revisions? I know it has more flash, and is supported by the K26RT-N builds.

    Worse comes to worst, I'll just use stock Shibby; but I do love the slickness of your implementation on top of it! :)
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice