AdvancedTomato USB Share Missing Files / Samba

Discussion in 'Tomato Firmware' started by wholeeo, Feb 12, 2018.

  1. wholeeo

    wholeeo Network Newbie Member

    Good Morning All,

    I was hoping someone could help me out with the issue I'm having. I guess I will list my equipment first,

    • R6700 (Nighthawk AC1750) flashed to an R7000.
    • Latest AdvancedTomato Firmware
    • Seagate Expansion 8TB External HD USB 3.0 (STEB800100) / ExFat File system.
    • Nvidia Shield TV
    • First Gen FireTV stick
    • Win 10 PC
    So my external hard drive is connected to my network via the USB 3.0 port on the front of the router. Devices on my network access it via Samba. For some time now new files that are added to the drive via QBittorrent are not showing up on my PC via file explorer. The only way that I can see them is by right clicking on them in QBittorent and selecting open file location or via command prompt (dir). This issue was also happening on my Shield TV where I couldn't see the new files via Kodi/SPMC but oddly enough I could see them with the VLC app. However, by removing the share from the ShieldTV and re-adding it I fixed the problem and all programs can now see the files on the drive.

    This however isn't the case for my FireTV or PC which can't see the new files even if I perform the steps taken on the Shield TV. What is weird and leads me to believe the issue has something to do with my router is that when I connect the drive directly to my PC via USB I can see all the files on the drive. I plug back into the router and am missing a ton of files.

    Can anyone offer any guidance on what the issue could be and how to fix it. Thanks!
  2. Solace50

    Solace50 Connected Client Member

    Check the permissions on the directory
    Ensure the file explorer/clients are refreshing on new content, even windows will fail to do so sometimes
    Ensure the disk is not damaged and failing to perform the writes, flash drives have this behavior when faulty which sets a write protected mode

    I'm assuming windows is not updating the share in this case
  3. eibgrad

    eibgrad Network Guru Member

    Does refreshing the File Explorer display (F5) reveal the new files?
  4. wholeeo

    wholeeo Network Newbie Member

    The permissions look to be fine. I am assuming something is indeed not refreshing on the clients side. The same files that I cannot see on Windows do not appear on my FireTV via Kodi either. The HDD doesn't appear to be damaged since everything works just fine when accessing via my Shield TV. I'm really at a loss. The only thing I can think of is flashing my router over to Asus-Merlin or DD-WRT to see if the issues persist. Thanks for your response.

    Thanks for your response. No, refreshing file explorer does not reveal the new files. Only plugging the drive directly to my PC reveals them.
  5. Sean B.

    Sean B. LI Guru Member

    If you share the drive out from a PC instead, are you able to then see the files from the FireTV? Post screen shots of the USB and NAS->USB Support and File Sharing tabs from the routers web interface please.
  6. wholeeo

    wholeeo Network Newbie Member

    Thanks for being willing to help me but this weekend I went ahead and backed up the data on the external and changed it to NTFS. I had flashed my router over to Merlin's fw to see if it was a Tomato issue but came to the realization that Merlin's fw doesn't support ExFat after the fact.
  7. alecsandes

    alecsandes Reformed Router Member

    Hi All,
    I am using the latest build for Advanced Tomato with latest Shibby Tomato on NetGear R7000.

    I have accidentally discovered that I have missing files in my shares.
    I use a 4TB Hdd split in 2 volumes with exFat file system.
    In one volume I have a enourmous amount of photos dating back from 2004 which are stored in 4 layers of folders, like Photo Archive/Personal/year/ - event/fb or print/photo.jpg

    As I said, I have found accidentally that in some folders I cannot see some photographs through Kodi, Windows10.

    I can see all the files, the ones which I cannot see in W10, from my tablet, Android with total commander .

    The 3rd level folder is not big, it contains around 10 sub folders and what is strange that the files which are missing are the same as in FB folder as in print folder (I export photos for fb and social media with lower quality and print quality)

    When I mount the hdd to w10 laptop, I can see the files with no issues.’

    File sharing is using authentication method with auto share partitions

    Can someone suggest something?!

    Should i switch to ntfs? Ext fs is not a solution.

    Thank you very much!!!
    Last edited: Jul 25, 2018
  8. Sean B.

    Sean B. LI Guru Member

    I'd suggest:

    1. Log into the router via ssh/telnet and check the file permissions of a file Win10 cannot see, compare to others it can and see if anything differs.

    2. On the Win10 client, open file explorer and navigate to the root of the share ( IE: The base directory ). Right click on it and verify "Always available offline" is not checked. If it is, uncheck it and test.
    alecsandes likes this.
  9. alecsandes

    alecsandes Reformed Router Member

    Hi Sean,

    Thanks for your involvement. So I have the following situation:

    1. I have compared files and there is no indication of differences:

    2. I could not find the checkbox you are mentioning however I found that there is a sync center in Control Panel and it has the offline files set to "Off". I never used this feature in any of the windows'es . I guess this link is about the same you are mentioning:

    3. I have mapped the respective drive in W10 and there is the same issue.

    4. I have put a network file manager on iPhone and I can see the files.
    5. I have seen that there are some files or folders with Archive flag on, disabled on the whole structure this flag and on some folders read-only flag was applied. - I have removed all flags.

    Still I have the same issue
  10. Sean B.

    Sean B. LI Guru Member

    On the Win10 client: Right click the start button and click "Apps and Features". In the window that opens, scroll to the bottom and click "Programs and Features". In the window that opens, in the left hand column click "Turn Windows features on or off". In the window that opens, scroll down and find the line that says "SMB 1.0/CIFS File Sharing Support" and verify both "SMB 1.0/CIFS Client" and "SMB 1.0/CIFS Server" are enabled:


    In the router's web interace, under USB and NAS->USB Support, verify the box for ExFat is checked in the File Systems Support line.

    Open File Explorer and click the "View" tab then click the "Options" button. In the window that opens, select the "view" tab, enable the option for "Show hidden files, folders, and drives" if it is not already:


    Try browsing the share directories using File Explorer and see if there's any difference in file visibility.
    Last edited: Jul 26, 2018
  11. alecsandes

    alecsandes Reformed Router Member

    Hi Sean,

    I truly thank you for your involvement.
    Related to the issue, I have checked all points and there is none in opposition to your recommendation.

    Offtopic - Now I understand why I had difference in files from the HDD connected to router and the one as back-up using the free file sync soft, although, while both connected to the computer had no differences...

    * I have Samba 3.0.37
    * I have tried as well to map external drive
    * I have rebooted several times the router
    * I have restarted samba service
    * it is clear that it is only windows issue as long other clients can see the files
    * I have tried another W10 computer, the issue is the same.

    Can I somehow force Samba or windows to rebuild the file indexes or maybe a SMB/CIFS driver?
    Switching to NTFS would solve the issue? In the end I will try this, but the amount of files is very big and I have only one USB 3.0 port :)))
  12. Sean B.

    Sean B. LI Guru Member

    While EXfat itself could be to blame, the fact that plugging the drive directly into any of your machines works just fine implies a configuration or implementation problem with how it's being shared or viewed on the network to me. Rather than compatibility with the file system directly. Currently, the only way to find out would be to try an NTFS format, as we haven't uncovered anything that would indicate it would or would not make a difference.

    With what OS, and using what steps did you originally format the drive as EXfat with?
  13. alecsandes

    alecsandes Reformed Router Member

    Hi Sean,
    I have use W10 format tool.
    Now I have remembered that after formatting and copying files I had to scan the drive as it showed problems when I was plugging it again.
    On the other hand, but I am not sure, I have used a 3rd party file copy (fast copy) soft. But I might have been used it on the “backup” hdd.

    I will plug the backup hdd which is also an exFat, then I will switch to ntfs.

    Do you have an idea if ntfs would sliw down transfer speeds between router and clients?! I have chosen exFat due to its “compatibility” with routers fw.

  14. Sean B.

    Sean B. LI Guru Member

    I believe you'll see faster read/write speeds with NTFS compared to EXfat.
  15. alecsandes

    alecsandes Reformed Router Member

    Hi Sean, All who will read this post.

    So, I have plugged the second HDD which was an exact copy of the first one (by CTRL-C CTRL-V) and the issue was the same!
    I opened EaseUS Partition Manager and I had a surprise of seeing that the HDD FS is Other, not ExFAT, see attached screen.
    So I guess it is a FS bug when I prepared both HDDs...
    In AOMEI I can see that the partitions are ExFAT but I it shows as I have chkdsk errors
    both softs won't let me to switch to NTFS

    Now I switch to NTFS....... 600 GB ... twice .... shoot me
  16. alecsandes

    alecsandes Reformed Router Member

    So I have converted to NTFS now :)))
    Missing files can be seen.
    Sean B. likes this.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice