After Upgrade the Internet Connection was down!!

Discussion in 'Sveasoft Firmware' started by haselbauer, Jul 28, 2004.

  1. haselbauer

    haselbauer Network Guru Member

    Hi boys and girls!

    I have a big problem!

    I have upgraded the satori 4.0 firmware of my wrt54g.

    I need to connect to the internet the PPTP. With all other upgrades i can connect to the internet, but with the satori i get no connection!

    ip, subnet, gateway, .... are the same like the older upgrades of

    Pleas help me.

  2. Toxic

    Toxic Administrator Staff Member

    did you reset firmware and reboot system?
  3. nteusink

    nteusink Network Guru Member

    same problem here, with the latest linksys firmware the WRT54G (v2) works fine, but after installing Satori a PPTP connection can no longer be established. I'm using a Speedtouch Home ADSL modem with Dutch ADSL (KPN Telecom). The webinterface reports "Can not connect to PPTP server" when trying to connect. I read portions of the source and tried to manually make a connection, to see if that works or if I get a useful error message. No luck so far. A strange detail is that I cannot ping my ADSL modem from the telnet console but when I give vlan1 an ip address via ifconfig I can, but still no luck connecting...

    The next thing I tried was using my old router (one of those with wires and stuff ;-) ) as a gateway and configured the WRT54G to use a static IP. In other words:

    Wireless Router >> Wired Router >> Modem >> Internet

    I could ping an internet host on the wireless router after that, so it seems to be a PPTP problem.

    Flashing the firmware back to Linksys official fixes the problem. Still trying to get Satori to work, if I find anything I'll report back.

  4. kimz

    kimz Network Guru Member

    i have also got this problem after upgrading (dutch isp w PPTP) is there going to be a solution for this?
  5. kimz

    kimz Network Guru Member

  6. nteusink

    nteusink Network Guru Member

    Haven't been able to get it to work. I also installed alchemy and had the same problems. Going to try wifibox now.

    -Edit: hmmm... same problem with wifibox...
  7. nteusink

    nteusink Network Guru Member

    I tried hyperwrt next (to see if any custom firmware would work) and it connects just fine. It makes sense as hyperwrt is almost the same as the linksys firmware. Unfortunately it has no advantages for me (being able to execute commands on the official firmware using the ping.asp hack), so I'm back on official v2.04.3 now... still trying to get alternatives to work.
  8. kimz

    kimz Network Guru Member

    yep, same here.... bummer :cry:
  9. haselbauer

    haselbauer Network Guru Member


    OK Boys an Girls!

    Thank you at first.

    Some of you have written my problem exacter!!

    I've tried to make other upgrades. so i have downloaded the older sevasoft version of the page!

    In this version all featers are working like the v2 !!

    I can connect to the internet, i can boost up my antennas AND i'm HAPPY !!!
    The name of the perfect upgrade:

    Sveasoft WRT54G Samadhi v2.00.8.6sv

    You can download it of

    THX @ ALL
  10. nteusink

    nteusink Network Guru Member

    I currently have it working with Alchemy-pre5.2.2 v2.09.1.8sv. After browsing the sveasoft forum, I noticed that lots of people were having similar problems. After reading their solutions and trying some combinations, I managed to get a connection. I telnetted into the router and pasted the following script to the console (if you want to try it, replace the value after USERNAME= with yours):

    ifconfig vlan1 broadcast netmask
    echo user $USERNAME > /tmp/ppp/options
    echo mtu 1436 >> /tmp/ppp/options
    echo noipdefault >> /tmp/ppp/options
    echo nomppe >> /tmp/ppp/options
    echo lock >> /tmp/ppp/options
    echo noauth >> /tmp/ppp/options
    echo name $USERNAME >> /tmp/ppp/options
    echo usepeerdns >> /tmp/ppp/options
    echo ipcp-accept-local >> /tmp/ppp/options
    echo ipcp-accept-remote >> /tmp/ppp/options
    echo debug >> /tmp/ppp/options
    sleep 10
    ping -c 4 [url][/url]
    The result:

    4 packets transmitted, 4 packets received, 0% packet loss


    This is based on a Dutch KPN Adsl ( mxstream) connection with a Speedtouch Home modem. I have not tested it with Satori.

    If this does not work for you, it would probably be a good idea to get a sveasoft subscription. Lots of info on the forums there.
  11. atzplzw

    atzplzw Network Guru Member

    I have the same problem with Satori and my ISP (PPTP) here in Austria.
    Has anyone tested the script with Satori till now?

    Also I need to enter a password. What about that?
    Do I need to run the script everytime the router reboots?

  12. atzplzw

    atzplzw Network Guru Member

    Does the dir /tmp/ppp exist before the file is created?
    I don't even have that dir and the options file in Satori...

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice