AG241V2 - Can't Startup

Discussion in 'Other Linksys Equipment' started by waiket, Jun 27, 2008.

  1. waiket

    waiket Addicted to LI Member

    Not sure which Annex is it, i bought this AG241V2 from Malaysia, dun hv any indicate on the box nor the case. Just found a hint in the manual last page.

    AG241-AU-QI-41221NC JL

    So, is it a AG241V2 - Annex A?

    and here is the problem:
    - once i reboot it, it can't establish connection with my ISP
    - the power LED keep flashing (green light)
    - only manual configuration IP setting computer are networked, the rest automatic mode are can't networked nor even able to get IP from the router.
    - can't login to the login page of the router (, keep connection timeout
    - tried press the reset button to restore the factory default setting. Fail, still like the same.
    - tried press the reset button for about 30secs, as heard from a friends it will lead to the firmware upgrade page if able connected. Failed, still can't login into the page.

    I'm totally don't have any experience dealing with networking devices, so can anyone teach what should i do to repair my router?
  2. mstombs

    mstombs Network Guru Member

    Suggests it is an Australian model manual at least, which will be Annex A but cannot use EU firmware as it has more flash/ram than EU models.

    If the switch is working but nothing else the device may be stuck in the bootloader waiting for new firmware by tftp, but without knowing which firmware you need I am not sure how to progress.
  3. waiket

    waiket Addicted to LI Member

    - anyways, my AG241V2's warranty is expired, willing to try as to gain some experience...
    - right now, i download a firmware: "AG241V2-EU-AnnexA-v2.01.03-code.bin" is it compatible? as i see all firmware which start with v2 are just from DE,FR or EU.. so which one u would suggest?

    - just for trying, can u write a step by step guide on what should i do?

    *oh yah, found much new term to me when browsing through the forum: debricking, tftp client.. what are those suppose to mean? tftp client? i just know there is a command start with tftp in the command prompt but client? is tat mean there is a third-party software to do the same job?
  4. mstombs

    mstombs Network Guru Member

    There's a Linksys tftp tool - look in the downloads section of this website. There's plenty of guides on the internet using tftp with the WRT54GL (and similar), the only difference I know is that the AG241 doesn't ever respond to ping, so timing of starting the tool a few seconds after power on is critical - just experiment, and using a hub/switch between PC and router helps.
  5. waiket

    waiket Addicted to LI Member

  6. mstombs

    mstombs Network Guru Member

    I am referring to that tftp process, but do not recommend the flash chip pin shorting, that seems risky (potential hardware damage). There should be a window of about 4 seconds after power up when the bootloader will accept new firmware via tftp - a hub/switch is useful if your PC takes time to notice the network connected. If you cannot get the timing right I would recommend connection of a serial console cable - but you have to make these.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice