Airport Express ate my WRT-54G

Discussion in 'General Discussion' started by tdmp, Jan 3, 2007.

  1. tdmp

    tdmp Network Guru Member

    Strange thing just happened. I tried to set up an Apple Airport Express as a USB print server independent of my linksys router. I'm in the middle of configuring the Airport Express when my linksys router goes "offline".

    Now it won't connect with either of my two laptops. I've turned it off / on, hard reset twice (along with the DSL modem). The web router status appears to be fine. Netstumbler shows it is transmitting; I can connect to the router via CAT5 cable, but can't obtain an IP address over wireless. I'm running v4.70.6 - HyperWRT 2.1b1 firmware, WRT54G v. 2. The two routers were about 6 feet apart during the setup.

    Has this happened to anyone before? Any suggestions? Is this router toast?
  2. orangekay

    orangekay LI Guru Member

    I have some very serious doubts that the AirPort Express had anything to do with any actual damage to your Linksys router's transmitter. Have you tried connecting when the AirPort is unplugged completely?
  3. tdmp

    tdmp Network Guru Member

    Yes, the Airport express is now unplugged and not transmitting. When I try to connect to my linksys wireless network, my computers either are continually "trying to obtain network address" or "Unable to detect network type". Something is definitely wrong with my router.

  4. orangekay

    orangekay LI Guru Member

    Try clearing the DHCP client table. Restarting the computers might not be a bad idea, either. OS X's DHCP client gets into some weird state where it needs a kick in the pants every once in a while--usually when you're mucking around with router settings.
  5. tdmp

    tdmp Network Guru Member


    OK, partial success here. I was able to Clear NVRAM and restore factory defaults. Now I am able to connect to the router via wireless. However,
    I am unable to save any settings (SSID, password, security settings, etc). To make things worse, I can't download any firmware to the router. It starts the firmware download but then keeps giving me a TIMEOUT ERROR. I think I have corrupted some part of the current firmware. I'll try more factory resets but I think I might have to buy another router.

    Moral of the story - configuring another router to join your existing network can be dangerous.

    Anyone have a WRT54G for sale?
  6. orangekay

    orangekay LI Guru Member

    You were probably breathing and blinking when it broke, too. Doesn't mean either one of them caused your router to die.

    Amazon has them on sale with a $10 rebate.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice