Alchemy 1.0 - problems with windows file sharing

Discussion in 'Sveasoft Firmware' started by SirDracula, Jun 4, 2005.

  1. SirDracula

    SirDracula Network Guru Member

    Here's my setup:

    - Linksys WRT54GS
    - Alchemy 1.0 final
    - 2 wired desktops
    - 1 wireless client laptop

    If I copy lots (200-300) files from the wired desktop to the wireless laptop, it works for a while but then it slows down to a crawl and eventually get an error message to the effect of "network share not available".

    If I copy the same files this time as a zip (no compression so I can keep the the same transferred size in case the total size is the problem) between the same same wired desktop and the same wireless laptop it works fine.

    If I copy the files individually between the 2 wired desktops it also works.

    The case that fails is lots of files between the wired desktop and wireless client.

    I have the loopback option disabled in Alchemy. Also, my wireless connection is rock solid, I keep ssh connections from the wireless client for many hours at a time without any problems, so a flaky wireless connection is not the case here.

    Any ideas why the windows files sharing dies from that wireless client?

    Thanks for your help.
  2. Toxic

    Toxic Administrator Staff Member

  3. SirDracula

    SirDracula Network Guru Member

    Thanks for your reply. Very much appreciated.

    Is there any *new* firmware out there that includes this fix, like DD-WRT or Talisman?

    If the Linksys firmware is the only one with the fix, do you happen to know if they finally aded static DHCP (i.e. assigning the same IP address via DHCP based on the MAC) -- this is the only reason why I don't run Linksys firmware and went with a 3rd party ...

    Thanks again.
  4. littlewhoo

    littlewhoo Network Guru Member

    You can apply this fix to any Firmware. They just did overclock the CPU to 216 MHz and changed some memory timing parameters. You can find the commands, that you have to enter to apply these changes to another firmware in the thread Toxic mentioned.
    Afaik overclocking the CPU to 216 MHz can be done with the commands
    nvram set clkfreq="216"
    nvram commit

    But you'd better check in the thread mentioned above, if this is correct and what the commands for setting the memory timing parameters are.

    No, they didn't.
  5. SirDracula

    SirDracula Network Guru Member

    Oh, so all that's required is the overclocking and memory timing changes ... I thought there was code that needed to be integrated. I'll slowly go over the 27 pages in that thread ...

    If it's all in the NVRAM then it's good, it will survive router reboots, but I guess a firmware upgrade followed by "reset to defaults" would wipe the changes out. Not a big deal, I would have to remember and check the settings again after a firmware upgrade.

  6. SirDracula

    SirDracula Network Guru Member

    Great. I tried the overclock to 216 and bricked my router. When I powered it off and then back on I got the constant blinking power LED. I even tried the pin 15-16 method ... no luck :(
  7. SirDracula

    SirDracula Network Guru Member

    My router is back from the dead and the overclock to 216 seems to fix it.

    I ran top on it while doing a big windows file sharing trasnfer and streaming music to another client, the CPU on this thing was pegged at 99% ... poor thing, no wonder it needs overclocking
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice