All servers/ports functional except ftp/21

Discussion in 'Cisco/Linksys Wireless Routers' started by bally132, Jan 1, 2006.

  1. bally132

    bally132 Network Guru Member

    I folks, glad this forum is here!
    My router is a WRT54G V5 with 1.00.4 firmware.

    I have 2 wired machines on my network, one is a Linux box with http and ftp servers, the other is a windows machine with ftp and other servers. I have several servers working on this network, including Apache on the linux box. Everything is working properly except ftp on both machines.

    I know the servers themselves are working because everything worked perfectly when using my old router. But the Linksys wrt54g seems to just ignore any requests for port 21. I've even put one machine in the DMZ and still no luck. This makes no sense to me.

    I've gone over the setup screens numerous times and can't seem to find what I've set wrong.
  2. bally132

    bally132 Network Guru Member

    I should also mention that I can connect to ftp on both machines locally. It's just from the WAN that I can't connect (Not even a 'hello'). However, transfers over the LAN are extremely slow (around 6 k/sec).

    I really don't understand why I have this problem. I've seen others with ftp problems, but never a solution that helped me.
  3. crawdaddy

    crawdaddy Network Guru Member

    I am going to assume this isn't the case according to what you said, but maybe your ISP decided to block port 21. Since it worked before, that isn't likeley. Unless the servers are somehow getting diffrent ip adresses than what you have forwarded, I don't see how that can happen. The router has no built-in FTP that I know of (it's got a tftp, but that's diffrent).
  4. EDinATL

    EDinATL Network Guru Member

    He's right, it's not his ISP either, the same problem is happening to me on my v4 WRT54G. I didn't have this problem with DD-WRT but with the latest standard firmware 4.20.7 it's definitely blocking incoming requests to port 21. I need to use the standard firmware for the Nintendo DS to work but I also need port 21. This is really annoying.

    DMZ or forwarding the ports does nothing. All other ports seem to work fine. Also disabling UPnP doesn't fix it.

    Lamest thing I've ever encountered in my life regarding a router.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice