(Almost) No brain method to read and write XFS on virtually every OS...

Discussion in 'Cisco/Linksys Network Storage Devices' started by psychowood, Jun 12, 2009.

  1. psychowood

    psychowood Network Guru Member

    Long antefact:
    I bought a NAS200 (I know, it's a bit on the slow side, but its sexyness compensates for the lack of speed) and a Seagate 1.5TB drive (I know, it's a bit on the hot side, but its cheapness compensates for the lack of coldness :biggrin: ), and I had to move ~1TB from a NTFS USB drive (two disks in JBOD, so connecting the drive directly was not an option).

    After formatting the new hdd in journaled mode via the web interface, I connected the USB drive to the NAS200, and issued a cp copy via telnet. And I waited. And I waited. Then I ran out of patience. :rolleyes:

    When I tried connecting the new disk to my mac, I discovered that XFS is simply ignored. Same for Win. Same for some random distros Linux LiveCDs I tried downloading.

    Short story:
    -Download VMware Player ( http://www.vmware.com/download/player/ ) and install it
    -Download a empty linux virtual machine (courtesy of easyvmx.com: http://tinyurl.com/EmptyLinuxVM ) and extract it in a directory
    -Download sysrescuecd iso ( http://www.sysresccd.org/Download ) and put it in the same directory of the linux vm you extracted in the previous step. If you don't want to mess with the configuration file, also rename it into "cd.iso".
    -Run the vm, boot SystemRescueCD and mount your XFS disk (I used a usb hdd case) in read-write mode.
    -Have a nice copying :)

    Perhaps it isn't really a no-brain method :) , at least I can confirm that works for sure* at least if you use the NAS200 without a RAID configuration. :thumbup:

    *You need a x86 CPU, tho. :biggrin:
  2. bluto_39

    bluto_39 Addicted to LI Member

    I have been following these instructions, but as I am a Linux neophyte, I have no idea on how to mount the disk. I am also using an external hdd case. Can you help?
  3. psychowood

    psychowood Network Guru Member

    You should identify your usb disk in /dev, mine was sdb, the data partition is the 1st one ( /dev/sdb1 ).
    Otherwise, run "tail -f /var/log/messages" before connecting the case to check the log and read the device name.
    Complete instructions here :)
  4. bluto_39

    bluto_39 Addicted to LI Member

    Thanks, but I am still having issues. My drive also shows up as /dev/sdb with 3 partitions - sdb1, sdb2 and sdb3. sdb1 has the largest partition and I try to mount that as an xfs filesystem type. I get back an error saying it can't read a superblock.

    Any other ideas? I should mention that I originally had my NAS200 drives striped in order to load balance. Is this what is screwing up the works?

    Thanks again for your help
  5. psychowood

    psychowood Network Guru Member

    With striped you mean in RAID0? If so, you need both disks connected to TRY to read the volume (otherwise it will always show as corrupted), and I'm sorry to say that I don't know what you exactly need to do to mount it...
  6. bluto_39

    bluto_39 Addicted to LI Member

    Thanks very much for all your help. I really appreciate it.
  7. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    It should be possible to mount RAID0 formatted harddisks from the NAS200 using mdadm. It's not for the faint-of-heart, mdadm takes a LOT of options but I'm sure it's possible.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice