an explicit upgrade guide for stock wrt54g to thibor 14

Discussion in 'HyperWRT Firmware' started by myrrhlin, Mar 11, 2006.

  1. myrrhlin

    myrrhlin Network Guru Member

    an explicit upgrade guide for wrt54g to thibor 14
    (a success story!)

    adapted from hanstoppable's guide on forums.

    my hardware: linksys wrt54g v2.2
    starting firmware: linksys v3.03.1, Oct. 18, 2004
    web interface shows: "Wireless-G Broadband Router" in upper right

    goal: upgrade to thibor 14.

    0. verify your router works. i've been using mine for months.

    1. download everything you think you might need. certainly and Hyperwrt_GS_Thibor14.bin. I also downloaded linksys firmware from their site and dd-wrt mini v23, and web pages full of instructions including how to revive a bricked router, and other stuff too.

    2. unplug all other connections, including WAN. dont want any interference. only your computer should be wired into the router.

    3. went to (address i've been using for this router), logged in, and on admin tab i reset the factory defaults. you might want to write down your settings first.. cause this is gonna erase em!

    4. because factory default puts router at, and my ip is no longer valid, I had to get a new valid one:
    controlpanel > network connections > LAN > tcpip properties > change to "automatic" (dhcp)
    if you're already on automatic, you'd still want to right-click on LAN icon and "repair connection" to get a fresh new ip address from the router.
    to check/confirm your computer's current ip settings:
    start > run > cmd [enter] gives you a command window.
    then you can type > ipconfig
    I did this to confirm the router gave me .1.100 address (factory settings DHCP gives out number starting at 100)

    (DIDNT DO THIS; but thought about it!) wireless > basic settings> wireless mode -> disabled. save settings. continue. (any comments about this? i didnt want interference, since factory default has wireless on and open, but was afraid to have a non-factory setting... paranoid i know!)

    5. Navigated to "Administration > Firmware Upgrade" section and browsed for the tofu13c firmware file called "code.bin". It is in the archive you should have unzipped.

    6. Clicked the upgrade button. it has been suggested that it is a good idea to wait five minutes. So I did. However, the upgrade was successful in about one minute with no hang or apparent problems. I waited five minutes anyway. Hey, why not?

    7. I clicked the "continue" button on the page that said the upgrade was successful, front page loads and in upper right hand corner i see "Firmware Version : v4.30.1, HyperWRT 2.1b1 +tofu13c" was indeed running. Yayness.

    8 Not sure if this was necessary, at this intermediate stage, but seemed like a good idea.
    Factory Defaults > "Clear NVRAM, restore factory defaults" router will reboot. takes about 30 seconds, then page reloads automatically.

    9. Then I navigated to the "Upgrade Firmware" section and browsed for Hyperwrt_GS_Thibor14.bin file I had already downloaded, and uploaded it to the router.

    10. after 70 seconds, I saw the page that said the upgrade was successful...and router was rebooted automatically, another 30 seconds, and front page reloaded automatically.

    11. Then I saw the firmware description up in the right corner "Firmware Version : v4.70.8, Hyperwrt 2.1b1 + Thibor14". Whew.
    also now says "Wireless-G Broadband Router with SpeedBooster" and "WRT54GL"

    12. Navigated to "Administration > Factory Defaults" and again did "Clear NVRAM, restore factory defaults". router reboots, and after 30 seconds Admin page reloads.

    13. I think everything is golden from here. Enjoy! I did have one little glitch though (see below). I think it can be resolved if you simply close your browser entirely and open it fresh at this point, before you start modifying settings.

    seems like a good place for this warning. DO NOT LOAD ANY SAVED SETTINGS FILE FROM PREVIOUS FIRMWARE. type in all your new settings by hand.


    My Little Glitch:

    Here's what I experienced at this point (not having closed my firefox browser): Started changing settings, everything working fine. Get a quick "Continue" button each time. Then I changed "local ip" address, then i have to wait for 30 seconds before continuing. Renewed my computer's ip address (right-click on LAN, "repair connection") so i can reconnect, type in router's new IP address and get in (without login), but now i can't make any other changes to router. That is, i'm able to navigate around to any config tab, but change something and click "save changes" gives me the result "The connection was reset.
    The connection to the server was reset while the page was loading."

    close the firefox tab which is pointed at the router, and open a fresh one. same trouble. even trying "reboot" in admin tab gives same error. Close the firefox tab again. So I open IE and log in to router. now i'm able to save changes just fine. make some changes and finally quit IE.

    after a while, I go back to firefox, open a new tab and point at router again. still no login necessary, but now i'm able to save some changes. weird.


    Big thanks again to hanstoppable, danielhaden and everyone else who added their comments and tips, both here and at forums and still other fora, and of course thibor and tofu. No hard resets necessary (see elsewhere for description of this).
  2. kulprit

    kulprit Network Guru Member

    Firstly, is it necessary to go from tofu 13c to thibor14 as I am already running tofu11. Will this be enough.

    Also, is a reset of factory defaults still needed as the time required to redo all the settings may negate the benefit I get from an upgrade.
  3. jruschme

    jruschme Network Guru Member

    I don't know about going straight from tofu11, but I did go from tofu13c to thibor14 without a nvram reset.

    It appears to work find with no problems... at least as well as it did under tofu13c. What I don't know is whether I'm missing out on anything by having not done the reset (i.e., are Speedbooster settings correct?).

    YMMV, but I think it should be safe enough.

  4. myrrhlin

    myrrhlin Network Guru Member

    although i haven't done it, from all my reading i am pretty sure you can go straight to thibor 14 from tofu 11 without trouble. let's say i'm 95% confident?

    better to be safe than sorry here. For me, the benefits _really_ outweighed the 15 minutes spent re-configuring the settings. I noticed the speed right away. But i was upgrading from a linksys firmware! If you're happy with tofu11, you don't need to mess with it. (As a side note, by playing with the settings will you see what's there and how they work. I don't consider that time wasted!)

    Here's the changelog showing what's been done since tofu11:

        * Upgraded IPP2P to version 0.81_rc1.
        * Modified minimum idle time for Dial On Demand to 0.
        * Added "Zonnedit","EZ-IP" and "EasyDNS" to DDNS page.
        * Added Local Log option to Log.asp.
        * Added 2 IMQ virtual devices for Advanced QoS functions(cli only).
        * Dropbear now supports AES128/256.
        * Added lots of iptables matches/targets whilst maintaining stability.
        * Fixed Conntrack bug not starting at bootup.
        * Fixed Parental Control not working. 
        * Added Port Redirection Functionality and Webpage.
        * Added P2P blocking in the Firewall GUI.Blocks Bittorrent, Kazaa, WinMX, Edonkey, DC and Gnucleus using ipp2p
        * Added P2P Specific QoS in GUI
        * Added Static DNS list option to use Static Entries as backup for ISP DNS Servers.
        * Added Portscan blocking option to firewall.
        * Set Max update period for DDNS to 28 days.
        * Integrated Safari capfix from tofu. 
        * Dropbear upgraded to 0.47.
        * sshd now stops immediately when disabled from the GUI.
        * Remote sshd and remote http access can now be enabled separately.
        * Misc cleanup of sshd related code.
        * Fixed tz-set timezone not being used in some cases. This is now written in /etc/TZ.
        * Fixed telnet-launched shell not loading profiles.
        * Device list now also linked to OUI search. 
        * Using 4.70.8(GSv3) codebase.
        * Modified SSHD behaviour so that disabling dropbear removes all instances and Rebooting is no longer necessary
        * Updated dropbear code(thanks Tofu)
        * Fixed multilanguage Web GUI bug first seen in Thibor12
        * Fixed /usr/sbin/ missing from ash's default PATH.   ?
        * Fixed SSHD remote port wasn't saved.
        * Afterburner setting removed (it wasn't supposed to be there and doesn't really do anything). 
        * Dropbear added thanks to Ewrt project and Thibor.
        * WOL support added thanks to qwerty.
        * BSSID in site survey is now linked to the OUI search in
        * Some QoS adjustments. ACK and ICMP packets can now be prioritized. Preset ports re-enabled, added a generic range of low ports and high ports. The Low priory setting is now usable and unclassified traffic is now placed in between Medium and Low rates.
        * Dnsmasq updated to 2.26.
        * Various GUI cleanups. 
        * Fixed PPTP/L2TP address used for DDNS.
        * Use of Dnsmasq for DNS in DHCP can now be disabled.
        * Use of ISP served DNS (from DHCP/PPPoE) along with static DNS can now be disabled.
        * DHCP client: Fixed a problem with udhcpc not closing sockets in some cases. Fixed a problem with the DHCP release button not working. udhcpc is now automatically restarted if it crashes. Thanks to koitsu for hunting the bugs down!
        * Time: Automatic NTP updates can now be disabled. Time is now updated even if WAN protocol set to disabled.
        * iptables: Missing SNAT iptables extension added. iptables_targets no longer display the standard and error targets which show up as a blank line and the word ERROR.
        * Site survey: Now works even without xmlhttp. Controls simplified.
        * Fixed a memory leak when viewing the status page. 
    (This list is a mash-up of tofu and thibor changelogs -- the item "ash's default PATH" appears in tofu but not in thibor changelog. not sure if it's in thibor.)

    anything look important to you? "memory leak" and dhcp client bugs seem important to me.
  5. Thibor

    Thibor Super Moderator Staff Member Member

    i'm not sure if the code was in place to allow upgrading cross platform back in tofu11, it may be but you'd have to try it to be sure. if it doesn't work then you'll need to upgrade to tofu13
  6. zachariah

    zachariah Network Guru Member

    myrrhlin: I've followed your directions very closely and sucessfully upgraded from linksys' crap firmware to tofu13c then thibor14. Only thing now is I'm suffering from frequent disconnections from applications such as AIM. I have made a seperate post about it here,, maybe you can take a look and give me some help otherwise I probably have to go back to 13c if no one with my hardware and firmware(you) can assist me.
  7. ofbarea

    ofbarea Network Guru Member

    Did you deleted the NVRAM?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice