[Announce] Jac0: Alternate firmware for NAS200 with ext2, dropbear, telnet, more

Discussion in 'Cisco/Linksys Network Storage Devices' started by jac_goudsmit, Mar 10, 2008.

  1. civic95man

    civic95man Addicted to LI Member

    i have a problem that i hope isnt too serious. I have had jac's custom firmware on my media server for a little over a month now. Everything worked great. Up until last week, the NAS would power down the hard drive after 10 minutes and the fan 10 minutes after that. I have not changed any of the settings, yet it doesnt turn the hard drive off any more. I've rebooted it twice now with still no luck. I also noticed that the drive activity light blinks every few seconds along with the network activity light. I've blocked the NAS IP from getting WAN access so nobody should be able to access it through the internet and I know that nobody is using it in the house.

    I just tried to scan the drive with the built in scan disk web interface and it fails to run. i checked the log and it said it was unable to scan because the drive was in use, yet nobody was accessing it that i know of.

    I'm pulling my hair out trying to figure this out. I have a 4.4.4i version of Twonky installed on the NAS. Thank you
  2. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    [sorry this has been sitting in an open window on my desktop buried under dozens of other windows for a few days]

    Hmmm a brain transplant... I guess that would be cool, in a way... You can put one of those motherboards in there and have it run Windows or a standard Linux distro or FreeNAS or whatever, and still keep the sexy box. You wouldn't have the LED's and the backup button anymore but that's no biggie.

    I'd be interested in such a project. You should take some pictures while you're working on it and post them somewhere!

  3. mpdrie

    mpdrie Addicted to LI Member

  4. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    The "R75" files on the Linksys FTP site appear to be an (old) archive of Crosstool 0.42 and are not a firmware release or beta version. They may have been misplaced by Linksys staff. By the way, the bigger file contains the smaller file and source code.

    See this thread.

    UPDATE Version R75 is now available as an official download (not beta). At the time of this writing, the incomplete source tarball is still online (90MB) so I encourage everyone to ask Linksys to put the full GPL sources online (they should add up to about 230MB so if you see a file of around that size, ignore this edit).

  5. civic95man

    civic95man Addicted to LI Member

    Okay, I found the culprit last week and both the fan and the hard drive are both powering down. It turned out to be the UPnP which was on by default. I turned it off and now it goes to sleep properly. I've been testing the media playback this weekend and it seems to be working fine. It is strange that it suddenly quit going to sleep. I hope this will help someone that had the same issue as me.
  6. wildwilla

    wildwilla Addicted to LI Member

    problem with RSA and SSH

    Hi there

    So i updated the frmware and telnet onto the box and set the password, edit and moved the file, rebooted, but then when i i try to SSH into the box i get the ollowing message.

    Someone could be eavesdropping on you right now (man-in-the-middle attack)!
    It is also possible that the RSA host key has just been changed.
    The fingerprint for the RSA key sent by the remote host is
    Please contact your system administrator.
    Add correct host key in /Users/userDir/.ssh/known_hosts to get rid of this message.
    Offending key in /Users/userDir/.ssh/known_hosts:5
    RSA host key for 192.168.0*.* has changed and you have requested strict checking.
    Host key verification failed.

    so i go to the Known_host s file and remove the line associated with the IP address and then i can get to the login but the password i change dit to does not work, even when i try the default root password.

    Any idea?

  7. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    How to re-enable Telnet on the Jac0 firmware

    Did you change the host name of the NAS200 after you let it create the key files? This may cause the problem that the host identification changed, and it may make it impossible to log in through SSH.

    If you locked yourself out from telnet and ssh access, follow these instructions:

    Use a UNIX compatible editor such as Notepad++ or Metapad to create a shell script in the rc.d directory on the first harddisk of the NAS200. The script file should have a name that starts with "rc." (e.g. \\nas200\disk 1\rc.d\rc.restoretelnet). Make sure you configure your editor to use LF-only (Unix) line endings or the script will not run. It should contain the following lines:

    rm /harddisk/volume_1/conf/no_telnetd
    Turn the NAS200 off by pushing and releasing the power button on the back side (it takes a few seconds to shut down after the beep), then power it up again. You will hear a beep followed (after a minute or so) by two beeps. Then you should have telnet access again and you can erase the shell script (it only has to run once).​

    Once you have telnet access, you can erase the key files using the command rm /harddisk/volume_1/conf/dropbear* and rebooting the machine again. If you reboot from the command line, always use /etc/rc.d/rc.reboot (not "reboot"!).

    The next reboot will take a long time (more than 5 minutes) because the box will regenerate the host keys. After this, you should be able to log in through SSH again and disable telnet by typing touch /harddisk/volume_1/conf/no_telnetd and rebooting again. Make sure you can log in through SSH before you disable Telnet! If you can't log in through SSH, use the passwd command in a telnet session to set your password.

    Once again, before you reboot after touching /harddisk/volume_1/conf/no_telnetd, make sure the shell script to erase that file is gone (duh!). Of course your can also choose to leave Telnet enabled if you trust everyone on your LAN (but remember your LAN includes your wireless LAN).

    Good luck!

  8. wildwilla

    wildwilla Addicted to LI Member

    hi Jac

    104 on the info, i will try this tonight.

    do you also know of the best way for me to upgrade the drives i have inside the box? currently i have 300 gigers and e new 1 TB drive arrved today.

  9. dinbinak

    dinbinak Addicted to LI Member

    Is it possible to create soft links on the NAS 200

    Hi Jac:

    You doing a great job. You make things better.

    Basically I am trying to work on Oracle using NAS200 as my storage space for database.

    Based on your doc in this forum , using the firmware I have upgraded and I am able to telnet. I have few questions (i am not an linux admin, just for your info):
    i) can i see these NAS200 Disks from my Linux system by giving fdisk -l . (I am able to run fdisk -l from telnet session of NAS200 and see).
    ii) can i mount NAS200 Disk (harddisk/volume_1/data) on linux or else can i create soft link pointing to it from the Linux system
    iii) can i create raw partitions of the NAS200 disks and access it from Linux system
    iv) also wanted to secure shell from Linux system to login into NAS200 without prompting for pass.

    I would appreciate if you could clarify my above doubts.


    Dinesh C
  10. nsbaca

    nsbaca Guest

    1. Fix the long indexing time issue when media server scans certain video file format
    2. Fix the slow write performance by enabling non-jounaled file system -- drive reformatting is required.
    3. Updated Media Server with QoS tagging support.
    4. Detect and display the invalid characters entered by user in WebUI.
    5. Hard Disk Configuration can be changed without reformatting the drives.
    URL: http://<NAS200_IP-Address>/Administration/mode.cgi
    6. Force to perform DDNS update when user click "Update Now" button.
    7. Fix the issue that WebUI cannot be accessed until system boot up scan disk completes.
    8. Fix that the configuration file cannot be restored if the file name includes space.
    9. WebUI, "Cancel" button will be disabled while performing "Reset to Default".
    10. WebUI, Add a test button for e-mail alert testing.
    11. Fix the issue that the drive size can not be recognized correctly when hard drive size over 500GB under JBOD/LVM configuration.
    12. Enhanced to prevent strange share folder name.
    13. Fix WebUI problem for share permission assignment when there are more than 7 users.
    14. Fix the IP address validation rule so that "xxx.xxx.xxx.0" will not be accepted.

    Unfortunately, the GPL code is still unavailable
  11. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    fdisk is a program to edit partition tables on local disks. It cannot be used for network disks. Although it's possible to repartition the NAS200 harddisks via a telnet session, you shouldn't do this because the Linksys software depends on the partitions the way they are. You should use directories to split the disk up between different users and purposes.

    The short answer is no.

    The long answer: on a Linux system you can use Samba or FTP to access the NAS200 over the network. On a Windows system you can also use FTP; you don't need Samba because Samba's functionality is built into Windows.

    In Linux, probably the easy way to access the NAS200 is to install Samba and use
    mount -t smbfs -o username=admin,password=secret "// 1" /mnt/disk1
    or something similar.

    In theory, you might. But in practice it's easier to simply mount one of the shared directories onto the Linux file system.

    The NAS200 runs Dropbear. Please read the Dropbear documentation and/or google for Dropbear public key authentication. It's possible that this will not work for the root user, so you may have to create a non-root user by editing the /etc/passwd file or using the adduser command. Remember to copy the file to /harddisk/volume_1/conf so it survives a reboot.

  12. Indifference

    Indifference Guest

    I installed nasi200-164.bin on my Nas200 and it works so much better now, thanks for making it. It is a shame that linksys released the nas200 with firmware that was so slow. nasi200-164.bin works even better than the updated firmware for the nas200, which a linksys rep gave me a couple weeks before it was widely available(on the website, I know the linksys forums had the beta for quite some time). Anywho my real purpose of this message is to ask why nasi200-164.bin twonky server and the PS3 dont mesh. My xbox 360 can still see the twonky media server and play all my wmv, and AVIs but my PS3 all of sudden makes about 600 of my 610 videos available on my NAS200 an "unsupported format". Is there an update to nasi200-164.bin that will fix this? I know this is probably a dumb/noob question but I really need help. Also how can I configure the twonky media server on the nas200?
  13. civic95man

    civic95man Addicted to LI Member


    I know your pain. I bought my NAS specifically to serve my media files to the PS3 and take the workload off of my windows computer. Are you using the built-in Twonky media server? If you are, you need to disable it through the config menu and manually install the latest version. There are great instructions written by Jac towards the beginning of the thread. I had to install the newer version (4.4.4i, although 4.4.5 is out) and it fixed all my PS3 troubles. I guess that the version on the NAS is not compatible completely with the PS3. Anyways, good luck and I hope it works for you.
  14. MatrixOnLine

    MatrixOnLine Guest

    Jac and all

    It's not really true that having the latest 4.4.5 Twonky fw is going to work with PS3. I have done few test with Twonky installed on my Windows machine and the real problem is whether Twonky understand that the client connected is a PS3 or not. What happened is that Twonky was seeing my PS3 as Generic DLNA Device.

    There is a page into the Twonky administration to manually select the client in case Twonky doesn't automatically understand the vendor/model. Here the picture:


    So what happened in my case was that PS3 was seen like a Generic DLNA Device. In this case Twonky only streams MPG and WMV files to the client. In fact as workaround I have renamed all my DivX movies as .mpg and it worked fine. I could watch the movies. I then tried with my NAS200 and it worked too! So renaming the files is the first option.

    What I have done after was to manually set the client as PS3. Look the picture here:


    In this was everything works perfect!!! So my PS3 can stream any files supported by the PS3 itself (I have renamed back the file to .avi). I could stream .mp4 files as well.

    Unfortunately this works only when you have Twonky installed on Windows or Linux because you have access to the Twonky Web GUI to manually set your client. In the case of a NAS (like NAS200) you don't have this page.

    So we have only two options here:

    1) Integrate into the NAS200 Web GUI the Twonky page to manually select your client model. This requires a new firmware release.

    2) Being able to telnet into the NAS and change the client.data file. It's a text file where Twonky put the client registered and the client model. It's the result of the changes in the web page mentioned at point 1. I believe that this file is called client.data on Windows and client.db on Linux. So on the NAS may be the second case. Here we probably need a new fw but could be also a customized fw from Jac since we just need telnet enabled.

    Finally just to let you know. I am working for a company very close to Linksys :). Sorry but don't want to say the name :tongue:. I have sent the same information to the NAS200 Product Manager to understand whether there is a plan to release a new fw and include this web page into the new GUI.

    Anyway the Twonky release into the NAS200 3.4R75 fw is Let's say that is newer than 4.4 where Twonky started to support PS3 but is older than where Twonky added extra support for PS3:

    * DivX and WMV support for PS3 (

    I anyway tried DivX on the current NAS200 (renamed to mpg) and it worked fine.
  15. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    Thanks MatrixOnline!

    I don't own an XBox but no doubt this is great information for people who do.

    I'd like to add that there is a third option: you can run the latest Twonky from the harddisk of the NAS200 if you run the Jac0 firmware. That way you can use all the features and you'll have access to the full Twonky web GUI to manually select the client model. You have to buy another license to Twonky (you can't use the license that comes with the NAS200) but I think it's worth the few dollars.

    If you're close enough to Linksys to know the Product Manager, can you let him/her know that they are required to put the GPL source code online? Currently the link on the website points to a tarball on the FTP site that only contains the cross-compiler, not the source code.

    Thanks again!

  16. dinbinak

    dinbinak Addicted to LI Member

    Thanks Jac for your prompt reply.

    I was not clear with the RAW partition. Can i create a unformatted disk if so how on NAS Box. If so how will I mount it? I want Oracle to recognize it as a RAW device. Any possibilities please let me know.

    Thanks once again.

  17. Alrizz

    Alrizz Guest

    Mounting shares from another NAS

    Hi all,
    I am not sure why I am having this problem now. I sent up my NAS200 and installed jac's modified firmware and got Twonkys runnning no problem, lots of reading these forum threads. I then had to mount a share from my other NAS USR8700 I forget the format of the mount command that in used but it worked and I was able to access the share and more importantly twonky could see it and I could stream my files from my other NAS to my ps3. Anyway I had to reboot and I lost the mounts. Long story made short I can not for the life of me get this share remounted I have read over many forum threads looking for ideas but to no avail.

    I have tried mount -o cifs // /harddisk/volume_1/data/public/Media2 username=username,password=secret and i now get no file or directory exists

    If anyone more linux savvy could point out my error in format it would be greatly appreciated
    cifs is installed

    ps thanks jac for the amazing job, looking forward to looking at your new project NASi200
  18. mlastra

    mlastra Guest

    USB NTFS question

    I have one doubt: is there any way to make the USB HD work if they are with NTFS? I mean you can read but not write on them. I have read the whole thread but I could not find the answer.

  19. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    I don't know what exactly you mean with "create" a "RAW" partition. A harddisk has a partition table with zero or more partitions and if you want access to the partitions you use device names such as /dev/sda1 /dev/sda2 etc. These are symbolic names that the operating system translates to node numbers so that it knows which device driver to talk to to access the data on a disk directly, i.e. at the sector level, that's what "raw" usually means. I don't know if Oracle uses a different definition, but you can't mount a "raw" partition over the network as far as I know.

  20. Frenkie

    Frenkie Guest

    Sorry for asking this, I don't know if it's been asked before.
    Is there a way to add the nfs protocol to the NAS200?
    I want to use my NAS for adding datastores for vmware on it.
  21. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    That was one of the first questions asked in this thread. You can download the NFS modules as a tarball from the location in the first post.

    Don't expect too much, though... NFS is even slower than Samba...

  22. sdblanchet

    sdblanchet Addicted to LI Member

    Hi Jac

    I have to admit, I still did not load your firmware (??.164.bin) :confused:

    Still, I got a problem I want to ask you about, it is related to the NAS200...

    I use this to mount the NAS200 to my linux box file system

    mount-cifs //nas200-1/PUBLIC\ DISK\ 1/DOWNLOAD /usr/local/data/DOWNLOAD rw -o credentials=/etc/rc.d/WhatEverFile

    It mounts fine but I got zero access to it, I can do "ls -l" or open it up in the file browser but I can simply do nothing with the files, no copy, rename, erase, chmod or whatever. Any ideas ?
  23. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    For now, it's not worth it -- the Nasi200 firmware (build 164) doesn't have the extra features that Jac0 has. I'm working on updating Nasi200 to R75 and then I'll add those features.

    I don't mount SMB/CIFS file systems from linux and it's not compiled in my kernels, so I can't test it, but from what I see on the man page I think in theory I would type something like mount -t cifs -o user=jac%secret "//nas200/DISK 1" /mnt/disk1.

    If you get no access, you're probably connected as guest user; maybe your credentials don't get picked up or are incorrect? Maybe there's a problem with mounting a directory that's inside an actual share ("PUBLIC DISK 1\DOWNLOAD" vs "PUBLIC DISK 1")?

    Maybe you should ask this question on a Samba-related message board. Or as a new thread in this forum or as a new thread on the Linksys forums. After all, this thread is related to the Jac0 firmware and your question is much more generic; you have a much better chance of getting an answer if you post it in a more public place.

    If you ask your question outside the NAS200 community, it might help to mention that the NAS200 runs Samba 3.0.22.

  24. sdblanchet

    sdblanchet Addicted to LI Member

    Thanks Jac

    Mounting it from the root works better. Could that be related to the fact that the users don't have the same id on my system compared to the nas200? If I try to adjust the uids, should I change my system's ids or the nas' ids ?

    Something to think about i guess
  25. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    I don't know, sorry...

    Whichever is easiest to you... If the NAS is the last device to enter a workgroup and you already have a number of users defined, it would probably be easiest to make the user ID's and passwords on the NAS match the ones you have already defined elsewhere. That's how I did it in my home network anyway, that way I don't have to enter my password all the time (the default password for resources on the workgroup is the same password as you used to log in with)...

  26. pen1010b

    pen1010b LI Guru Member

    I got jac0 image installed.. Made a custom RC.x script.. put newest twonky on HDD, and started it.. all works great.. only downloaded compile for linux, and did no changes..

    So latest twonky, 4.4.6, works great with ps3, if you install on HDD..

    btw, Thanks for great image!.. planned to compile new R75, but with small changes your image works fine without daring to compile and fix image for box..
    but step 1, getting mobile usb serial cable is in place, so i might make my own image too.. but what to fix/change is not planned..

    problem mentioned here, was that Sony changed an Init info sent from box, so your resources/clients.db needed updating to "PLAYSTATION 3" and not "PLAYSTATION3"
  27. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    Thanks pen1010b, that's great info!

    I don't own a PS3 myself so I can't test or troubleshoot the use of it with the NAS200.

    By the way, I'm thinking for the NASi200 project we should make it much easier to run an updated Twonky... Would be nice if it could automatically run a harddisk-based Twonky instead of the internal one. Hmmm...

  28. pen1010b

    pen1010b LI Guru Member

    I am sure a little "if [ -e /harddisk/1/data/twonky ]" would incorporate into image quite nicely and start excutable if found..
    Anyways the rc script gets the job done for now..

    Have you found out how to identify which /harddisk is used? I started the setup with a virtual drive, but it was assigned disk 3, so your image could not find anything in hardisk/1/data... so for now i use 2 seperate disks..

    Whats the max size for image? have not checked any mtd's, so atm i do not know kernel/root mtd partitions.. maybe you already know?

    would a "noatime" on mountpoints not make the drive access a little faster, btw?
  29. pen1010b

    pen1010b LI Guru Member

    I can answer my own question now :)

    noatime has no effect on transfers, as i measured it..

    and the sizes of mtd's
    1792 mtdblock0
    6144 mtdblock1
  30. 4d45ch

    4d45ch Addicted to LI Member

    Great job,

    i use raid 0 with 2tB

    all work ok but my system disk (raid 0) is on volume_3

    no more different

    Twonky 4.4 work great with PS3 (after update firmware ps3 above2 .4, wonky need 1 modification in database

    THANKS Jac0
  31. ARP ONE

    ARP ONE Guest

    I am fairly new with the world of NAS, but I'm deeply interested. Is there any way for you to give me a step by step procedure on how to have my NAS200 support NSF? I'd really appreciate it. Thanks!
  32. metheos

    metheos Addicted to LI Member


    Can I use my NAS200 with my apple tv? so that my apple tv sync with the 1TB Nas :)
    When you connect the ATV to an iTunes library for the first time, the ATV displays a code that needs to be entered in iTunes in order to use the library. I'm not aware of any NAS that allows you to enter that code.:frown:
  33. Terin

    Terin Guest


    Wow! It took a while (about 4 hours) to figure everything out... but now I (kind of) know Linux better.

    My big issue right now is that TwonkyMedia kinda sucks. I have a bunch of OGM, MKV containers (and other formats, i.e. xVid, h264) and none are recognized by Twonky. That basically renders the UPnP pointless.

    However, it looks like GeeXboX would work nicely:

    Have you tried building this or does anyone else have any experience with this? It'd be a nice (free) alternative. If anyone has built this, can they provide the binaries... I'm still, very much, a Linux newbie, and I don't think I'd have any clue how to install/compile this stuff...
  34. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    If by NSF you mean NFS: there are some clues as to how to use the NAS200 as NFS server near the beginning of this thread. Basically you have to download the extra filesystem modules, insmod them and run a script to set up your shares.

  35. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    I'm sorry, I don't have any Apple hardware so I'm afraid I can't help...

  36. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    Great! That's what it's all about: learning stuff about Linux, applying your new knowledge, enjoying the fact that it was you who made it work, and sharing your new knowledge with others.

    I'm sorry stuff like this is not very easy at this time... The NAS200 doesn't use a standard distro so you can't use the binaries that are available on the geexbox site; you'll have to compile it yourself. There's no easy recipe for compiling stuff to work on the NAS200 at this time, and I don't have time to give you specific instructions here.

    The short version is that you will have to set a number of environment variables such as CC before you run ./configure, so that the rest of the build process will use the Linksys cross-compiler and linker for the build. You will also have to build their prerequisites: libdlna and libupnp (the NAS200 has libupnp 1.4 but GeexBox uShare states that it requires 1.4.2). pkg-config may also be required but I think you will only need that on your host system, you don't need to cross-compile it for the NAS.

    Creating a webpage that tells you how to build stuff for the NAS200 is definitely on the agenda, but it will probably take a while before I get to it. Keep your eye on this forum!

  37. fastie

    fastie LI Guru Member


    Thank you for your work on this..
    I have installed your firmware but when I want to do the ssh password it does not save the settings. I change the password and then copy the passwd file over to the conf folder on the harddisk but then I reboot with rc.reboot and when it comes back I try to login as root and the password is not working.. then when I login with telnet and look in the conf folder the passwd file is no longer there..
    Is there anything I am missing?
  38. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    It sounds like you're doing all the right things... I assume you made sure your full paths were correct: /etc/passwd and /harddisk/volume_1/conf . I find it strange that you don't see any passwd file in /harddisk/volume_1/conf when you reboot, because that's where the Linksys software stores it... If you don't copy a file there yourself, the Linksys software will do it when you change a password through the web interface.

  39. pen1010b

    pen1010b LI Guru Member

    His issue is probably that he got a JBOD enabled, and one big filesystem?
    as you write in your image details, only a seperate disk setup will work..
    I had the same issue in the beginning as i used JBOD too, so the volume_1/conf was just a RAMDISK link.
  40. fastie

    fastie LI Guru Member

    Hi Jac
    Ok so if I understand it right you say when I change a password in the web gui it will also copy it over. So I tried it and change my admin password and it does not copy it over. So still no file. Do you think this got anything to do with the fact that I downgraded the firmware from 3.4R75? Do you know of anything I can try?
    BTW: let me know if I can help you test the NASi200 firmware.
  41. fastie

    fastie LI Guru Member

    No I don't have a JBOD but do have it as RAID 1.
    Could this be the same for RAID1?
  42. fastie

    fastie LI Guru Member

    Sorry.. It looks like it was my RAID setup..
    Fine for now.. got everything working and waiting for home time so I can go and test it on my PS3
  43. matsimoto

    matsimoto LI Guru Member


    this thread is so long I think missed something, but please help me to find it.
    I used the enable NFS script posted in this thread, but it does not work :(.

    The script creates the following output when started by manually:
    Using /harddisk/volume_3/data/extra/modules/net/sunrpc/sunrpc.ko
    Using /harddisk/volume_3/data/extra/modules/fs/exportfs/exportfs.ko
    Using /harddisk/volume_3/data/extra/modules/fs/lockd/lockd.ko
    Using /harddisk/volume_3/data/extra/modules/fs/nfsd/nfsd.ko
    insmod: cannot insert `/harddisk/volume_3/data/extra/modules/fs/nfsd/nfsd.ko': Unknown symbol in module (-1): No such file or directory
    mount: Mounting none on /proc/fs/nfsd failed: No such device
    ./startNFS: 22: /harddisk/volume_3/data/extra/sbin/rpc.portmap: not found
    ./startNFS: 22: /harddisk/volume_3/data/extra/sbin/rpc.nfsd: not found
    ./startNFS: 22: /harddisk/volume_3/data/extra/sbin/rpc.statd: not found
    ./startNFS: 22: /harddisk/volume_3/data/extra/sbin/exportfs: not found
    ./startNFS: 22: /harddisk/volume_3/data/extra/sbin/rpc.mountd: not found
    Where startNFS is the name of the script. I use RAID 0 but this is no problem till now.
    I read several postings for this problem but there are no answers ...

    The questions are:
    What can I do for getting nfsd.ko loaded ?
    Where can I get "...sbin/rpc.mountd" ?
  44. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    I agree, but people keep posting new problems in this thread instead of starting new ones... :(

    All needed files should be in this file on my website. I tested it and it worked, but it's so slow that I don't use it myself.

  45. matsimoto

    matsimoto LI Guru Member

    Hi Jac,

    you are right, I opened a new thread.

    btw: the link in your post gives 404.
  46. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    Fixed... (Sorry)

  47. pen1010b

    pen1010b LI Guru Member

    NFS tar ball still not working! as nfsd.ko is missing a module i guess..
    and no sbin files found here...

    Still the same nfsd.ko error when trying to insert module.
    Script tried out, same as doing it manually..

    nfsd: Unknown symbol posix_acl_from_xattr
    nfsd: Unknown symbol posix_acl_to_xattr
    nfsd: Unknown symbol posix_acl_valid
    nfsd: Unknown symbol nfsacl_decode
    nfsd: Unknown symbol posix_acl_alloc
    nfsd: Unknown symbol nfsacl_encode
    nfsd: Unknown symbol posix_acl_from_mode

    Using /harddisk/volume_1/data/fs/sunrpc.ko
    Using /harddisk/volume_1/data/fs/exportfs.ko
    Using /harddisk/volume_1/data/fs/lockd.ko
    Using /harddisk/volume_1/data/fs/nfsd.ko
    insmod: cannot insert `/harddisk/volume_1/data/fs/nfsd.ko': Unknown symbol in module (-1): No such file or directory
    mount: Mounting none on /proc/fs/nfsd failed: No such device
    ./start: 20: /harddisk/volume_1/data/extra/sbin/rpc.portmap: not found
    ./start: 20: /harddisk/volume_1/data/extra/sbin/rpc.nfsd: not found
    ./start: 20: /harddisk/volume_1/data/extra/sbin/rpc.statd: not found
    ./start: 20: /harddisk/volume_1/data/extra/sbin/exportfs: not found
    ./start: 20: /harddisk/volume_1/data/extra/sbin/rpc.mountd: not found

    reading about the issue, it seems that its a compile issue of the kernel..
    CONFIG_FS_POSIX_ACL needs to be enabled in kernel to work with NFS, so i wonder if anyone got the nfs module to work.
  48. Merkley

    Merkley Addicted to LI Member


    I'm very much a noob when it comes to linux (and most of this stuff apparently)

    I'm trying to follow along, but I keep running into problems where I am supposed to have some type of knowledge to do "X" as the instructions are making assumptions I know how to do things. Help would be appreciated ... I just want to get my Twonky server running again so I can stream to my PS3...

    I have flashed to the Jac0 firmware
    I have connected via telnet and done this;
    ((FYI, quote are commands entered (without the quotes))
    the system says 'changing password for root.......'
    (then it asks for the password, I put in the same one twice, all is well)
    then I do this:
    "cd etc"
    "cd rc.d"
    "sh rc.reboot"

    Then after it reboots I am trying to go in using putty... use user name of "root" to which it shows 'root@ password:' -- I enter the password I used, and it just closes Putty instantly, no reason, nadda.

    Also, looking ahead on the instructions I think I'll need help on the copying of the password from one place to the other. (and editing the root directory... my file has the word root in it more than one place... <SIGH>)

    I think I can use some of the startup script help posted on page 3 or 4 for GregiBear to help me, but I'm not quite sure.

    This might be beneath the user base here so if anyone wants to help offline (not on the forum) I would also appreciate that ... CDN.Merkley (AT) gmail.com

    Thank you in advance...

    PS. Anyone working on a step by step guide... maybe I can do that once I get this working... I certainly think there are a few others that want to do this, but are intimidated because they're LOST (I thought I would have a few bumps along the way, but not that it would be THIS bad...)
  49. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    I'm sorry but because it's so easy to break the box if you don't know what you're doing, I made the instructions deliberately vague in some places...

    You have to copy the passwd file from /etc to /harddisk/volume_1/conf using "cp /etc/passwd /harddisk/volume_1/conf" after you change the password and before you reboot, otherwise your changes will not survive the reboot. Also, instead of the last 3 commands you can simply enter "/etc/rc.d/rc.reboot".

    As I said, the instructions are deliberately vague to make sure that people don't get themselves in trouble just trying out some stuff. For now, this is only for persistent people like you :biggrin:

    As for installing a new Twonky: Download the Twonky version for i386 Linux, use a command shell (telnet or SSH) and the tar command to unpack it somewhere on your hard disk and read the instructions on the Twonky website carefully, especially the part about entering the full pathname when you start it.

    By the way the BusyBox tar command is a little wonky; instead of the usual "tar xfvz myfile.tar.gz" you have to do "tar xvz -f myfile.tar.gz".

  50. Merkley

    Merkley Addicted to LI Member

    An inch closer... maybe...

    Well, I'm still trying to get this working... and I still haven't broke it... yet! :wink:

    I downloaded "twonkymedia-i386-glibc-2.2.5-20081002.sh" from the twonky website and put in on my NAS box... and am trying to run it via a telnet session. My command is "sh twonkymedia-i386-glibc-2.2.5-20081002.sh" ... when it runs I get this as output:

    mkdir: Cannot create directory `/usr/local/TwonkyVision': Read-only file system

    I then try a CHMOD:
    $ chmod -R 777 *
    chmod: bin: Read-only file system
    chmod: bin: Read-only file system
    chmod: lib: Read-only file system
    chmod: lib: Read-only file system
    chmod: local: Read-only file system
    chmod: local: Read-only file system
    chmod: sbin: Read-only file system
    chmod: sbin: Read-only file system
    chmod: tmp: Read-only file system
    chmod: tmp: Read-only file system
    chmod: zoneinfo: Read-only file system
    chmod: zoneinfo: Read-only file system

    I read around about doing a "chown" on that directory, but it doesn't seem to work as described.... I get this:
    $ chown root *
    chown: bin: Read-only file system
    chown: lib: Read-only file system
    chown: local: Read-only file system
    chown: sbin: Read-only file system
    chown: tmp: Read-only file system
    chown: zoneinfo: Read-only file system

    Sigh... I thought being a "windows guy" just meant I had to deal with blue-screens, and a bloated OS... :wall: Anyway, I'm determined to get this to running because I have SOOO many MP4's that my PS3 can't play after the 2.4x update. If there is an easier way to that I'm all ears/eyes. Right now I have to convert and re-encode everything.... that's about 4-6 hours per movie.... :flabbergasted:

    I'll read / learn whatever, just point me where... (and of course, I'd be happy to get noob level instructions that solve this specific install/config issue.. I gotta be close... riiight?)

  51. Merkley

    Merkley Addicted to LI Member

    Maybe vague is part of the problem

    You know, as I sat and read more and 'tried things' I actually think that it may be the vagueness that would cause a problem... "wanna-be's" like me that have some need to do this, but don't have the skill.

    At this point I'm willing to also talk to someone over the phone (I'll call or you call) or even barter something; like one of my PS3 games for your time... I know that defeats the point of forums, but at about 30+ hours of time reading and trying things I'm just frustrated... and now my wife is even saying "why don't you just give up?" --- haha, non-techies... they just don't understand the challenge of learning something new that is on the upper boundary of your skill (or a little above it maybe).

    (Anyone know why my Putty connection just closes when I enter in the password for root? Only happens with the right password....)

    M :help:
    (Too bad they don't have the message icon for shooting oneself in the head... lol)
  52. santosh_koshy

    santosh_koshy Addicted to LI Member

    upslug queries. Kindly revert.....

    Dear Jac,

    I have a NAS200 whose firmware I upgraded using the Linksys software. But, the system crashed. To recover, I was able to telnet to the Redboot and push it into an upgrade state. The problem that I face is that the source code compiles into a squash binary with a .bin extension. To upgrade the firmware, the upslug2 tool is used and it does not seem to be accepting the .bin extension and reprts a bad signature error.

    Kindly revert if you have any suggestions on how I will be able to upgrade the firmware to make the usystem more work once again

  53. santosh_koshy

    santosh_koshy Addicted to LI Member

    Dear Jac,

    I have a NAS200 whose firmware I upgraded using the Linksys software. But, the system crashed. To recover, I was able to telnet to the Redboot and push it into an upgrade state. The problem that I face is that the source code compiles into a squash binary with a .bin extension. To upgrade the firmware, the upslug2 tool is used and it does not seem to be accepting the .bin extension and reprts a bad signature error.

    Kindly revert if you have any suggestions on how I will be able to upgrade the firmware to make the usystem more work once again

  54. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    I was successful in using the upslug tool to upload a firmware image in Redboot update mode. I haven't used upslug2 (nor looked at its source code) but in theory that should work as long as it doesn't enforce any NSLU2-specific things such as file size.

    The .bin file extension shouldn't be a problem: if upslug2 complains about it, you can always rename the file, the file name is not important to the NAS200.

    The bad signature message is because the NAS200 image generator (oddly called "bind") doesn't put the "sErCoMm" signature in the file. That's okay because the NAS200 Redboot doesn't check for the signature anyway. With upslug, there is a -f switch that forces it to upload the image even if it doesn't have the signature; I expect upslug2 to have something similar.

  55. alejandro_liu

    alejandro_liu Addicted to LI Member

    Actually the "bind" utility does put a "sErCoMm" signature, but I think it is in the wrong place and in the wrong order (big vs. little endian).
  56. Hackit

    Hackit LI Guru Member

    This all sounds great, i have one question.

    Can any report if they find the nass200 more stable?

    like the disappearing on the network, no response from buttons?

    Great to you you doing the JAC
  57. fubarbloke

    fubarbloke Addicted to LI Member

    Same thing happened to me with Cyberduck (a Mac app). The problem seems to be that Cyberduck uses the SFTP protocol to manage the interface/browser, regardless of whether you're using SFTP or SCP protocol for the actual transfer. It logs in, calls for SFTP, doesn't find it and leaves.

    If I'm reading the posts here correctly, WinSCP doesn't have that problem, although I'm not familiar with it (or Putty) -- those are Windoze apps.
  58. Hackit

    Hackit LI Guru Member

    So is the nas200 more stable?
  59. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    The Jac0 firmware doesn't fix any bugs that are in the R62 firmware, so (apart from the enhancements) the Jac0 firmware is exactly as stable (or unstable, if you want) as the original R62. The purpose of Jac0 was specifically to add Telnet, SSH and user scripts, while keeping the Linksys software unmodified. I simply didn't feel like reverse-engineering problems like the duplicate FTP directories because it takes a lot of time to do and brings little value to the majority of users.

  60. jwophof

    jwophof Addicted to LI Member

    Hi Frenkie, did you manage to use the NAS200 as a datastore for your ESX server? If so can you provide more details please? I am trying to use the NAS200 for a ESX 3.5 server. I seem unable to get NFS working on the NAS200.

  61. nasuser

    nasuser Addicted to LI Member

    Jac2a problem?

    If I do a shutdown from the menu the power led goes off but the drives continue to to spin as well as the respective led's stay on. Ethernet led stay on as well. Shuts down properly with 34R75 but I lose functionality. Suggestions?
  62. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    See the "known problems" section in the Jac2a article...

  63. Klap

    Klap Guest


    i log in putty and wen i put wron password say

    "acces denaid" (correct)
    but wen i put the correct passowrd. root and root (i change to that),
    close the putty windows and dont happend nothing ..
  64. EgyptianPrince

    EgyptianPrince Addicted to LI Member

    1. Log in to the NAS200 through telnet

    what's the login name and password???? i can't log in with my admin account anymore
  65. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    RTFM. There is no user name or password when you log in through Telnet.

    Also, please use Jac2b instead of Jac0.
  66. Hi axe2j and jac!

    I've tryed the script below:

    But it doesn't work to start NFS.

    The ${SBIN}/rpc.* don't exists. Could u help me? Thx
  67. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    You will have to download the binaries from axe2j's website, store them on your harddisk and set access rights.

    Also, please use Jac2b instead of Jac0.

  68. dksmar

    dksmar Network Guru Member

    to change the password at your wiki we follow these steps:

    1.Log in to the NAS200 through telnet
    2.Use the passwd command to change the password
    3.Use vi to edit /etc/passwd to change the login directory from "/root" to e.g. "/" or "/harddisk/volume_1/data"

    at step 3 i cannot understand which is the login directory of root using vi it says at that line

    the directory of root is "/root:/bin/sh" or "/bin/sh" that i should change to "/" or "/harddisk/volume_1/data"

    thanks in advance
  69. Poulpi06

    Poulpi06 Addicted to LI Member

  70. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    The format of /etc/passwd is username:password:userid:groupid:full name:home directory:login shell. In the line that you're quoting above, the root directory is "/root" (which doesn't exist) and the login shell is "/bin/sh" (which you can leave as it is).

    Please use version Jac3a instead of Jac0.

  71. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice