[Announce] Jac2b Alternate Firmware for NAS200

Discussion in 'Cisco/Linksys Network Storage Devices' started by jac_goudsmit, Feb 1, 2009.

  1. mdsilva

    mdsilva Addicted to LI Member

    Hi everyone, how do i change the port ssh runs on? any hints?
  2. jackito

    jackito LI Guru Member

    Add two lines to the /etc/services file with the port you would like to use.
    The first part is the service alias and the second parameter is the port that you want to use for that service:

    ssh-alternative      8022/tcp
    ssh-alternative      8022/udp
    Then edit the /etc/inetd.conf file and change the line for SSH server to look like this:

    ssh-alternative stream tcp nowait root /usr/sbin/dropbear -i -p 8022
    Then restart INETD:

    All this changes are in RAM so if you restart the NAS200 you will need to make the changes again. Of course you can always write a very simple startup script that changes/overwrites both files /etc/services and /etc/inetd.conf before INETD is starting.
    Actually I´m running to instances of SSH one that can be contacted from the Internet that only allows public-key auth and another one running in a different port than the default that allows also password auth that can be contacted only from LAN. :wink:
  3. fhguarni

    fhguarni Addicted to LI Member

    Private and public keys...

    Ups! I am very sorry! I was not very explicit :oops:

    I need to backup important data of many users. I want to do it with rsync, but I want to manage the access to NAS with public and private keys. So I mean that I want to use a pair of Private/Public RSA keys, but I don't know where I can put public key for each user. How can I do that?

    Thank you very much Jac! :smile:

    P.D. Sorry for my bad English
  4. mdsilva

    mdsilva Addicted to LI Member

    :thumbup: Thankyou, works
  5. fastie

    fastie LI Guru Member

    Hi Jac

    Firstly Thanks for this firmware great work.

    I am trying to add the NFS module to my newly updated NAS200 with Jac2b firmware.
    When I follow the post in Jac0 I got all the modules but when I try insmod nfs.ko I get the following error.
    "insmod: cannot insert `nfs.ko': Unknown symbol in module (-1): No such file or directory"
    Now this is my first attep to add this..
    Any reason why this is?
    Thanks again.
    BTW: how you getting on porting OpenWRT?
  6. mdsilva

    mdsilva Addicted to LI Member

    Hi, not sure if this is a Jac2b issue or not but here is a problem i have found (while tryign to get the torrent thing working):

    if i write a script that calls ps and i run it, it displays nicely apart from the fact it doesnt wordwrap (which is fine). like so:
        1 root      1932 S    init
        2 root         0 SWN  [ksoftirqd/0]
        3 root         0 SW   [watchdog/0]
        4 root         0 SW<  [events/0]
        5 root         0 SW<  [khelper]
        6 root         0 SW<  [kthread]
       40 root         0 SW<  [kblockd/0]
       41 root         0 SW<  [ata/0]
       42 root         0 SW<  [ata_aux]
       43 root         0 SW<  [ksuspend_usbd]
       46 root         0 SW<  [khubd]
       48 root         0 SW<  [kseriod]
       75 root         0 SW<  [kswapd0]
       76 root         0 SW<  [aio/0]
       77 root         0 SW<  [xfslogd/0]
       78 root         0 SW<  [xfsdatad/0]
      209 root         0 SW<  [scsi_eh_0]
      210 root         0 SW<  [scsi_eh_1]
      229 root         0 SW   [mtdblockd]
      271 root         0 SW<  [kmmcd]
      439 root      1564 S    lld2d eth0
     1762 root         0 SW<  [xfsbufd]
     1763 root         0 SW<  [xfssyncd]
     1798 root         0 SW<  [xfsbufd]
     1799 root         0 SW<  [xfssyncd]
     1949 root     11272 S    upnpd &>/dev/null
     1956 root      1624 S    CheckHDDPower
     1981 root     11272 S    upnpd &>/dev/null
     1982 root     11272 S    upnpd &>/dev/null
     1984 root     11272 S    upnpd &>/dev/null
     1986 root     11272 S    upnpd &>/dev/null
     1988 root      3168 S    /usr/sbin/thttpd -C /etc/thttpd.conf
     2005 root      1392 S    /usr/sbin/download
     2011 root      1520 S    /usr/sbin/inetd
     2016 root      2108 S    /usr/sbin/QuickSet
     2018 root      2040 S    /usr/sbin/USB_Detect
     2021 root      2040 S    /usr/sbin/USB_Detect
     2023 root      1856 S    /usr/sbin/ResetButton
     2025 root      1852 S    /usr/sbin/PowerButton
     2027 root      2036 S <  /usr/sbin/backup_button
     2029 root      1960 S    /usr/sbin/do_umount
     2031 root      1344 S <  /usr/sbin/USBButton
     2055 root      1592 S    /usr/sbin/crond
     2084 root      1628 S    /usr/sbin/CheckHDDDrive
     2096 root      6192 S    /usr/sbin/smbd -D
     2098 root      6192 S    /usr/sbin/smbd -D
     2100 root      4824 S    /usr/sbin/nmbd -D
     2102 root      1932 S    init
     2910 root     11272 S    upnpd &>/dev/null
     3127 root      2556 S    ./dctcs --torrent-directory=/harddisk/volume_2/data/public/torrents/torrents/ --do
     4329 root     28104 S    ctorrent -S localhost:15000 -d /harddisk/volume_2/data/public/torrents/torrents/st
     4439 root         0 SW   [pdflush]
     4627 root         0 SW   [pdflush]
     4751 root      2040 S    /usr/sbin/dropbear -i -p 22222
     4752 root      2044 S    -sh
     4753 root      1912 R    ps
    Note that the ctorrent and dctcs lines cut off.

    But if i call that script from the crontab file, it seems to trancate each line. like so
      PID  Uid     VmSize Stat Command
        1 root         12 S   init
        2 root            SWN [ksoftirqd/0]
        3 root            SW  [watchdog/0]
        4 root            SW< [events/0]
        5 root            SW< [khelper]
        6 root            SW< [kthread]
       40 root            SW< [kblockd/0]
       41 root            SW< [ata/0]
       42 root            SW< [ata_aux]
       43 root            SW< [ksuspend_usbd]
       46 root            SW< [khubd]
       48 root            SW< [kseriod]
       75 root            DW< [kswapd0]
       76 root            SW< [aio/0]
       77 root            SW< [xfslogd/0]
       78 root            SW< [xfsdatad/0]
      209 root            SW< [scsi_eh_0]
      210 root            SW< [scsi_eh_1]
      229 root            SW  [mtdblockd]
      271 root            SW< [kmmcd]
      439 root        116 S   lld2d eth0
     1762 root            SW< [xfsbufd]
     1763 root            SW< [xfssyncd]
     1798 root            SW< [xfsbufd]
     1799 root            SW< [xfssyncd]
     1949 root        456 S   upnpd &>/dev/null
     1956 root        124 S   CheckHDDPower
     1981 root        460 S   upnpd &>/dev/null
     1982 root        460 S   upnpd &>/dev/null
     1984 root        460 S   upnpd &>/dev/null
     1986 root        460 S   upnpd &>/dev/null
     1988 root         72 S   /usr/sbin/thttpd -C /etc/thttpd.conf
     2005 root         12 S   /usr/sbin/download
     2011 root         72 S   /usr/sbin/inetd
     2016 root         12 S   /usr/sbin/QuickSet
     2018 root         52 S   /usr/sbin/USB_Detect
     2021 root          8 S   /usr/sbin/USB_Detect
     2023 root         12 S   /usr/sbin/ResetButton
     2025 root         36 S   /usr/sbin/PowerButton
     2027 root         40 S < /usr/sbin/backup_button
     2029 root         12 S   /usr/sbin/do_umount
     2031 root         36 S < /usr/sbin/USBButton
     2055 root        308 S   /usr/sbin/crond
     2084 root        140 S   /usr/sbin/CheckHDDDrive
     2096 root          8 S   /usr/sbin/smbd -D
     2098 root          8 S   /usr/sbin/smbd -D
     2100 root        396 S   /usr/sbin/nmbd -D
     2102 root          8 S   init
     2910 root        460 S   upnpd &>/dev/null
     3127 root        272 S   ./dctcs --torrent-directory=/harddisk/volume_2/data/p
     4329 root      17384 D   ctorrent -S localhost:15000 -d /harddisk/volume_2/dat
     4439 root            SW  [pdflush]
     4627 root            SW  [pdflush]
     4751 root        472 S   /usr/sbin/dropbear -i -p 22222
     4752 root        492 S   -sh
     4763 root        612 R   ps
    Any way to fix this?
  7. alejandro_liu

    alejandro_liu Addicted to LI Member

    Obviously you are running diffent PS from the comand line and from your script. Check the header line:



    PID Uid VmSize Stat Command

    The first example is consistent to what you will see from gnu coreutils, while the second line is usually from busybox.

    With gnu coreutils, you can usually use the "w" option to get wide output. While in busybox, usually the available options is rather limited (and usually do not include the w option).
  8. mdsilva

    mdsilva Addicted to LI Member

    alejandro_liu, you are right i was runnign 2 differnt ps's. One ps was from the firmware and the other from the newer busybox

    i made it run the same one and it still has the trunc problem.
  9. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    Did you get the modules for the Jac2b kernel or for the Jac0 kernel? They are different. The modules for jac2b are in http://www.goudsm.it/nas200/extrafsmodules_jac2b.tar.gz .

    I don't use NFS myself, it's way too slow to be useful. Sneakernetting files with a USB stick is faster. If you already got the correct modules but they still won't work, I'm afraid I don't have an answer. I also don't have the binaries for NFS. Maybe someone can put a tarball together that can simply be unpacked and works "out of the box"?

    Because of deadlines at work (and the whooshing sounds they made as they passed(*)), I've have had no time whatsoever to work on it in recent weeks. Sorry... I'll get back to it as soon as I can.


    (*) Quote from Douglas Adams
  10. jackito

    jackito LI Guru Member

    Also keep in mind module dependencies. I don´t use NFS but for example if nfs.ko module depends on another module, you will need first to load the module that nfs.ko depends on in order to make nfs.ko work.
  11. pascals

    pascals LI Guru Member

    same thing for me ....
    try to connect to with telnet .... and it works
  12. pascals

    pascals LI Guru Member

    How to : shutdown NAS200 when UPS out of battery

    Hello ... thanks JAC for this new firmware

    when there is a long power outage, your computer shutdown correctly controlled by your UPS, but NAS200 crash immediatly ... When you restart NAS, it check it's filesystem long long time ...
    With the addition of the SSH server on the firmware (thanks again JAC) we can correctly shutdown the NAS BEFORE ups shutdown ...

    only for linux users (windows users .... google is your friend !:biggrin:)
    on the linux server which connect physicaly to the UPS (where UPS daemon run)

    install EXPECT package

    create a small script :
    ## using EXPECT to emulate RSH.
    ## send command /etc/rc.d/rc.halt using APCUPSD scripts
    spawn ssh -l root nas200 "/etc/rc.d/rc.halt"
    expect "password:" {send "your_root_password\n"}
    match_max 100000
    expect "$"

    chmod 755 shutNAS​

    NOW execute it directly :

    Modify your UPS shutdown script (mine is an APC)

    add the folowing lines :




    echo "Battery power exhaused on UPS ${2}. Doing shutdown." | ${WALL}
    ${SMS} "Power exhaused. Shutdown"
    echo "Battery time limit exceeded on UPS ${2}. Doing shutdown." | ${WALL}
    ${SMS} "Power time limit. Shutdown"
    echo "Remaining battery charge below limit on UPS ${2}. Doing shutdown." | ${WALL}
    ${SMS} "Power charge limit. Shutdown"
    echo "Remaining battery runtime below limit on UPS ${2}. Doing shutdown." | ${WALL}
    ${SMS} "Power runtime limit. Shutdown"


    or to be really clean, add a local variable at the top of this script, as I made with my SMS command :cool:


    and replace all the lines by

    That's all :thumbup:
  13. pascals

    pascals LI Guru Member

    NAS200 : ready for 2tb disks ???

    Hello Jac,

    someone from LINKSYS hotline said to me that the NAS200 is limitated to 1tb disk
    I saw on FAQ that someone have some problem to format RAID1 of 1.5tb :mad:

    What do you think about this limitation ???
  14. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    I remember seeing people with problems running really large disks on the NAS200 but I think they were simply disappointed about how long it took to format such a disk on the NAS200 (many hours!).

    I think the 1TB "limit" that the support people will tell you about, has to do with the fact that at time when the NAS200 was designed, 1TB was the largest SATA hard disk available on the market. As far as I know, the Linux kernel in the NAS200 uses 48 bit LBA which should be able to handle 2TB drives just as well as 1TB drives.

    So, in summary: I think you can install a 1.5TB or 2TB drive in the NAS200 and it will work. Whether you want to wait for a format that takes an entire day, is up to you. I have a 1TB Western Digital Caviar Green in my NAS200 and it took half a day to format; it took 3 days to copy 400GB of data to it.

  15. fhguarni

    fhguarni Addicted to LI Member

    Public/Private RSA keys

    Hello Jac.

    I want to use RSA (public/private) keys to gain access to NAS. How can I configure dropbear to use public/private keys and no password? Where can I put the public key for each user?

    Thanks :)
  16. fastie

    fastie LI Guru Member

    Hi Jac

    yes I had the wrong modules, but I have downloaded this ones and tried to install it and still the same problem..
    I am getting the following error..
    $ insmod nfs.ko
    Using nfs.ko
    insmod: cannot insert `nfs.ko': Unknown symbol in module (-1): No such file or directory

    I understand you don't use it but if there is any information you can give me to troubleshoot this it would be great.. I have tried to install all the nfs modules and they all come up with the same.

    Thanks again
  17. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    I did some trial-and-error with the tarball I downloaded from my own website, and it looks like your problem is that you're not insmodding the modules in the proper order. For more information see this post (not from me) in the Jac0 thread.

    It looks like you have to load sunrpc.ko, lockd.ko and nfs_acl.ko before you can load nfs.ko. However in the article above, axe2j's script doesn't even use nfs.ko, it uses nfsd.ko. For nfsd.ko (in addition to sunrpc, lockd and nfs_acl) you also need exportfs.ko.

    Hope this helps!


    PS I don't have binaries for the NFS daemons and tools...
  18. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    I'm sorry I'm not familiar enough with Dropbear to help with this one. Please refer to the Dropbear documentation and/or forums.

  19. jackito

    jackito LI Guru Member

    From the dropbear command line help:

    -s              Disable password logins
    So, edit your /etc/inetd.conf and change the ssh line from this:

    ssh stream tcp nowait root /usr/sbin/dropbear -i
    To this:

    ssh stream tcp nowait root /usr/sbin/dropbear -i -s
    To use your keys create a ".ssh" directory under the home directory of the user that is going to login through ssh. The directory must have full permissions only for the user. For example:

    cd /harddisk/volume_1/conf/user_home
    mkdir .ssh
    chmod 700 .ssh
    Create a "authorized_keys" file inside .ssh directory with read-write permissions only for the user. For example:

    cd .ssh
    touch authorized_keys
    chmod 600 authorized_keys
    Edit the "authorized_keys" file and add your keys, one per line.
    Save the file, exit vi and then restart "xinetd" daemon:

    That´s all, anyway, my advice, before adding the "-s" parameter and restarting "xinetd" is to try to login with your RSA key at least once to verify everything is working because if something is wrong then you will not be able to login using passwords anymore (as a workaround you can run two instances of ssh in different ports, one with password login and one with RSA keys login only).

  20. fhguarni

    fhguarni Addicted to LI Member

    Thank you very much Jackito! :thumbup:
  21. negllic

    negllic Addicted to LI Member

    Custom website in nas200 with Jac2b ??


    I'm planning to upgrade my NAS200 with Jac2b.

    Can you tell if this firmware will allow me add a custom web site in the NAS200 and how ???
    What I want to do : I'm doing a lot a pictures. I store all my pictures in the NAS200. But, when I looking for a picture, I take a long time as NAS200 is slow... I would like to a custom website with pages of thumbnails.

    In advance : THANKS !!

  22. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    Running a web site from the NAS200

    Since there already is a web server (thttpd) on board which runs the Web GUI, it's pretty easy to set up another web server. All you need to do is start another instance of the program. Here's how to do it for a photo website.

    First of all, use a program on your PC that creates the HTML pages with thumbnails and stuff, for example the excellent and free (donationware) Web Album Generator. Let the program generate its files in an empty network directory on the NAS200 somewhere. Let's say \\NAS200\DISK 1\webroot. Inside the NAS, this directory is /harddisk/volume_1/data/webroot (assuming you are using one disk or you're running in Separate Disks mode; if you use a RAID mode, change the volume number accordingly).

    Next, make sure the internal web server which already runs the web GUI is set to a different port than 80. We want your photos to be available on the usual HTTP port 80 so we have to move the web GUI out of the way. Log in to the Web GUI and go to the bottom of the System Options page, and change the port to something other than 80. The number you set it to is not really important, but you have to remember it to be able to log into the web GUI again!

    Now, we can run another instance of the thttpd web server. All you need is a simple script. Here is something you can use and modify for your pleasure:

    # rc.myweb
    # Create a directory "rc.d" in the root directory of your harddisk and
    # create this file there to automatically start your web server when
    # the system starts.
    # Use the built-in editor of WinSCP to create this file, or use an editor 
    # that is able to create Unix-compatible line endings such as Notepad++.
    # The editors that are built in to Windows cannot do this: they
    # will generate CR-LF line endings and the file needs to have LF only line
    # endings.
    # The user name should be the user name that you used to log in to
    # the NAS to create the webroot directory, so that the web server
    # will have at least read access to all the files.
    /usr/sbin/thttpd -d /harddisk/volume_1/data/webroot -r -u admin
    I just did a quick test with a web album generated by Web Album Generator and it works great. The only problem I had was that by default, when I connected to the web server, it showed me a directory listing of the web album instead of the web album itself. This appears to be caused by a modification by Linksys to the thttpd program:

    The thttpd program on the NAS200 uses index.cgi instead of index.html as default web page..

    There's an easy workaround: just copy your index.html to index.cgi and the web page will come up just fine. And because the original index.html is also still there when you make a copy, any pages that refer to it will also still work.

    Of course you can share your website with the world: all you need to do is change your router settings so that incoming traffic on port 80 goes to the NAS. If you expect a lot of traffic on your web site, you may want to look into throttling options of thttpd so it won't bog down performance.

    For more information about thttpd, check out their website.


    PS1 The information assumes that you run a website that doesn't need CGI. If you're setting up a web server with cgi pages, you will have to figure out a way to work around the modified default page, e.g. by specifying a cgipat parameter that doesn't match /index.cgi.

    PS2 Many internet providers block port 80 so that others can't connect to your web server if you make it public. You can add an option to the command to let the server run on a different port. Please read the documentation on the thttpd website.
  23. negllic

    negllic Addicted to LI Member

    Many thanks !!

    Just 2 words : many thanks !!! :)
    Your explanation is "cristal clear". :thumbup:

  24. negllic

    negllic Addicted to LI Member


    Just one more question, maybe a little bit out of the subject...

    I did everything you wrote and it works !!
    But (there is always a "but" :)) : I copied index.html to index.cgi. When I go to the web browser, I do not get the page I would like but the html code !!!

    Any advise ?? MANY MANY THANKS !!

  25. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    Hmmm... Looks like reusing the built-in thttpd is a problem because of the Linksys configuration changes. When you browse to the website with Firefox, it will just show you the HTML code, with Internet Exploder you do get the web page. Or was it the other way around?

    Either way, it should still work normal if you add "index.html" to the URL.

    Looking at the many changes that Linksys made to the code (see http://nasi200.svn.sourceforge.net/viewvc/nasi200/source/trunk/thttpd-2.23beta1/?pathrev=84), maybe it's better to build your own clean version of the web server (thttpd is still a good choice), or google for a pre-built version of thttpd for i386 Linux. An alternative is to download the Jac2b sources, change the config.h so it accepts other default files besides index.cgi and recompile it for yourself. Send me an email to get the location, I use the same ID on Yahoo as here.

    I will try to find some time to compile a clean thttpd some time later this week, but I can't promise how soon that will happen; I'm extremely busy at work right now.

  26. negllic

    negllic Addicted to LI Member


    Correct. Firefox goes wrong whereas IE is OK.

    Correct also. With the url http://nas200/index.html, it works on both browsers.

    I send you an email

    If you provide me source code, I will also try to do it and let you know if I succeed.

  27. svn server

    Hi Jac,

    have you ever tried to install an svn server on the device?

  28. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member


  29. SimZ80

    SimZ80 Addicted to LI Member

    Hi all! i'm new here and i'm Italian so sorry for my poor English...
    I've NAS200 with original R75 firmware in my home, no one have access to my pc.
    I'm not happy about this device because:

    _sometimes when i switch ON the nas, it looking for second disk and more of time don't found the Hdd so it rebuild the raid1... i've tryed to clean sata connector but i believe is problem of firmware. (The second hdd work great)
    _The nas is very slow and sometimes it take several minutes just to read the files.

    I'm Windows user and i've not experience with linux...my questions are:
    _If i upgrade the firmware to JAC2B i will see increase the stability?
    _What i will found after the upgrade (web interface differences...)?
    _What is the telnet? Why i've to disable it?
    _Someone can enter in my nas from dynamic dns service?

    Thanks for reply
  30. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    No. Jac2b will basically give you:
    • All the functionality of Linksys R75
    • Ability to run custom scripts at startup
    • Ability to run updated Twonky media server
    • Ability to connect to a Linux shell prompt via unencrypted (telnet) or encrypted (SSH) connection
    • Ability to copy files via Secure Copy Protocol (SCP), through encrypted connection (much better than FTP because FTP is unencrypted and is difficult or impossible to set up behind a NAT firewall).

    The web interface is the same as before. Also, the rest of the software is basically the same as R75 except I added Dropbear (SSH/SCP client and server) and made a couple of changes to the existing scripts. If you are not familiar with Linux, this is not for you.

    Telnet is network access to a command prompt. The reason it's enabled is that it's the only way to set the root password (Telnet on the NAS200 doesn't ask for a password). The reason why you should disable it (or at least not allow it from the Internet) is that it's unencrypted.

    Ummm yes but you don't need Jac2b for that, the Linksys software already does that.

    Hope this helps!

  31. foondar

    foondar Guest

    Hey, I am not a linux expert either but I am trying to get the updated Twonky running, so i updated the firmware.
    Is it possible for someone to show me what the tree structure of my DIsk 1 would/should look like?
    I only have 1 hard drive in the NAS right now, so my folders look like this:
    /harddisk/volume_1/data/rc.d/twonky <<---original server
    /harddisk/volume_1/data/rc.d/twonky50 <<---updated server

    Is that correct?
    I ask because it still does not seem to be working, my PS3 still says unsupported data.

  32. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    No. The original server is already in the ROM. All you need to do is create an rc.d/twonky50 directory in (in your case) /harddisk/volume_1/data and unpack the Twonky Linux there.


    Sorry I can't give you a directory listing because I'm travelling and my NAS200 is offline. Anyone else?

  33. SimZ80

    SimZ80 Addicted to LI Member

    jac_goudsmit thanks for the clear reply and for your work!
  34. roelof999

    roelof999 Guest

    Renaming USB disks


    The Nas200 does not support renaming of the USB disks
    (default Hdd_[1|2]_1). Does this Jac2B alternate FW allow me to do this?

  35. kgbester

    kgbester Guest

    Great upgrade, but Twonky not working

    Hi, thanks for the hard work with the firmware upgrade. I downloaded your latest version and it installed no problem on a working system with 2 mirrored drives, all data intact. I was also able to change the root password using your instructions.

    I am fairly new to Linux (using Ubuntu 9.04), but I was able to get the recommended version of Twonky onto the NAS and also added the scriptdirs.txt file into /harddisk/volume_3/conf. Also also ran 'chmod -R 777 twonky50' in the rc.d folder and it set the permissions.

    However, when I try and run twonky I get the following error:

    Starting /harddisk/volume_3/data/rc.d/twonky50/twonkymediaserver ... /harddisk/volume_3/data/rc.d/twonky50/twonkymediaserver: 1: Syntax error: ")" unexpected

    I would really appreciate some help as I seem to have followed all the steps to no avail.


  36. houlie

    houlie Addicted to LI Member

    Updating busybox 1.4 with jac2b


    I installed jac2b succesfully but I would like to update busybox to version 1.4.

    Did anyone tried this before?


  37. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    Neither the Linksys software nor the Jac2b software will let you do this.

  38. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    Basically the NAS200 is telling you there is a closing parenthesis on line 1 of the file. Are you sure you downloaded the Linux version?

  39. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    It's not possible to replace Busybox in-place. However, check out this thread if you want to run a different Busybox on your NAS200.

  40. houlie

    houlie Addicted to LI Member


    but is there a way to install rsync on the NAS200? the interest of having ssh/scp only is somewhat limited if there is no rsync command available. NAS 200 is also a storage device after all.

  41. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    Look here.

  42. negllic

    negllic Addicted to LI Member

    Custom startup scripts are not called at startup


    I made several testing on my NAS200. I quite sure now when I say "custom startup scripts are not called at startup".

    Here are some informations about my configuration :
    • NAS200 is running on RAID-1. Therefore, valid directory is /harddisk/volume_3/data/rc.d
    • NAS200 is running with Jac2b firmware
    • My scripts are named "rc.myweb" and "rc.newbusybox".
    • I add a command in each script like : echo "Start of script rc.myweb $(date)" >> /harddisk/volume_3/data/rc.d/myweb.log
    • The scripts actually runs when I start them manually. They do add one or more line in the log file
    • Scripts are never called during startup (actions not done and nothing added in the log file)

    What did i do wrong ?

    Many thanks in advance for your help.

  43. jackito

    jackito LI Guru Member

    I did it but to:

    BusyBox v1.13.3 (2009-03-27 11:38:01 CET) built-in shell (ash)
    Enter 'help' for a list of built-in commands.
    root@NAS200 ~#
    If this version is good for you check this thread. :)
  44. dINIs

    dINIs LI Guru Member

    Hi Jac,
    V3.4R79 is out!
    Do you plan to integrate it into Jac2b?
  45. jackito

    jackito LI Guru Member

    Jac3? :wink:

    Maybe it´s a good oportunity also to upgrade to the last version of busybox (I can work on it), BitTorrent and rsync support all by default (I can work on it too).
  46. Poulpi06

    Poulpi06 Addicted to LI Member

    it's a good oportunity, while waiting NasI200 :thumbup:
  47. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    I just noticed on the Linksys forums that R79 is out. I also noticed that there's a 418MB file that apparently contains the source code. All good news indeed!

    I haven't installed the new release on my box yet (and won't be able to do so until next week because I have visitors this week and I'll be traveling during the weekend), but I will certainly have a look at the source tarball to see if/how I can integrate my changes. I also have a few other changes in mind, including possibly an automatic pivot_root to the config partition of the first hard disk, so that it's easier to update software that's in the ROM such as Busybox.

  48. Pa0l0ne

    Pa0l0ne Addicted to LI Member

    ...indeed...In Jac we trust....
  49. Fed7

    Fed7 Addicted to LI Member

    Hi all!
    I have one NAS200:biggrin: ... but i have upgrade firmware to V3.4R79 before read this (wonderful) post.

    My question .... it's possible downgrade to Jac2b fw?

    Tks ;)
  50. Pa0l0ne

    Pa0l0ne Addicted to LI Member

    i think no prob for this "downgrade", but remember to backup your data for all evenience...
  51. Fed7

    Fed7 Addicted to LI Member

    tks ;)

    after the modding:
    - it's possible formatting in etx2/3 mode? now the system using XFS (access with ssh and run mk2fs command)
    - if run from client rsync (ssh mode) i resolve this?
      rsync: chown “/media/7FNAS/Backup/Immagini″ failed: Permission denied (13)
    and all errors .... i don't use the "-a" switch because the FS don't support this feature!
  52. spirit69

    spirit69 Addicted to LI Member

    Hi Jac and all others, quick question.

    I read in the announcement that the new alternate firmware supports:

    "Based on Linksys firmware V3.4 R75, i.e. many bugfixes and full web GUI support for non-journaled (ext2) file system"

    But does it also support the journaling filesystem which the Nas200 now uses? I'm running the latest firmware with two 1.5tb disk in raid1 and i think i would like to update to your version....and to be on the safeside i want to make sure it supports journalling?

  53. jackito

    jackito LI Guru Member

    XFS is Fully supported. So you can downgrade safely. :)
  54. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    It should be safe to downgrade from R79 to Jac2b. It shouldn't change your data but of course I should recommend making a backup...

  55. Fed7

    Fed7 Addicted to LI Member

    tks ;)

    i have just making backup .... because i have buy, more weeks ago, the Seagate Barracuda with bug 7200.11 :eek:
  56. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    You should use the web interface, not the command line, to reformat your drive(s). If you don't, the Linksys software may not mount it the next time it reboots.

    On the other hand, if your drive is already formatted in non-journalling mode (ext2) from the web GUI and you manually reformat it using ext3, it MAY mount correctly on reboot -- I don't know if the Linksys software mounts the partitions with an explicit file system parameter.

    I would be interested to hear what happens if you try.

  57. leptogenesis

    leptogenesis Addicted to LI Member

    I manually formatted the "data" partition to ext3. after reboot, nas200 mounts it as ext2 filesystem. I have to manually unmount it and mount it again if I want to use the journaling. remounting as

    mount -o remount -t ext3 /dev/sda1

    does not work.
  58. Poulpi06

    Poulpi06 Addicted to LI Member

  59. How can I modify a NAS200 or a dlink DNS 321 for AES encryption of an entire volume. We currently use truecrypt on PCs (WinXPpro) but there is a 10 user connection limit. It is mandated that all tax-payer data is stored on an encrypted volume. At some preparation sites we need more than 10 workstations.
    Kevin McDonald
    AARP TaxAide Foundation
    Member, National Technology Commitee
  60. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    I would suggest using TrueCrypt to create a volume-in-a-file for each workstation, and storing those files on the NAS, or on some other insecure medium. You can use the official firmware for this, you won't need my firmware. And you can do it on any kind of NAS. And you won't run into the problem of a limit of a number of users per volume because each user has their own volume. Hope this helps!


    PS Make backups!
  61. jackito

    jackito LI Guru Member

    Also you will not load the lame NAS200 CPU with all the encryption tasks that will probably make it unusable at all.
  62. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice