[Announce] Jac4 Alternative Firmware for NAS200

Discussion in 'Cisco/Linksys Network Storage Devices' started by jac_goudsmit, Aug 13, 2009.

Thread Status:
Not open for further replies.
  1. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    Correct me if I'm wrong, but I think if your USB hard disk is formatted NTFS it will automatically be mounted and shared (read-only: the NAS200 operating system doesn't support writing to NTFS).

    If not, you can write a short script that executes the mount command, and store it in the rc.d directory. If you mount the drive on a directory that's already shared, the drive's data will also be shared.

  2. column

    column Addicted to LI Member

    I would like to use ntfs not for usb drives but for internal ones. Is it true I will not get write possibility for them?
  3. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    Yes, that is true.

  4. robert350

    robert350 Addicted to LI Member

    Does anyone know how to start a SSH session? I've tried with putty but something is going wrong.

    I initiate putty SSH, ip addres of nas200 ( port 22.

    Putty says:
    login as:
    I 've tried with root, admin or even leave it out.

    Putty says:
    admin@'s password:
    I push root on my keyboard

    Putty says:
    Access denied
    @'s password:

    What is going wrong? What can I do?
    Thanks a lot
  5. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    You should log in as root. The default password is also root.
    You cannot log in as admin through ssh: accounts that are created for use with the web GUI cannot be used for SSH logins and vice versa, because the web GUI uses the shell string in the /etc/passwd file for a different purpose.

    If you are running a RAID configuration, you are running into the bug that the /etc/passwd file is not copied to the hard disk correctly after the root password is changed to "root" on the first run.

    Create a directory "rc.d" in the "DISK 1" share of your NAS (unless you already have that directory). Then download this file and unzip it in the rc.d directory. Your rc.d directory should now contain a file called "rc.resetrootpassword".

    Now turn your NAS off with the power button on the back side (it will beep when you push it; wait until the lights go off). Then turn it back on again. It will beep once and then (after a while) it will beep twice. After this, you should be able to log in as root, password root. The script renames itself to "password_reset_done" to confirm that it worked. You can erase that file.

    After this, change your password from the SSH prompt using the passwd command, and after changing the passwd command, copy the /etc/passwd file to you config partitions:
    login as: root
    root@'s password: root
    BusyBox v1.00-rc2 (2009.08.09-23:13+0000) Built-in shell (ash)
    Enter 'help' for a list of built-in commands.
    $ passwd
    Changing password for root
    Enter the new password (minimum of 5, maximum of 8 characters)
    Please use a combination of upper and lower case letters and numbers.
    Enter new password: <your new password>
    Re-enter new password: <your new password again>
    Password changed.
    $ for x in 1 2 3; do cp /etc/passwd /harddisk/volume_$x/conf; done
  6. robert350

    robert350 Addicted to LI Member

    absolutely perfect! Great! Thanks a lot
  7. robert350

    robert350 Addicted to LI Member

    Only two questions:

    It's possible to copy files between usb drives and the sata drives, using SSH? For instance, I have 20 gb in my mini HD USB which I wanted to copy to my NAS200. It would be useful to copy the files using SSH in order not to switch my computer on.

    Another question. Instead of using a program to transfer files, I've shared my nas200 over the net opening port 445 towards nas200 (using NAT in my router I open port 445 to It works fine, slow but useful. It's dangerous? Could be some exploit program or virus or whatever dangerous for my nas200?

    Thanks a lot.
  8. Poulpi06

    Poulpi06 Addicted to LI Member

    yes it's dangerous :confused:
  9. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    Yest this is possible and is actually more efficient that copying the files via a computer...

    As far as I know, most ISP's block this port to protect users from inadvertently sharing files on their computers if they put it on the Internet without firewall, so I'm kinda surprised that it works for you.

    I agree with Poulpi06: sharing this port is dangerous, although because it's a Linux machine it's probably less dangerous than if it were a Windows machine. If your nasty neighbor is able to guess a username and password that you create on your NAS, they can reach all the files that that user can access.

    EDIT: Furthermore if you have "convert failed logins to guest logins" enabled, hackers may already be able to reach many of your files even if they don't know any user names or passwords.

  10. robert350

    robert350 Addicted to LI Member

    Thanks jac, I have blocked port 445, but when I let it open to towards my nas200 it works fine over the internet (for little files of course, beacuse it is too slow).

  11. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    I don't doubt that it works fine but the issue was not whether it would work, but whether it was a good idea. And the answer was a resounding "no". :smile:

  12. niar71

    niar71 Addicted to LI Member

    thanks for great job

    Two things
    first after the upgrade the firmware name rename the same is this correct?
    second i donwloaded twonky media server but the only ini i can find is twonkymedia-mediaserver.ini and it look like this
    what must i do ??

  13. p.busser

    p.busser Addicted to LI Member

    Hi Jac,

    Where can I download the source code of your modified NAS200 image?
  14. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    The easiest is to start with the ini file that's stored in the /etc directory. Copy that to your twonky directory and make the changes that I mentioned in the first posts to enable the web server (using a Unicode capable editor like Wordpad).

  15. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    The location is in the first post under "further information about the files".

  16. p.busser

    p.busser Addicted to LI Member

    Hi Jac,

    I see. Thank you for your answer and for the firmware!
  17. Treah

    Treah Addicted to LI Member

    btw jac something in your firmware prevents the disk from spinning down. I confirmed this by loading another file system built from the nas sources and it spins down normally but for some reason when I load yours the drive never goes to bed. Did you disable that or is something messed up somewhere?
  18. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    My disks spin down just fine and I didn't make any changes to any code that spins the disks up and down... Are you running the media server or some other software that might keep the disks busy?

  19. DJ Soulfly

    DJ Soulfly Addicted to LI Member

    I had the same problem. It was caused by a network mapping in Vista and my Windows 7 computer. Shutting down these systems ore deleting the mapping solved my problem
  20. Treah

    Treah Addicted to LI Member

    I don't use windows 7 but I do have them maped to one of my computers. I am not running the media server. Its strange, I thought it might have something to do with my mod since I run a fan off of the drive power but then I ran it with my root file system and it was back to the way it was working before. Note that I suspect its spindown the real thing that I am noticing is when I go to first access something after its had no activity for a long time there is this 4 second delay then it loads it up. With the jac firmware it just pops up right away. This is why I think they are not spinning down. I would have to confirm it by checking the logs if such ones get created I am not sure. In reality tho I am not too worried about it too much and if jac is not having the problem then it must be something I am doing on my network.
  21. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    The power to the drives is always on (unless the system is on standby of course). The fan power header is switched on and off by a GPIO output of the CPU. I don't think I ever attempted to figure out what transistor type is used to drive the fan output but I reckon if the fan draws less than 200mA it's probably safe to connect it to the fan header. If it draws more, you should probably add an extra transistor or a relay. My 50mm fan is connected directly to the fan header and it's been working just fine for probably more than a year.

    The kernel spins the fan up after a certain number of read/write commands in a short time, I don't think it turns it off but I may be wrong. I think there's a (closed source) program running to turn the fan off and I get the feeling it doesn't just check the time since the last access but also the temperature; again I may be wrong.

    You can start the kernel logger and syslogger by running /etc/rc.d/rc.syslogd. I find it useful sometimes to start the loggers and start a background task to dump the messages to my terminal e.g. "tail -f /var/log/messages &" or "tail -f /var/log/messages |egrep -v 'Fan is' &" (the latter option will keep it from printing "Fan is off" or "Fan is on" every so often. Note that /var is mounted in RAM so it will fill up your memory after a while.

  22. Treah

    Treah Addicted to LI Member

    I was referring to the harddrives spinning down not the fan. I know the fan wont ever stop cause its not connected to the fan header at all. I don't have it connected because the led+fan draws too much power I think and the fan never comes on.
  23. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    Ah... Oops... I must not have been awake when I wrote that... or something... :biggrin:

    The hard disks spin down by themselves, you can use the hdparm tool to control that. Of course if a program keeps accessing the disks it will keep spinning. I know my Vista machine causes the drives to spin up when I open My Computer because it wants to determine the amount of free space of my mapped drives...

  24. rubbertail

    rubbertail Addicted to LI Member

    Twonky5 - again :(

    Unfortunately, I have the same problem - with a RAID-0 running. I also tried the "trick" with adding volume_3 in the /etc/scriptdirs.txt, but when starting twonky via SSH, I still get the answer "twonky 4.4.xxx started" instead of the 5.x version I put into /harddisk/volume_3/data/rc.d/twonky5/.

    As I am no Linux wizard (not a complete idiot in computers though at least), could I get a bit of help there too? And I hope I didn't overread the solution... :(

    Thank you very very much for the great work though - Chapeau!

  25. rubbertail

    rubbertail Addicted to LI Member

    New development: I now get
    $ /etc/rc.d/twonkymedia.sh start &
    $ Starting /harddisk/volume_3/data/rc.d/twonky5/twonkymediaserver ... /harddisk/volume_3/data/rc.d/twonky5/twonkymediaserver: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory

    Obviously it now gets to the right instance of twonky, but it seems there is a library missing. Um... help? %(

    Oh, the Twonky version is 5.1.2 for Linux.
  26. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    The C++ library is not part of the NAS200, because no other programs use it, including the on-board Twonky. It's likely that other libraries are needed too, and I don't have time right now to figure out which ones. You will have to use an earlier version of Twonky for now. I use 5.0.61.

  27. niar71

    niar71 Addicted to LI Member

    The only thing that can acces is public disk 1 & 2.I use RBrowser for mac.How can have acces to the main system?
  28. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    You quoted part of the instructions to update the Twonky server, but RBrowser appears to be an FTP/SCP/SFTP browser (I don't have a Mac) so I assume what you're trying to do is access the ini file in /etc, and your problem is not really Twonky related.

    If you only see the "PUBLIC DISK 1" and "PUBLIC DISK 2" directories, it means you're logged in through FTP as guest. Make sure you log in as root using the SCP protocol. You can't log in through SSH or SCP as one of the users that you create through the web GUI, and you can't log in as root through FTP or Samba.

    Disable any options in RBrowser that lets it revert to SFTP or FTP if it can't get an SCP connection. On the NAS, disable the "Convert failed logins to guest logins" option.

    SFTP is not supported on the NAS200, you have to use SCP for secure access.

  29. superlaido

    superlaido Addicted to LI Member

    i have a question about permissions on nas200 shared with my roommate.
    I'm working on a secure access through ssh.
    Everything works great with Samba and ftp but something is going wrong using ssh.
    If i log as lawrence (user law, login as lawssh as suggested by you)

    law@ali-u-baba:~$ ssh lawssh@
    lawssh@'s password: 
    BusyBox v1.00-rc2 (2009.08.09-23:13+0000) Built-in shell (ash)
    Enter 'help' for a list of built-in commands.
    $ pwd
    $ whoami
    $ ls -l 100_0480.jpg 
    -rw-rw-r--    1 law      everyone   834198 Dec 30 22:57 100_0480.jpg
    $ chmod uga-rw 100_0480.jpg 
    $ ls -l 100_0480.jpg 
    ----------    1 law      everyone   834198 Dec 30 22:57 100_0480.jpg
    $ rm 100_0480.jpg 
    rm: remove `100_0480.jpg'? y
    $ chmod uga-rw 100_0481.jpg 
    $ ls -l 100_0481.jpg 
    ----------    1 law      everyone  1009862 Dec 30 22:58 100_0481.jpg
    $ exit
    Connection to closed.
    I can erase a file (not readble, not writable) in my home directory.
    If i log with an another user (chiabre, ssh login chiabressh)
    law@ali-u-baba:~$ ssh chiabressh@
    chiabressh@'s password: 
    BusyBox v1.00-rc2 (2009.08.09-23:13+0000) Built-in shell (ash)
    Enter 'help' for a list of built-in commands.
    $ whoami
    $ cd /harddisk/volume_3/data/law/
    $ ls -l 100_0481.jpg 
    ----------    1 law      everyone  1009862 Dec 30 22:58 100_0481.jpg
    $ rm 100_0481.jpg 
    rm: remove `100_0481.jpg'? y
    $ ls -l 100_0481.jpg 
    ls: 100_0481.jpg: No such file or directory
    I can erase a file without permissions.

    This is strange in unix enviroment, where am i wrong? :confused:
    Thanks in advice for any reply.

    (sorry for my bad english)
  30. Treah

    Treah Addicted to LI Member

    As you can see the file has the group permissions for everyone so if the group permissions include write access it can remove the file. This is normal behavior tho i dunno why it shows ---------- there?
  31. superlaido

    superlaido Addicted to LI Member

    Hi treah,
    the permissions ---------- it's my intentionnaly test, before delete the file i remove any kind of permissions with chmod uga -rw FILENAME

    With my user is correct to remove the file, and the only strange thing is that on ubuntu or macosx the system ask me if i want delete a readonly file.

    The strange behavior is in the second quote. I repeat the experiment for another user (chiabre) on a file without any permissions, the user can access a directory owned a delete a file of the kind ---------- .. This is very strange in my opinion. It's impossible on other unix system delete this file.

    I think this is a problem if you want to share the nas200, i can make a mistake and erase data not owned.
    Become an embarassing situation to explain to the owner of the data..:rolleyes:

    Thanks for the attention,
  32. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    Delete-permissions are governed by the directory, not by the file. You can always delete a read-only file if you have write-access to the directory IIRC.

    Also, if you remove group execute-access to the directory, someone who is not in the directory group can't see what's in the directory.

    So if you do a chmod 700 on the directory you can keep your roommate from changing stuff.

    The reason it's asking is that on many Unix distros the rm command is really an alias for rm -i. On the NAS200 this is not the case of course so it will never ask unless you tell it to.

    I already explained why it's even possible to erase a read-only file: directory permissions.

    As far as I know this is standard behavior on all *nixes that I've seen (Linux, BSD, SunOS, Solaris).

    The NAS200 is intended to share its data through FTP and Samba only, and the FTP and Samba servers will expose a virtual file system that only contains the data that you want exposed to the user that's logged in.

    The SSH command prompt is somewhat of a backdoor that will give you access to the entire filesystem, including the parts mounted in ROM and RAM. Even if your roommate can't access or delete your files, it may still be possible for him/her to cause trouble because they can access the /etc directory and the config partitions and possibly even change or delete files there. If you really want to keep others from getting into your NAS and wreaking havoc, you should not give them an SSH account...

  33. Treah

    Treah Addicted to LI Member

    Lol I figured this was something the distros did cause ive never had rm ask me to remove a file. But I use lfs which does not make this alias by default so im used to it never asking.
  34. DoubleD

    DoubleD Addicted to LI Member

    MKV Files.

    Does anyone know if this modified firmware will work for MKV files? if so what version of the twonkymedia server do i need to be running as well.

  35. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    As far as I understand from a quick Google search, Twonky doesn't understand MKV files but I may be wrong or this info could be outdated (the newest timestamp I could find was 2008). You will have to convert your video or use a different method to play it...


  36. DoubleD

    DoubleD Addicted to LI Member

    Thanks Jac,

    I found that by changing the file extension from .mkv to .avi, it was able to see and play the mkv files.

    saved me from having to re-encode them.
  37. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    Thanks! Good find!

  38. DoubleD

    DoubleD Addicted to LI Member

    I just installed your modified firmware, and i'm looking at installing a new Twonky Media Server. The instructions say to create a rc.d folder on the "DISK 1" share, but I'm only seeing the "PUBLIC DISK 1" Share. any ideas how i can get the other one?
  39. DoubleD

    DoubleD Addicted to LI Member

    Was able to turn on FTP access and use an ftp client. Got it loading the new twonky server but lost the mkv ability.

    does anyone know what version of twonky was using on the original NAS200 firmware?
  40. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    Yes. Disable the "convert failed logins to guest logins" option on the system options page in the web gui.

    Windows will always send the current user ID and password to any machine that it tries to connect to (don't worry, the password is encrypted). If you didn't create an account on the NAS200 with matching user ID and password and the option is on, you will be logged in as guest. If the option is off, the NAS will send an error back to Windows and Windows will ask for proper credentials.

  41. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member


  42. DoubleD

    DoubleD Addicted to LI Member

    Sorry about the questions, but I think your mod is great, made it worth buying the nas200, otherwise the features would of been limiting. I'm trying to configure the content folders, but i keep getting

    "videos/by folder/arddisk/volume_1/data/public/" then my videos/folders. is there way to remove the extra start folders, so it would just be "videos" then my videos and folders. I went into the twonky server config using port 9000, went to sharring, and tried to put in "/harddisk/volume_1/data/public" but when i select save, it just clears the path out.

    any ideas?
  43. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    Can you post your ini file?

  44. DoubleD

    DoubleD Addicted to LI Member

    After playing with it all night, tring to change the ini manualy, change other settings, I decided to start over, and replace the INI with the default from Twonky, and restart the entire NAS and it is now letting me chage the content folder uasign the twonky interface.
  45. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    DoubleD, I deleted your message because your posted INI file had a Twonky serial number in it. You probably don't want them to blacklist you for giving out your license key...

    I couldn't really see anything obviously wrong with it, except that it was set up so it would do everything in a /var/twonkymedia tree. Keep in mind the /var directory is mounted in RAM, so you will run out of memory very quickly. Your NAS will become unresponsive and/or the oom_killer in the kernel will eventually shut down the Twonky server or some other program(s).

  46. DoubleD

    DoubleD Addicted to LI Member

    Thanks for deleting the ini. I didn't even think about the serial # being in the file.
    I just realized that using the link back on the 1st page of posts on where to download the media server from it points to version 5.0.68, so i just downloaded 5.1.2 but will not load the media server. have you tried your code with 5.1.2? is there any special tricks needed to get it to work.

    to do the upgrade I removed the older twonky5 folder and created a new one and ftped the files there, and replaced the ini with that of the one from 5.0.68. I also tried a fresh ini file. and still no go.
  47. DoubleD

    DoubleD Addicted to LI Member

    If I SSH into the nbox, and run "/etc/rd/c/twonkymedia.sh start &" i get the error below.

    $ /etc/rc.d/twonkymedia.sh start &
    $ Starting /harddisk/volume_1/data/rc.d/twonky5/twonkymediaserver ... /harddisk/volume_1/data/rc.d/twonky5/twonkymediaserver: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory
  48. DoubleD

    DoubleD Addicted to LI Member

    I have read some posts about the libraries not curerentl;y included. Just wondering if there was an progress made.

    jac_goudsmit, you commented on everything being done in the /var folder, where so you suggest i change the path to?

    "I couldn't really see anything obviously wrong with it, except that it was set up so it would do everything in a /var/twonkymedia tree. Keep in mind the /var directory is mounted in RAM, so you will run out of memory very quickly. Your NAS will become unresponsive and/or the oom_killer in the kernel will eventually shut down the Twonky server or some other program(s)."

    Thanks for all your help.
  49. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    The latest Twonky server will not work because since version 5.1.* the Twonky programmers switched to newer libraries which are not provided on the NAS200. You will have to use a 5.0.* version.

    It's probably possible to get a newer Twonky server to work but you will have to do some Linux hacking to find out which libraries you need, and you will have to run the program by directly starting an updated ld-linux.so.* with a few well-constructed parameters otherwise it still won't run. That's how I got JungleDisk Server Edition to work.

    Instead of the /var/twonkymedia directory you can (and should) use a directory on your hard disk. I would probably create a directory that starts with a period ('.') to keep it hidden from the FTP server, e.g. /harddisk/volume_1/data/.twonkydata

  50. Djniklos

    Djniklos Addicted to LI Member

    Hello everyone,

    I want to install the firmware Jac4. The facility carries formatting a hard disk?

    Thank you for your attention.
  51. pabpoo

    pabpoo Addicted to LI Member

    Found something in a Twonky Forum:

    Version References:
    required from libc.so.6:
    0x0d696911 0x00 08 GLIBC_2.1
    0x09691f73 0x00 07 GLIBC_2.1.3
    0x0d696912 0x00 05 GLIBC_2.2
    0x0d696910 0x00 04 GLIBC_2.0
    required from libpthread.so.0:
    0x0d696912 0x00 06 GLIBC_2.2
    0x0d696911 0x00 03 GLIBC_2.1
    0x0d696910 0x00 02 GLIBC_2.0
    private flags = 2: [APCS-32] [FPA float format] [has entry point]
  52. DJ Soulfly

    DJ Soulfly Addicted to LI Member

    jac_goudsmit are you still continu developing your firmware? If so when can we expect jac5?
  53. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    I am extremely busy at work at this time so I have little or no time to work on the NAS200 unfortunately. And it doesn't look like this will change for a while... :frown:

    I did some work over the Christmas holiday to integrate Unionfs into the kernel and to do some testing with kexec-tools. Unfortunately after integrating Unionfs, insmod was unable to load the pbuttons.ko module which is essential to make the buttons work (such as the shutdown button). If you can think of a solution to this problem, I'll try to put together a new version by this weekend :biggrin:

  54. ddougan

    ddougan Guest


    Does your firmware upgrade improve the unit's performance? Sorry if this is answered elsewhere - I couldn't see when I checked.

    I have been working on a unit for a client and found it very slow copying files - about 4 times slower that copying to my server.


  55. dsc68

    dsc68 Addicted to LI Member

  56. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    No, and this is impossible as far as I know. The hardware is simply too slow...

    The server you're comparing with must be slow too... The servers that we have at my office are at least 5 to 10 times faster than the NAS200...

  57. inco

    inco Guest


    i am getting this kind of error after i upgrade the firmware from 74 to jac4:
    "Error: Fail to get samba information"
  58. leceur

    leceur Addicted to LI Member

    Ok Jac, I love this stuff and have read through all 16 pages....2 things:
    1) I also get the library error as I've installed the latest 5.1 version. Where can I get an older working version?

    2) When I look at the status of the server i get the following error:
    $ pwd
    $ sh twonkymedia.sh status
    [: ==: unknown operand
    A TwonkyMedia server seems to be running with PID , but no PID file exists.
    Probably no write permission for /var/run/mediaserver.pid.
    I then go look in the /var/run folder and the above mentioned pid file is not there
    $ ls -l
    -rw-rw-rw-    1 root     root            4 Feb 10 15:26 backup_button.pid
    -rw-rw-rw-    1 root     root            4 Feb 10 15:26 do_umount.pid
    drwxr-xr-x    2 root     root            0 Aug  7  2009 down
    -rw-rw-rw-    1 root     root            5 Feb 10 15:26 hdd_power.pid
    -rw-r--r--    1 root     root            4 Feb 10 15:25 lld2d-eth0.pid
    -rw-r--r--    1 root     root            3 Feb 10 15:25 repair
    -rw-r--r--    1 root     root            5 Feb 10 15:26 thttpd.pid
    -rw-rw-rw-    1 root     root            4 Feb 10 15:26 upnpd.pid
    -rw-rw-rw-    1 root     root            5 Feb 10 15:26 usb_det.pid
    What could be wrong? So far I can't see the webserver running on any device (even the old server is now gone and still can't access the web page on port 9000.....

    HOLD THE PRESS! Just installed an older version (4.4.18) and all is working. Scan is running so let's see if I can finally stream to my XBOX 360!
  59. leceur

    leceur Addicted to LI Member

    Ok I still have 1 problem, how do I enter the location for the server to scan for media files?
    I have used:
    /DISK 1/Movies
    but the scanner picks up nothing! It does add Internet radio so something is working...
  60. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    If Twonky doesn't want to make their older versions available to the public, that's up to them, they own the software after all. Maybe you can post a message in their forums to see if someone will help you?

    If you have experience with Linux you may be able to get the 5.1 version to work in a similar way as I made Jungle Disk Server Edition work: get the libraries from a source that's known to be good, and use the same trick as I used: basically you have to start the updated ld-linux.so.2 yourself with the correct parameters so that it loads the Twonky server and searches for the updated libraries in a path that you specify.

    The script was probably written for bash but the NAS200 has Busybox ash, not bash. Look for a line in the script that checks for a string by using the == operator and change it into a single = surrounded by spaces.

    [ "abc" == "abc" ] && echo true || echo false
    [ "abc" = "abc" ] && echo true || echo false
    Note: if you try the following on ash, it will echo "true" because it regards the entire string as one expression. Always use spaces around the operator.
    [ "abc"=="def" ] && echo true || echo false
  61. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    /harddisk/volume_1/data/Movies should do it if that's the location where your files are. If you're running in RAID mode, the disks are mounted on volume_3 instead of volume_1. WinSCP should help you locate the file from the server's point of view.

  62. leceur

    leceur Addicted to LI Member

    Ok I've found a 5.0.61 version. I can't get onto the NAS with PUTTY naymore now though. I've reverted back to the original Linksys Firmware, your firmware nad did a restore of user accounts but the root password is no longer root or the password I entered.... Any way to completely erase the firmware and rebuild?
    Ok gone back the the manufacturer setting, installed your firmware but when I want to start Twonky from the Putty console I get:
    sh twonkymedia.sh start
    Starting ./twonkymedia ... ./twonkymedia: 1: Syntax error: word unexpected (expecting ")")
    Any idea? With PS AX I don;t see any Twonky running....
  63. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    Obviously you can't use the root account or password from the original firmware: it doesn't have a Telnet or SSH server on board.

    I don't know what would get you locked out of your NAS.

    If you flashed my firmware you can create a script in the rc.d directory to reset the root password: Create a directory "rc.d" under the root directory ("DISK 1" or "DISK") of your shared drive, then unzip this file to that directory and restart the NAS by using the power button on the back side. When you switch the power on, the script will reset the root password to "root" and will then restart the NAS again. When you hear two beeps, the NAS is ready; you should change your root password again (don't forget to copy the /etc/passwd file to the config partition)

    I'm not sure what you mean... If you erase the firmware, the NAS won't work anymore. You can flash another firmware but you already know that. You can rebuild my firmware on a Linux PC if you download the source code, but I don't think that's what you want either.

    If you're working in RAID mode, you should change your scriptdirs.txt file. There is an old bug in my scripts that I haven't fixed yet. run this from the command line:
    echo /harddisk/volume_3/data/rc.d >/harddisk/volume_3/conf/scriptdirs.txt
    If you're not in RAID mode, I will need more information. Where did you install the updated Twonky, which tarball did you use, how did you unpack the tarball, what did you change to the ini file, how did you change it, etc.

  64. leceur

    leceur Addicted to LI Member

    -Ok got the root password back so can login again, phew.
    -Going back and forth between various firmware's looked like that didn't always work 100%. So I went back to manufacturere settings and then installed your firmware, all looks good.
    -Not working in RAID mode.
    Volume mode = Two Seperate disks (only have 1 disc installed)
    My twonkyvision-mediaserver.ini (changed with wordpad):

    Installed Twonky at:

    When I start twonky from /etc/rc.d I get:
    Starting /harddisk/volume_1/data/rc.d/twonky5/twonkymediaserver ... /harddisk/volume_1/data/rc.d/twonky5/twonkymediaserver: 1: Syntax error: word unexpected (expecting ")")
    so it does look in the right place....
  65. diegus

    diegus Network Guru Member

    NAS200 not working after jac4

    hello, I installed the jac4 firmware from the update firmware section inside the nas200, after that, it is not working, I can not access from the http nor FTP. The power led is blinking from green to orange. I need the data inside!! any way to downgrade to the original firmware??? Thanks!!!!
  66. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    Please see my answer in the other thread you started about this issue.

  67. leceur

    leceur Addicted to LI Member

    Some more insight in why maybe my Twonky won't start. I removed the /harddisk/volume_1/data/rc.d folder and started my twonkymedia.sh from /etc/rc.d. It says:
    Starting /etc/twonkymediaserver ... TwonkyMedia Version
    takes about 5 minutes to get back to the prompt without any message. When I do PS AX I don't see any Twonky service running and can't see it from any networked machine...

    Ok now I reverted back to the original Firmware and my Media Server is visible again. wonder what's wrong....
  68. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    It might help to start the system logger and kernel logger to see what's going on...
    tail -f /var/log/messages | grep -v "Fan is" &
    After this, start your Twonky server and watch for messages on your terminal. Maybe it helps, maybe not.

    Note, you shouldn't leave the system and kernel loggers running: the messages file will eventually fill up all the RAM. To stop them, do:
    killall syslogd
    killall klogd
    rm /var/log/messages
  69. leceur

    leceur Addicted to LI Member

    Thanks again JAc but even with the options above I see nothing happening and the Twonky server just won't start. I will try the older Twonky version once more but otherwise I guess it's not working...
    As soon as I copy the older 4.4.18 Twonky version and run it it works! Just don't understand why the 5.0.61 version won't work?
  70. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    I tested my firmware with Twonky 5.0.61 so it should work if you follow the instructions precisely.

    The error text kinda makes me think that the command interpreter thinks that your server (which should be a binary file) is a script.

    Maybe you downloaded the Windows version instead of the Linux version?

    Or maybe you have the Linux version for a different target (e.g. ARM instead of x86)?

    Maybe you used FTP to download/upload the files and forgot to switch to Binary mode (text mode is the default with most FTP programs)?

    Did you remember to either set the correct access rights on the Twonky files, or restart the NAS? The server binary must be executable and accessible by root.

    Did you restart the NAS by unplugging it or by typing "reboot" instead of "/etc/rc.d/rc.reboot"? If so, your files may be corrupt. Maybe you should try extracting the files again?

    Have you tried starting the Twonky server by hand, by going to /harddisk/volume_*/data/rc.d/twonky* and running "$PWD/twonkymedia &" (without the quotes)? Remember to use $PWD, the Twonky server insists on seeing a full path in the program name (a silly bug if you ask me).

    Did you put a license code in the INI file? Without it, the program runs in trial mode. If you try to run it more than 30 days after installing it, it will stop. It probably checks the timestamps on the files for this.

  71. leceur

    leceur Addicted to LI Member

    Agree it should as I did follow your instructions to the letter, but it doesn't
    Does look like it but don't know why he would think that

    No dubbel checked that

    Nope certainly the x86 version

    Have my FTP default in Binary but never used it for this.

    Well in one instance I had issue's with not being able to create new folders at all.
    As I was thinking it was an access rights issue, I downloaded a completely new version 6.0.65 and unzipped that to a new folder. I first stopped the Twonky server from within PUTTY, renamed rc.d to rc.d2. So the new version was installed in the old rc.d/twonky folder. Did the "$PWD/twonkymedia &" in the new rc.d/twonky folder (with the 5.0.65 version) and low and behold! It gave an error.... So I did "chmod 777 *" in the twonky folder and tried again. OH YES it started, I am now running 5.0.65!

    Rebooted as written and there should be no file problems.

    An other great tip! I always started Twonky in the folder by typing:
    "sh twonkymedia.sh start"

    Don't have a license yet as I first wanted to get it to work and see if I get out of it what I want, and it looks like I am about too.

    So if all goes well I will be buying the code soon and enjoy my media on my XBOX 360.
    JAC, you're a star! Thanks for the persistent and clear help there!
  72. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    A better command would be ". twonkymedia.sh start" or (if the script has execute access rights) /path/to/twonkymedia.sh start. Running the script with "sh" starts another instance of the shell which only takes up memory; using the "." command runs the script in the current shell.

    By the way, the script doesn't require the full path, it's the program that needs it. The script starts the program with a full path.

    I suspect that your problems were caused by something in the Twonky provided script that's not compatible with the Busybox shell... The Jac4 Twonky startup script starts the updated server program directly, it doesn't depend on a script in rc.d/twonky*, exactly for this reason.

  73. jackito

    jackito LI Guru Member


    Does anybody know what the "/usr/sbin/QuickSet" binary is doing actually?


  74. jackito

    jackito LI Guru Member

    Hi Jac,

    This is more like a change request than a question. :rolleyes:
    For the next Jac firmware release, is it possible a little modification to the init script?

    Right now the script, when trying to search for a USB filesystem, is mounting sdc1 as vfat like this:

      case $x
          /bin/mount /dev/$x /mnt -t vfat 2>/dev/null
    Is it possible to change the mount parameters to something like this:

      case $x
          /bin/mount /dev/$x /mnt -t vfat -o rw,uid=501,gid=501,fmask=0013,dmask=0000,iocharset=utf8 2>/dev/null
    Right now sdc1 is mounted by default like this:


    When you mount sdc1 again in another mount point it´s getting mounted using the same mount parameters as the previous mount (done by the init script at boot).
    So only GUEST user can write to it. :frown:

    With this small change, the "all" group is going to have write permission and any user is going to be able to use the free space there for whatever they want after mounting sdc1 again at a new mount point.


  75. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    I will consider it.

    (TODO: Make a TO DO list :cool1:)

  76. blegger

    blegger Guest

    Newbie questions...


    I really appreciate this topic, as i was about to give up on this.

    First of all i wanted to ask something....

    How can i know the version of Twonky that it is running, how can i be sure it is the manually installed one instead of the firmware's?

    After following the instructions i could setup a server, but i can only reproduce music from it. No videos at all and no pictures, but the ones of the music (the front of the discs i have on music), and i am not even sure where theese images where downloaded from, but i'm sure i didn't.

    If i copy any of the video files i got to a pen drive, and i plug it to the PS3, i can reproduce it normally, so it isn't an incompatibility issue.

    I've read a lot here about some scripts, but as i understand nothing out of them.

    Would it be possible for any of you to explain something about them, how too install them and what they do each?

    Thank you very much, and please do not hesitate to ask me anyinfo you may need about my installation so we can troubleshoot this. (PS3 Slim 120GB running latest version of software, 3.15 i guess) and NAS-200 bought in France.

    King regards,


    I've modified my media server settings on the LINKSYS, to stream just video from the Videos folder, and it worked. This is weird, if i share just viode it works, but if i want to share all, i can just access Music. Any idea?

  77. harshalsk

    harshalsk Addicted to LI Member

    I had V3.4R79 and then tried to update to latest jac4 firmware. Now the power light is blinking orange/green and Ethernet light is blinking. Does that mean update is failed and is it safe to power cycle this? This is happening since last 2 hours.

    Please advice.
  78. harshalsk

    harshalsk Addicted to LI Member

    Jac4 update failed for my NAS200.

    Oh! well I restarted it and came back up with old version just fine. I will try jac4 update again.
  79. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    If you followed the instructions to modify the INI file, you should be able to connect a web browser to port 9000 of the NAS, to see the web interface. That's the easiest way to confirm that it's running, other than logging in through SSH or Telnet and running "ps ax" which will tell you the path from where the Twonky server was started.

    You are either running the on-board Twonky (version 4.4.x) instead of the updated one (5.0.x), which is known to have compatibility problems with the PS3, or the server isn't done scanning directories yet (it scanned the music directories but not the video directories).

    Another possibility is that the NAS is running out of memory; this may happen because the Twonky server stores data in /var/twonkymedia which is mounted as RAM disk. It's possible to remount some directories elsewhere to save some memory, see the NAS200 FAQ question W4. You will need to create a script to do this automatically at startup time; the script is on the FAQ page (it's the second block of code). The easiest way to create it is with the built-in editor of WinSCP but I'm sorry, I don't have time to provide more details right now.

    Hope this helps!

  80. DoubleD

    DoubleD Addicted to LI Member

    Server wont start after switching to Raid

    I had the firmware running and work until I went to a raid config. the process i did was.

    1. Used FileZilla to backup the rc.d folder to my computer
    2. changed Drive Config to mirror the drives (This wiped the drive clean)
    3. Used fileZilla to move the rc.d folder back to /harddisk/volume_3/data/rc.d
    4. Tried running "sh /harddisk/volume_3/data/rc.d/twonky5/twonkymedia.sh start"
    and got "TwonkyMedia server not found"
    5. ran "chmod 777 twonkymedia" and "chmod 777 twonkymediaserver"
    6. Tried running "sh /harddisk/volume_3/data/rc.d/twonky5/twonkymedia.sh start"
    again and got "Starting /harddisk/volume_3/data/rc.d/twonky5/twonkymedia ... /harddisk/volume_3/data/rc.d/twonky5/twonkymedia: 1:ELF: not found"

    Any ideas why it wont load anymore?
  81. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    The most common cause of this error is that you copied the startup script to your PC in ASCII mode and copied it back in BINARY mode, and now it contains a Carriage Return character at the end of each line, which is wrong in Linux. The Linux (Busybox?) program loader is telling you that there's a problem on line 1 of the script because it's trying to start "/bin/sh<CARRIAGE-RETURN>" to read the script, and it doesn't exist of course.

    You shouldn't use the script that comes with the Twonky download anyway: it contains some commands that don't work on the NAS (like ps --no-headers -o "%c" -p $PID). If you want to start the program from the command line, you can simply type /harddisk/volume_3/data/rc.d/twonky/twonkymedia (optionally followed by -D; you have to start the program with a full path or it won't work) or you should start the script that's stored in the flash ROM: /etc/rc.d/twonkymedia.sh

    If my script can't find your twonky server (you can tell by using the ps command: you should see a bunch of processes running in /harddisk/volume_3/data/rc.d/twonky, if they run from /etc it means it's using the old one), you may have to modify the scriptdirs.txt in the config partition (/harddisk/volume_3/config/scriptdirs.txt in your case) to contain only one line that says: /harddisk/volume_3/data/rc.d. You should edit the file using a Unix-compatible editor (WinSCP has one built-in, I don't know about FileZilla), or with vi from the command line. You'll have to edit the file in your config partition and copy it to /etc, or restart the NAS so it copies it automatically.

    Hope this helps.

  82. DoubleD

    DoubleD Addicted to LI Member

    Thanks Jac,

    That did it, I used the original download again, and gust replaced the ini file from my backup. and modified the scriptdirs.txt and all is working again.
  83. sarix

    sarix Addicted to LI Member

    Odd acting problem

    So I have this odd problem, so my NAS I think it's has an over heating problem but I might be wrong. Periodically it will turn off all the lights but the ethernet, it will still respond to ping but nothing else not even the power button to turn it back on. So most of the time when this happens I have to unplug it over night turn it back on and it will load up.... The odd problem I'm having now is that now I can't log in to the website with my admin (root) log in... For a while there the Shell root password had defaulted back to root, and every time i would change it and then reboot, it would come back as root, but today it stopped doing that. But I still can't login as an admin to the page, I try my root login, every way possible, I've tried the default admin login for the nas. Nothing but I can still login as the other users and everything is working fine I can still write new files and read old ones and it's even keeping those through reboots.

    So any ideas on how to get the admin working again for the website?
  84. sarix

    sarix Addicted to LI Member

    So I feel like a putz.... but I tried "admin" with the correct password and it let me into the admin section. I can't remember if that is correct or if it's supposed to be root for the web GUI. But I have that fixed at lease manageable for now.
  85. asadou

    asadou LI Guru Member

    Hi Jac, is it possible to move the SSH from port 22 to some other thing??? Thanks.
  86. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    "root" can only be used for ssh, not for the web GUI, and the accounts that can be used for the web GUI (including admin) can only be used for the web GUI and not for ssh.

    In fact because of the way Sercomm uses the /etc/passwd file it's only ever possible to have an account that can either log in through ssh or an account that can log in to the web GUI, you can't create an account that can do both. The Sercomm software uses "/dev/null0" and "/dev/null1" as shell strings in /etc/passwd to indicate whether the selected user can/cannot use the admin part of the web GUI. If a user has something other than those two strings as shell, they can't log in to the web GUI or Samba or FTP at all, and of course unless your shell is set to something like /bin/sh or /bin/ash you can't login through ssh.

    Of course it's possible to work around this by creating symlinks from /dev/null0 and /dev/null1 to /bin/sh but I recommend against it. It's easier to just create a second username in /etc/passwd with the same UID and GID numbers as another user ID (you can even copy the encrypted password), but with a correct shell string and root directory.

  87. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    Yes. All you need to do is:
    • Add a line to /etc/services to identify the alternate SSH port
    • Add a line to /etc/inetd.conf to connect the service to the dropbear program
    • Restart inetd if it's already running

    For example you can place a script like this in your rc.d directory:
    # Save this as /harddisk/volume_*/data/rc.d/rc.altssh
    # The volume number depends on your configuration.
    # Use a Unix-capable editor or use the editor that's built into WinSCP.
    # Replace 22222 by another port number if you wish
    echo "altssh 22222/tcp" >>/etc/services
    echo "altssh stream tcp nowait root /usr/sbin/dropbear -i" >>/etc/inetd.conf
    # It's not necessary to (re)start inetd from the script because it will get
    # started automatically by the boot scripts.
    # If you type the above commands on the command line, you can run
    # /etc/rc.d/rc.xinetd to restart the inetd program. 
    # Restarting inetd will not disconnect your current session.
    # Note, the NAS will also still listen on port 22 for ssh sessions.
    I didn't fully test this, so let us know if it worked.

  88. asadou

    asadou LI Guru Member

    Cool, thanks Jac! I'll try that tonight as soon as I get back home. Is there a way of running a CVS or SVN server in this tiny box? cheers!
  89. asadou

    asadou LI Guru Member

    changing over the port to other number worked great, thanks Jac!
  90. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    I never tried... It mostly depends on what kind of resources those programs require...

  91. tzoscott

    tzoscott Guest


    GREAT job, btw. I've followed this thread for months and you've done a Herculean effort in supporting everyone. For me, the addition of SSH made the box so much more useful.

    That's all for now.

    I am interested in doing a full build myself, want to update the UI some..

  92. dinox86

    dinox86 Guest

    OpenWRT port

    Hi Jac,

    any news about porting to OpenWRT?
  93. darkdragn

    darkdragn Guest

    I've been following this for a while as well... almost a year now, and my only question is... are you still working on a Jac5? Hopefully with nfs support, and NTFS rw support for the usb ports... please? *puppy eyes*
  94. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    Yes I am "working" on Jac5. Work is progressing very slowly because I have so little time. I am staying up to date with what's happening in OpenWRT land too but Jac5 has a higher priority.

    I don't want to give away too much detail at this time because I don't want to promise anything that I can't do. I want to make it even easier to update on-board software such as Twonky, I want to make it easier to run other software such as JungleDisk Server and I want to make it easier to customize booting.

    Right now I'm working on setting up a Perforce based version control system on my Linux machine, so I have a better overview of my changes. I know Perforce is not common in the Open Source world but it's something that I work with every day. Too bad there are no Perforce hosting sites as far as I know.

  95. shanelai

    shanelai Guest

    will updating this firmware will affect the data in my HDD attached in NAS200? Is it safe to update this firmware eventhough i know nothing about programming? I worry whether i able to log in to admin page after upgrade the firmware.
  96. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    The data on your hard disks is not changed by installing my firmware, and after you install it, you can always go back to the stock V3.4R79 firmware that you can download from Linksys/Cisco. Of course there's always a small chance that accidents happen like a power outage during the flash, so I can't guarantee anything and I won't accept responsibility if something goes wrong and you can't access your data. You should always make backups, even if you are running in RAID mode. That said, I will help you if your flash goes bad, and you can still use SystemRescueCD to access the data on your disks from a PC if your NAS is hosed.

    You don't really need to know anything about programming to install the firmware, but it does help if you know a thing or two about the Linux command line. For starters, you need to know how to change the default root password from "root" to something else. If you don't know how to do this (or why you should do this), this may not be the right firmware for you.

    You will still have the full web GUI, I didn't make any changes to it (it won't even tell you you're running my firmware instead of the stock firmware). All your user names, passwords, shared directories and other settings will stay intact.

    Please read all the instructions on the first page and make sure you understand them before you decide to install. Oh, and by the way, updating the Twonky server is kinda broken at this time because the people at Twonky changed to different system libraries. I'm trying to find some time to put something together to fix this...

  97. adasch

    adasch LI Guru Member

    Hello, JAC,

    great firmware!


    Can you confirm:


    any revision don't work function rescan continuous (option -1)

    twonky see some problem with this, You can see it in log file

    and folder watch is empty.

    in build in twonky all work ok, twonky create many files in watch folder.


    if it possible

    can we install opt firmware?

    like mc?

    on WRTSL54GS with usb flash (must be ext2) i don't have any problems with mc, rutorrent etc...

    mkdir /mnt/usb/opt
    mount -o bind /mnt/usb/opt /opt
    cd /tmp
    wget http://update.groov.pl/optware-install.sh
    chmod +x optware-install.sh
    export PATH=/opt/bin:/opt/sbin:$PATH
    ipkg update
    ipkg install mc

    return error
    "Can't find /opt in /etc/fstab"
    after mount

    if it possible to solve this problem?

    more about optware


  98. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    I think this should work, however it may run out of memory. Twonky 5.1 and higher currently don't work at all because they switched to a newer libc.

    You can run programs like Midnight Commander and various Torrent clients but there is no ipkg program on my firmware, so there's no easy way to just "grab" a package and run it.

    My firmware is intended as a minimum "fall-back" firmware that allows you to log in to a shell prompt without getting rid of any of the stock features such as the web GUI. If you want to run additional software, you will have to copy it to the hard disk or a USB stick and start it from there. You will need to use the x86 version of the software and you may have to recompile it against the libraries that the NAS200 has. If you don't know how to do this, you may want to run another firmware such as UFS200, which includes Midnight Commander and CTorrent. UFS200 needs my firmware to boot up from a USB stick but my firmware won't interfere with UFS200's functionality (it won't use memory space while UFS200 is running, for example). Check the forum page to find it.

    Optware is intended for the NSLU2. The NSLU2's hardware is based on a MIPS processor and the NAS200 is based on the RDC3210 processor (x86 compatible). This makes almost all software for the NSLU2 completely incompatible with the NAS200.

  99. DJ Soulfly

    DJ Soulfly Addicted to LI Member

    Jac does the firmware allow to connect a external USB CD-ROM drive to be mounted and shared over the network? If so can i simply just mount the drive or is there a limitation in the running kernel which doesn't recognize the drive?
  100. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    It should be possible, in theory at least. I seem to remember doing some testing with an external USB-to-IDE adapter connected to a CD-ROM drive but I don't remember what the result was. This was in the time that I made the iso9660 and other filesystem modules available as separate download so with some creative googling you may find out more.

    The only thing that might get in the way is that Linksys/Sercomm made some modifications to the USB stack so that USB mass storage devices are automatically mounted and shared.

    Of course you will have to insmod the filesystem modules that I make available for download (particularly iso9660.ko) but that shouldn't be too much trouble.

    To share it with the world, it should be enough to simply mount the drive onto a directory that's already shared.

    Of course even if you're unable to share an actual CD-ROM drive you can still insmod the iso9660.ko module and loop-mount an ISO image to share it.

    Let us know how it turns out!

Thread Status:
Not open for further replies.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice