Any RVS4000 owners here?

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by Toxic, Sep 20, 2006.

  1. Toxic

    Toxic Administrator Staff Member

    afaik there are no alternative firmwares for this router. I know performance is slow if IPS is enabled so try disabling it. are you using gigabit lan adaptors on your PC's? if so try enabling Jumbo Frames (size depends on size of LAN port on your PC) in the L2 Switch settings.. if you are not using IPV6 the set RVS4000 to IPV4 only.

    i have also seen two other betas which i will put up on the site sortly.

    1.2.06 and 1.2.05

    only changes i see are these:

    Firmware 1.2.06 fixed the following issues.
    - "Deny All" ACL Rule blocks internet access.
    - RVS4000 supports Vista (SP1 and non-SP1) QVPN 1.2.8 (with public ip and with private ip).
  2. wireless-Bob

    wireless-Bob Addicted to LI Member

    I have been using the RVS4000 that replaced an ailing BEFSR41. Other than it thinking I was attacking the LAN with malformed UDP packets when I was performing an ftp download (which required a reset to clear its tiny little mind), I have had no problems with this box.

  3. Puffnstuff

    Puffnstuff Network Guru Member

    I had this sorry router for a little over two weeks and between not being able to access ftp files and it slowing down I just couldn't take it anymore. In the end today I took it back and got a refund and replaced it with a d-link dgl-4500 router which outclasses it in every way. Things are back to normal now and I don't think that I'll be buying anymore linksys branded routers. Tis a shame since I've been using them for years now but since cisco took them over seems the consumer level stuff has gotten worse. Could it be they want to drive us to buy the more expensive cisco branded stuff? They managed to drive me back to d-link.
  4. donathome

    donathome LI Guru Member

    FTP Question

    Bob - I am having this issue also. Can you be more specific on which reset procedure you used to clear the FTP issue? Thanks in advance.
  5. linksys_rvs4000

    linksys_rvs4000 Addicted to LI Member

  6. bavcon22

    bavcon22 Addicted to LI Member

    RVS4000 owner1

    I have RVS4000. I try to connect to my home LAN but I'm not able to "see" my home resurcue. What can I do? My router firmware is 1.2.10. My QuickVPNplus software 1.0.6.
    Response when I try to extablish VPN tunnel:

    C:\DELO\RVS4000>QuickVPNplus -f config.xml
    QuickVPNplus ver: 1.0.6
    Flags: 2 (0x2)
    OSver: 5.1
    [T] Figuring out local interface.

    [T] ipADD
    [T] defGW
    [T] match found - I am done here.
    [T] interface type: 6

    Local ip address:

    Requesting configuration data from ...
    [T] Uri:

    using WinHTTP
    SSLsrvCert: Linksys_RVS4000 RVS4000 Linksys US
    [T] HTTP response: 200 - OK

    [T] Server response
    conn 6100_rw_rw

    Presharedkey: xxxxxxxxxxx

    Deactivating ipsec policy QuickVPNplus ...
    ipseccmd -w REG -p QuickVPNplus -y
    Error converting policy: 0x2

    The command completed successfully.
    Removing ipsec policy QuickVPNplus ...
    ipseccmd -w REG -p QuickVPNplus -o
    Error converting policy: 0x2

    The command completed successfully.
    Creating ipsec policy QuickVPNplus rule Host-RemoteNet ...

    ipseccmd -w REG -p QuickVPNplus -r Host-RemoteNet -t -f -n ESP[MD5,3DES]3600S/50000KPFS -a PRESHARE:"xxxxxxxxxxx" -lan -1p

    The command completed successfully.
    Creating ipsec policy QuickVPNplus rule RemoteNet-Host ...

    ipseccmd -w REG -p QuickVPNplus -r RemoteNet-Host -t -f -n ESP[MD5,3DES]3600S/50000KPFS
    -a PRESHARE:"xxxxxxxxxxx" -lan -1p

    The command completed successfully.
    Activating ipsec policy QuickVPNplus ...

    ipseccmd -w REG -p QuickVPNplus -x

    The command completed successfully.

    Configuration done.

    Activating tunnel...

    Preverjanje dosegljivosti z 32 B podatkov:

    Pogajanje o IP varnosti. (Negotiating IP Security)
    Iztekla se je časovna omejitev za zahtevo. (Request timed out.)
    Iztekla se je časovna omejitev za zahtevo. (Request timed out.)
    Iztekla se je časovna omejitev za zahtevo. (Request timed out.)

    Statistika preverjanja dosegljivosti za
    Paketov: Poslanih = 4, Prejetih = 0, Izgubljenih = 4 (100% izguba),


    My configuration file:

    <?xml version="1.0" encoding="ISO-8859-1" standalone="yes" ?>
    <quickvpnplus version="1">

    <!-- ******* the following parameters MUST be defined either here or using cmd line switches ******* -->

    <!-- ******* password if not defined here or in the cmd line will be requested during program execution ******* -->

    <!-- ******* QuickVPNplus by default uses port 443. You may need to use 60443 with some routers ******* -->

    <!-- ******* optional parameters, delete the ones you don't need ******* -->

    <!-- ******* if you want QuickVPNplus to check the SSL certificate presented by the server you can set a subject to be matched ******* -->

  7. Ironwalker2

    Ironwalker2 LI Guru Member

    No Issues here with latest firmware.
    IPS on
    cat6 through entire network and gige ethernet cards/switches
    FTP server works fine and entire network with top tier OOL Boost works at full speeds.
  8. zampaz

    zampaz Guest

    4000 owner seeks WAN IP

    Why I'm cruizin linksys blvd:

    Cable ISP: Comcast (New Mexico)
    RCA by THOMSON Cable Modem w/VOIP Model: DHG535-2
    Linksys Router Model:RVS4000

    ISSUE: Unable to obtain ISP assigned DHCP WAN address after firmware 1.2.11 update.

    same as everyone else I guess.
    Having a hard time getting through to someone for some support.
  9. apollyonus

    apollyonus Guest

    I "inherited" 4... I'm about done with them.
  10. dvision

    dvision Addicted to LI Member

    have one

    Bought one 2 days ago, I'll post here my conclusions very shortly.

    I have a big issue with this router. I bought it for its advertised 800mbit NAT throughput. I could only see 24mbit through NAT (WAN to LAN transfer and vice-vers). Only when using FTP protocol the speed was close to 100mbit.
    :thumbdown: Very weird! I need a solution asap! I can't return the product as I bought it online.
  11. orientdude

    orientdude Addicted to LI Member

    This RVS4000 is a crap router! I tried updating the firmware due to the famous FTP server issues (worked for months then puff!!) from 1.1.14 to the 1.2 using the firmware utility. It flashed the EEPROM then the router completedly locked up with solid red DIAG led constantly on. Really need to get this solved with linksys and now without 1gig and back on the old WRT54GS. The older products just wins hands down!!!!

    Can anyone provide the older firmware versions or knows where I can download them from??? Thanks!
  12. dvision

    dvision Addicted to LI Member

    have you tried with other protocols but FTP?
  13. beisik

    beisik LI Guru Member

    i would just like add that i just bought a rvs4000, and my downloads are pretty ok, 5,6mb d/l, 1,2mb u/l with torrents. I disabled the IPS service and i am using a DMZ port. So far i have no complaints about anything with this router. oh, i have a 100/10 connection, and i am using the latest firmware (1.2.1 i guess).

    Could there be somekind of a difference between the US and the EU model?

    edit: i´ve had d/l speed up to 7mb/s tonight, i think that´s just about as fast as my 100/10 can REALLY download.
  14. dvision

    dvision Addicted to LI Member

    I had even 11 Mbytes dl and 7Mbytes ul through NAT. I'm searching for a gigabyte provider currently :D
  15. beisik

    beisik LI Guru Member

    So why are people crying about having crappy transfer rates?
    I just tested a 1gb null download from funet, and i got a d/l rate of 10.4mb/s.
  16. dvision

    dvision Addicted to LI Member

    I think because they do not disable the IPS. One can not expect that processor to do IPS at 100mbit speed...:cool:
  17. beisik

    beisik LI Guru Member

    My toughts exactly :D
    I believe that this is a great router for home users with fast internet hookups,
    so far i´ve had no need for IPS nor the quickvpn solutions, and with those disabled it gives me a great bang for the buck. It´s pretty hard to find a decent router for a 100mb connection, so far i´ve tested a couple and they all ended up capping my d/l speed to 4-5mb/s. I have to admit that 5mb/s is fast enough, but getting a 100mb connection was a good reason to upgrade my router.
  18. janne

    janne Addicted to LI Member

    I'm actually at the process of looking for a router for my 100/10 internet connection. Based on the last few replies to this thread it would seem that with the latest firmware the WAN <-> LAN throughput problems are a thing of the past, given that you disable IPS.

    I'm a correct in assuming this?
    And is the firewall in the device usable without a major performance hit?
  19. dvision

    dvision Addicted to LI Member

    Actually this router is ok if you don't want to have any open ports.
    If you need to publish a service through this router and disable the IPS, it will hang very very often. With the IPS enabled the throughput is around 16mbit, 2mB. You do the math. I dumped mine, cause I use one of my computers for hosting some services for my friends. So I grabbed an old pc and installed Clarkconnect on it, with all the security features. Good luck!
  20. janne

    janne Addicted to LI Member

    Ok, thanks for the info. I'am going to need port redirections to machines in LAN and preferably a working firewall. I guess this one isn't an option then. Too bad the specs are so good on paper. Gotta find another alternative.
  21. dvision

    dvision Addicted to LI Member

    Tell you what. Ckeck this out and the system requirements list
    You can buy a GreenPC/Shuttle (100watts max power consumption) e.g. with around 300 euros, install an extra network card and connect it with your home computers using a switch or a hub. If you want to go on this road, but you don't know how to configure the gateway, I will gladly help you configure it over the internet ;=). Best of luck!
  22. cello

    cello Addicted to LI Member


    dvision can you send me your config file, i want to see if i have the same problem.

  23. cello

    cello Addicted to LI Member


    is there any way you can send me your config file. i know you said you had issues with IPS.
    i want to see if i have the same issue.

  24. Eldorage

    Eldorage LI Guru Member

    I have had mine since March 2007.
    I don't use IPS or VPN.
    I do use "Internet Access" rules to restrict kids' time on the net.
    It never hangs or crashes. Current up time is 61 days; before that I had nearly 5 months up time.
  25. Rod K

    Rod K Network Newbie Member

    Yes, I am using the RVS4000 router. I have 5 offices using them.
  26. Toxic

    Toxic Administrator Staff Member

    thanks but the thread was started in 2006 and the last post before yours was done in 2009. think this thread is somewhat old now.
  27. dragonmas

    dragonmas Network Newbie Member

    I have a RSV4000 v2,updated to latest firmware. I can change the default user name but cannot change default
    password. I go under administration and change and click save but changed password is never saved. Any suggestions?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice