Anyone have DD-WRT on WRT54G v8.203?

Discussion in 'DD-WRT Firmware' started by billybob_jcv, Apr 29, 2008.

  1. billybob_jcv

    billybob_jcv Addicted to LI Member

    Has anyone flashed DD-WRT onto a WRT54G with v8.203? I tried using the instructions for v8 & v8.2, flashed it with vxworkskillerGv8-v3.bin and I received an "Upgrade is successful. Rebooting..." in my browser window. At that point I pulled the power cord, plugged it back in and I was greeted with no power light, solid green lights on all 5 port lights and no other lights. I can't ping it, can't reset it and no lights flash on power-on. I've got nothing.

    I now have another v8.203 (only version of the WRT54G they have at my Fry's) and I'm afraid the same thing might happen. I can think of 2 possible causes for my first failure: 1) I might have pulled the plug too soon after getting the success message from flashing with vxworkskiller, and 2) Since I pulled it from a new unopened box, I did not think I needed to do the reset to defaults. I really think I did everything else by the book.

    Is either of those a possible cause for my first brick? If so, then I'm willing to try again, if not, I'll probably return the new one and either get a WRT54GL or just bail on the whole exercise and buy a dedicated bridge.
  2. mstombs

    mstombs Network Guru Member

    Who is in charge of version numbering in Linksys - are they deliberately trying to confuse users?

    The good Linksys reputation was earned with WRT54G V1-V4, but they then cut costs and have produced a series of ram challenged dogs, each lasting only a few months - one production run each?

    V5 and 6 are VxWorks
    V7 was an oddball Atheros chipset + VxWorks?
    V7.2 Broadcom/Vxworks
    V8 VxWorks/Broadcom and non changeable antennae
    V8.1 Linux/Broadcom
    V8.2 VxWorks again

    who can guess what have they changed in V8.203?
  3. danix71

    danix71 LI Guru Member

    Why in the world did you do that?

    OT: Don't you feel (good) like a beta-tester ? :biggrin:
  4. billybob_jcv

    billybob_jcv Addicted to LI Member

    I was following these instructions:

    # Configure your computers local lan ethernet address to, subnet, gateway . Then connect an Ethernet cable to your computer and port 1 of your WRT54Gv8 router (Do Not Use Wireless).
    # Unplug the power cord from the WRT54Gv8.
    # Push the reset button while plugging in the power cord and hold the button for about 20 seconds.
    # Open your browser and enter into the address bar
    # Use the firmware upgrade dialog to flash vxworkskillerGv8-v3.bin.
    # If you see a dialog to reboot the router, power cycle the router by unplugging the power cord and plugging it in again.
    # Wait for about 1 - 2 minutes.

    My mistake was thinking the "Upgrade is successful. Rebooting..." page was the same as the page being referred to on the highlighted line. So, when I saw that page, I pulled the plug. Clearly, that was not a good thing... :rolleyes:

    My second try with a new v8.2 was successful. I waited a couple of minutes after the vxworkskiller load, and everything worked great. I have the client bridge up and running. Thanks!
  5. ndrew2505

    ndrew2505 Addicted to LI Member

    i flashed vxworkskiller then used linksys tftp util to flash the firmware with. after flashing fw i unplugged then plugged back in and was on dd-wrt.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice