anyone know how to reset wrt54g v3.1 after bad flash ?

Discussion in 'Cisco/Linksys Wireless Routers' started by bla0909, Feb 1, 2006.

  1. bla0909

    bla0909 Network Guru Member

    Been trying all the tips i have found on the net but still can't connect to the router.

    I need to reset the router to factory defaults to be able to connect to it again. I am unable to connect to the router both cabled and wireless. I have lights in the ethernet ports on the router when i attach a computer to it , but can't ping the router.

    I have no idea what went wrong with the firmware as it was downloaded from and said successful when finished.
  2. Guyfromhe

    Guyfromhe Network Guru Member

    what have you done so far?
    have you done the TFTP trick to upload firmware on boot?
    is it still within the warantee period if so you may want to RMA it.
    if not you can try the flash shorting tricks,
  3. TimBit

    TimBit Network Guru Member

    ok I'm lost
    Flash Shorting tricks ??
  4. Guyfromhe

    Guyfromhe Network Guru Member

    ok lets start with what you've already tried before I start recomending what you should do next...
  5. bla0909

    bla0909 Network Guru Member

    First i've tried the reset botton for a few seconds.

    Then i find a site that had a 'long reset' solution, pressing the reset button for 30 seconds and removing the power cable while pressing the reset button.

    I cannot get an ip from the router automatically, nore can i ping the router if i set the ip manually. Don't think i will be able to use tftp without establishing contact with the router.

    The following lights on the router is active :
    - power
    - wlan (my wifi cards don't find any wireless networks)
    - Ethernet 1 and 3 (2 computers are cabled to the router)

    Shouldn't the router default to after a reset ? if so, setting the ip on the cabled nic to should allow me to ping

    Sorry if there are some bad english, i'm from Norway
  6. Guyfromhe

    Guyfromhe Network Guru Member

    try leaving the ping running as you start the router, see if you can ping it, you may only be able to ping it for a short while but see if it responds at all..
  7. bla0909

    bla0909 Network Guru Member

    Hi again, thank you for trying to help me out here :)


    Before the router comes on i get 'Destination host unreachable' and after i get 'Request timed out'

    Not one successful ping :sad:
  8. AStupidName

    AStupidName Network Guru Member


    A couple of things.

    -Do you remember/have you tried the original IP if it had another?
    -Have you set the network card to 10mbit/Half Duplex?
    -Are you within the warranty period?

    If the first two fail, and the answer to the third is "No" then you're about to get your first look at your router's guts. But that's for later, after you've tried the first steps.
  9. sirosis

    sirosis Guest

    I just did it with mine. Search the site for unbricking information.

    What I did with my wrt54g v3.1 was short pin 16 to the ground antenna (the one with the cable attached to it). Then I TFTPd the latest linksys firmware back to it. Then wait 20 seconds until it reboots on its own.
  10. bla0909

    bla0909 Network Guru Member

    tried with original ipand YES 10Mbit/Half duplex and no warranty.

    Will try to search the forum for unbricking information.

    I have no opened up the router ......

    Can you please direct me to the link you used to fix this. I need some drawings so i can find out what to shortcut.
  11. bla0909

    bla0909 Network Guru Member

    I am now able to ping the router at

    When i try the linksys update tool it recognizes the router, but when i press update i get 'cannot connect to server' :sad:

    No luck using tftp either.

    How do i get the frimware back on the router now ???
  12. bla0909

    bla0909 Network Guru Member

    I even have a wireless network now named organic, got a ip when i tried to connect to it that was with gateway !

    Tried to open and was asked for username and password but admin/admin didn't work

    Was hoping to update the firmware through wireless ...

    Strange thing is cabled nics can not get ip automatically but wireless does . Opening with cabled don't work but opening wireless does ...

    Really hope that someone can tell me how to get this router up and running again.

    thanks in advance

    EDIT : Router is up and running again :cheer: , found an old tftp on

    Thank you very much for your help
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice