Asus RT-AC3200 supported by Tomato

Discussion in 'Tomato Firmware' started by shibby20, Nov 8, 2015.

  1. kunikatsu

    kunikatsu New Member Member

    Just loaded 137 for RT AC3200, everything works except nvram set clkfreq=1400,800 / nvram commit. Thanks, Shibby.

    Sent from my iPhone using Tapatalk
  2. Roy2001

    Roy2001 Addicted to LI Member

    Have you compare the wifi range and signal strength with Netgear factory firmware? On my R8000, Tomato wifi is much weaker.
  3. kunikatsu

    kunikatsu New Member Member

    Nope, I switch over from Asus RT ac68u. RT AC 3200 is much better in terms of wireless. I can't go back to stock firmware as I am using vlan, firewall script, vpn client route to virtual wifi and etc. Tomato by shibby ver 137 is rock solid. I haven't had any vpn drop or anything that require me to reboot the router.

    Sent from my iPhone using Tapatalk
  4. perezil

    perezil New Member Member

    I have the same intention. The hardware is nice, but the OEM firmware is disgustingly flawed. TRENDnet is not going to help fix it. I currently run DD-WRT on it and it does a lot better. I use Tomato 1.28 BY SHIBBY on my Netgear WNR3500L and have downgraded my hardware back to it for now.

    I hope you can help (anxiously awaiting) :-D

    (P.S. I don't have a lot of free time, but I am willing to help. Let me know where you need me.)
  5. perezil

    perezil New Member Member

    @shibby20 , I think I found the information needed to finalize the support for TEW-828dru
    The Skyworks and Anadigics amplifiers.

  6. rickmav3

    rickmav3 Serious Server Member

    Is JFFS working? Erased all data in NVRAM, first setting tried is to enable JFFS. It just says Stopped. Same after trying to Format / Erase.
  7. warsev

    warsev Networkin' Nut Member

    Setting up a new RT-AC3200 with Tomato/Shibby 138-AIO. I notice that "export" is gone from the nvram utility. Is this intended, or is this a bug? Or is "export" being replaced with "show"? I was kinda fond of "nvram export --set".
  8. koitsu

    koitsu Network Guru Member

  9. wbirdy_one

    wbirdy_one Serious Server Member

    Any update to this. Is it implemented in the newest version?
  10. athattaway

    athattaway New Member Member

    Is there a specific stock firmware version that is needed prior to the update to Tomato? I have attempted to update twice, but it appears to be soft-bricking the router and requires that I reload the stock firmware using the ASUS recovery utility.

    The ASUS website has a note on their newest firmware version that:

    ASUS has been dedicated to cooperate with third party developers to come up with more innovative features.
    To comply with regulatory amendments, we have modified firmware verification rule to ensure better firmware quality.
    This version is not compatible with all previously released ASUS firmware and uncertified third party firmware.
    Not sure if it affects things or not. I tried loading flashing an older version of the firmware, then flashing to 132, but the router ui will not return from the firmware update screen and has to be recovered.

    Edit: Not sure what the problem was, but it worked itself out after the third attempt to factory the device. Went from ASUS -> 1.28b132 -> 1.28b138 and after a factory reset, the device came back up and was responsive.
    Last edited: Sep 26, 2016
  11. wbirdy_one

    wbirdy_one Serious Server Member

    I installed V138 some days ago and had also some problem.
    After flashing tomato shibby, try resetting nvram by holding down WPS when powering on..
  12. expertskindoc

    expertskindoc New Member Member

    I like to turn off my guest wifi at night, it's interface wl0.1, but when i go into telnet and do this command:
    wl -i wl0.1 radio off
    Then eth1 or wl1 would have radio off.
    I tried enclosing in single or double quote, same effect.
    How do i turn off guest wifi that is on br1?
    Is there a command to list all interfaces in cli, unix, telnet, ssh....
    Right now i'm using access retriction for nighttime, but radio off would be preferred.
    Thanks in advance for reply
  13. user123456

    user123456 New Member Member

    Just got a new one today and had some trouble with installing 138. The ASUS utility put it on the router fine but it would never come up, seemed to be boot looping after a while (I let it sit for over an hour). Tried 137 and had the same problem. After seeing this thread I tried 132 instead and it installed fine. Then I updated to 138 from the web page and now it's running 138.
  14. AndreHJ

    AndreHJ New Member Member

    I've just got an RT-AC3200 with stock firmware, and tried installing Tomato using the web interface and the rescue tool (running as root using Wine, as I don't have any computer with Windows); I can't get any of them to work.

    The web interface rejects the image. When trying to upload the image using the rescue tool, it claims the router is not in recovery mode (which it was). I've tried numerous times, but no go.

    My old RT-N16 was rock stable with Tomato for years -- until it died. I already miss having Tomato, so any hints on how to install it will be greatly appreciated!
  15. Roy2001

    Roy2001 Addicted to LI Member

    For those who are using AC3200 with Tomato, do you noticed wifi signal is weaker than with stock firmware? I have a Netgear R8000 and wifi is much weaker with Shibby than Netgear stock FW.
  16. daryl_425

    daryl_425 New Member Member

    Does anyone know if wireless client mode works with RT_AC3200? I tried with merlin fw and stock on media bridge mode and it works. But when using tomatousb v138, nothing I've tried gets this to connect to my main AP. Turned off encryption, tried from all three radios, cleared flash, etc. Thanks.
  17. grendelous

    grendelous Network Newbie Member

    In case you didn't get this working, here's what worked for me. I just got an RT-AC3200 with stock firmware and it's wouldn't accept either 132 or 138 in the web interface. I used the ASUS firmware restoration utility (I'm on a Mac, so I dunno if it's called the same thing on Windows) to flash it back to FW_RT-AC3200_30043789529.trx which I downloaded from ASUS. Then I upgraded to Tomato 132 via the web interface and from there to 138. I tried going to 138 directly but it didn't work.
    tenskwatawa likes this.
  18. tenskwatawa

    tenskwatawa Networkin' Nut Member

    Thanks grendelous - it works perfect!
    I wonder do you have the same issue on 138 and rt-ac3200 - I don't see any connections tcp or udp in QoS - View Details - I see only few (3-4) IGMP or ICMP.
  19. grendelous

    grendelous Network Newbie Member

    No, I see details there.
  20. Lupercal

    Lupercal New Member Member

    Just purchased an Asus Rt-AC3200 and flashed it with the latest, 140, Tomato in the hopes of wireless bridging a network and broadcasting on the other two radios. Unfortunately, I can't seem to even get it to connect to my wireless network with Wireless Client mode or Wireless ethernet bridge mode. "Media Bridge" mode worked just fine in both stock Asus firmware and Merlin.

    Does anyone know if Wireless bridging works in Tomato on this router currently?
  21. kerbdog

    kerbdog LI Guru Member

    I've just flashed (for the first time) an Asus RT-AC3200 to Shibby's 140 K26ARM USB AIO-64K build.
    If I try and change the 'Country / Region' in the Advanced/Wireless setting with a hope to use the different frequencies my home country will allow, back at the wifi config it won't allow me to change or show the frequencies on the 5Ghz radios, only the 2.4Ghz.
    Don't know if this is a known issue or not?

    I've flashed the image again ticking the 'erase all data in NVRAM memory', still no luck.

    By default when the device is initially flashed the 'Country / Region' in the Advanced / Wireless setting defaults to 'Singapore.' When I change it the channel selected 'Auto' can no other options are available.

    Anyone else seeing this?
  22. AndreDVJ

    AndreDVJ LI Guru Member

    Depending on the country you choose and channel width, you'll lose channel selection.

    I set all radios to United states, so at 80Mhz I have two channels to choose for each control sideband.
  23. kerbdog

    kerbdog LI Guru Member

    Thing is, if I change the country away from the default option of 'Singapore' after a flash - it doesn't show any channel selections, just 'Auto'. Even if I choose Russia I get no channel options other than 'Auto'
  24. AndreDVJ

    AndreDVJ LI Guru Member

    Broadcom wireless driver is stupid:

    1) I set country set to RUSSIAN FEDERATION on my R8000, and I lost channel selection on both 5Ghz radios, across all channel widths (20/40/80Mhz).
    2) Then I set back both radios to UNITED STATES, and I lost channel selection at 80Mhz channel width.
    3) Rebooting the router afterwards, restored channel selection for all channel widths.

    Try setting to UNITED STATES, and then reboot the router.
    kille72 likes this.
  25. kerbdog

    kerbdog LI Guru Member

    Ah ok. I think I tried that but will check again in awhile and report back :) cheers for the tip!
  26. kerbdog

    kerbdog LI Guru Member

    Yup, seems that the driver might be very stupid - selecting US and all seems well now.
    Will it ever play nice with the country setting?
  27. rootMBX

    rootMBX Networkin' Nut Member

    I spent a VERY long time working on bridging two RT-AC3200 on versions prior to 140. I found that choosing channels that weren't available with Asus/Merlin's firmware would prevent a connection. Sounds like 140 is limiting the choice via GUI so this may be worth another try...

    I ended up using Toastman on one RT-AC3200 with an Access Point on eth1 and a RT-AC68U as the bridge. I'll report back if I can get dual RT-AC3200 connected with 140.

    Here are the channels available on Asus firmware (at 20 MHz, if memory serves. You should only attempt to use these on Tomato even if GUI allows for others.

    5 GHz: Tomato eth1 (Asus 1)

    5 Ghz: Tomato eth3 (Asus 2)
  28. starkline

    starkline Network Newbie Member

    Just out of curiosity, has anyone been able to get QoS working in build 140? Outbound QoS seem to be functioning, but there doesn't seem to be anything I can do to get Inbound QoS working.

    As a stop-gap, I enabled IP-Bandwidth limiting for my file server, but doing so seems to cause Outbound QoS to cease functioning.

    Can anyone report if build 137 has a functioning QoS implementation?

    Cheers, and kind Regards to all.
  29. tvlz

    tvlz LI Guru Member

    Currently IPv6 bypasses inbound QOS due to missing tc rule something like
    tc filter add dev $WAN_DEV parent ffff: protocol ipv6 prio 11 u32 match ipv6 dst ::/0 action mirred egress redirect dev ifb0
    Replacing $WAN_DEV(vlan2/ppp0)

    EDIT: see PR#49
    Last edited: Jun 20, 2017
  30. starkline

    starkline Network Newbie Member

    I didn't know that about IPv6, but no, I am not using IPv6. I have it disabled in Tomato.
  31. tvlz

    tvlz LI Guru Member

    starkline and Elfew like this.
  32. starkline

    starkline Network Newbie Member

    tvlz: Thanks so much for looking into the QoS issue and taking the time to submit a pull request. I wish I had the knowledge required to compile for my router so I could test out the fix. Do you happen to know if there is a source for nightly builds? My Google searches didn't reveal anything like that for sibby's builds.

  33. kille72

    kille72 LI Guru Member

    I can compile a test version for AC3200 with this fix tomorrow if you want.
  34. starkline

    starkline Network Newbie Member

    That would be fantastic!! I'd really appreciate it. Thanks so much for offering to compile. You are a Golden God.
    kille72 likes this.
  35. kille72

    kille72 LI Guru Member

    Ehh...I have sad news, after all new commits, SDK7 does not work at all...I do not know when this is fixed. Sorry.
    Last edited: Jun 23, 2017
  36. kille72

    kille72 LI Guru Member

  37. starkline

    starkline Network Newbie Member

    I really appreciate you taking the time to do this for me. Are your comments re: SDK7 not working applicable to my case? Apologies, I simply do not know enough about the firmware to know.

    Again, thanks!!!!
  38. hodorific

    hodorific New Member Member

    just got a new ac3200. i cant seem to get tomato on it. trying the earlier posters recommendation of using the firmware utility to go to the old version from asus site then go to shibby 132.

    firmware utility wants router in rescue mode...put it in rescue mode with the slow blinking power light, try to downgrade firmware and it keeps telling me router needs to be in rescue mode.

    any idea of how to beat this? thanks much

    ***edit...finally was able to get an old version of asus firmware on it then go to shibby!!
    Last edited: Jul 21, 2017
  39. Saturn49

    Saturn49 New Member Member

    Thanks for porting Tomato to this device Shibby.

    I had a few issues with 140 on it, however, mostly dealing with the 5Ghz wireless.

    I was able to get the wireless in some strange states, most of which I could only resolve by clearing the NVRAM. For instance, both 5G radios were running at really low power, to the point a device sitting within inches of it still couldn't connect. Another time only eth3 did that but eth1 was fine.

    I don't have exact duplication steps but it probably has something to do with what I was trying to do with it, which was:
    1. Use one of the 5G radios for a WAN (connecting to a hotspot)
    2. Use the other two radios for the LAN
    3. Add virtual wireless interfaces to both the LAN radios.
    4. Have more lax security on the virtual wireless - WPA/WPA2 and TKIP/AES and broadcast SSID vs WPA2/AES and no broadcast SSID on the non-virtual wireless.

    I never could get a 5G radio for the WAN. I could only get it working briefly by selecting eth3 for the WAN, since selecting eth2 put eth1 in wireless client mode and vice versa (definitely a bug here). Then I had to go Advanced->VLAN and unbind eth3 from a bridge, and then it would (usually) connect to the hotspot and start working. That is, until I rebooted or power-cycled the router. Then it would refuse to connect anymore and appeared that the radio reverted to AP mode.

    If I unbound eth3 from the bridge BEFORE putting it into wireless mode, the the device would disappear entirely until I cleared the NVRAM (and started over...)

    The Virtual Wireless page still allowed me to (try to) create virtual interfaces on a wireless client radio, though they wouldn't actually appear after hitting save, that may have been one of the steps that I (accidentally) took to get the radios in a non-functional state.

    I also gave up trying to set the security different on the virtual wireless, as I think that is one of the things that made the radios get into a bad state.

    I was finally able to get things working (except using wireless for WAN) by being very methodical and changing one thing at a time, verifying it worked, the radios hadn't gone into low/no power mode and saving the configuration so that if it got into a bad state I could clear the NVRAM and restore from a known-good configuration.

    Has anybody else had these sorts of issues with the wireless on the AC3200? I ended up just setting up an old WRT320N as a wireless bridge.
  40. Dougle

    Dougle New Member Member

    I've been trying to get the Wireless Client mode working on my AC3200 with build 138 and ran into similar issues:

    1. In Basic>Network>WAN Settings: When Type is set to DHCP, selecting 5GHz/eth1 put 2.4GHz/eth2 into wireless client mode further down on the page and vice versa, just as described by @Saturn49. This is the only place where this error occurs. Going to Advanced>Virtual Wireless and changing the settings there matched the correct interface in Basic>Network>WAN Settings.
    2. I have not been able to get my router to connect to a wireless network as a client. I do not know what host router is used by my apartment complex, but talking with their tech support I was able to verify the AC3200 is attempting to connect, but is not getting an IP address. On my side I looked in Status>Device List and was able to see a device on eth3. My refresh time was set to 3 seconds and the device would appear for 1 refresh and then disappear for about 10 seconds, at which point the cycle would repeat. I read the MAC address in my listto the technician who verified the it was the address of their access point. He logged into their AP and verified my MAC address would show on his screen for a few seconds and then disappear. We verified all the security settings were correct, but the AC3200 would never maintain a connection and never get an IP address. I tried the Advanced>VLAN unbind suggested by @Saturn49, but no change.
    On item 2, does anyone have any suggestions or updates? Is this something that is improved in the 140 build?

    Thanks for any help!
  41. TEK411

    TEK411 New Member Member

    Shibby20 thank you for the great work you are putting in for the RT-AC3200. It is much appreciated! I hope you continue dev for this router as the tomato firmware is awesome!
  42. txnative

    txnative Addicted to LI Member

    Have you tried the wireless ethernet bridge?
  43. Dougle

    Dougle New Member Member

    Thanks for the suggestion. When I tried Wireless Ethernet Bridge it seemed like a device connected on the Eth3 interface, but no clients could reach the DHCP server. Pings from the router would give a destination host unreachable.

    Any other suggestions?
  44. txnative

    txnative Addicted to LI Member

    Are you selecting from Wireless(2.4ghz/eth1) or The Wan Settings? I've always done it through the Wireless(2.4ghz/eth1) selecting the Wireless Ethernet Bridge, and of course there are steps to assure proper configuration so you can connect to WAP so you can utiliize the ethernet ports of your wireless ethernet bridge, but i take that this not what you are trying to achieve? I did notice if you select from the Wan Settings when selecting the Wireless Client Mode it does those settings too, but in the past the Wireless Client Mode feature didn't work if not configured properly but I maybe wrong since I don't or never have used it, I looked at wifi-planet site there they have it how to set it for both Client Bridge and Ethernet Bridge scenarios. Here's the link
    Last edited: Aug 9, 2017
  45. rootMBX

    rootMBX Networkin' Nut Member

    DHCP is not passing through your router. This guy fixed it by running a Windows Server with the DHCP and DNS roles behind the second router. He was linking two RT-3200s via media bridge.

    This is what happened to me.

    It's a shame such an expensive router can't do what ASUS initially advertised.

    Does anyone have any idea if these issues will ever get fixed?

    BLEH-ASUS Network Newbie Member

    Second 5ghz radio doesn't work for me.. anyone else have this issue?
  47. Bad_Dog

    Bad_Dog Connected Client Member

    Yup - me... until I followed RootMBX's advice above. I'm upgrading from a RT-N16 and spent an evening configuring the new AC3200. Got all three WiFi's setup and being recognized by my laptop, until I realized it was set to SINGAPORE. Changed all three to UNITED STATES. It wasn't until the next day that I didn't see the second 5Ghz connection, which I'm using for Guests.

    The GUI for channels for each has far more than it should, I'm guessing. To quote RootMBX, only choose from the following channel options:

    5 GHz: Tomato eth1 (Asus 1)

    5 Ghz: Tomato eth3 (Asus 2)

    I changed my second 5G to channel 149 and now I see it from my laptop. Yay!
  48. GunerT

    GunerT New Member Member

    Will there be any possibility for Smart Connect feature?
  49. tjedrak

    tjedrak New Member Member

    I have problem with my RT-AC3200 (H/W Ver R4.12)
    only VPN firmware works for this router. Tried all AIO like:
    • tomato-RT-AC3200-ARM--140-AIO-64K.trx
    • tomato-RT-AC3200-ARM--2017.3b17-kille72--AIO-64K.trx
    • tomato-RT-AC3200-AT-ARM7-3.4-140-AIO-64K.trx
    • tomato-RT-AC3200-AT-ARM7-3.5-140-AIO-64K.trx
    and nothing, after flashing it reboots and booting in a loop, no option to ping it, doesn't start at all, power led indicator constantly is ON, eth4 blinking, after a couple of seconds all LEDs blink and the same process all over again.

    But when I use firmware of tomato-RT-AC3200-ARM--140-VPN-64K.trx or tomato-RT-AC3200-ARM--2017.3b17-kille72--VPN-64K.trx then it works smoothly, nothing to complain.

    Any thoughts? I'm so frustrated I've tried every known trick on the internet, NVRAM erase by WPS, etc.
  50. premudriy

    premudriy LI Guru Member

    Just got ac3200 today and I have the same issue as tjedrak. VPN version runs, but flashing AIO boot loops.

    I was able to get AIO working when I flashed VPN, then in Administration changed the port for the Tomato UI, then flashed AIO without erasing NVRAM. As soon as I erase NVRAM, the AIO (both Shibby 140 and Kille 2017.3) stops booting and it goes into boot loop (no ping either).

    My H/W version is R2.35

    Also even with VPN version the ac3200 seems to reboot a few times before UI comes up (takes about 3 min to fully boot, is that normal for Tomato on ac3200?). I would have thought that I got faulty hardware, but seeing how tjedrak has the same problem, I wonder if this revision has something different vs others.
  51. premudriy

    premudriy LI Guru Member

    tjedrak, I have a question for you: Did you at any point in time flash your ac3200 with version of Asus firmware?

    I'm asking because after some reading I think I start to get why this issue might be happening. I've tried their 328 firmware because I've been running Tomato on RT-N66U for years and wanted to see what's the latest state of the firmware today. I've found some info in other forums that Asus firmware 382 hanges CFE. Not 100% sure what it changes exactly, maybe size of NVRAM like previous routers had 64K update. So I'm thinking (and this is guessing right now) that if size of NVRAM went to 128K and Tomato can read only 64K, then not all address space can be read by Tomato and some variables cannot be read, hence causing the reboot with AIO. Wish someone more knowledgeable would confirm or refute such possibility. Also if this is the case I'm thinking that even VPN build of Tomato might write some settings and then will be unable to read it during normal use. If tjedrak did not update to Asus 382 base, but flashed to Tomato straight from 380 base, then my assumptions would be refuted right away, so I'm eagerly waiting for your reply.

    I'm tempted at this point to return/replace this router and get another one with 380 base. I know if this is the case with CFE, then eventually all future models would ship with modified CFE, but at this time even Merlin doesn't have builds for 382 base yet and i need new router now and so for now I'd be forced to use only Asus original firmware, but I need Tomato's vlan or in the worst case at least DHCP with hostname (what I believe Merlin fw provides). (edit: tempted to replace if tjedrak did not flash to 382 base at any point in time).
  52. premudriy

    premudriy LI Guru Member

    Alright, looks like I messed this router now by going to 382 firmware. Whoever is interested, please see this thread:

    So looks like this will be an exchange for the same model and hopefully it won't have 382 fw yet when it arrives. I'll try again on a new device and see if I can still get Shibby 140 on it (looks like it should still be possible with 380 fw).

    edit: btw, since I'll still have this router for a few days before return, if anyone wants me to try something risky like downgrading CFE, I can try doing it. I'll have to send it back next Tuesday.
  53. premudriy

    premudriy LI Guru Member

    Just wanted to report that I've finally achieved success with the replacement router in having Tomato on it.

    Also some people mentioned that they've had trouble reverting to earlier versions of official firmware from ...280... version and restoration utility keeps saying that router is not in recovery mode. I've had this problem too and for a moment thought that they've blocked something else in the new batch of routers. Uploading via CFE web also didn't work: the lan led kept blinking like data is uploading, but the power light kept blinking also (which should stop in either on or off state once firmware starts being uploaded).

    Long story short, here's what worked. I've put router into recovery mode and then just used tftp on linux and ran these commands:

    > tftp
    > timeout 500
    > connect
    > (to)
    > binary
    > put firmwareFile.trx
    > quit
    and it worked just fine.

    So for people that buy this router, RT-AC3200, don't make the same mistake I did and don't install ...282... version of the official firmware if you want to have Tomato on it.
    Joe A likes this.
  54. Richard K

    Richard K Networkin' Nut Member

  55. koitsu

    koitsu Network Guru Member

    nvram export (specifically the export sub-command) does not exist on ARM. It didn't exist in November 2016 (referenced post), and it still doesn't exist as of September 2018. You will need to look at other solutions (there are some on the forum -- please search/dig around), or make decisions appropriately.
    AndreDVJ likes this.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice