ASUS RT-N16 Slowdown!

Discussion in 'DD-WRT Firmware' started by Tichie, Dec 3, 2011.

  1. Tichie

    Tichie Networkin' Nut Member

    Hi Guys I need help I am getting a slow connection on the router ever since I got it. I get speeds of 5 to 3Mbps when I should be geting 19-20Mbps. I have searched everywhere but still no answer I am running the build 14986. I have done a hard reset, reboot the router and disabled the firewall, even change builds but still the same issue. I know is not the router cause it's Brand New. Any help would be greatly apprecited.

    Linux version (root@dd-wrt) (gcc version 4.1.2) #1977 Sat Aug 7 00:53:12 CEST 2010
    CPU revision is: 00019740
    Determined physical RAM map:
    memory: 07fff000 @ 00000000 (usable)
    On node 0 totalpages: 32767
    Normal zone: 255 pages used for memmap
    Normal zone: 0 pages reserved
    Normal zone: 32512 pages, LIFO batch:7
    Movable zone: 0 pages used for memmap
    Built 1 zonelists in Zone order. Total pages: 32512
    Kernel command line: console=ttyS0,115200 root=1f02 rootfstype=squashfs noinitrd
    Primary instruction cache 32kB, physically tagged, 4-way, linesize 32 bytes.
    Primary data cache 32kB, 4-way, linesize 32 bytes.
    Synthesized TLB refill handler (20 instructions).
    Synthesized TLB load handler fastpath (32 instructions).
    Synthesized TLB store handler fastpath (32 instructions).
    Synthesized TLB modify handler fastpath (31 instructions).
    PID hash table entries: 512 (order: 9, 2048 bytes)
    CPU: BCM4716 rev 1 at 480 MHz
    Using 240.000 MHz high precision timer.
    console [ttyS0] enabled
    Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)
    Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)
    Memory: 124656k/131068k available (3144k kernel code, 6264k reserved, 1479k data, 144k init, 0k highmem)
    Calibrating delay loop… 239.20 BogoMIPS (lpj=1196032)
    Mount-cache hash table entries: 512
    NET: Registered protocol family 16
    Generic PHY: Registered new driver
    PCI: Using membase 8000000
    PCI: Initializing host
    PCI: Reset RC
    PCI: Fixing up bus 0
    PCI: Fixing up bridge
    PCI: Setting latency timer of device 0000:01:00.0 to 64
    PCI: Fixing up bridge
    PCI: Setting latency timer of device 0000:01:00.1 to 64
    PCI: Enabling device 0000:01:00.1 (0004 -> 0006)
    PCI: Fixing up bus 1
    NET: Registered protocol family 2
    Time: MIPS clocksource has been installed.
    IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
    TCP established hash table entries: 4096 (order: 3, 32768 bytes)
    TCP bind hash table entries: 4096 (order: 2, 16384 bytes)
    TCP: Hash tables configured (established 4096 bind 4096)
    TCP reno registered
    RT-N16 GPIO Init
    devfs: 2004-01-31 Richard Gooch (
    devfs: boot_options: 0x1
    squashfs: version 3.0 (2006/03/15) Phillip Lougher
    io scheduler noop registered
    io scheduler deadline registered (default)
    HDLC line discipline: version $Revision: 4.8 $, maxframe=4096
    N_HDLC line discipline registered.
    Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing disabled
    serial8250: ttyS0 at MMIO 0x0 (irq = 8) is a 16550A
    PPP generic driver version 2.4.2
    PPP Deflate Compression module registered
    PPP BSD Compression module registered
    MPPE/MPPC encryption/compression module registered
    NET: Registered protocol family 24
    PPPoL2TP kernel driver, V1.0
    tun: Universal TUN/TAP device driver, 1.6
    tun: (C) 1999-2004 Max Krasnyansky
    PCI: Setting latency timer of device 0000:00:02.0 to 64
    VID 0 is set in nvram, Ignoring
    eth0: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller
    PCI: Setting latency timer of device 0000:00:01.0 to 64
    Physically mapped flash: Found 1 x16 devices at 0x0 in 8-bit bank
    Amd/Fujitsu Extended Query Table at 0x0040
    Physically mapped flash: CFI does not contain boot bank location. Assuming top.
    number of CFI chips: 1
    cfi_cmdset_0002: Disabling erase-suspend-program due to code brokenness.
    Flash device: 0x2000000 at 0x1c000000
    bootloader size: 262144
    Physically mapped flash: Filesystem type: squashfs, size=0x1fb5dc
    partition size = 2176000
    Creating 5 MTD partitions on "Physically mapped flash":
    0x00000000-0x00040000 : "cfe"
    0x00040000-0x01fe0000 : "linux"
    0x0018cc00-0x003a0000 : "rootfs"
    mtd: partition "rootfs" doesn't start on an erase block boundary — force read-only
    0x01fe0000-0x02000000 : "nvram"
    0x003a0000-0x01fe0000 : "ddwrt"
    Found a 0MB serial flash
    sflash: found no supported devices
    Broadcom Watchdog Timer: 0.07 initialized.
    u32 classifier
    Actions configured
    Netfilter messages via NETLINK v0.30.
    nf_conntrack version 0.5.0 (2048 buckets, 8192 max)
    ctnetlink v0.93: registering with nfnetlink.
    IPv4 over IPv4 tunneling driver
    GRE over IPv4 tunneling driver
    ip_tables: (C) 2000-2006 Netfilter Core Team
    ClusterIP Version 0.8 loaded successfully
    TCP bic registered
    TCP cubic registered
    TCP westwood registered
    TCP highspeed registered
    TCP hybla registered
    TCP htcp registered
    TCP vegas registered
    TCP scalable registered
    NET: Registered protocol family 1
    NET: Registered protocol family 17
    Welcome to PF_RING 3.2.1
    (C) 2004-06 L.Deri
    NET: Registered protocol family 27
    PF_RING: bucket length 128 bytes
    PF_RING: ring slots 4096
    PF_RING: sample rate 1 [1=no sampling]
    PF_RING: capture TX No [RX only]
    PF_RING: transparent mode Yes
    PF_RING initialized correctly.
    PF_RING: registered /proc/net/pf_ring/
    802.1Q VLAN Support v1.8 Ben Greear
    All bugs added by David S. Miller
    decode 1f02
    VFS: Mounted root (squashfs filesystem) readonly.
    Mounted devfs on /dev
    Freeing unused kernel memory: 144k freed
    br0: Dropping NETIF_F_UFO since no NETIF_F_HW_CSUM feature.
    device br0 entered promiscuous mode
    Algorithmics/MIPS FPU Emulator v1.5
    device vlan1 entered promiscuous mode
    device eth0 entered promiscuous mode
    device eth1 entered promiscuous mode
    device wl0.1 entered promiscuous mode
    device vlan2 entered promiscuous mode
    br0: port 4(vlan2) entering learning state
    br0: port 3(wl0.1) entering learning state
    br0: port 2(eth1) entering learning state
    br0: port 1(vlan1) entering learning state
    device br0 left promiscuous mode
    device br0 entered promiscuous mode
    device br0 left promiscuous mode
    device br0 entered promiscuous mode
    br0: topology change detected, propagating
    br0: port 4(vlan2) entering forwarding state
    br0: topology change detected, propagating
    br0: port 3(wl0.1) entering forwarding state
    br0: topology change detected, propagating
    br0: port 2(eth1) entering forwarding state
    br0: topology change detected, propagating
    br0: port 1(vlan1) entering forwarding state
    etherip: Ethernet over IPv4 tunneling driver
  2. kthaddock

    kthaddock Network Guru Member

    You can't have same speed as stockfirmware as dd-wrt have more features and consume resurces.
    If you talk about WAN-LAN speed should RT-N16 get ~100Mbs without Qos and minimum extra firewalls rules.
    Wifi there you can expect at max ~5-9Mbps but that depend on your environment, how many others using in your region.
    You always get faster speed with stockfirmware. Btw there is some new build in Fractals post in DD-WRT forum to test if you want.

  3. ReDaLeRt

    ReDaLeRt Networkin' Nut Member


    Test the 15508M Eko NEWD-2 build. Maybe there is any solved bug on your firmware build.

  4. mito

    mito Network Guru Member

    Hi, before all i tested dd-wrt firms on my RT-N16 but lost conecton many times a day , all of them for me were slower and than stock firm but it had crappy behavior, later on tested Toastman's and since then i stay with it, in my signature you can check that i have different routers with the firmware that i found works best for my needs, for example for my WRT600N there is nothing better than EKO's.
  5. lancethepants

    lancethepants Network Guru Member

    Just to clarify, Toastman mod is a TomatoUSB firmware, and I also highly recommend it. I also run the rt-n16 and easily get my 12 Mbps connection, though as kthaddock mentions, it should be capable up to 100Mbps.
  6. Tichie

    Tichie Networkin' Nut Member

    Hi Guys Thanks I have been running tomato and had no single Issue At all. Looks like tomato is the best that works for me.
  7. mito

    mito Network Guru Member

    Editing my earlier post, currently i am giving a try to Shibby's as it is a different Tomato flavor that may fill my needs. As every Tomato, it is running fantastic.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice