Asus RT-N53 + Shibby's 115 USB N53 image: poor wireless performance

Discussion in 'Tomato Firmware' started by rabbit_ears, Dec 15, 2013.

  1. rabbit_ears

    rabbit_ears Reformed Router Member

    Just flashed RT-N53 A1 with Shibby's 115 USB N53 image after a long day of trying (Asus restoring utility doesn't recognize the device in restore mode; BCM CFE mini browser worked after a couple of attempts to counter the timeout.). I am new to Tomato and need some help with the wireless performance: the 2.4GHz only gets 1-2 Mbps and 5GHz is decent at ~30Mbps (the latest stock firmware can do ~55Mbps on both bands, but, tends to lock up after 4-5 days of use). I've used the default settings and the only changes are related to security (WPA2 Personal, AES).
  2. Mate Rigo

    Mate Rigo Networkin' Nut Member


    I have a Asus RT-N53 A1, A1 stands for revision.
    My experience is, using Shibby build 115 N53 is that 2.4GHz Wifi only works correctly using the 802.11g standard. When I use 802.11n only, then some of my device perform very poor, such as my Xperia Android mobile, which gets download rates only up to 30 kByte/s.
    I did try various options, such as tweaking the radio power, using different channels, and so on. The only thing that works proper for the 2.4 radio, is using "Wireless Network mode G Only".

    There is however another problem I experienced.
    There seems to be some sort of memory problem, where I will get random restarts, where afterwards the 5Ghz radio won't restart correctly (I guess the unexpected reset will not reset the 5GHz radio's circuitry properly). Thus I have to make a manual reboot after that.

    I edited this: 2014.01.05
    The soultion did not work afterall.
    I am now running Victek's: Tomato RAF Firmware v1.28.9013 MIPSR2-RAF-V1.2x K26 USB RT-N53, no restarts after 5 days
    My solution to this was found in here:
    What I did is:

    I wrote the following:

    echo 1448 > /proc/sys/vm/min_free_kbytes

    In the Administration/Scripts/Init

    Now I am up and running since ~3 days, which is a record for me :)

    I am running QOS, and an OpenVPN server.

    I am planning to make a more detailed explanation about my router's sudden restarts, I just wanted to answer quickly.
    Last edited: Jan 5, 2014
  3. rabbit_ears

    rabbit_ears Reformed Router Member

    Thx for the tip. After changing to "G only" for 2.4GHz, the performance is much improved to around 12Mbps, which is still low in comparison to 5GHz (20Mbps) and modem speed of 50+Mbps. I am just running the default settings, nothing special.
  4. Mate Rigo

    Mate Rigo Networkin' Nut Member

    I just did a testing using various settings.
    I used the Netio software for this.

    The server was connected with a LAN cable to the router, while on the other side I have a win7 laptop with an Intel Advanced-N 6235 card.
    To be honest there was no big difference between the 2.4GHz, and the 5GHz performance.

    However I also tested using my android phone, where I experienced a 10x performance increase using the G only setting, as I previously mentioned. In this test, I simply downloaded a huge app from the Play Store, and watched the realtime bandwidth monitor in Tomato.

    I also experienced poor wifi performance with a Nexus 7.

    I think this problem also existed on the previous builds. (I am using shibby build since v113)
  5. rabbit_ears

    rabbit_ears Reformed Router Member

    I suspect the performance issue is partly due to the lack of newer BCM drivers used by Asus. Just wondering if anyone has tried Tomato with the newer drivers.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice