ASUS RTN-16 automatically powers down shortly after boot

Discussion in 'Tomato Firmware' started by phykris, May 15, 2013.

  1. phykris

    phykris LI Guru Member

    I had a problem with my ASUS RTN-16. It would automatically power down about 5 to 6 seconds after boot. I used Toastman firmware. The router would power down at more or less a random time.

    Sometimes it took 5 seconds, sometimes 5.5 seconds. So, I thought it might be a hardware problem. I opened the router (you've to take the rubber feet away, and you'll see the screws).

    There is a 680uF, 16V Taiwanese electrolytic capacitor (brand HERMEI) near the power supply connector that looked very much like it exploded. I replaced it with something I had at home (470uF, 25V) and now it's working fine again.

    I wrote this post to help others (that use google) and that may encounter the same problem.

    The ASUS RTN16 is an extremely stable device when running toastman 's software, the first real problem I had with it, is this hardware problem.
  2. Toastman

    Toastman Super Moderator Staff Member Member

    Following your useful post, I thought it would be useful to add that electrolytic capacitors are used in all home routers, and usually last 3 years or so before either swelling up and exploding, or drying out and losing their capacity.

    I have many hundreds of WRT54GL's, some of which date right back to the first models, and never had any failures. Recently, however, they started to become unreliable. Rather than replace the whole lot with new AP's, I replaced all of the capacitors and the flash chips (which are also close to their erase limits, I believe). I did the same with all ADSL modems.
  3. phykris

    phykris LI Guru Member

    How did you get the bootloader into the flash chips? Aren't this SMDs? (on bord with JTAG or an external programmer?) Must be not so easy to replace them by hand.

    I am a bit surprised that the flash chips are nearing their end of life. Does tomato write statistics or DHCP records to flash? I am a bit worried that DHCP records are stored in flash, so for every new device that goes online one flash write cycle is lost...?

    Suppose the records are written daily for each of 100 devices, you would get 1*365*100 = 36500 cycles per year. After 3 years your flash might be nearing end of life....

    Until now I didn't notice any flash problems, but I've much less users than you, which might mean the problem is related to the number of users (and thus DHCP).

    This ASUS router was used just a bit older than 1 year. The purple little HERMEI elcos are known for their bad quality. Too bad ASUS chose for this brand.

    The quality of the ELCOs has gone down together with their size. 25 years ago, when they were still produced outside China, they used to much bigger and better.
  4. Toastman

    Toastman Super Moderator Staff Member Member

    You can replace these chips by hand with quite rudimentary tools if you are used to working on SMD components, but you wouldn't want to do many of them, that's for sure. I actually found a guy who does this professionally, he had better tools and was able to do it in his free time (when his boss was on holiday). Easier to copy the chips with a real copier. There may have been no need to replace the flash, it's just done to put these routers into a real refurbished condition.
  5. phykris

    phykris LI Guru Member

    Ok, again a problem with this asus rtn-16 router. 2 of the 4 LAN ethernet ports just have given up. I can't get any physical connection on them (LED doesn't go on when I plugin the ethernet cable). This router is less than 2 years old. Anyone knows how to fix this?

    PS. all other routers I have are linksys, never had any problem. This is my first asus router.
  6. koitsu

    koitsu Network Guru Member

    There are many people on this forum who use Asus RT-N16 routers with success -- I myself am one of them. And I've had 3 of them in my lifetime, with no problems with any of them.

    Hardware goes bad universally. There is nothing "brand-specific" about hardware going bad. People have had all sorts of Linksys-brand routers go bad too due to overheating (particularly their Exxxx series, where the ventilation slits are on the bottom of the router, roughly 4mm from the floor -- absolutely hilarious).

    In your case, you admit clearly the following:

    Because of the nature of this, any/all chips, circuitry, or other analog (or digital) components on the router could be damaged or malfunctioning. You could have a chip consisting of ten thousand transistors, where one transistor intermittently fails. All of these chips have one thing in common: they're powered by a power supply/transformer that downsteps everything into lower voltages (and DC of course). If that PSU or related power circuitry explodes or "goes wonky", the underlying chips could have potentially gotten higher amounts of voltage and been damaged. That includes the Ethernet switching IC, but could also be affecting the SoC.

    My advice to you: RMA the router with Asus directly, or get yourself a replacement RT-N16 and see if you can reproduce the problem (my guess is you won't be able to given the nature of what's transpiring).

    Good luck and let us know how things turn out.
  7. Victek

    Victek Network Guru Member

    Switch block is a passive component (isolation transformers per each socket) connected also through capacitor (high pass filter) to switch chipset (U22), if two of LAN lines works OK then it's possible your switch block is damaged by some over voltage at the LAN side (sometimes PoE with wrong wiring), nevertheless test following voltages on board:

    F3 - 12 Volts.
    F1-F2 - 5 Volts
    D3 (Anode) 3.3Volts
    Q2 in Emitter (right of Switch chipset BCM53115SKFBG (U22)) 2.5 Volts.
    U3 (Watchdog) pin 8 1.2Volts.

    If the voltages are OK then probably your switch block is damaged. I discard U22 (switch chipset) due to transformer and ceramic capacitor isolation.
    pharma and Monk E. Boy like this.
  8. HunterZ

    HunterZ Network Guru Member

    Sorry for the necro, but I'm curious as to whether to OP or anyone else has managed to repair or RMA their RT-N16 with this problem.

    I received an RT-N16 in mid-2012 and had been using it as my primary home router with great success, having flashed Toastman's Tomato builds on it.

    One or two nights ago, however, I noticed that it was mysteriously powered down. I pulled the power connection and restored it, and it booted back up. This morning I woke up and noticed that it was again powered down, but this time the lights would stay on for only a second (at first, and gradually even shorter each time until it now sometimes doesn't light up at all). I am convinced that this is a hardware problem because I hadn't changed its configuration for quite some time.

    I'm thinking of trying to RMA since Newegg says it's supposed to have a 2-year manufacturer warranty. If that doesn't work out then I may also take a screwdriver and a soldering iron to it.

    I've now replaced it with a new Asus RT-N66U (which is also now running Toastman's Tomato with as similar of settings as I could manage, given that my last human-readable NVRAM settings dump was from mid-2013), but the RT-N16 would still be quite useful to me as a second wireless AP and/or gigabit ethernet switch if I can get it working again (I would possibly be able to finally retire my trusty old WRT54g that I've been using in one capacity or another for the past 7-8 years).
  9. lefty

    lefty Addicted to LI Member

    Not sure if you have tried it already but it may be helpful to try a new/different power supply. Just make sure it matches your volts/amps and you should be ok.
  10. HunterZ

    HunterZ Network Guru Member

    Oh yeah, thanks for reminding me to mention that: I did in fact try a spare power supply with the exact same specs as the one that came with the RT-N16, but it didn't help.
  11. Victek

    Victek Network Guru Member

  12. HunterZ

    HunterZ Network Guru Member

    Called up Asus this morning and was blown away when they gave me an RMA quickly and without hassle. It probably took longer to navigate their phone tree than to talk to the customer service rep! Now I just need to get it shipped off to California to actually get repaired/replaced.
  13. phykris

    phykris LI Guru Member

    I just took another look on this old post and did a google search. I can find a lot of posts defining exactly the same problem, which also occurs at other ASUS models.

    ASUS seems to have chosen to go for low quality capacitors.

    I live in Thailand, customer service is probably not at the same level as in the USA. Sent an e-mail to ASUS, never got a reply.

    (I think was my first and last ASUS router.)

    At this moment I am looking for cheap but reliable routers, which will be used as access points (only). They should support wireless-n and have good range. They should support tomato (any minimal toastman build).
  14. HunterZ

    HunterZ Network Guru Member

    I didn't have any luck with their email support either, but had a surprisingly good experience with their phone support.
  15. n4mwd

    n4mwd Serious Server Member

    I just wanted to break my silence is give a big thanks to the OP for posting this solution. My RT-N16 just blew out this morning and powered down after a few seconds. I replaced the cap with a 1000uf cap and all is well for the time being. I couldn't clear the original cap holes so I used a tiny PCB drill bit to drill them clear. I hope I don't regret doing that.

    I see the OP had additional problems a few months later. I hope he was able to fix the problem again. If so, I hope he will chime in and explain.

    I purchased mine on 2/24/13 and today is 9/8/14 so its about a year and a half old. I'm wondering if I have additional problems like the OP did if I can still RMA it back to ASUS given that I kinda flashed it with Toastman Tomato and also put a different cap in there? Someone said it had a 2 yr warranty, but I'm not seeing anything about that.

    Again, thanks for the informative post because keeping this router up and running is very important since it runs my asterisk phone system and I don't get any phone calls without it. Total down time was only about an hour.
  16. HunterZ

    HunterZ Network Guru Member

    I was able to RMA mine a couple months ago, almost 2 years after buying it. They didn't ask any questions other than about the failure mode. It had Toastman on it as well, but I didn't tell them that and they didn't ask.

    The self-repair may invalidate the warranty. That's why I tried for (and got) the RMA first, which resulted in me getting a new (or possibly refurbished) unit covered by the original warranty term (meaning it's probably expired now). The replacement unit has Toastman on it and is still working fine.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice