ASUSWRT Merlin Build 384.5 or later ON Linksys EA6900 or EA6700

Discussion in 'Other Firmware Projects' started by Starbuck99, Jun 26, 2018.

  1. apvmtan

    apvmtan Serious Server Member

    Code:
    sromrev=8
    boardnum=00
    boardtype=0x0646
    boardrev=0x1103
    boardflags=0x00000110
    boardflags2=0x00000000
    xtalfreq=25000
    clkfreq=800,666
    reset_gpio=11
    gpio9=usbport1
    sdram_config=0x0149
    et0mdcport=0
    et0phyaddr=30
    et0macaddr=94:10:3E:86:05:E7
    vlan1ports=1 2 3 4 5*
    vlan1hwname=et0
    vlan2ports=0 5u
    vlan2hwname=et0
    landevs=vlan1 wl0 wl1
    wandevs=et0
    lan_ipaddr=192.168.1.1
    lan_netmask=255.255.255.0
    gpio7=wps_button
    gpio10=usbport2
    boot_wait=on
    wait_time=1
    watchdog=2100
    ctf_fa_cap=0
    devpath0=pci/1/1
    0:venid=0x14E4
    0:sromrev=11
    0:boardflags=0x00001000
    0:boardflags2=0x00100002
    0:boardflags3=0x00000003
    0:xtalfreq=40000
    0:devid=0x43A1
    0:macaddr=94:10:3E:86:05:E7
    0:aa2g=7
    0:agbg0=0
    0:agbg1=0
    0:agbg2=0
    0:txchain=7
    0:rxchain=7
    0:antswitch=0
    0:femctrl=3
    0:gainctrlsph=0
    0:papdcap2g=0
    0:tworangetssi2g=0
    0:pdgain2g=4
    0:epagain2g=0
    0:tssiposslope2g=1
    0:rxgains2gelnagaina0=6
    0:rxgains2gelnagaina1=6
    0:rxgains2gelnagaina2=6
    0:rxgains2gtrelnabypa0=1
    0:rxgains2gtrelnabypa1=1
    0:rxgains2gtrelnabypa2=1
    0:rxgains2gtrisoa0=13
    0:rxgains2gtrisoa1=13
    0:rxgains2gtrisoa2=13
    0:maxp2ga0=106
    0:maxp2ga1=106
    0:maxp2ga2=106
    0:pa2ga0=0xff34,0x19cd,0xfccc
    0:pa2ga1=0xff38,0x1966,0xfce7
    0:pa2ga2=0xff38,0x1991,0xfcdd
    0:cckbw202gpo=0
    0:cckbw20ul2gpo=0
    0:mcsbw202gpo=0x75310000
    0:mcsbw402gpo=0x75310000
    0:dot11agofdmhrbw202gpo=0x0000
    0:ofdmlrbw202gpo=0
    0:sb20in40hrpo=0
    0:sb20in40lrpo=0
    0:dot11agduphrpo=0
    0:dot11agduplrpo=0
    0:pdoffset2g40ma0=0x8
    0:pdoffset2g40ma1=0x8
    0:pdoffset2g40ma2=0x8
    0:rpcal2g=0xffff
    0:ccode=#a
    0:regrev=0
    0:sar2g=24
    0:ledbh10=7
    devpath1=pci/2/1
    1:venid=0x14E4
    1:sromrev=11
    1:boardflags=0x30000000
    1:boardflags2=0x00300002
    1:boardflags3=0x0
    1:xtalfreq=40000
    1:devid=0x43A2
    1:macaddr=94:10:3E:86:05:EB
    1:aa5g=7
    1:aga0=0
    1:aga1=0
    1:aga2=0
    1:txchain=7
    1:rxchain=7
    1:antswitch=0
    1:femctrl=3
    1:subband5gver=4
    1:gainctrlsph=0
    1:papdcap5g=0
    1:tworangetssi5g=0
    1:pdgain5g=4
    1:epagain5g=0
    1:tssiposslope5g=1
    1:rxgains5gelnagaina0=2
    1:rxgains5gtrelnabypa0=1
    1:rxgains5gtrisoa0=7
    1:rxgains5gmelnagaina0=2
    1:rxgains5gmtrelnabypa0=1
    1:rxgains5gmtrisoa0=7
    1:rxgains5ghelnagaina0=3
    1:rxgains5ghtrelnabypa0=1
    1:rxgains5ghtrisoa0=8
    1:rxgains5gelnagaina1=2
    1:rxgains5gtrelnabypa1=1
    1:rxgains5gtrisoa1=9
    1:rxgains5gmelnagaina1=2
    1:rxgains5gmtrelnabypa1=1
    1:rxgains5gmtrisoa1=7
    1:rxgains5ghelnagaina1=3
    1:rxgains5ghtrelnabypa1=1
    1:rxgains5ghtrisoa1=7
    1:rxgains5gelnagaina2=2
    1:rxgains5gtrelnabypa2=1
    1:rxgains5gtrisoa2=8
    1:rxgains5gmelnagaina2=2
    1:rxgains5gmtrelnabypa2=1
    1:rxgains5gmtrisoa2=7
    1:rxgains5ghelnagaina2=3
    1:rxgains5ghtrelnabypa2=1
    1:rxgains5ghtrisoa2=8
    1:maxp5ga0=106,106,106,106
    1:pa5ga0=0xff15,0x1b55,0xfc9d,0xff14,0x1b18,0xfca2,0xff1a,0x1b5c,0xfc9d,0xff1b,0x1af0,0xfcaa
    1:maxp5ga1=106,106,106,106
    1:pa5ga1=0xff13,0x1b41,0xfc9f,0xff14,0x1b85,0xfc97,0xff17,0x1b50,0xfc9e,0xff19,0x1b38,0xfca2
    1:maxp5ga2=106,106,106,106
    1:pa5ga2=0xff12,0x1b8f,0xfc96,0xff12,0x1b97,0xfc95,0xff16,0x1bd6,0xfc91,0xff15,0x1b80,0xfc98
    1:pdoffset40ma0=0x0
    1:pdoffset40ma1=0x0
    1:pdoffset40ma2=0x0
    1:pdoffset80ma0=0x0000
    1:pdoffset80ma1=0x0000
    1:pdoffset80ma2=0x0000
    1:mcsbw205glpo=0xCA864200
    1:mcsbw405glpo=0xCA864200
    1:mcsbw805glpo=0xCA864200
    1:mcsbw1605glpo=0
    1:mcsbw205gmpo=0xCA864200
    1:mcsbw405gmpo=0xCA864200
    1:mcsbw805gmpo=0xCA864200
    1:mcsbw1605gmpo=0
    1:mcsbw205ghpo=0xCA864200
    1:mcsbw405ghpo=0xCA864200
    1:mcsbw805ghpo=0xCA864200
    1:mcsbw1605ghpo=0
    1:mcslr5glpo=0
    1:mcslr5gmpo=0
    1:mcslr5ghpo=0
    1:sb20in40hrpo=0
    1:sb20in80and160hr5glpo=0
    1:sb40and80hr5glpo=0
    1:sb20in80and160hr5gmpo=0
    1:sb40and80hr5gmpo=0
    1:sb20in80and160hr5ghpo=0
    1:sb40and80hr5ghpo=0
    1:sb20in40lrpo=0
    1:sb20in80and160lr5glpo=0
    1:sb40and80lr5glpo=0
    1:sb20in80and160lr5gmpo=0
    1:sb40and80lr5gmpo=0
    1:sb20in80and160lr5ghpo=0
    1:sb40and80lr5ghpo=0
    1:dot11agduphrpo=0
    1:dot11agduplrpo=0
    1:rpcal5gb0=0xffff
    1:rpcal5gb1=0xffff
    1:rpcal5gb2=0xffff
    1:rpcal5gb3=0xffff
    1:ccode=#a
    1:regrev=0
    1:sar5g=20
    1:ledbh10=7
    bl_version=1.1.2.0
    bootflags=1
    secret_code=12345670
    odmpid=RT-AC66U_B1
    model=RT-AC68U
    ATEMODE=1
    HW_ver=1.90
    PA=5003
    nospare=1
    cpurev=c0
    94:10:3E:86:05:E7 +4 is 94:10:3E:86:05:EB https://www.tkcomputerservice.com/hexadecimal_conversion_chart.htm#close

    At the top is what my asus cfe looks like (I have changed my mac address to yours, the one I uploaded has my mac address) hope this help.
     
    Stimpy88 likes this.
  2. gametx

    gametx New Member Member

  3. ymom411

    ymom411 Reformed Router Member

    Thanks guys. So now I have ruled out that I had a bad MAC address. That gives me hope.

    Tonight I'll see if the router accepts the Brainslayer FW so I can start from the beginning. I'll post back with the results.
     
  4. apvmtan

    apvmtan Serious Server Member

    This is what I did after I uploaded the Asus cfe with Brainslayer FW still within the modem. I turned off the ea6900 and unplugged it, I hold the red reset button with a pin and then turn the ea6900 on, the Linksys LED should light up and eventually turn off and after about 20-30 or maybe more seconds it will turn back on again, release the reset key. I use ASUS Firmware Restoration version 2.0.0.0. from windows to flash asus merlin firmware.
     
  5. ymom411

    ymom411 Reformed Router Member

    Tried this again and before I started I confirmed that the vortex CFE is loaded with the correct MAC addresses and the the router is running vortex ea6900 380.70.

    No matter what I do the router will not accept the Brainslayer FW. I've also tried to re-upload vortex ea6900 380.70. For both I get an "invalid image" error. For Brainslayer I am using linksys-ea6900-webflash.bin and for Vortex I am using the TRX file. If I try to upload via the CFE recovery page, I get a "timed out" message error.

    I'm at a loss as to what to do next, but at least the router is running with the vortex FW.
     
  6. gametx

    gametx New Member Member

    Take the cfe.bin that's been uploaded for you in post #101.

    Use WinSCP to copy the .bin file and mtd-write (511 kb version from here https://github.com/RMerl/asuswrt-merlin/blob/master/release/src/router/rom/cfe/mtd-write) to /home/root.
    Run in ssh on the same directory 'chmod u+x mtd-write' and then './mtd-write new_cfe.bin boot' and 'reboot'. Then do 'mtd-write2 FW_RT_AC68U_30043763626.trx linux' (or the newer one, or Merlin's) and reset nvram. You'll have it running in no time (+ 3 minutes) - and from there you'll be able to change the firmware as you wish from the webui.
     
  7. ymom411

    ymom411 Reformed Router Member

    Can't thank you enough for your patience and help. I managed to load vortex 384.6 on the router. All my attempts to load an ASUS firmware failed with a "bad trx header" error. I'll try again tomorrow after I get some sleep.
     
  8. Zoltrix

    Zoltrix Network Newbie Member

    Thanks for the help. I totally misunderstood what the instructions meant regarding the mac address side of things. I've now added those correct mac addresses to my new-cfe.bin file.

    But I don't know how to apply those changes now that I am running the AdvancedTomato firmware? If I use the "mtd unlock /dev/mtd0" command it gives me an error.
     
  9. Starbuck99

    Starbuck99 Network Newbie Member

    Anyone having trouble installing latest firmware, follow post #101 from gametx
    The easiest least problematic way of updating either firmware or the CFE is using mtd-write
    This can unfortunately only be done from within either some version of Merlin or the official ASUSWRT firmware.
    Mtd-write doesn't work properly in either tomato or dd-wrt.
     
  10. Zoltrix

    Zoltrix Network Newbie Member

    Hey mate, do you mean post 106? Thie info below? How do you get the Merlin or the official ASUSWRT firmware installed when running tomato?

     
  11. apvmtan

    apvmtan Serious Server Member

    you need to add a file call mtd-write to the same place with your new cfe in order to upload it or you have to go back to the older ddwrt which has the file embedded.
     
  12. apvmtan

    apvmtan Serious Server Member

    The easiest way is to flash the older ddwrt firmware that cybrnook provided in his original thread, I think the other guy's thread has it for download and update cfe with that version of ddwrt.

    The other way is to download a file call mtd-write and put it in the same location with the new cfe and update it. I think newer ddwrt, tomato, Asuswrt etc don't have that file thus the error.

    I have a mtd-write dated back 2011 and I used it to flash a revised vortex cfe when I had a version of vortex asuswrt on my ea6900. (thanks to cybrnook)

    Also for tomato and Asuswrt, the location is no longer at /tmp/root but /tmp/home/root (I think that is the right path if memory serves me right).

    Update, refer to post #38 of the following thread if you have tomato or asuswrt and you want to update your cfe from there https://www.linksysinfo.org/index.php?threads/discontinuing-this-guide.71718/
     
    Last edited: Sep 25, 2018
  13. Zoltrix

    Zoltrix Network Newbie Member

    Thanks for the help Starbuck99 and apvmtan. So I can leave tomato running and use the mtd-write tool? Just upload it to /tmp/home/root and run these commands? "Run in ssh on the same directory 'chmod u+x mtd-write' and then './mtd-write new_cfe.bin boot' and 'reboot'."
     
  14. apvmtan

    apvmtan Serious Server Member

    Yes, you can leave tomato running but please read post #38 of the following thread if you have tomato or asuswrt and you want to update your cfe from there https://www.linksysinfo.org/index.php?threads/discontinuing-this-guide.71718/

    You need to download the proper mtd-write from link on that post.
     
  15. Zoltrix

    Zoltrix Network Newbie Member

  16. Zoltrix

    Zoltrix Network Newbie Member

    ah no go... got the following error

    Code:
    root@unknown:/tmp/home/root# ./mtd-write -i new-cfe.bin -d boot
    ./mtd-write: can't load library 'libdisk.so'
    
     
  17. apvmtan

    apvmtan Serious Server Member

    My mtd-write file is 77kb in size. Bear in mind I used it with vortex merlin firmware on my ea6900 and vortex cfe.

    upload the mtd-write to the same directory as your new-cfe.bin

    SSH to your router then do the following command one by one.



    cd /tmp/home/root

    ls
    (make sure all the files are there)

    chmod +x mtd-write

    mtd unlock /dev/mtd0

    mtd write -f new-cfe.bin mtd0


    I'll try to test it with merlin firmware on my router and see if I have the same error when I have some time in the afternoon and report back.
     
  18. Zoltrix

    Zoltrix Network Newbie Member

    The mtd-write file I got from jernau's CFETOOLS.zip is 717kb, and the one from github is 512kb...
     
  19. Zoltrix

    Zoltrix Network Newbie Member

    Heya... latest output below

    Code:
    root@unknown:/tmp/home/root# ls
    mtd-write    new-cfe.bin
    root@unknown:/tmp/home/root# chmod +x mtd-write
    root@unknown:/tmp/home/root# mtd unlock /dev/mtd0
    -sh: mtd: not found
    root@unknown:/tmp/home/root#
    
     
  20. Zoltrix

    Zoltrix Network Newbie Member

    Can I switch back to dd-wrt just by using the upgrade option in tomato? And then do the mtd-write?
     
  21. apvmtan

    apvmtan Serious Server Member

    You are right, it was 717kb, my eyes are failing me. Do you have vortex cfe on it now? you should be able to flash back to ddwrt from tomato if you do but you need to do a reset afterwards by pressing the wpa button until the linksys logo starts flashing.

    Personally, I use Asus recuse utility to upload different firmware. Was busy yesterday but will try to test this afternoon and see.
     
  22. Zoltrix

    Zoltrix Network Newbie Member

    Not sure about the vortex cfe. I used the cfe from here https://userscloud.com/nmncz3kl7ra7 that was provided as part of the instructions here http://www.linksysinfo.org/index.ph...n-ea6900-v1-v1-1-without-32k-bug-renew.74084/

    If Asus rescue is the preferred way, are the instructions here accurate? https://www.asus.com/au/support/FAQ/1000814/

    Can you use that to flash ddwrt?
     
  23. apvmtan

    apvmtan Serious Server Member

  24. Zoltrix

    Zoltrix Network Newbie Member

    Thanks again for your help. Using the Asus utility I got the ddwrt firmware back on. Then I updated the cfe file with the correct MAC addresses, etc.

    I then flashed tomato back on. Then tried to put the official Asus firmware back on again. Which didn't work. I'm guessing maybe this guide doesn't work for v1.1 Australian versions of the EA6900.
     
  25. cybrnook

    cybrnook Addicted to LI Member

    Why do you keep bouncing back to tomato?

    Just flash the new CFE, boot into recovery web server, upload Merlin, and then hold the WPS button during the first cold boot to wipe nvram, done.
     
  26. apvmtan

    apvmtan Serious Server Member

    If you have Asus cfe already and can not boot into recovery web server, use Asus utility to flash Merlin or official asus firmware. I don't know which Tomato you flashed but if you flashed ea6900 tomato, it may cause some problem but either recovery web server or Asus utility will fix it.
     
  27. Zoltrix

    Zoltrix Network Newbie Member

    The original instructions say to flash to tomato before flashing to the official Asus firmware. It also says to install the official Asus firmware before installing Merlin.

    Are you saying you can go straight from ddwrt/mini webserver to Merlin?
     
  28. cybrnook

    cybrnook Addicted to LI Member

    You can go from the webserver to whatever you really want :) just wipe nvram after the flash.
     
  29. Zoltrix

    Zoltrix Network Newbie Member

    Cool thanks for the tip. Is there a particular Merlin version I should use? Eg the one for ASUS RT-AC68U?
     
  30. cybrnook

    cybrnook Addicted to LI Member

    Only one version you can use.... RT-AC68U
     
  31. Zoltrix

    Zoltrix Network Newbie Member

    Just flashed Merlin using the mini webserver and after clearing the NVRAM, Tomato came up lol wtf
     
  32. Zoltrix

    Zoltrix Network Newbie Member

    I..... don't..................... believe it..............................
     

    Attached Files:

    • yay.JPG
      yay.JPG
      File size:
      105.1 KB
      Views:
      28
  33. sohouser

    sohouser New Member Member

    Finally after several attempts asus firmware is running on my router. its been running stable for the last 6 hours. Temp is high ~80C but checking on other forums it seems okay. Thanks
     
    Last edited: Sep 30, 2018
  34. baani59

    baani59 Reformed Router Member


    How did you resolve this problem?
     
  35. Zoltrix

    Zoltrix Network Newbie Member

    I ended up using the Asus rescue utility to go back to ddwrt, and then reapply the cfe file. What firmware are you currently on?
     
  36. baani59

    baani59 Reformed Router Member

    I am on Xwrt 380.69.
    According #125 - "Just flash the new CFE,..."

     
  37. Zoltrix

    Zoltrix Network Newbie Member

  38. baani59

    baani59 Reformed Router Member

    Thank you.
    I'll try it next week. My wife is away. :D
     
    Zoltrix likes this.
  39. Zoltrix

    Zoltrix Network Newbie Member

    ;)
     
  40. bzbeer

    bzbeer New Member Member

    Hi, first post here. Thanks for all the information & guides.

    I flashed my EA6900 to Xwrt-Vortex (followed the guide by @cybrnook) about two years back. Been using it without any issues and am currently on FW 380.70.0 (the latest release). Since it will not be getting any further updates, I want to flash it with the official Asus RT-AC68U firmware on my EA6900 (am interested in the AiMESH feature).

    So, my question is, to move from XVortex 380.70.0 to offical Asus FW, what steps do I follow?

    Since I already have SSH & Telnet enabled, can I just get the nvram and stock-cfe.bin and start from there?
    OR do I need to use Asus Rescue Tool to flash BrainSlayer's DD-wrt version and start from there?
    OR is there a simpler process?

    Sorry if I seem to be repeating the same question again. I've read all the posts several times - been here for a couple of hours now but I just seem to be missing some key element. The posts #125 and #137 seem to have the answer but it is eluding me.

    I'd appreciate if someone can explain the steps in a bit more detail for me. Thanks
     
  41. cybrnook

    cybrnook Addicted to LI Member

    Post #28 has the CFE you want (B1). Download that, use the CFE Edit tool to add in the basic values we need, mac addresses, secret key, then flash.

    When you reboot, you would use the recovery webserver at least for the initial flash. Once flashed, hold the WPS button during first boot to wipe/reset your nvram and reload from the new values.
     
    bzbeer likes this.
  42. bzbeer

    bzbeer New Member Member

    Thank you for the reply.
    I downloaded the B1 firmware and will try it this evening.
    I will post an update..... Hope everything goes well.
     
  43. cybrnook

    cybrnook Addicted to LI Member

    I want to make sure I was clear, and not assuming.

    You are going to make your cfe using the cfe editor. Then you will flash that CFE from the OS of your current build using the uploaded mtd-write you will need to upload.

    Once the CFE is flashed, you reboot in recovery webserver and flash your latest Merlin build. Once done, shut it down, and then hold WPS on first boot to wipe nvram.
     
  44. bzbeer

    bzbeer New Member Member

    Thanks for clarifying. Yes, that is what I understood.

    So, I was at it for about 2 hours this night and failed to even start the update.

    First, I tried to flash brainslayer's dd-wrt firmware without any success. I followed the steps and the light was flashing but the Asus Restore utility kept saying that the "Router is not in rescue mode".

    After struggling with that for an hour I gave up on that and tried to see if I can update the CFE directly. While SSH worked fine, WinSCP wouldn't connect. I figured SFTP is not available on the XVortex fw, so tried to use PSCP instead to copy the files but that too didn't work. And I stopped trying after an hour.

    So, 2 hours of effort and I didn't advance a single step - am exactly where I was when I started :mad:

    I have a TM-1900 coming in tomorrow and will do that first before attempting the EA6900 again.
     
  45. Zoltrix

    Zoltrix Network Newbie Member

    Anyone having issues with Merlin reliably working? I did have it working. Now won't boot into Merlin anymore, just the mini webserver recovery page.
     
  46. bzbeer

    bzbeer New Member Member

    I gave it another go today morning and SUCCESS!!
    My EA6900 is now running the latest RT-AC68U firmware (Version 3.0.0.4.384.32799).

    Here are the steps I followed:
    - The EA6900 (v1.1) was running Xwrt-Vortex FW ver 380.70. First I reset it to factory defaults and turned it off.
    - Set my PC IP address to 192.168.1.2 and connect the router via network cable.
    - Restarted the router in "Rescue Mode". (I figured out what I did wrong yesterday, I was waiting too long to let go of the reset button, held it pressed for more than 15 secs. It worked if I let go after 10 secs).
    - Used the Asus Firmware Restoration utility to flash Brain Slayer's dd-wrt FW.
    - Restarted the router and enabled SSH & Telnet. Was now able to connect with Putty & WinSCP.
    - Opened the "cfe_ac66u_b1_1.1.2.0.bin" (from post #28, thanks @Starbuck99) in the CFEEdit tool and changed four values for et0macaddr, 0:macaddr, 1:macaddr and secret_code to match my router's values.
    - Saved it as new-cfe.bin, uploaded it to the router and flashed it using mtd (as per instructions)
    - Powered off the router and restarted it in rescue mode to get the 'CFE miniWeb Server' page. Tried to flash the RT-AC68U firmware through that but it just hung for a while and timed out. Tried it four times with same result.
    - So the next time, I restarted the router in the rescue mode but instead of the miniWeb Server, I used the Asus Firmware Restoration utility to flash the firmware. It worked on the first try. Upload was a bit slow, but it completed and verfied successfully.
    - Powered off the router and restarted it with the WPS (blue) button pressed to clear nvram. Held it pressed for about 30 secs after power on and the released it. But no web-gui, waited 3 minutes and restarted the router but still no web-gui.
    - I was about to restart it again when I noticed that he LAN port light was blinking rapidly indicating some traffic. So I left it like that and went and did something else. I came back after 30 mins and hit refresh and finally got the Asus Quick Wizard page. Yay :D

    Whole process took about an hour. All options seem to available, but time will tell if they all work and how stable it will be. Planning to configure the Ai-Mesh with my TM-AC1900.

    One question - any reason why we are using the RT-AC66U CFE instead of RT-AC68? The web-gui also says RT-AC66U-B1. Would be nice if it can say Rt-AC68U.
     
  47. cybrnook

    cybrnook Addicted to LI Member

  48. bzbeer

    bzbeer New Member Member

    You know, I did see that post yesterday but it didn't register at all.... it was all greek & latin to me :p
    But reading it now makes sense. Hey, that's a clear measure how much I've learnt in one day!

    On a side note, I am unable to get the AC68U router (modified TM-AC1900) see the EA6900 as AiMESH node. I have another TM-AC1900 and it was found and configured as a node after couple of tries. But the EA6900 is not being found no matter how many times I try. I tired downgrading the firmware to two of the older versions, but still no luck.

    Can anyone confirm that the AiMESH works on the EA6900 with AC68U firmware? If yes, please post the version of firmware you are using. Thanks.
     
  49. cybrnook

    cybrnook Addicted to LI Member

    http://www.linksysinfo.org/index.ph...n-linksys-ea6900-or-ea6700.74209/#post-299084
     
  50. leoncici

    leoncici Network Newbie Member

    This also works exactly the same for the R7000. but when i change the lan ip address, it reboot all the time.
     
  51. leoncici

    leoncici Network Newbie Member

    you used 3 routers for testing AIMESH.and i want to know which is the router ?and whch is the Node?
     
  52. baani59

    baani59 Reformed Router Member

    I flashed my router at the weekend from Xwrt 380.69 to Asus Merlin 384.7 successfully. Many thanks Starbuck99, cybrnook and Zoltrix.

    (I used CFE from #28, but the router's USB3.0 port didn't work. I added a row "gpio10=usbport2" and that's fine.)
     
  53. bzbeer

    bzbeer New Member Member

    Well, after trying several days to get the EA6900 work as an AiMESH node, I gave up. I tried different firmwares, went back to Brainslayer's DD-WRT and re-did all the steps twices just to make sure I didn't miss anything. So while the latest AC68U firmware seems to run fine on the EA6900, I am unable to get it to work as an AiMESH Node.

    Tomorrow I am gonna try and see if it will work as an AiMESH Router and detect the two other TM-AC1900s as AiMESH nodes.
     
  54. bzbeer

    bzbeer New Member Member

    Success!! With the EA6900 as the AiMESH Router, it is able to detect the TM-AC1900 as the AiMESH node.

    Didn't work the first couple of tries, and the GUI was very sluggish and slow to respond to clicks. Reset & reboot didn't have any effect. Then I took the CFE by 'apvmtan' in post #101, changed the mac addresses & secret key to my router's values and flashed that new CFE file (earlier I was using the CFE from post #28). It made a big difference, the GUI is much smmother now and quick to respond.

    I am gonna try using the E6900 as a Node again, hopefully it will work this time.
     
  55. bzbeer

    bzbeer New Member Member

    No luck in getting the EA6900 to be seen as a AiMesh Node. Any idea what I might be doing wrong?

    I have two TM-AC1900s flashed to RT-AC68U firmware. I can setup either of them as the AiMESH Router and it can find the other one as a Node, but cannot find the EA6900 as the Node.

    But if I setup the EA6900 as the AiMesh Router, then it can find both TM-AC1900s as the Nodes.

    Details - EA6900 v1.1, flashed with CFE by user 'apvmtan' in post #101

    I first tried all three with the latest AiMESH firmware version 3.0.0.4.384_32799. Then I found thread in snbforums that said AiMesh is broken after the 21140 version. So I downgraded all three to firmware version 3.0.0.4.384.21140, but it didn't make any difference. I still cannot setup the EA6900 as an AiMesh Node.
     
  56. gametx

    gametx New Member Member

    Alright @bzbeer - let's lighten up the mood of this thread a bit... you have 3 routers -2 T-Mobile Asus routers and one Belksys (EA 6900,) all running some Asus firmware and you can AiMesh them together. Cool!
    Well, what exactly is the reason you want the only non-ASUS router in the group to be the AiMesh router (as opposed to a node?)

    I'm uncertain, as in I can't quantify that, but the amount of radiation through-out the neighborhood would be pretty much the same. To downgrade the firmware just to make that scenario work? Is it worth it?

    There might be a seriously strong reason for which one of the best router firmware around (I mean Merlin's AsusWRT - my opinion) does not support AiMesh - we can debate that without any fruitful results, I guess... But I will always go for the tighter vs. fancier approach to my router's firmware.

    On a slightly different topic, I suggest that once you have your Asus router up an running you may want to consider the goodies at Diversion's (add-blocker) web site. The skynet firewall is a superb add-on and all those bright folks who write those programs (look for 'amtm' - stands for Asus Merlin Terminal Menu) are extremely (as in almost un-believable fast and responsive) to any suggestions/concern with their software.

    Also, I believe that the Merlin/Asus firmware is one of the friendliest VoIP supportive options out there. I'll just add a couple more things here - in my view there is nothing basically wrong with the EA6900 firmware - just more real business oriented with less options...

    ...and as you said - with all these things just taking 30 minutes off will save some time (I don't call it procrastination in this context :))
     
  57. bzbeer

    bzbeer New Member Member

    Thanks for the reply. And yes, that is correct.

    No, I want the non-Asus router (the EA600) to be the node. But for some reason the EA6900 is not getting detected as a Node by either of the TMs. But the EA6900 can detect both TMs as Nodes.

    I've been using a TM router with Merlin FW for about 2 years now and have it all configured and setup exactly the way I want (static IPs, port-forwards, scheduling, parental controls etc). And its been rock solid. Don't want to transfer it to a new unproven router if I can help it.

    I am not really concerned with transmission rates, I am sure it is more or less the same across the three routers. I just want to stick to the router that has proven extremely reliable in the past as the main router.

    I thought Merlin's FW didn't support AiMesh becasue the source is closed and not released to public?

    Perhaps explaining my house layout will help. My house has three levels - basement, ground & upper. The FIOS line comes in at one corner of the basement. That is where I setup my main router. (Or I have to run a cat cable through the walls to get it to the center of the house, which I don't want to do).

    Previously I had the EA6900 with XVortex FW set up as a repeater on the main level. It worked fine for the most part, but it occassionally struggled while streaming HD movies from the Plex server in the basement to the TV in the living room. And coverage on the upper level is about average, and poor in the corner rooms.

    With the AiMesh and three routers, I hoped to cover all three levels with a strong signal and have greater throughput. But so far I am not impressed, the 'mesh' is not seamless and my phone & laptop drop the signal when roaming between different areas of the house and it sometimes takes a couple of minutes to reconnect. It got so annoying that I am now back to the repeater setup.

    Thanks for the info, I will surely check it out.
     
  58. gametx

    gametx New Member Member

    Your layout looks quite similar to what I previously had.
    I also had some issues with connectivity between the floors. What I ended up doing was moving the main router from the corner (provider's point of entry in the basement,) to a more central location (high up on the shelving unit.) I then found an electrician / wire-fisher familiar with my layout (I understand you are reluctant in doing that.)
    For a few dollars he pulled a cable to the upper floor and I connected a router in AP mode. Problem eternally solved at all 3 levels. (BTW those repeater solutions also cut bandwidth in half.)
    But it's all your choice...
     
  59. baani59

    baani59 Reformed Router Member

    On my EA6900 is Asus Merlin 394.7_2 (CFE from this topic #28). Its webgui is slow and 5g wifi is weak, otherwise working properly. With Xvortex 380.69 (and CFE) it was better. I would like to improve the 5g wifi. 1:sar5g=20 -> 15 or ??? (The factory default is 15, maybe) What are your opinions?
     
  60. bzbeer

    bzbeer New Member Member

    Yes, running a cable to the center would be great. But the house layout means that they have to punch holes in at least two places for routing the cable. That is a big no-no from my wife. Maybe I should look at how far they can run the cable without having to make any holes in the walls...

    And yes, I know the repeater mode cuts bandwidth by half... which is why I wanted the AiMesh. Will probably try again this weekend if I have some free time.

    I experienced similar slow Web GUI when using the CFE from post #28. Then I switched to the CFE from post #101 and it fixed the issues. And it also has the recommended(?) values for sar5g, sar2g and other variables.
     
  61. apvmtan

    apvmtan Serious Server Member

    I am having trouble to set up media bridge, I suppose I'll have to flash tomato AC68U firmware with this cfe? TIA
     
  62. argh0815

    argh0815 Serious Server Member

    Is there a specific reason why it's recommended to set ctf_fa_cap=0 in the CFE? This disables Flow Acceleration which interestingly works flawlessly on my EA6900 running XVortex 380.68_4. I'm on Gigabit Fiber and my CPU usage at full download speed never exceeds 10%.
     
  63. bytebitten

    bytebitten New Member Member

    This weekend I manage to install Asus original firmware on my EA6900 using the method described in first post and the CFE from post #28 + #30. The router seems to work fine except for that I can't make the time scheduling work properly (neither Wireless Scheduling nor Time Scheduling in AiProtection->Parental Controls). Anyone experiencing the same problems or have any idea of what can be wrong?

    I also tried the Merlin firmware resulting in the same behavior.

    When setting times for Wireless Scheduling it seems as current state is set when pressing apply but then no more updates according to the schedule are done.
     
    Last edited: Nov 1, 2018
  64. bytebitten

    bytebitten New Member Member

    Has anyone tried to use time scheduling on an EA6900 with Asus (RT-AC68U_3.0.0.4_384) or Merlin (RT-AC68U_384.7_2) firmware? I can't make it work.

    A simple way to test it is to enable wireless time scheduling (wireless->Professional->Enable wireless scheduler) and set the next hour to "off" and wait... My wifi is not turned off during the hours selected.
     
  65. baani59

    baani59 Reformed Router Member

    I think there is a little bit chaos around the CFEs.
    Whatever, I used CFE from #28 with variables from #101.
    I am on Asus Merlin 384.7_2 now. Web GUI is quick and 5g wifi mayby stronger. :)
    CPU Frequency: 800 MHz
    Temperatures: 2.4 GHz-44°C 5 GHz-46°C CPU-52°C with outer ventilator.
    @bytebitten
    I tried the wireless time scheduling, its working.
     
    Last edited: Nov 5, 2018
  66. bytebitten

    bytebitten New Member Member

    @baani59 Thank you for checking, I will give the CFE from #101 a try and see if that makes any difference.
     
  67. Patrick Bergeron

    Patrick Bergeron New Member Member

    I followed all the steps of this thread. Before each step I was reading 2-3 times to make sure. I also had the problem with mtd-write "can't load library 'libdisk.so'" (#116). I decided to use the commands, step 16 of the thread specified at #1. After this step, my router didn't load the CFE miniweb server. It is bricked. I tried everything to bring it back without success. I'm not enough technical to do the serial cable operation. I'm sad it didn't work.

    Do you have an idea what went wrong?
     
  68. baani59

    baani59 Reformed Router Member

    Try the router's rescue mode and the Asus Firmware Restoration utility according #146.
     
    Last edited: Nov 9, 2018
  69. Patrick Bergeron

    Patrick Bergeron New Member Member

    It's not working. The LAN green light is blicking. That's the only sign of life.
     
  70. bytebitten

    bytebitten New Member Member

    In what way was it not working? Do you get the message that the router is not responding or does it upload the firmware?

    I had to do several attempts before I got a successful flashing, one of the occasions the firmware transfer aborted at 50% every time, I managed to pass that by holding the reset button pressed during the whole transfer.
     
  71. bytebitten

    bytebitten New Member Member

    Now I have tried the CFE from post #101 but still no success, have I missed something basic like that I have to enable something first to make the time scheduling work?
     
  72. baani59

    baani59 Reformed Router Member

    I’m sorry, the wireles time scheduling really doesn't work.

    I was superficial. :( My local time was in "off" time window, when I save the scheduling and so its working.

    Later, when the time reached the next "off" period my wifi already doesn't turned off.
     
  73. bytebitten

    bytebitten New Member Member

    Thank you for for telling me! I was beginning to get bold after all my head-scratching trying to figure out why it did not work for me. So it might be an error in the CFE or software then?
     
  74. baani59

    baani59 Reformed Router Member

    I think, that this is software problem.
    Also in the AC68U's topics several people indicated, from some software versions doesn't work wireless time scheduling properly.
    Interesting that is not for everyone.
     
  75. WhiteSpy

    WhiteSpy New Member Member

    Many thanks to Starbuck, Cybrnook and everyone else who contributed. I now have an Asus clone.
    Being a little green though, I had a couple of questions for anyone who may know the answer...

    1) Going forward, when updating to new AC68U releases, do I have to continue with this process, or is it just regular updates via GUI from here on out?
    2) Does anyone know the answer to post 162?

    Apologies for the noob questions. Just stated to grasp all this over the weekend.
    Cheers!
     
  76. baani59

    baani59 Reformed Router Member

    WhiteSpy likes this.
  77. WhiteSpy

    WhiteSpy New Member Member

  78. jyan01

    jyan01 New Member Member

    Hi All:

    I got my EA6900 cloned as RT-AC68U, I realized the ASUS official firmware has some broken item, ie: Web History (I understand is closed source so would need to wait for ASUS to fix). Also, DDNS to ASUS.com, I presume this wont work on the clone? Or is there a fix (besides using the 3rd parties, the free ones are a nuisance as you wold need to login the acct or do a dance to get the freebie). Let me know.
     
  79. baani59

    baani59 Reformed Router Member

    You can find solution to Web History problem in this topic.


    Allegedly, Asus checks the mac address of the routers at registration. The mac address must be in the asus mac range.
    I used the Asus DDNS on EA6900 (Xwrt)for two years but doesn't work now. (AC68U clone with Asus Merlin). I think this is not software problem.
     
    Last edited: Nov 30, 2018
  80. eduardoll

    eduardoll New Member Member

  81. migtoe

    migtoe New Member Member

    Thanks bzbeer, followed your instructions using Asus restoration tool during CFE miniWeb Server page and now on latest version of Asuswrt-Merlin :cool:. I wasn't have any success flashing right off the CFE miniWeb Server page, though DDWRT and Tomato flashed fine on that page but not the Asus firmware.

    I have a question if anyone knows? I enabled web history in QOS and a Trend Micro warning appears about sharing your data with them :eek:...Is it possible to remove or block the Telemetry type software? maybe within custom CFE?

    Searched about Trend Micro and AsusWRT and snbforums popped up with some worrying things like "Trend Micro tools tossed from Apple's Mac App Store after spewing fans' browser histories Data caught being siphoned off to outside server" ....I just got on Asuswrt-Merlin but if there's no way around this I might go back to Advanced Tomato or Fresh Tomato :oops:. Seems like so much shilling going on at SNBforums also with comments saying you should trust TrendMicro and they are doing it for our safety...

    I did find a fork of merlin - [Fork] Asuswrt-Merlin 374.43 LTS releases (V37E4) which apparently doesn't have Trend Micro stuff? .....still reading through comments. Successfully flashed that fork onto Linksys EA6900.:cool:
     
    Last edited: Dec 2, 2018
  82. bzbeer

    bzbeer New Member Member

    With my EA6900 as the main router, it can see and configure my TM-AC1900 as an AiMesh node. But if I use the TM-AC1900 as the main router, it can not see the EA6900 to be configured as an AiMesh node.

    Also, AiMesh was buggy for me, even when I removed the EA6900 and used only two TM-AC1900s in the mesh. Connection dropped frequently (sometimes every 2-3 minutes) even when I am sitting at the same spot (no moving around) and took a long time (almost a minute) to re-connect. Streaming videos (Netflix, Youtube) would hang & buffer frequently. It was not at all usable, so I went back to using it as a repeater and everything is working fine now.
     
  83. bytebitten

    bytebitten New Member Member

    After several attempts to make the time scheduling and the aimesh work on my EA6900 I decided to try to return to original state of the router. After writing back the original CFE and firmware I am now stuck in not being able to enter the Linksys settingspage (I get the loginpage but then it just hangs) nor can I load any firmware bigger that 16k (it seems as) i.e anything else that the Linksys firmware. I have tried the ASUS restoration tool, tftf and tftp2, the only tool that seems to do anything is the tftp2 that perform a download once out of twenty tries. but if the firmware is bigger that 16k it aborts.

    Any suggestions on how I can de-brick my router or any download firmware for EA600 that is smaller than 16k to being able to download something useful to it again?
     
    Last edited: Jan 2, 2019
  84. osdieman

    osdieman Reformed Router Member

    Hi Guys.

    I have followed all the steps here and run succesfully the latest firmware..
    Now my question ( i know it is the wrong place ) but is there anyway to activate at least Aimesh as Node on a rt-ac66u non b1 version.. maybe by editting the bootloader for this device..?
     
  85. AminHa

    AminHa New Member Member

    Hi @Starbuck99
    Thank you very much . I jus saw this article
    I have one question, i have ea6700 but not sure which old stock firmware to use as per above instructions, is it the one foe ea6900 or the one for ea6700? Which version?
    Thanks
     
  86. AminHa

    AminHa New Member Member

    hi all,
    any one can help on my questions above
    Much appreciated
     
  87. Mike Ong

    Mike Ong New Member Member

    hi,

    newbie here. I registered an account here to say "thank you" for this post. Over the weekend I have converted my EA6900 into a clone of AC68U. I want to share my experience with others as it may save a few hours for those who were struggling like I was.

    Like several others before me, I had converted my EA6900 with xvortex' CFE and already had xvortex firmware installed from a few years back. The step I took to flash AC68U-compatible firmware were:
    1. start with a fresh CFE for AC66U,
    2. use CFE editor and modified it according to post 1,
    3. double check it with post #101,
    4. use mtd-write to write the new CFE,
    5. reboot the router (powering-off) into mini-cfe webpage (red reset button, 10-15 seconds),
    6. flash the official AsusWRT,
    7. reboot and CFE reset (blue button, 30 seconds),
    8. flashed Merlin.
    I literally spend 1 whole day on it. The difficulties I had initially, which was resolved eventually (but I don't know exactly why/how), was that I COULD NOT flash *any* firmware at step 4:
    1. mtd-write (mtd-write <firmware> linux) gives segmentation fault,
    2. mini-CFE pages does not load firmware, it simply hangs,
    3. Asus Firmware Restore software says the router is NOT in the rescue mode
    Then I realized that the MAC address I used for 5G was wrong: It wasn't the mac address for WAN+4 (brain crap, couldn't add in HEX). So I took some rest, start from scratch, and finally was able to flash an AsusWRT using mini-cfe web page.

    I don't know if having a wrong MAC address was the reason for the inability to upload firmware. My recommendation is to start from scratch using AC66U CFE and double check everything with post #101.

    I suspect that if one already has the correct CFE flashed, one should be able to go from XVortex to Merlin without the intermediate AsusWRT.

    I haven't checked if AiMesh is working; I already have 3 T-mobile-converted AC68U working in AiMesh. Currently using the EA6900 in bridge mode.

    hope this helps,
     
    Last edited: Jan 9, 2019
  88. AminHa

    AminHa New Member Member

    Hi gametx,
    I managed to flash my EA6700 correctly and everything is working very fine except ports as you explained above
    Have you managed to get the correct ports order for EA6700?
     
  89. Mike Ong

    Mike Ong New Member Member

    hi all,

    I managed to buy an EA6900 v1.1 and converted it using this guide. I had previously converted an EA6900 v1.0. Both were using the modified CFE as posted from post #101, modified with mac addresses as well as the secret code. I am able to flash both the latest Asus and Merlin firmwares.

    I had a bit more time this week so I decided to see if I can use EA6900 as an AiMesh node. I flashed the latest Asus firmware (3.0.0.4.384.45149) for AC68U to EA6900 v1.1. While it flashed fine, I am unable to pair it to my AiMesh router. Tried over couple of hours.

    I have checked the mac address and they are indeed correct (the macadd for 5GHz is 4+ the macdd for 2.4GHz). Trying to pair the node, I press the red reset button for 5-10 seconds, and place the EA6900 close to the AiMesh router (1-3M). I then logged on to the webserver of the AiMesh router, and searched for the node.

    I have repeated this process for about 10+ times, each time moving the node to varying distances/location related to the router. I have done this before (currently having 1 AiMesh router + 2 nodes).

    While there were indirect indication that EA6900 can be used as an AiMesh node, can anyone confirm that it indeed will work? Any hints on how to pair it to my existing AiMesh network?

    regards,

     
  90. Starbuck99

    Starbuck99 Network Newbie Member

    Make sure you have different MAC Addresses for the 2 routers.
    I made the same mistake before.
     
  91. Mike Ong

    Mike Ong New Member Member

    Thanks for the suggestion. I made that mistake before as well when converting T-mobile router to Asus. However, I just checked:

    1) the mac address is indeed unique and matches with the sticker at the back of the router,
    2) the mac address for 5ghz is the mac address for the LAN+4

    I'll try to pair the ea6900 as an AiMesh node if I can find time. In the meanwhile, any help (or confirmation) is appreciated,

    regards,
     
  92. Mike Ong

    Mike Ong New Member Member

    Still no luck getting the converted ea6900 to work as an AiMesh Node. What I have done thus far include (but not limited to):

    1) reflash the CFE
    - I took the CFE from post #101, changed the mac addresses and the secret code,
    - the mac address for the lan and 2.4GB are the same. For 5GHz the mac address is lan+4.
    - reset the router,
    - reflashed the firmware,
    - from webGUI, double-checked the mac addresses,
    - reset the router again

    2) trying to set up AiMesh node:
    - by moving ea6900 to various locations relative to the router, but always 1-3m away
    - turn off the other two existing nodes (ethernet backhauled),
    - used a wired connection between AiMesh router (lan port) to ea6900 (wan port)

    At this point I am simply looking for confirmation that an ea6900 converted router will indeed work as an AiMesh Node.

    any help is very much appreciated,

    regards,
     
  93. david901

    david901 Network Newbie Member

    Hi,I am try on my R7000, use CFE modified from post #101, I can boot miniweb CFE, but can't boot any firmware (ASUS or Merlin), can you provide your CFE for R7000 for reference?
    @leoncici
     
    Last edited: Apr 11, 2019
  94. david901

    david901 Network Newbie Member

    After all,I succesed,thanks。
     
  95. david901

    david901 Network Newbie Member

    Try modify your EA6900 CFE.

    1、delete the line nospare=1 or nospare=0

    2、add ATEMODE=0

    I did it for my R7000,and it works good as AiMesh router or node.


    This is my post in Koolshare http://koolshare.cn/thread-158885-1-1.html
     
    Stimpy88 and Mike Ong like this.
  96. bobbyvont

    bobbyvont New Member Member

    try this cfe
    Code:
    boardtype=0xD646
    boardnum=01
    boardrev=0x1100
    boardflags=0x00000110
    boardflags2=0x00000000
    sromrev=8
    clkfreq=800,666
    xtalfreq=25000
    sdram_config=0x0149
    et0phyaddr=30
    et0mdcport=0
    et0macaddr=00:90:4C:0F:F0:01
    vlan1ports=1 2 3 4 5*
    vlan1hwname=et0
    vlan2ports=0 5u
    vlan2hwname=et0
    landevs=vlan1 wl0 wl1
    wandevs=et0
    lan_ipaddr=192.168.1.1
    lan_netmask=255.255.255.0
    gpio7=wps_button
    boot_wait=on
    wait_time=1
    reset_gpio=11
    gpio9=usbport1
    gpio10=usbport2
    devpath0=pci/1/1
    0:venid=0x14E4
    0:sromrev=11
    0:boardflags=0x00001000
    0:boardflags2=0x00100002
    0:boardflags3=0x00000003
    0:xtalfreq=40000
    0:devid=0x43A1
    0:macaddr=00:90:4C:0F:F0:01
    0:aa2g=7
    0:agbg0=0
    0:agbg1=0
    0:agbg2=0
    0:txchain=7
    0:rxchain=7
    0:antswitch=0
    0:femctrl=3
    0:gainctrlsph=0
    0:papdcap2g=0
    0:tworangetssi2g=0
    0:pdgain2g=14
    0:epagain2g=0
    0:tssiposslope2g=1
    0:pdoffset2g40ma0=3
    0:pdoffset2g40ma1=3
    0:pdoffset2g40ma2=3
    0:rxgains2gelnagaina0=4
    0:rxgains2gelnagaina1=4
    0:rxgains2gelnagaina2=4
    0:rxgains2gtrelnabypa0=1
    0:rxgains2gtrelnabypa1=1
    0:rxgains2gtrelnabypa2=1
    0:rxgains2gtrisoa0=7
    0:rxgains2gtrisoa1=7
    0:rxgains2gtrisoa2=7
    0:maxp2ga0=0x60
    0:maxp2ga1=0x60
    0:maxp2ga2=0x60
    0:pa2ga0=0xff22,0x1a4f,0xfcc1
    0:pa2ga1=0xff22,0x1a71,0xfcbb
    0:pa2ga2=0xff1f,0x1a21,0xfcc2
    0:cckbw202gpo=0
    0:cckbw20ul2gpo=0
    0:mcsbw202gpo=0xCC666600
    0:mcsbw402gpo=0xCC666600
    0:dot11agofdmhrbw202gpo=0x6666
    0:ofdmlrbw202gpo=0
    0:sb20in40hrpo=0
    0:sb20in40lrpo=0
    0:dot11agduphrpo=0
    0:dot11agduplrpo=0
    0:rpcal2g=0XFA1A
    0:sar2g=24
    0:ledbh10=2
    0:ccode=#a
    0:regrev=0
    0:temps_period=5
    0:tempthresh=120
    0:temps_hysteresis=5
    0:phycal_tempdelta=0
    0:tempoffset=0
    devpath1=pci/2/1
    1:venid=0x14E4
    1:sromrev=11
    1:boardflags=0x30000000
    1:boardflags2=0x00200002
    1:boardflags3=0x00000000
    1:xtalfreq=40000
    1:devid=0x43A2
    1:macaddr=00:90:4C:0F:F0:07
    1:aa5g=7
    1:aga0=0
    1:aga1=0
    1:aga2=0
    1:txchain=7
    1:rxchain=7
    1:antswitch=0
    1:femctrl=3
    1:subband5gver=4
    1:gainctrlsph=0
    1:papdcap5g=0
    1:tworangetssi5g=0
    1:pdgain5g=4
    1:epagain5g=0
    1:tssiposslope5g=1
    1:rxgains5gelnagaina0=1
    1:rxgains5gelnagaina1=1
    1:rxgains5gelnagaina2=1
    1:rxgains5ghelnagaina0=2
    1:rxgains5ghelnagaina1=2
    1:rxgains5ghelnagaina2=3
    1:rxgains5ghtrelnabypa0=1
    1:rxgains5ghtrelnabypa1=1
    1:rxgains5ghtrelnabypa2=1
    1:rxgains5ghtrisoa0=5
    1:rxgains5ghtrisoa1=4
    1:rxgains5ghtrisoa2=4
    1:rxgains5gmelnagaina0=2
    1:rxgains5gmelnagaina1=2
    1:rxgains5gmelnagaina2=3
    1:rxgains5gmtrelnabypa0=1
    1:rxgains5gmtrelnabypa1=1
    1:rxgains5gmtrelnabypa2=1
    1:rxgains5gmtrisoa0=5
    1:rxgains5gmtrisoa1=4
    1:rxgains5gmtrisoa2=4
    1:rxgains5gtrelnabypa0=1
    1:rxgains5gtrelnabypa1=1
    1:rxgains5gtrelnabypa2=1
    1:rxgains5gtrisoa0=7
    1:rxgains5gtrisoa1=6
    1:rxgains5gtrisoa2=5
    1:maxp5ga0=0x5C,0x5C,0x5C,0x5C
    1:maxp5ga1=0x5C,0x5C,0x5C,0x5C
    1:maxp5ga2=0x5C,0x5C,0x5C,0x5C
    1:pa5ga0=0xff2e,0x185a,0xfcfc,0xff37,0x1903,0xfcf1,0xff4b,0x197f,0xfcff,0xff37,0x180f,0xfd12
    1:pa5ga1=0xff33,0x1944,0xfce5,0xff30,0x18c6,0xfcf5,0xff40,0x19c7,0xfce5,0xff38,0x18cc,0xfcf9
    1:pa5ga2=0xff34,0x1962,0xfce1,0xff35,0x193b,0xfceb,0xff38,0x1921,0xfcf1,0xff39,0x188f,0xfd00
    1:pdoffset40ma0=0x0
    1:pdoffset40ma1=0x0
    1:pdoffset40ma2=0x0
    1:pdoffset80ma0=0x0000
    1:pdoffset80ma1=0x0000
    1:pdoffset80ma2=0x0000
    1:mcsbw205glpo=0x88653320
    1:mcsbw405glpo=0x88653320
    1:mcsbw805glpo=0x88653320
    1:mcsbw205gmpo=0x88653320
    1:mcsbw405gmpo=0x88653320
    1:mcsbw805gmpo=0x88653320
    1:mcsbw205ghpo=0x88653320
    1:mcsbw405ghpo=0x88653320
    1:mcsbw805ghpo=0x88653320
    1:mcslr5ghpo=0
    1:mcslr5glpo=0
    1:mcslr5gmpo=0
    1:sb20in40hrpo=0
    1:sb20in40lrpo=0
    1:sb20in80and160hr5glpo=0
    1:sb40and80hr5glpo=0
    1:sb20in80and160hr5gmpo=0
    1:sb40and80hr5gmpo=0
    1:sb20in80and160hr5ghpo=0
    1:sb40and80hr5ghpo=0
    1:sb20in40lrpo=0
    1:sb20in80and160lr5glpo=0
    1:sb40and80lr5glpo=0
    1:sb20in80and160lr5gmpo=0
    1:sb40and80lr5gmpo=0
    1:sb20in80and160lr5ghpo=0
    1:sb40and80lr5ghpo=0
    1:dot11agduphrpo=0
    1:dot11agduplrpo=0
    1:rpcal5gb0=0X6343
    1:rpcal5gb1=0X7043
    1:rpcal5gb2=0X7748
    1:rpcal5gb3=0X8257
    1:ledbh10=2
    1:ccode=#a
    1:regrev=0
    1:sar5g=20
    1:temps_period=5
    1:tempthresh=120
    1:temps_hysteresis=5
    1:phycal_tempdelta=0
    1:tempoffset=0
    bl_version=1.0.2.0
    bootflags=1
    secret_code=12345678
    odmpid=RT-AC68U
    ATEMODE=0
    HW_ver=170
    model=RT-AC68U
    MY EA6900 and it works good as AiMesh router or node.
     
  97. leoncici

    leoncici Network Newbie Member

    thank u,i also come from koolshare.
     
  98. david901

    david901 Network Newbie Member

    :):)
     
  99. Mike Ong

    Mike Ong New Member Member

    Thanks very much. I can personally confirm this is working.

    I took the CFE from post #101. That CFE already has the following two entries, so I simply changed the values of these two fields and flashed it back to ea6900. I then flashed the router with the latest firmware (3.0.0.4.384_45713) and managed to connect the ea6900 (v1.1) as an AiMesh node.

    regards,

     
  100. david901

    david901 Network Newbie Member

    :):)You are welcome.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice