Asuswrt-Merlin on Netgear R7000

Discussion in 'Other Firmware Projects' started by XVortex, Mar 27, 2015.

  1. qamartheone

    qamartheone Serious Server Member

    can someone tell/guide me in going back to stock netgear firmware from latest ng build of xvortex..heard few ppl were brickin their r7000 in doin so?
     
  2. Alex Ng

    Alex Ng New Member Member

    Hi there. Complete noobie here. Just wanted to check whether I can flash to the latest build of xvortex directly from any version of netgear stock firmware (i'm currently running V1.0.9.34_10.2.36).
    Also, if I'm going directly to the NG builds, do I have to flash 380.70 first or can I flash from stock to the latest as per the instructions?
    I'm wanting to try xvortex mainly because of the option for usb modem which stock firmware doesn't offer. Can anyone comment about the usability of this function?
    Thanks in advance.
     
  3. thernus

    thernus New Member Member

    I have found there are some issues with USB modems and XWRT (on both r7000 and r8000 routers where the modems worked fine on my old RT-88U) or at least XWRT doesn't like the USB modems I have for some reason (Netgear ac320u/ac790s/ac800s)

    If any of the above modems are set to the primary WAN (and only WAN) most of the time when the router reboots, it resets the router to factory defaults which is pretty crazy, I found a post on page 46 with a person with the same issue but different modem.

    A work around I have found is to just turn on Dual-WAN and have wired WAN the primary and USB modem as secondary and let it fail over to the secondary (only one plugged in) it just delays the bootup/wan connection a extra 30 seconds or so.
     
  4. Daniel Cronan

    Daniel Cronan New Member Member

    Greetings! Using the newest 384.8_2 build. Routing rules and a few other things on the VPN Client page have to be re-entered every time I upload a new server, and also DNS servers in WAN have to be re-entered every time I upload a new server. Is this the new going thing? All of that information stuck on the 380 versions. Noticed it by doing a leak test shortly after upgrading; it showed DNS leaks. Corrected it by again entering my VPN DNS server information, which I had already entered in the boxes the day before and saved.

    EDIT: Fixed. Went back to last 380 build. Everything is great again. Not having to re-add DNS servers, re-do routing rules, and re-check the blocked clients option every time I change VPN servers.
     
    Last edited: Dec 22, 2018
  5. OldSkulRide

    OldSkulRide Serious Server Member

    Guys, does Huawei E3372 work on r7000 and xvortex firmware as fallback device for internet in case cable goes down? I have option to get it cheap.
     
  6. Stimpy88

    Stimpy88 Reformed Router Member

    Have a great Christmas everyone
     
    phalkon30, Makaveli, KingP1n and 2 others like this.
  7. KingP1n

    KingP1n Network Newbie Member

    2019 will bring many great fw updates for our beloved R7000..thanks to XVortex and RMerlin. Merry Christmas to all and the community here.
     
    XVortex, Stimpy88 and Ubimoo like this.
  8. buggage

    buggage Network Guru Member

    Hi,

    Just picked up an R7000 the other day due to seeing the compatibility list with other firmware, however none of the .chk files are being accepted to upgrade to.

    Initial R7000 firmware: V1.0.9.34_10.2.36

    File: R7000_384.8_2.chk (and others).

    Error: Goes to the flashing page for about 2 sec and then "The firmware is not compatible with your router. Error code -2." I had seen in this thread talk about. Have never tried upgrading prior on this device. Did see there have been some issues trying to go back to stock, but I can't even get out of stock...Did Netgear change something where this no longer works? Thanks.
     
  9. Frank2

    Frank2 Networkin' Nut Member

    Page 1 of this forum shows you how to do it.
    It appears you are trying to install a 384NG FW build before you install 380.

    When coming from 380 to 384/NG You MUST flash the 380.70 build first.

    It's all explained on page 1, 1st post.
     
  10. buggage

    buggage Network Guru Member

    Thanks, but that does not work either. The R7000_380.70_0.chk also give the same incompatible error and will not upload. That's why I'm thinking something else is going on.
     
  11. slidermike

    slidermike Addicted to LI Member

    I dont "know" this but Asus started locking down the stock firmware after a certain revision so you have to back-rev the stock to the last unlocked ver. Then do whatever you needed to. Could be that Netgear is following suit though I have no knowledge of this. Just a possibility.
     
  12. Frank2

    Frank2 Networkin' Nut Member

    Hmmmmm, not sure then. Will have to wait for one of the gurus to chime in. I've reached the limits of my technical expertise. Sorry.
     
  13. buggage

    buggage Network Guru Member

    I guess I might be somewhat screwed. Did a few other searches and found a couple of other references to the same where it looks like the only way some others were able to change the firmware was with a serial connection and access to the CFE... Hoping that's not exactly the case, but not looking like there's much I can do in the meantime. I can't even revert to previous Netgear firmware versions.
     
  14. ollimö

    ollimö Serious Server Member

    Did you alkso try the .trx files or just the .chk? .chk does not work for me either since some time but .trx has done the trick past releases. Good luck!
     
  15. buggage

    buggage Network Guru Member

    Thanks for the replies. I was able to successfully flash it this morning (with the .chk file), but found another suggestion to try the nmrpflash utility here: https://github.com/jclehner/nmrpflash

    I had tried a few other TFTP methods that did not work, this one did. Had a minor scare when the device just went into a boot loop after the firmware was loaded, but I just had to factory reset it and it's all good now!
     
    Last edited: Dec 27, 2018
    Stimpy88 likes this.
  16. chert1024

    chert1024 New Member Member

    Does adaptive QOS work with this latest firmware? I went back to stock since the 3 previous firmware I tried didn't have it functioning. I have 15 to 20 devices in my network with a 100/100 fiber connection and that's why having a good functioning auto QOS is important to me.
     
  17. Daedelus

    Daedelus Network Guru Member

    I'm pretty sure the definition of the WiFi 5GHz MAC on my unit is wrong but not sure why or how to cure it.

    On my unit 5GHz MAC = 2.4GHz MAC + 1 this results in the same (conflicting) MAC for 2.4GHz Guest1 and 5GHz (E6:F4:C6:XX:XX:82)

    This results in being unable to use the 5GHz band if the 2.4GHz Guest1 is enabled.

    I expected 2.4GHz to be E4:F4:C6:XX:XX:81 & 5GHz to be E4:F4:C6:XX:XX:85.
    i.e. 5GHz MAC = 2.4GHz MAC + 4

    I think the firmware automatically calculates the 5GHz MAC so I'm unsure how to correct this - any ideas?

    Some (hopefully useful info)

    The R7000 It has the original unmodified cfe
    On base the MAC printed is E4:F4:C6:XX:XX:81

    Some info from putty etc.

    br0 Link encap:Ethernet HWaddr E4:F4:C6:XX:XX:81
    eth0 Link encap:Ethernet HWaddr E4:F4:C6:XX:XX:81
    eth1 Link encap:Ethernet HWaddr E4:F4:C6:XX:XX:81 <- 2.4GHz
    eth2 Link encap:Ethernet HWaddr E4:F4:C6:XX:XX:82 <- 5GHz
    vlan1 Link encap:Ethernet HWaddr E4:F4:C6:XX:XX:81
    wl0.1 Link encap:Ethernet HWaddr E6:F4:C6:XX:XX:82 <- 2.4GHz guest 1

    nvram values:

    et0macaddr=E4:F4:C6:XX:XX:81
    lan1_hwaddr=
    lan_hwaddr=E4:F4:C6:XX:XX:81
    wan0_hwaddr=E4:F4:C6:XX:XX:81
    wan0_hwaddr_x=
    wan1_hwaddr=
    wan1_hwaddr_x=
    wan_hwaddr=E4:F4:C6:XX:XX:81
    wan_hwaddr_x=

    wl_hwaddr=E4:F4:C6:XX:XX:81

    wl0_hwaddr=E4:F4:C6:XX:XX:81 <- 2.4GHz
    wl0.1_hwaddr=E6:F4:C6:XX:XX:82 <- 2.4GHz guest 1
    . . .
    wl0.13_hwaddr=E6:F4:C6:XX:XX:8E
    wl0.14_hwaddr=E6:F4:C6:XX:XX:8F
    wl0.15_hwaddr=E6:F4:C6:XX:XX:80

    wl1_hwaddr=E4:F4:C6:XX:XX:82 <- 5GHz
    wl1.1_hwaddr=E6:F4:C6:XX:XX:83 <- 5GHz guest 1
    wl1.2_hwaddr=E6:F4:C6:XX:XX:84
    . . .
    wl1.13_hwaddr=E6:F4:C6:XX:XX:8F
    wl1.14_hwaddr=E6:F4:C6:XX:XX:80
    wl1.15_hwaddr=E6:F4:C6:XX:XX:81
     
  18. Makaveli

    Makaveli Networkin' Nut Member

    Use the search function the information you are looking for is probably like 10-15 pages back in this thread.
     
  19. Daedelus

    Daedelus Network Guru Member

    Yes I looked there & tried

    nvram set et0macaddr=E4:F4:C6:XX:XX:81
    nvram set 0:macaddr=E4:F4:C6:XX:XX:81
    nvram set 1:macaddr=E4:F4:C6:XX:XX:85
    nvram commit
    reboot

    However after the reboot 1:macaddr is reset to E4:F4:C6:XX:XX:82

    The pages seem to discuss that there is an issue but but offers no clear solution or explanation of the mechansism of the generation of the 5GHz MAC and how to affect that generation or change the resultant MAC.

    i.e. are the CFE values of pci/1/1/macaddr pci/2/1/macaddr used by the firmware to generate MACs or totally ignored & would a custom CFE provide a solution.
     
    Danie1San and Stimpy88 like this.
  20. Danie1San

    Danie1San New Member Member

    @Daedelus
    Having just updated to the NG build this weekend (from a much older build), I found that I have the same issue as you.
    I had tried the same commands as above but my 1:macaddr also resets back to the device MAC address +1.
     
  21. David1

    David1 Serious Server Member

    ░█░█░█▀█░█▀█░█▀█░█░█░░█▀▄░█▀▀░█░█░█░░█░█░█▀▀░█▀█░█▀█░█░
    ░█▀█░█▀█░█▀▀░█▀▀░▀█▀░░█░█░█▀▀░█░█░█░░▀█▀░█▀▀░█▀█░█▀▄░▀░
    ░▀░▀░▀░▀░▀░░░▀░░░░▀░░░▀░▀░▀▀▀░░▀░▀░░░░▀░░▀▀▀░▀░▀░▀░▀░▀░
     
  22. David1

    David1 Serious Server Member


    if i am understanding correctly you are saying your 2.4Ghz guest 1 has the same mac as ur 5Ghz, but in your post they are not the same , one is E6 and the other is E4, therefore not the same,

    i have the latest firmware and i enabled my 2.4ghz guest and i have no problem connecting to both guest and 5ghz
    my mac are

    wl0.1_hwaddr=6A:FD:3A:XX:XX:86
    wl1_hwaddr=68:FD:3A:XX:XX:86

    its switching the 6th bit in the mac causing it to increase by 2
     
  23. Daedelus

    Daedelus Network Guru Member

    Thanks David1 - aaaah yes you are correct regarding the macs. I did miss that (mea culpa). So it should work for me - but sadly it doesn't with 2.4GHz Guest1.

    Over the last few days I've been using 2.4GHz Guest2 (wl0.2_hwaddr=E6:F4:C6:XX:XX:83) with no errors in the System Log & able to connect to 5GHz etc.

    However if I disable 2.4GHz Guest2 and enable Guest1 (wl0.1_hwaddr=E6:F4:C6:XX:XX:82) the System Log produces a constant stream of:

    Jan 1 09:38:13 kernel: br0: received packet on eth2 with own address as source address​

    and I'm unable to connect to the 5GHz channel. All very annoying.

    The pragmatic side of me says just use Guest2 but my perfectionist side is nagging me to sort it out.
     
  24. David1

    David1 Serious Server Member

    so i have had a look at it a bit more looks like eth2(5Ghz)(1:macaddr) and Guest 2.4(wl0.1) is conflicting, so you were right

    what i did was turn off guest network

    nvram set 1:macaddr=68:FD:3A:XX:XX:98
    nvram commit

    and then turn on the guest network, you will see the 5ghz mac change and if you dont reboot it seems to work
    but like you said after reboot the settings are not saving
     
  25. qamartheone

    qamartheone Serious Server Member

    which chk file u used?
     
  26. buggage

    buggage Network Guru Member

    The one included along with the .trx in the firmware download.
     
  27. juched

    juched Serious Server Member

    Create your guest network using the second guest network slot and it will not conflict. I found this out and shared here months ago.
     
    Stimpy88 and slidermike like this.
  28. elRadix

    elRadix Reformed Router Member

    Makaveli, Stimpy88 and slidermike like this.
  29. tripfish

    tripfish New Member Member

    Hello,

    I'm on 384.8. I tried to change the wifi Tx power adjustment for 2.4 and 5 GHz, but I can't see any difference.
    Used the slider and the nvram settings (wl*_txpower) via ssh. After a reboot the values are correct, but I don't see any difference in signal strength. Checked it with WifiInfoView for Windows and Wifi Analyzer on my smartphone.

    I previously had a RT-N56U with the padavan FW. There I could see a difference.
     
  30. Stimpy88

    Stimpy88 Reformed Router Member

    I doesn't work, hasn't for as long as I can remember. And yep, I've done tests with an analyser, no power or s/n increases at all.

    Sit back and wait for the usual "why do you want to increase power?", "why do you want more radiation?", "I don't know why people want to mess with that!" and "you have to improve your receiver before you mess with power", and the golden oldie... "I wish it was removed from the firmware, you should not have the right to break the law" rants to start...
     
    tripfish likes this.
  31. slidermike

    slidermike Addicted to LI Member

    lol, if it doesn't work via the command line argument then it has likely been pulled into the proprietary blobs/kernel for whatever reason Asus decided to.
    I am pretty sure Merlin would know and might have even mentioned it in the past. I believe he has said Asus is pulling more and more into the closed source material so it cannot be override.
    If you want to use this firmware then you just have to deal with that as a limitation. Other opensource firmware such as dd-wrt still allow you complete control over the tx.
     
    Stimpy88 likes this.
  32. Stimpy88

    Stimpy88 Reformed Router Member

    Yep, I expect you are right, the driver is a black box. I can't remember the last firmware this option worked in, unfortunately, not that it is much of a viable option to run old firmwares these days!
     
  33. KingP1n

    KingP1n Network Newbie Member

    Question for anyone here...I read a few forums and mix reactions on overclocking the R7000. I'm currently running my R7000 to 1.4 (1400/800) for over 6 months without any issue. Do you know or read of anyone overclocking to 1.6? I would to try but I've read successful attempts and some not so successful with bricking their routers. What's your take on this? Should I even attempt this going from 1.4 to 1.6? Any info is greatly appreciated.
     
  34. slidermike

    slidermike Addicted to LI Member

    1200/800 works for all, 1400/800 works for most, 1600/800 works for a few.
    It's up to you if you want to try it.
    The safest way is to apply it but don't save the OC to nvram.
    So if it becomes unstable a reboot will restore you to a lower rate.
    You won't gain any performance from any OC unless your running cpu intensive functions like ip filters, qos or VPN.
     
  35. KingP1n

    KingP1n Network Newbie Member

    How do I apply without saving to nvram? Thanks for the reply
     
  36. slidermike

    slidermike Addicted to LI Member

    At the command prompt you just make the change.
    That is an instant "apply" and as long as you don't "save" it is just in the current running session.
    I forget the exact syntax but it should look something like this.
    "nvram show | grep clk"
    that should give you the current command structure & clock freq.
    Then you type something like
    "set clkfrq=1400/800"
    May not be the exact syntax since I have not done it in a long time but should be very close.
    to save a config its like
    "nvram save"
    Of course none of the "", those are just to show you the command lay between.
     
    Stimpy88 likes this.
  37. Sl4fko

    Sl4fko Network Newbie Member

    What is a correct way to upgrade a router if I have Diversion, Skynet and AMTM installed? Just run over with install?

    What if I upgrade AND erase nvram?

    1.) It is clear, that it is best to config the router from scratch... Also JFFS partition or can I export it?
    2.) SWAP file can stay on USB or also format with EXT file system?

    So basicaly, do I have to do everything from scratch if I upgrade or can something stay from before?

    Hopefuly I was clear with what I want to say...


    Thanks!
     
  38. Makaveli

    Makaveli Networkin' Nut Member

    All you need to do is use the .trx for the upgrade.

    I also unmount the usb drive diversion is running on before I flash.

    After flash is complete and everything comes up all the scripts start up and everything should be how it was on previous firmware.

    if you start erasing Nvram and the JFFS partition you will have to reinstall everything from scratch. I only find this necessary if i'm troubleshooting an issue.
     
  39. Sl4fko

    Sl4fko Network Newbie Member

    Do I have to stop/disable Diversion (or any program that uses SWAP...) first and then remove USB stick or is it all the same?
     
  40. Makaveli

    Makaveli Networkin' Nut Member

    You can but I didn't and it was fine.
     
  41. KingP1n

    KingP1n Network Newbie Member

    Thought I was overclocking but bogomips shows:

    cat /proc/cpuinfo
    Processor : ARMv7 Processor rev 0 (v7l)
    processor : 0
    BogoMIPS : 1998.84

    processor : 1
    BogoMIPS : 1998.84

    This are the default settings...does this mean we're prevented from Oc?
     
    Last edited: Jan 18, 2019 at 2:27 PM
  42. slidermike

    slidermike Addicted to LI Member

    KP, I brought that up a while back myself.
    I believe that Asus locked down the clocking by pulling it into a closed portion.
    Though at the time someone else came back and said they were OC. So maybe it reports as OC but in reality it isnt.

    If thats the case, you can still OC but you would have to go the route of editing the CFE. Which is less preferred, especially for testing or pushing the limit.
    I have never heard of an R7000 unable to OC to 1200/800 so if I were OC'ing mine and wanted to hard code it into the CFE then thats what I would do. Anything over that is questionable.
    The other option would be to abandon this fork and go to dd-wrt or tomato where (last I heard) OC was still command line easy peasy.
     
    Stimpy88 and KingP1n like this.
  43. clweb

    clweb Network Guru Member

    I think the bogoMIPS are calculated at boot.
     
  44. Makaveli

    Makaveli Networkin' Nut Member


    cat /proc/cpuinfo
    I'm at 1.2Ghz

    Processor : ARMv7 Processor rev 0 (v7l)
    processor : 0
    BogoMIPS : 2398.61

    processor : 1
    BogoMIPS : 2398.61


    To check clocks
    nvram get clkfreq

    run this to set it
    nvram set clkfreq=1200,800

    If you want to save changes
    nvram commit

    Reboot
     
    Last edited: Jan 19, 2019 at 1:17 AM
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice