Asuswrt-Merlin on Netgear R7000

Discussion in 'Other Firmware Projects' started by XVortex, Mar 27, 2015.

  1. Sl4fko

    Sl4fko Reformed Router Member

    Right... I would do reset after every upgrade. Just to make sure...

    1. Flash 380.70
    2. Factory reset
    3. Flash 384.10_2
    4. Factory reset
    5. Config the router
     
    XVortex and fertyczko like this.
  2. fertyczko

    fertyczko New Member Member

  3. Sl4fko

    Sl4fko Reformed Router Member

    I remember having a problem seeing 5 GHz signal with my Nexus 6P; changing channel to 116 did the trick. Try different channels for 5 GHz signal.

    You can change region only via SSH scripts, no gui option.
     
    fertyczko and slidermike like this.
  4. PC_Arcade

    PC_Arcade Reformed Router Member

    Every time I try to upgrade from 384.9 to the latest version I get the following error:

    "Firmware upgrade unsuccessful. This may result from incorrect image or error transmission. Please check the version of the firmware and try again"

    Thing is, I'm using R7000_384_10_2 from http://xvtx.ru/xwrt/download.htm on my Nighthawk AC1900 (the .trx file)

    I have no idea why this would be, I've looked in the log and nothing obvious seems to be in there, can anyone help me troubleshoot?
     
    Last edited: May 1, 2019
  5. fertyczko

    fertyczko New Member Member

    So, after succesfull upgrade to v. 384.10.2 on my R7000 - I can now connect using SSH and WiFi 5Ghz is working fine. Thank You Sl4fko and slidermike.
    I have changed channel to 104 and 5Ghz is working very good. Last question - have I still to change this WiFi Region via script? My country is Poland. How can I check the actual region settings on my router?
     
  6. Sl4fko

    Sl4fko Reformed Router Member

    Read this and this.

    Basically, all of us use channels 1, 6 or 11 (2.4 GHz signal) so that there is no interference between your and neighbours SSIDs (overlapping).

    So...

    If you can "see" your routers SSID with all your devices there is practically no need to change the region.
     
    Last edited: May 3, 2019
    Makaveli and phalkon30 like this.
  7. LuisCarlosHK

    LuisCarlosHK New Member Member

    I using Netgear R6900 as repeater.
    I flashed to merlin firmware for a long time.
    So I try to access to my router by using 192.168.1.1 to update the firmware but not working.
    How can I access to my router?
     
    Last edited: May 4, 2019
  8. slidermike

    slidermike Addicted to LI Member

    A repeater would likely use dhcp for an address.
    You will have to look at uuour dhcp serverr to find out the Ip address of the repeater.
     
    Makaveli likes this.
  9. Sl4fko

    Sl4fko Reformed Router Member

    If it is in repeater mode, then its IP is most definitely not 192.168.1.1...

    If you are connected to the repeater, run "cmd" and then "ipconfig /all".
    The gateways IP is your routers/repeaters IP.

    Or simply reset the router with a reset button on the back. After that you can connect to it via default ssid...
     
  10. Frank2

    Frank2 Networkin' Nut Member

    I know this is an old post, but thought I would point out that DuckDNS gives you a constant DDNS (NO 30 day renewal). I've been using it for a long time now and never had a problem. Also never had a reminder to renew, which is nice. Just something to consider. And, it's free. Just sayin' Not sure why some DDNS providers want 30 day renewals.
     
    Stimpy88 and riksterinto like this.
  11. Lmansc

    Lmansc New Member Member

    Hello I have one problem with my r7000 and asuswrt merlin latest version I can´t get more than 400 mbps in my gigabit connection I tried everything and I tried 2 different firmware netgear stock and this one. I have ctf and fa enabled. I tried to enable and disable Jumbo frames and stp with no results. I tried to put 9000 mtu instead 1500 with no results. I tried to disable ipv6 and firewall with no results. Wan is enabled, upnp and nat too. I do not what can I do now for improve my connection speed. My company router is attached with netgear via wan. In my company router I can get 980 mbps and 100 upload speed
    But with r7000 I got this
    Download Mbps
    389.32
    Upload Mbps
    89.93
     
  12. GDT78

    GDT78 Serious Server Member

    Seems like 384.11 is on the way...
     
  13. XVortex

    XVortex Addicted to LI Member

    Yep. V384.11 has been released and uploaded.

    One of the most interesting feature of this firmware is the DoT (DNS-over-TLS) support.
    Thanks Themiron and RMerlin for this!

    Plz consider a donation for RMerlin or Me if you'd like it too :)
    Enjoy.
     
    peyton, riksterinto, Stimpy88 and 5 others like this.
  14. Lmansc

    Lmansc New Member Member

    Can you tell me how can I fix my problem please?.
     
  15. clweb

    clweb Network Guru Member

    I have a R7000 With Merlin 384.10_2, not overclocked.
    I have CTF enabled. AI Protection nad QOS are disabled.
    I made test with PC (Ubuntu) connected via RJ45 to the router.
    I get 880 Mbps down and 300 Mbps up.
    I get the same values when directly connected to my provider's box.

    So I think there is no basic speed problem with the router/Merlin.
     
  16. miroco

    miroco Serious Server Member

    A big thanks to Merlin and XVortex for the V384.11 and @themiron for the implementation of DoT (DNS-over-TLS).

    I could also get AiMesh to work with V384.11 using @djgodlike's guide. This time around AiMesh work wired as well as wireless.

    Ai-Mesh seems rather resilient. I've changed IP-address on the router (it then reboot) and changed the mode from router to AP without ill effect. Testing the resilience I also turned the devices off and then on again. Despite the rough treatment AiMesh restores the connection again by itself.

    It displays the icon of an Asus RT-AC68U despite being a bonafide Netgear R7000. Both devices are Netgear R7000 routers using XVortex custom CFE.

    Speaking of the custom CFE, Recovery Mode. I've unsuccessfully tried to find the static IP-address and how to use the tool. How about a link on the OP?

    @Sl4fko

    From Asus FAQ on WiFi Roaming.

    "Enable the Roaming Assistant feature so the client's device will automatically disconnect from the main wireless router if the signal strength is under specific threshold and it will connect to a stronger signal."

    How to enable the Roaming Assistant
    https://www.asus.com/us/support/FAQ/1036730/

    How to fix WiFi roaming
    https://www.smallnetbuilder.com/basics/wireless-basics/33180-how-to-fix-wi-fi-roaming

    How to set up roaming assistance in AiMesh
    https://dongknows.com/asus-aimesh-overview/

    Beacon interval and hand-off
    http://homenetworkadmin.com/what-is-beacon-interval/
    "Lower intervals are recommended for use with multiple access points, as the more frequent broadcasts allow devices to decide on the better AP for connection."
     

    Attached Files:

    Last edited: May 10, 2019
    slidermike, duceyaj, peyton and 3 others like this.
  17. sdroute

    sdroute Network Newbie Member

    After reviewing the V384.11 changelog, I did not see any mention of the unreliable networkmap listing, a known issue in the V384.9 changelog. Has this been addressed?

    I am still on 380.70 and have been holding out on NG. I’m looking for a good time to make the switch.
     
    Stimpy88 likes this.
  18. Makaveli

    Makaveli Networkin' Nut Member

    For me the networkmap listing is worse on 384.11 I upgraded this morning and it shows 0 clients however if you check the wireless log everything is connected.

    Even though 384.10_2 was said to have a unreliable network map it worked fine for me on that build.

    This is in Firefox.
    When making a change on the Wan page then hitting apply it will just sit on the screen applying. The changes do go through but it seems to sit on that page forever.

    Will see how it goes the rest of the night as I continue to test.

    If I find anymore quirks I may go back to 10_2 but tomorrow.
     
    Last edited: May 11, 2019
    Stimpy88 likes this.
  19. Attila

    Attila Network Newbie Member

    networkmap listing is not working on 384.11 I upgraded this morning and it shows 0 clients
     
    Stimpy88 likes this.
  20. XVortex

    XVortex Addicted to LI Member

    I have no issues with networkmap listing. I have this options enables/disabled in Tools->Other settings.
    Maybe BWDPI/AiMesh somehow affects this issue....

    asus.png
     
  21. miroco

    miroco Serious Server Member

    Nor I have issues with networkmap listing. And I have AiMesh enabled. AiMesh has been up and running for tree days now. Just a thought, what if OUI (macaddress lookup) somehow got blocked? How would that affect the networkmap?
     

    Attached Files:

  22. David1

    David1 Serious Server Member

    mine is also showing 0 clients and show ai mesh as unselected even though i have tried selecting both yes/no

    upload_2019-5-12_17-20-31.png
     
    Stimpy88 likes this.
  23. Attila

    Attila Network Newbie Member

    I reflashed the firmware was thinking i messed up but no, what i'm did is assigned statically the ip addresses in dhcp server menu for me looks like the router doesn't see or recognize the wirelles an wired clients see them offline...
     
    Stimpy88 likes this.
  24. Attila

    Attila Network Newbie Member

    that's why wee don't see any clients on the list.
     
  25. Makaveli

    Makaveli Networkin' Nut Member

    My settings are the same as yours but the client list shows 0.

    When you view the wireless log however everything is connected, there has been a few people on SNB also reporting the issue so it does seem to be affecting some but not all if it works for you. For now i've gone back to 10_2.

    @XVortex

    Did you just do a dirty upgrade from the trx file or Clean install?

    Do you have any additional scripts running or just bone stock?
     
    Last edited: May 12, 2019
    Stimpy88 likes this.
  26. moh33t

    moh33t New Member Member

    I'm also seeing 0 clients on the network map panel on v384.11. I dirty flashed from v384.10 on my R7000. All my devices have static IP allocated in the DHCP page. I tested by removing some of the devices from the static IP list, still they don't show up on the client list, but I can see them in wireless log.

    Device is on wireless router mode with per IPTraffic enabled with BWDPI enabled while AIMesh and AIcloud are disabled.

    Thanks you so much @XVortex for releasing DoT on R7000 and for releasing regular updates.
     
  27. ringlord

    ringlord Network Newbie Member

    I am on 384.11 in AP mode and my list shows 27 devices.
    I have stock CFE 1.0.0.0

    [​IMG]
     
    Last edited: May 14, 2019
  28. halcy0n9001

    halcy0n9001 Network Newbie Member

    Hi All,

    I've been playing with wireguard lately and would love to run this on the router rather than each device. I know I won't be able to use the firmware GUI - how else can I achieve this?

    Thanks!
     
  29. XVortex

    XVortex Addicted to LI Member

    I always do a dirty install / upgrade (include alpha/beta builds). I have been doing nvram reset a very long time ago.
    No. I haven't any scripts in autorun.
     
    Makaveli likes this.
  30. Goned91

    Goned91 Network Newbie Member

    Hi,

    Same issue for me - R7000 - 0 clients on the network map panel on v384.11.

    Back to 384.10_2 - work well for network map

    Regards,
     
  31. Makaveli

    Makaveli Networkin' Nut Member

    Do you use any tools for the NVRAM rest or just commands?
     
  32. Sl4fko

    Sl4fko Reformed Router Member

    I'm on latest 384.11, network map works fine on my both R7000...
     
  33. buggage

    buggage Network Guru Member

    Interesting....not working here - 0 clients - wonder what the difference is?
     
  34. Makaveli

    Makaveli Networkin' Nut Member

    For those that have it working.

    Are you using the stock CFE ? what version?

    Are you in AP mode or Router?

    Any scripts running ?
     
  35. Sl4fko

    Sl4fko Reformed Router Member


    Using custom CFE v1.0.2.1, edited EVERY field in it (including all MAC addresses). One router, one CAT6 connected AP, both working with it. Running Diversion, Skynet and amtm. Upgrade from 384.10_2, just a reboot, no factory default performed.
     

    Attached Files:

    Makaveli likes this.
  36. David1

    David1 Serious Server Member

    I put on custom cfe 1.0.2.1, the network map is working now and showing all clients
     
    Last edited: May 14, 2019
    Makaveli likes this.
  37. miroco

    miroco Serious Server Member

    I'm on custom CFE 1.0.2.2 on both devices.

    AP-mode and AiMesh.

    No scripts.
     
  38. Kees17760

    Kees17760 Network Newbie Member

    +1
    Standard configuration, no scripts running, using assigned addresses for wired clients and DHCP for wireless clients Enabling/Disabling BWDPI has no effect.

    R7000 running cfe version 1.0.0.0

    Reading things about cfe makes me wonder, should i do something?
    Never touched that before
     
    Last edited: May 14, 2019
  39. Ubimoo

    Ubimoo Serious Server Member

    CFE 1.0.0.0
    I don't see any clients
     
  40. Attila

    Attila Network Newbie Member

    (network map) maybe in the next release will be fixed ?
     
  41. tomthebomb1968

    tomthebomb1968 Network Newbie Member

    Hi , I havent changed CFE ever so dunno which im on . Upgraded to latest firmware (dirty) and have 0 clients showing in webui. Using the ASUS Router android app via phone all clients displayed correctly . No big deal for me was just searching to see if anyone else had same after upgrade and found this thread.

    If I do a complete fresh install and then assign my static ip devices and port forwarding requirements will that fix it?

    Thanks
     
  42. Attila

    Attila Network Newbie Member

    I already did that but still not showing.
     
  43. Makaveli

    Makaveli Networkin' Nut Member

    Ahhh so i'm also still on the Stock CFE 1.0.0.0

    And it seems those that have it working are on CFE v1.0.2.1+

    I'm wondering if that is the issue so far seems to be leading that way.
     
  44. Makaveli

    Makaveli Networkin' Nut Member

    Question since you have modified all MAC addresses are you now able to use Guest networking Slot #1 without it conflicting with the Mac address for 5 Ghz Radio?
     
  45. miroco

    miroco Serious Server Member

    I just configured a 5 GHz guest network using slot #1 with my Apple TV on the "main" 5 GHz network of the AiMesh combo. I configured my iPhone to use the recently created guest network and upgraded the apps on it while listning to uninterrupted music from my Apple TV. As far as I can tell, no conflict.
     
  46. Makaveli

    Makaveli Networkin' Nut Member

    I think with AI Mesh involved that is abit different.
     
    Last edited: May 15, 2019
  47. Goned91

    Goned91 Network Newbie Member

    Hi,
    How to upgrade to CFE 1.0.2.1+ ?
    Regards,
     
  48. Makaveli

    Makaveli Networkin' Nut Member

    Its on the first page of the thread.

    Also quick question for the rest.

    Based on the instructions i've modified the CFE with the Correct et0macaddr.

    https://www.linksysinfo.org/index.p...lin-on-netgear-r7000.71108/page-7#post-262027

    https://www.linksysinfo.org/index.php?threads/asuswrt-merlin-on-netgear-r7000.71108/#post-259279

    One set of instructions say this is all that matters while I see instructions to modify

    pci/1/1/macaddr
    pci/2/1/macaddr


    Is it correct that the Firmware will just calculate them based off the Lan Mac Address and to ignore them?

    "Regardless how you set your mac addresses in the custom CFE, the xvrt will calculate based on the et0macaddr address. The LAN address will be the et0macaddr, the 2.4GHz is the same as LAN, and the 5GHz will be LAN address + 4."


    [​IMG]
     
    Last edited: May 15, 2019
    Stimpy88 likes this.
  49. Kees17760

    Kees17760 Network Newbie Member

    Ok, R7000 on 384.11
    First was on CFE 1.0.0.0 and clients were NOT showing in Network Map.
    Then upgraded CFE via instructions from the first page.
    Used Address schema
    et0macaddr=x
    pci/1/1/macaddr=x+1
    pci/2/1/macaddr=x+2
    That wasn't too hard.

    Now i'm on CFE 1.0.2.1 and clients are showing :)

    Guest networking Slot #1 still conflicting with the Mac address for 5 Ghz Radio though (tried Asus Address schema too, alas with same results).
     
    Last edited: May 15, 2019
    Makaveli likes this.
  50. Goned91

    Goned91 Network Newbie Member

    Ok thanks for reply, but flash CFE to another version has some disadvantages...

    I wait if the new version solve this issue with the CFE stock (1.0.0.0) :)

    Regards,
     
  51. Makaveli

    Makaveli Networkin' Nut Member

    I highly doubt a new version is going to fix it.

    There is clearly a requirement in this firmware that need the newer CFE.

    And the next firmware should still have it.
     
  52. Goned91

    Goned91 Network Newbie Member

    Ok so it's need to be specify to upgrade CFE for 384.11 and more firmware new version up
     
  53. GDT78

    GDT78 Serious Server Member

    Do I need to do a factory reset after a new CFE flash?
    CFE 1.0.2.2 is the one linked on the first post, is it right?
     
    Last edited: May 15, 2019
  54. Kees17760

    Kees17760 Network Newbie Member

    It's 1.0.2.1 (at the time of writing)
    Initially it works without the Factory Reset, but did one just to be safe.
     
  55. Makaveli

    Makaveli Networkin' Nut Member

    I did the CFE update to 1.0.2.1 and rebooted the router.

    The clients still show 0 but I believe I need to do the factory reset however because of all my scripts running I will do that another day. I believe once I factory reset and wipe the jffs partition everything should be fine.
     
  56. Goned91

    Goned91 Network Newbie Member

    Good, i want to do same but i have question:

    In how to is say :
    1) Netgear:
    et0macaddr=LAN_MAC_Address
    pci/1/1/macaddr=et0macaddr
    pci/2/1/macaddr=et0macaddr-1

    But, my mac addr et0 finish by 8D, so is 8C for pci/2/1 ?
    If true, why if i look my eth2 is finish by 8E and not 8C ?

    Regards,
     
  57. Makaveli

    Makaveli Networkin' Nut Member

    I believe when we first got NG build there was an issue with it changing the mac so my mac was not the original. However I still have my Box for the router which has the original mac on the sticker so I changed it back.

    Lets say et0macaddr = 00:90:4C:0F:F2:A7

    pci/1/1/macaddr=x+1 (00:90:4C:0F:F2:A8)
    pci/2/1/macaddr=x+2 (00:90:4C:0F:F2:A9)

    However what I posted in bold above is correct.

    "Regardless how you set your mac addresses in the custom CFE, the xvrt will calculate based on the et0macaddr address. The LAN address will be the et0macaddr, the 2.4GHz is the same as LAN, and the 5GHz will be LAN address + 4."

    So after I loaded the new CFE regardless of what I set in

    pci/1/1/macaddr=x+1 & pci/2/1/macaddr=x+2

    The router will change it based on the etomacaddr.
     
    slidermike likes this.
  58. Goned91

    Goned91 Network Newbie Member

    Yep but you explain for number mac...but me is not number the last..is an letter LOL
    So if i understand - A B C D E F

    If mine is D so pci/1/1 is E and pci/2/1 is ....+4 not work .. the last mac hexa is F
     
  59. Makaveli

    Makaveli Networkin' Nut Member

    After a factory reset everything is working fine client list is back up.

    Just leave it in dummy mode and put in the Mac address and save it.

    There is no need to go to advanced and to modify those fields if you haven't figured it out.

    As posted in bold the firmware will calculate those based off eothmacddrr
     
  60. slidermike

    slidermike Addicted to LI Member

    Mak is right.
    If you think F is the end then you dont understand how the mac rolls over (similar to IPs).
    Besides, you can even put someone elses info into the router and it wont hurt a thing.. As long as both r7000 that share the same mac's arent connected on the same network there is no issue.
    Messing with the CEF is considered an advanced function and one that isnt suggested if you do not know what your doing. You could brick the router if you dont do it correctly so there is that.
    I guess you have to decide just how badly you want the connected device list to work.
    Good luck if you do decide to do the CEF upgrade. Dont want you to have a brick.
     
  61. ringlord

    ringlord Network Newbie Member

    I am on CFE stock (1.0.0.0) in AP mode and my network map shows 27 devices, so it's not required to upgrade CFE, at least not in AP mode.
     
    phalkon30 likes this.
  62. GDT78

    GDT78 Serious Server Member

    Did anybody try to configure 2 R7000 with XVortex in AiMesh mode?
    I currently have one setted as main router and the other one of them setted in media bridge mode, I'd like to turn switch this one to aimesh mode.
     
  63. ringlord

    ringlord Network Newbie Member

  64. Kees17760

    Kees17760 Network Newbie Member


    Unless you wanted to overclock. I wouldn't advise this, but while being there this is the place to do it.
    CFEEdit > Advanced Mode > clkfreq=1000,800 (default)
    I use clkfreq=1200,800 on my R7000, which runs fine for me.

    Mind you: Overclocking is at your own risk! It may or may not work for you.
     
    Last edited: May 16, 2019
  65. Pierre Chartrand

    Pierre Chartrand New Member Member

    tried 3 different R7000 update to 384.11.

    Network map from main page
    there is no Client List.
    this worked with 384.9 , never tried 384.10_2

    has anybody seen this.
     
  66. slidermike

    slidermike Addicted to LI Member

    Like ringlord, I am in AP mode and client list works fine in every recent build.
     
    Last edited: May 17, 2019
    ringlord likes this.
  67. Makaveli

    Makaveli Networkin' Nut Member

    I would advise most people to actually overclock and check that is it stable over say a month period before applying permanent clocks in the CFE.

    Only as of yesterday did I modify my CFE for 1.2Ghz default but this is after running it at that speed for 2 years!

    So I know its stable, most people won't have an issue with the 200 mhz overclock but I would test for stability
    first before changing the CFE clocks.


    There are like 8 post on this very page discussing the issue and how to fix it right above your post dude what do you mean has anyone seen this issue.
     
    mito likes this.
  68. mito

    mito Network Guru Member

    I used to have my R7000 overclocked at 1400 three years ago and during months, with no any issue, but did not noticed great advantages, a little faster response, and only a little raise in temperature, so returned to default as said in my signature.
     
  69. Makaveli

    Makaveli Networkin' Nut Member

    I'm not surprised it worked for you each router will be different i've heard people having it stable at 1.4 and others not so much.

    Are you really still on 380.57 firmware that is ancient!
     
    Last edited: May 17, 2019
    mito likes this.
  70. mito

    mito Network Guru Member

    Hi Makaveli, yes I am on 380.57 , now I am not so involved in this great thing about firmware, lot of work and increased family, but from time to time I come to see my friends.
    Have no any trouble with 380.57 only I make it restart every day at 6am , you know, just in case, and runs great, regards and smiles!
     
  71. Makaveli

    Makaveli Networkin' Nut Member

    Surprised you haven't at least updated to 380.70 to be alittle more up to date on security patches.
     
    phalkon30 and mito like this.
  72. mito

    mito Network Guru Member

    Have no to much time, but thanx a lot for the advise, i'll do asap!
     
    Makaveli likes this.
  73. buggage

    buggage Network Guru Member

    Just wanted to confirm that after upgrading the CFE and factory default, the client list functionality did indeed return, and everything's working properly once again.
     
  74. XVortex

    XVortex Addicted to LI Member

    Seems... the custom CFE becomes mandatory. or.... it's just a 1-2 different settings in NVRAM (CFE) area.
    It is interesting to find out what.
     
    Stimpy88 and Makaveli like this.
  75. Pierre Chartrand

    Pierre Chartrand New Member Member

    You are right, 384.11 show's clients when in AP mode, Router mode 384.11 show's no clients.
     
  76. Goned91

    Goned91 Network Newbie Member

    Look like CFE 1.0.0.0 work with 384.11...why is different in AP mode than Router mode ? @XVortex
     
  77. Pierre Chartrand

    Pierre Chartrand New Member Member

    Just finished checking 384.10_2 Network Map shows client count and Clients are showing in view list.
     
  78. ringlord

    ringlord Network Newbie Member

    If I am not mistaken in AP mode, the WAN port is the same subnet as the rest of the devices.
    In other words my R7000 has an ip-address (192.168.1.x) that is in the same subnet as all the devices connected to it and those listed in the client list.
    In router mode, the WAN port will have another subnet (assigned by the ISP), but not 100% sure about this...
     
  79. GDT78

    GDT78 Serious Server Member

    I just updated to 384.11 and custom CFE 1.0.2.1 modded with my settings. I didn't a factory reset but I get 0 clients issue on network map. The only way to get it working is to factory reset?!?
     
  80. Makaveli

    Makaveli Networkin' Nut Member

    Yes you have to factory reset.

    The good news however is you can save your settings and backup the jffs partition and restore after flashing.
     
    GDT78 likes this.
  81. VoYaGeRTM

    VoYaGeRTM Networkin' Nut Member

    Hello,

    I use stock CFE and in router mode.
    I still have network maps working.
    It allways worked for me in every ng firmware.

    Haven't installed the latest yet.
    Will try that somewhere this weekend.
    On 384.7 atm.


    Verstuurd vanaf mijn Mi A1 met Tapatalk
     
  82. Pierre Chartrand

    Pierre Chartrand New Member Member

    Hi
    After updating firmware to 384.11 zero client in list
    Just tried factory reset, after backing up configuration, and restore.
    Still same problem. No Client in list, also Client status keep searching , never finished
     
  83. Frank2

    Frank2 Networkin' Nut Member

    Does anyone know if Merlin/Xvortex uses port UDP 3478 for anything? I am running a Unifi controller in the cloud but I cannot fix a STUN error that uses port UDP 3478. I tried to port forward 3478, but no Joy. Thoughts?

    BACKGROUND: STUN stands for Session Traversal Utilities for NAT and includes a set of protocols used in networking to better handle communication when going through network address translation (NAT). In simple terms, STUN provides a way for devices to securely communicate with other devices when they're located behind a router. This is necessary because the devices in your network have individual IP addresses that are used to communicate internally, but not known to servers/clients outside of your network. STUN when used by a particular application, will go and initiate a connection with a public STUN server and request to know what address will be used by the STUN server to communicate with the device through its router.

    UniFi devices use STUN to properly communicate with the UniFi Controller. In this case, the controller acts as the STUN server. In order for STUN communication to work properly, the UniFi device must be able to resolve to the UniFi Controller via the inform URL and communicate with the address via port 3478.
     
  84. miroco

    miroco Serious Server Member

    Thank you Merlin and XVortex for the 384.11_2

    I upgraded the AiMesh node using WinSCP/Putty, since there is no "Check" button in the GUI on Xvrt-Vortex. SSH is however enabled.

    Turn off all the devices (router and nodes). Then start the node you want to upgrade. Assign a static ip-address to your computer, like 192.168.1.5 / 255.255.255.0 and connect an ethernet cable to a lan-port on the node.

    The node will use 192.168.1.1 / 255.255.255.0 even if you assigned different ip-range on your AiMesh combo.

    Using WinSCP, copy the firmware file to /tmp/home/root

    Through Putty:

    Run command: mtd-write2 firmware.trx linux && reboot

    The router you upgrade through the GUI as usual.

    P.S. I just ordered an Asus rt-ac86u :)
     

    Attached Files:

    Last edited: May 20, 2019 at 10:59 AM
  85. sn2018

    sn2018 Connected Client Member

    After updating firmware to 384.11, everything seems to be fine but zero client in list
    Did save config, factory reset, restore config. Still 0 client.
    Update CFE (from post 1 of this thread), factory reset, restore config, client count shows up in network map.
    While I am at it, update FW to 384.11_2.
     
  86. shanester

    shanester Serious Server Member

    I was on 384.10_2 and noticed that my client list was not accurate (missing hosts/IPs). I upgraded to 384.11 and as other members stated, the client list was zero.
    I updated the CFE to 1.0.2.1, followed the documented steps. The client list reappeared, but it is still not accurate.
    I have upgraded to 384.11_2 and have the same results. My client list shows 28, however I have at least 50 active clients validated through a simple IP scanner.

    Is this a bug in the firmware? Is there a setting that I may have overlooked that would prevent accurate results?
     
  87. Kees17760

    Kees17760 Network Newbie Member

    Hi,

    Does anyone know a way to change router's menu to Dutch? (it's not in the main screen's drop down menu)
     
  88. serarien

    serarien New Member Member

    Hi there!

    First of all, thanks for the great work done on Xwrt-Vortex! I've been using it for few years now and so far so good!

    I'm actually willing to make iPhone tethering work.
    After some researches, I found the module is not included in Xwrt-Vortex (I'm on 384.11_2 on a Netgear R7000).

    Code:
    admin@R7000-D7F7:/lib/modules/2.6.36.4brcmarm/kernel/drivers/net/usb# ll
    -rw-r--r--    1 admin    root         22368 May 18 12:18 asix.ko
    -rw-r--r--    1 admin    root         11052 May 18 12:18 cdc_ether.ko
    -rw-r--r--    1 admin    root          9176 May 18 12:18 cdc_mbim.ko
    -rw-r--r--    1 admin    root         19232 May 18 12:18 cdc_ncm.ko
    -rw-r--r--    1 admin    root         17376 May 18 12:18 qmi_wwan.ko
    -rw-r--r--    1 admin    root         12840 May 18 12:18 rndis_host.ko
    -rw-r--r--    1 admin    root         26584 May 18 12:18 usbnet.ko
    Also, I think it is included in default Asus-Merlin builds:
    github /RMerl/asuswrt-merlin/blob/master/release/src-rt/linux/linux-2.6/drivers/net/usb/ipheth.c


    The link to the module itself:
    github /dgiagio/ipheth


    Please tell me if I need to provide more information.
     
  89. swaaye

    swaaye Network Guru Member

    I think AP Isolation is not being applied to the Guest Wifi. When AP Isolation is enabled for both 2.4 and 5 GHz, a device on the guest wifi can scan for network clients and still find the router and other guest wifi clients.

    And I reverted to 384.10-2 for now so the network client list works. CFE 1.0.0.0.
     
  90. GDT78

    GDT78 Serious Server Member

    So if I backup settings/jffs, reset to factory settings and restore them all, should I be ok?
     
  91. Makaveli

    Makaveli Networkin' Nut Member

    Yes this is what I did and had no issue.
     
  92. Josh Skinner

    Josh Skinner New Member Member

    Have you, or anyone else, figured out a way to get the Client List working without updating to a custom CFE? Must be a bug in .11/.11_2
     
    riksterinto and Stimpy88 like this.
  93. morpheus6969

    morpheus6969 Addicted to LI Member

    There is obviously a problem with the client list, i'm sure it will get fixed at some point.
     
  94. DjonniDK

    DjonniDK Serious Server Member

    Despite the risk of sounding a little like a noob.
    WOL works beautifully, but Wake On Wan is a harder task. Static IP is set up, but as far as I can read, the R7000 on this (and many other) firmware does support ARP binding. Meaning that after a while of shutdown IP to MAC address is lost until it's powered on again. (don't want it to sleep/hibernate, as I have some software that doesn't play well with that after wake-up).
    I know everything works, as Wake On Wan works for a short while after shutdown.

    On firmware 380.70 as it's rock stabile for me. But would of course upgrade, if ARP binding is present.

    In any case, any feedback would greatly be appreciated.
     
  95. GDT78

    GDT78 Serious Server Member

    Worked for me, too.

    I tried to enable AiMesh but I can't connect to node with wifi. It's not clear to me how to connect with UTP from LAN to WAN.
     
  96. miroco

    miroco Serious Server Member

    @GDT78

    Let's assume you have 2 x R7000 units and want set them up as an AiMesh and you have made the necessary nvram settings "nvram set amas_force=1" followed by "nvram commit" on both of the units. Se user @djgodlike's guide.

    I started out by first preparing the node. Under "Administration - Operation Mode" you will now have a few new settings to choose from, amongst them "AiMesh Node". That's your pick. At the end of this process you will see a big blue status bar advancing from left to right. At that point you can turn your attention to the router. Replicate the setting you made on the node on the router, with the exception of choosing "Wireless router mode / AiMesh Router mode (Default)" instead.

    It's at this point you shall connect the network cable (UTP) to one of the LAN-ports on the router with the WAN-port on the node.

    The AiMesh nvram settings also fitted the "Network Map" pane on the router with a new big round button with the AiMesh symbol on it. Press it and then the "Search" button in the top right corner. If everything is working out for you, you should almost instantaneously see a rotating progress indicator in a rectangle showing that it found your node and that it’s about to set it up. The process can be rather finicky at times, but as @djgodlike pointed out; "After I waited a couple minutes I connected the Node by UTP from LAN (router) to WAN (node) and tried searching for a node and found one..."

    When you are done with the setup, you can hopefully remove the backhaul cable "UTP" from the setup. That of cause depends on the distance between the 2 units / obstructions due to adverse building materials impeding / dampening GHz radio signals.

    Make sure you are on a recent firmware version. I'm on 384.11_2 myself.

    Good luck
     
    Last edited: May 22, 2019 at 9:06 PM
    slidermike and Makaveli like this.
  97. wans10

    wans10 New Member Member

    Can I install R7000 XWRT-Vortex firmware on the Netgear R6400 ? If so,how do I do it?
     
  98. GDT78

    GDT78 Serious Server Member

    Thank you for answering.
    I already enabled AiMesh with nvram set amas_force=1 on both routers. I tried to connect the node with wifi and not UTP because my main router is currently sited on a wardrobe and it's a bit tricky to reach it.
    I run into the error reported by @djgodlike with wifi, so I suppose I need to make them connect with UTP for the first time, I have no chance to use Wifi...
     
  99. riksterinto

    riksterinto Networkin' Nut Member

    I tried the Asus Android app and oddly every device is listed twice in the app while web front page shows 0 connected. I don't see anything obvious missing in my nvram that isn't in the custom cfe. Maybe something extra in the nvram is causing the problem. Doesn't seem to affect other functionality though.
     
  100. Kees17760

    Kees17760 Network Newbie Member

    Anyone?
     
    Last edited: May 24, 2019 at 7:14 AM
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice