Asuswrt-Merlin on Netgear R7000

Discussion in 'Other Firmware Projects' started by XVortex, Mar 27, 2015.

  1. mito

    mito Network Guru Member

    BTW, i have same signal as Netgear default firm at same place at home with XWRT on 2.4Ghz at 38% and 5Ghz at 49%.
    If i go higher the signal stays the same and if very high the signal lowers.
     
  2. MrDoh

    MrDoh Addicted to LI Member

    So why not start there as a default, then? Users can always lower it if they don't need the default. Just curious what your thought process is here?
     
  3. Entasis

    Entasis Network Newbie Member

    Me too. These staggered settings work quite well with my setup as I use a EX6200 extender as well.

    I'm a very early adopter of the R7000, and have used DD-WRT firmware with success (plus, I'm very thankful to Kong and BrainSlayer) but this collaboration between Merlin and Vortex has produced the Goldilocks R7000 firmware. Set it and forget it...my life, and residence, hasn't been this calm for a long time regarding wireless. Thank you, thank you, thank you!
     
    myersw and mito like this.
  4. mito

    mito Network Guru Member

    Agree 100% !
     
  5. MrDoh

    MrDoh Addicted to LI Member

    I'm back on tomato ARM for the R7000...working well for me, and includes IPv6 functionality. I want to support and use firmware where IPv6 works, even though I don't really need it at this time. I'll try this one again when it supports IPv6 for me on Comcast, but do use this firmware on my Asus RT-AC68P where it works really well (and so does IPv6) *smile*.

    However, this firmware does work well on the R7000, quite an achievement. And Xvortex has responded to problems graciously and promptly. Good stuff!
     
    mito likes this.
  6. cybrnook

    cybrnook Addicted to LI Member

    Confirmed, I used XVortex's advice on Netgears addressing schema.

    these are variables I set in mine:
    et0macaddr=00:90:4C:0F:F1:A2 (same as et0macaddr pulled from original CFE, fake mac used for this example)
    pci/1/1/macaddr=00:90:4C:0F:F1:A2 (same as et0macaddr)
    pci/2/1/macaddr=00:90:4C:0F:F1:A1 (same as et0macaddr, with -1 for the last digit. So instead of 2, I have 1)
    secret_code=XXXXXXXX (Created my own unique 8 digit PIN for WPS) - Even though I won't use it. (not X's)
    serial_no=XXXXXXXXXXXX (Set to my unique serial number, again not just X's)

    @XVortex , I notice in the editor for the CFE, we have the ability to add line items. Do we have the ability to set static variables, instead of having them created dynamically on the firmware load.

    For example, pre-defined in the CFE:

    pci/1/1/ccode=#a
    pci/2/1/ccode=#a


    If I were to also add the line items:

    wl0_country_code=#a
    wl_country_code=#a
    wl1_country_code=#a

    And modify all to US instead of #a, would your custom firmware by default load as US? I know you have implemented a dynamic load of the #a country code, and then we just manually change the nvram variable. If I was to do the above and pre-define:

    wl_country_code=US
    wl0_country_code=US
    wl1_country_code=US
    pci/1/1/ccode=US
    pci/2/1/ccode=US

    1, would the CFE accept new static variables such as "country_code" which are not native to the provided CFE.
    and
    2, would the firmware default to the CFE values upon flash and load, or would it still load #a in your custom build, needing manual adjustment?

    !!This is all based off the custom Asus CFE!!

    Thanks in Advance,
    Hans
     
    Last edited: May 31, 2015
    myersw likes this.
  7. tigs

    tigs Network Guru Member

    I am still losing wifi connection from time to time. I was streaming music and all of a sudden lost connection (blackberry playbook). It reconnects by itself afterwards. My wife also complained about losing connection from time to time (iphone 5S).

    Having thought it was 2.4GHz specific issue, I have turned off the 2.4GHz completely. It happens to the 5GHz as well.

    I wonder how you guys set the wifi with 2.4GHz and 5.0 GHz simultaneously. If i set both on the same SSID, would that solve the problem? Is this what simultaneous dual bands is supposed to do?
     
  8. Kasper

    Kasper New Member Member

    Mine are 2 separate SSID's and I have manually picked the channel's and frequency for both bands. Have you manually selected channels and frequency?
     
    slidermike likes this.
  9. slidermike

    slidermike Addicted to LI Member

    +1
    Same here.
    Troubleshooting random wifi is difficult.
    Could be the router, could be power, could be the location of the router, could be a neighbors wifi, Bluetooth or cordless phones, could be microwaves. Could be a combination of triggers.

    You really have to narrow it sow to what you can prove is occurring when it happens each time and slowly you should see 1 or more constants.
     
  10. decompiled

    decompiled Reformed Router Member

    Anyone else have the wired graph working? I have tried CFT on and off but nothing displayed for wired. Ethernet and Wifi both working for me.
     
  11. Sky1111

    Sky1111 Network Newbie Member

    Guys, I run into a strange problem: when utorrent is running, I cannot watch movies from a different PC on my network using Airvideo on a iPad-mini2. Basically video stops every 2-3 seconds and buffers; I came with iPad to the router - same problem (so it was not the wireless signal).

    As soon as utorrent exits, on the same iPad mini I can watch the same and all other content with no problems.

    CPU usage on the router did not go beyond 30% per core at any time.
    I am running VPN client with selective IR routing; the source PC and iPad are not on VPN

    I did not have this problem with DD-WRT. Any thoughts?
     
  12. mito

    mito Network Guru Member

    Never had not only one disconect since upgraded with Xvortex, just now finished watching three chapters at Netflix on 5Ghz at 12 meters from router and two concrete walls with two doors open, while wife is at her comp with her emails and music also at 5Ghz, Tx 49%
    BTW, two different SSID.
     
    Last edited: May 20, 2015
  13. r7kr63

    r7kr63 Reformed Router Member

    I had the same issue as you had. from a wireless settings perspective, this is how my radios are set. Also, I have pulled back on the TX for 2.4 and 5ghz, as I am in close proximity to the router, but covers my whole environment. I have turned off 2,4ghz radio, but, this is how it was set, before turning the radio off. Label radio SSID's so that you can distinguish between 2.4ghz and 5ghz. With these settings none of my wireless devices drop, ever..

    -------------------------

    Band 2.4ghz - PROFESSIONAL
    Enable Radio Yes No
    Set AP Isolated Yes No
    Roaming assistant DISABLE
    Enable IGMP Snooping DISABLE
    Multicast Rate(Mbps) AUTO
    Preamble Type SHORT
    AMPDU RTS ENABLE
    RTS Threshold 2347
    DTIM Interval 3
    Beacon Interval 100
    Enable TX Bursting ENABLE
    Enable WMM APSD DISBALE ( You can try either on or off)
    Reducing USB 3.0 interference ENABLE
    Optimize AMPDU aggregation DISABLE
    Optimize ack suppression ENABLE
    Turbo QAM ENABLE (WIRELESS MODE must be set to auto)
    Airtime Fairness DISABLE
    Explicit beamforming DISABLE
    Universal Beamforming ENABLE
    Regulation mode OFF
    Tx power adjustment around 20-35 %

    ---------------------------

    Band 2.4ghz GENERAL
    SSID
    Hide SSID Yes No
    Wireless Mode AUTO *RE: TURBO QAM above
    Channel bandwidth 20/40MHZ
    Control Channel 1 (this channel works well for me)
    Extension Channel
    Authentication Method WPA2-Personal
    WPA Encryption AES

    -------------------

    Band 5GHZ Proffesional
    Enable Radio Yes No
    Enable wireless scheduler Yes No
    Set AP Isolated Yes No
    Roaming assistant DISABLE
    Enable IGMP Snooping DISABLE
    Multicast Rate(Mbps) AUTO
    Preamble Type SHORT
    Fragmentation Threshold 2346
    AMPDU RTS DISABLE
    DTIM Interval 3
    Beacon Interval 100
    Enable TX Bursting DISBALE (for 2.4ghz only)
    Enable WMM ENABLE
    Enable WMM No-Acknowledgement DISBALE (this made samsung and iphone drop connections when enabled)
    Enable WMM APSD DISBALE (same as 2.4ghz)
    Optimize AMPDU aggregation DISABLE
    Optimize ack suppression ENABLE
    Airtime Fairness DISABLE
    802.11ac Beamforming DISBALE
    Universal Beamforming ENABLE
    Regulation mode OFF
    Tx power adjustment 18% (I am in a small area. Not too far from router. Covers my environment completely).

    ----------------------

    Band 5 GHZ GENERAL
    SSID
    Hide SSID Yes No
    Wireless Mode N/AC MIXED
    Channel bandwidth 80
    Control Channel 132 (works on my area)
    Extension Channel AUTO
    Authentication Method WPA2-Personal
    WPA Encryption AES

    EDIT: Forgot to add. When I make wireless changes, I always boot the router after changes, even if it looks like the router rebooted itself. You may want to also reboot your wireless devices when you are all done making changes on the router..
     
    Last edited: May 20, 2015
    tigs and harrykh like this.
  14. r7kr63

    r7kr63 Reformed Router Member

    Have never seen any traffic on wired. Just WAN and wireless
     
  15. myersw

    myersw Network Guru Member

    @cybrnook
    Thanks for your clear write up for the MAC address entries if installing the modified CFE. Nice to have clear examples for us klutzes. I always liked how Asus had made it hard to brick one of their routers. With the modified CFE I can have that on my r7000. Only downside is having to reinstall the OEM CFE if I want to go to the OEM firmware. Not sure why I would want to do that with XVortex firmware available as well as the other 2, Tomato and DD-WRT.
    --bill
     
    kamaaina and cybrnook like this.
  16. cybrnook

    cybrnook Addicted to LI Member

    But to also confirm a quote from XVortex "Asus (XWRT) firmware calculates (from et0macaddr) and overwrites both WiFi mac addresses.", he said that this build is calculating pci1 and pci2 off of macaddr (et0). Which I just verified, because even though in my CFE I have pci2 as:

    pci/2/1/macaddr=00:90:5D:0F:F1:A1

    When i check in nvram, I have:

    admin@NETGEAR-SR71:/tmp/home/root# nvram show | grep pci/2/1/macaddr

    size: 45567 bytes (19969 left)
    pci/2/1/macaddr=00:90:5D:0F:F1:AB

    So you can see it is in fact using its own MAC, not whats defined as seen by using B instead of 1 for the last digit.

    However, if you were to switch to DD-WRT or Tomato, I am sure it would use the CFE variables.
     
    Last edited: May 20, 2015
  17. cybrnook

    cybrnook Addicted to LI Member

    I suspect likely your main problem is the default country code for this custom firmware is #a, wich basically means all countries channels, and no power restrictions.

    The issue is if you leave your channels (2.4 and 5.0) on "AUTO", then it is likely going to dynamically switch at some point in time to a channel that your clients wont support. So is best to set your country code with the scripts (or just manually input them into nvram), and then also manually set 2.4 and 5.0 to run on a specific channel and width.

    (Lot's of good info can be found just by starting on page one and reading through this thread)
     
  18. tigs

    tigs Network Guru Member

    Thank you: @Kasper @slidermike @mito @cyrnook and especially @r7kr63 for your lengthy write up. I will further experiment on this.

    I have been using fixed channels for both bands (6 for 2.4 and 149 for 5GHz).

    @cyrnook

    i think your country code point makes a lot of sense. I hope this can be hard-coded into the custom CFE. thanks
     
    cybrnook likes this.
  19. cybrnook

    cybrnook Addicted to LI Member

    @XVortex @RMerlin , donation sent to both Roman and Eric, thanks for everything guys.
     
  20. XVortex

    XVortex Addicted to LI Member

    Much appreciated. Thanks.
     
    cybrnook likes this.
  21. Diverge

    Diverge Networkin' Nut Member

    Waves @XVortex

    I might have to try this firmware on my R7000. That would make 2 devices that have firmware you've had a helping hand in creating. My NAS and my router.
     
  22. Seal Wolfy

    Seal Wolfy Serious Server Member

    I have a thumb drive inserted on the back of the R7000 router (USB 2.0). Is there a way to access from Windows 7? any help is appreciated. Thanks.
     
  23. tigs

    tigs Network Guru Member

    enable "Network Place (Samba) Share / Cloud Disk" under USB application/Media Services and Servers

    You can create users/password under samba with specific access permission. pay attention to "work group", it has to be the same as the computer you are accessing the drive from.
     
  24. Johnathon

    Johnathon Connected Client Member

    Question,

    Is there any advantage in using a different region for your router config (e.g. setting up to use EU vs United States)? Just curious, I recall some talk about using Singapore awhile back because it had higher transmit power? I apologize for my limited knowledge, just been curious.

    Thank you.
     
    tigs likes this.
  25. Seal Wolfy

    Seal Wolfy Serious Server Member

    Thanks
     
  26. Seal Wolfy

    Seal Wolfy Serious Server Member

    Can I ask how to enable IPTraffic monitoring to a usb flash drive? Thanks
     
  27. MrDoh

    MrDoh Addicted to LI Member

    You might take a look at this posting...there's further discussion after that as well (note that the actual numbers are for an earlier release of tomato ARM, not XVortex, but maybe food for thought and playing *smile*):

    http://www.linksysinfo.org/index.php?threads/tomato-for-arm-routers.69719/page-9#post-250697

    Hope that this helps you!
     
  28. kamaaina

    kamaaina Serious Server Member

    Setting it to Europe or Singapore also gives you additional channels 12,13, and I believe even 14 in SG for 2.4 GHz, which you should not use in the first place (stick to 1,6, or 11). I recall as well that for Tomato on the 7000 setting SG and zero for tx meant max power for 5G but that might have been early versions. Somebody recently posted somewhere that Anguilla now seems to boost 2.4 ghz a bit more on Tomato. Not sure if this applies here. Seems above 2 posters stated settings that give similar to stock tx range, I would follow that.

    Haven't had a change yet but will probably try this FW soon.
     
  29. cybrnook

    cybrnook Addicted to LI Member

    Delete
     
    Last edited: May 31, 2015
  30. BillTech

    BillTech New Member Member

    Hi whats the ipv6 issue i have comcast and loose my ipv6
    might try the tomato but i sure like this one will it be fixed anytime soon?
     
  31. cybrnook

    cybrnook Addicted to LI Member

    Okay, so what I noticed about the traffic monitor (and I assume this is a @RMerlin thing), is when the system is idle, Wired reports accurately (Notice the range of the graph's Y axis):
    [​IMG]


    But as soon as you put a load on your line, the graph opens up, and your graphical representation of your network usage seems to no longer work (out of bounds or something on both wired and wireless it seems):
    [​IMG]


    Post #350 over in Merlin's thread says it's also not just us:

    http://www.snbforums.com/threads/asuswrt-merlin-378-53-is-now-available.24172/page-18#post-183366
     
    Last edited: May 24, 2015
  32. MrDoh

    MrDoh Addicted to LI Member

    I'm also on Comcast, as I mentioned in previous posting. IPv6 does work with tomato ARM (Shibby v129), though. Tomato ARM even filters ICMPv6 packets as it should, according to the online "IPv6 connectivity and speed test", gets 19/20.

    An afterthought, for tomato ARM, adding these 2 commands to your firewall script ("Scripts" in the admin GUI under "Administration") should be helpful for IPv6 on Comcast:

    echo 0 > /proc/sys/net/ipv6/conf/`nvram get wan_iface`/forwarding
    ip6tables -A PREROUTING -t mangle -p icmpv6 --icmpv6-type neighbor-solicitation -i vlan2 -d ff02::1:ff00:0/104 -j DROP
     
    Last edited: May 23, 2015
    Johnathon and BillTech like this.
  33. Michael Pryor

    Michael Pryor New Member Member

    Man this is really really good AND stable. Thank you so much. If you've used the stock, ddwrt or anything else, get ready because this knocks it out of the park.
     
    Last edited: Jun 15, 2015
  34. madbiker

    madbiker New Member Member

    I installed v378.53_0 a few days ago and I'm very satisfied with it. I still have a question regarding the adjustment of WIFI power: unlike some posts above I do not want to increase power output, I would rather lower it, but far as I can tell changing the setting in wireless>professional does not seem to have any perceptible effect. I reduced the level down to 1% (the minimum possible) and all my clients still see the same level. As anyone observed the same thing?
     
  35. slidermike

    slidermike Addicted to LI Member

    Glad you too are enjoying XVortex work Mike.
    I donated weeks ago but I don't generally go outside and tell everyone I just spent some $.
    :)
     
  36. myersw

    myersw Network Guru Member

    XVortex is the best firmware I have used on my r7000. I have also donated many weeks ago. ;)
    I am bummed that my router lost power because the electric company was replacing a pole. Yes I know about UPS's. Lost how long router had been up, which was since I had installed 378.53, which was when it became available. Now up for 4 days.
    --bill
     
  37. TC777

    TC777 Networkin' Nut Member

    Thank you for this firmware, so far I like it a lot. It has the things in it that were always missing in the Asus firmware. I am using it with my R7000. Especially the live wireless client connection strength.
     
  38. Jazzeyman

    Jazzeyman Network Newbie Member

    In general, how does the range of 2.4GHz and 5GHz wireless using the Vortex firmware compare to the stock Netgear?
     
  39. myersw

    myersw Network Guru Member

    For me the range is better. Plus you can adjust xmit power setting. Every wireless situation is unique so your experience may be different, but most folks report an improvement. If you do install, note the suggested xmit sitting that XVortex suggests on the first post where the links to the firmware are. Mine are set to 40% both bands.
    --bill
     
  40. Jazzeyman

    Jazzeyman Network Newbie Member

    Thanks, I'll give it a try.
     
  41. mito

    mito Network Guru Member

    I tested almost every firm for r7000, you can watch mi post #601 the first at this page, replaying someone who asked similar questions.
    I arrived to that numbers after testing one by one with client at same site. As Myersw says, every wifi spot is different.
    Just my 2cts.
     
  42. madbiker

    madbiker New Member Member

    Yes, the range is very good. However on my router, changing the txpower through the GUI seems to have no effect (even after reboot): The readings of "wl -i eth1 txpwr1" or "wl -i eth2 txpwr1" is always "TxPower is 127 qdbm, 31.75 dbm, 1496 mW Override is Off"

    Moreover if set a ridiculously low power through the command line:
    # wl -i eth2 txpwr 1
    (and the same same on eth1)

    then power is supposedly reduced:
    # wl -i eth2 txpwr1
    TxPower is 0 qdbm, 0.0 dbm, 1 mW Override is Off

    but my clients still receive the same level as before...

    So can we really tune the txpower on Xvortex's build or is it always going at full blast? Is this a problem specific to my router? Did I miss something?
     
  43. myersw

    myersw Network Guru Member

    @madbiker
    You have obviously done some testing of xmit power settings on this firmware. Would be nice to hear from the developer as to whether the GUI should make, and more importantly, does make a change and you are some exception as happens with these firmwares.

    In my case my wireless connections, 2.4 and 5 seemed to work better when I reduced to 40% from the default 100%. Have no firm measured facts to back this up. My thought was that the 100% was causing distortion in the wireless signal and reducing made it better.

    --bill
     
  44. XVortex

    XVortex Addicted to LI Member

    You should test tx power by:
    wl txpwr_target_max
    command.
    Asus fw does not set tx power directly anymore.
     
  45. madbiker

    madbiker New Member Member

    Hi XVortex,

    You guessed correctly that I do not fully understand how this "wl" command is supposed to be used; the built-in help is limited and not that helpful... Do how have a link to a better documentation?

    Anyway, after setting
    # wl -i eth2 txpwr 1
    (and the same same on eth1)

    I get :
    # wl -i eth1 txpwr_target_max
    Maximum Tx Power Target (chanspec:0x1804): 1.00 1.00 1.00
    # wl -i eth2 txpwr_target_max
    Maximum Tx Power Target (chanspec:0xe09b): 1.00 1.00 1.00

    And, as I said previously, this does not seem true according to what my wifi clients see.

    In any case this power setting problem is a minor one (wifi works very well, after all) and I want to thank you for your work that brought us this great firmware for the R7000!
     
  46. Nekonen

    Nekonen Serious Server Member

    Btw, is the IPV6 support in this firmware completely broken or does it work only in certain situations? The reason why I'm asking this is because my ISP is going to start supporting native IPV6 in their network really soon and I'm tempted to upgrade my current router to R7000 since it seems to offer quite amazing performance with XWRT.

    However, if the IPV6 support is totally broken and unlikely to be fixed, my next best choice for a new router would be Asus RT-AC68U with RMerlin's firmware, right?
     
  47. XVortex

    XVortex Addicted to LI Member

    Please wait for the next version. Merlin have changed many ipv6 things in upcoming release.
     
    harrykh, William Clark and cybrnook like this.
  48. Marvin123

    Marvin123 New Member Member

    I have an extremly slow VPN Connection with the latest asuswrt-merlin fw. PPTP. Anyone else? FritzBox VPN works perfectly.
     
  49. cybrnook

    cybrnook Addicted to LI Member

  50. XVortex

    XVortex Addicted to LI Member

    CFE variables is just a default variables that used for factory defaults or after reset.
    wl*_country_code are calculated vars. it populated by firmware. these vars will be overwritten.
     
    cybrnook likes this.
  51. cybrnook

    cybrnook Addicted to LI Member

    Then have you noticed ther are two variables that are ignored after reboot when attempting to be set in nvram (from your scripts), those are:

    wl0_country_code=
    wl1_country_code=

    When trying to set these on the latest firmware to anything other than #a (US in my case) they default back to #a after reboot.
     
  52. XVortex

    XVortex Addicted to LI Member

    wl0_country_code and wl_country_code copied from pci/1/1/ccode
    and
    wl1_country_code copied from pci/2/1/ccode
    so
    if You want to permanently set your region just edit pci/*/1/ccode variables by CFEEdit.
     
    myersw and cybrnook like this.
  53. myersw

    myersw Network Guru Member

    Noticed what I think is odd behavior in the traffic monitor. Last night I was watching a movie via dlna from my NAS which is hard wired to the r7000. Was viewing via a Roku box which is connected on the 2.4 channel. When viewing the traffic monitor today I noticed that the traffic was showing up on the wireless as expected, but have 2 unexpected things in the monitor. One there is no wired traffic showing, which has been reported previously, and the other is the traffic shows up as WAN traffic. Showing as WAN traffic will throw off the total datly and monthly traffic stats, I think, as I thought they were supposed to be showing only the WAN traffic. In other words traffic that is going to and from Internet connection.
    Here are 2 files showing what I am seeing.Router-traffic is showing the 2.4gig traffic graph and traffic-wan is showing the WAN tab
    --bill
     

    Attached Files:

  54. Kartik

    Kartik New Member Member

    I have installed the Netgear R7OOO v378.53 firmware and I had the below queries.

    1. I do not find the option to change the region from the GUI, is there a way to check the current region from the CMD and set it ?

    2. Is there a way to have the traffic meter just like the Netgear Stock which gives the date and option to set monthly limit as per MBs. ? This is quite important for me because of my ISP since there is a FUP limit on downloads and sometimes they show increased data and reduce the speed, the netgear traffic meter actually has helped me fight them on this.

    3. There is a limit while setting the router password, can this be increased, If yes then how ?
     
  55. FallOut

    FallOut Connected Client Member

    @XVortex or anyone else

    I came across this thread and it is really fascinating, I don't know if this is the right place to ask, but it seems to have some people talking about the CFE. I have a non-working AC-68-P (or AC6-8-U can't remember which exactly, have to go look) and got an R7OOO as a replacement for it, but I miss the ability to run pure (none RMerlin) Asuswrt, if I were to copy everything from the old AC-68-P router (MAC address, serial number, boardname, etc...) to the CFE provided by @XVortex would I be able to install and run Asuswrt firmware directly without modding anything? Or would I just brick my router?

    Maybe I can just install the AC-68-P CFE directly off the broken router?
     
  56. cybrnook

    cybrnook Addicted to LI Member

    I belive your question has been answered earlier in the thread, but you would brick your router. The custom CFE is only to allow the R7000 to run this custom merlin version. As well, at this point custom CFE is no longer needed.
     
    FallOut likes this.
  57. tigs

    tigs Network Guru Member

    If asuswrt-merlin can be patched to work with R7ooo, why can't asuswrt be patched to work with R7ooo? The question is why. Merlin has everything asuswrt has and more.

    As far as I know the custom CFE only adds some brick proof feature to R7ooo, it does not convert it to a native Asus router. Moreover, you lose the ability to use native netgear firmware. However, Xvort has created a patched version of netgear FW that works with the custom CFE if you ever need to revert. There is no need to reflash the CFE.

    let me see if I can summarize this as this gets asked quite often. In order to run xvort on R7ooo, you do NOT need the custom CFE. You can flash the router directly with one of the xvort versions.

    If your router is running netgear OEM FW, flash the CHK version within the netgear GUI directly.

    If you are running anything else (dd-wrt, TomatoUSB or an older version of xvort), flash the TRX version within the GUI.

    if you are coming from dd-wrt, BE aware that the login info under dd-wrt are encypted. You may (or may not, I did not test) experience difficulty logging in after you flash xvort (and certainly, Tomatousb). I would recommend going back to netgear OEM first, then flash the xvort. There should not be a problem coming from Tomatousb.

    To leave xvort: if going to tomatousb, you can flash any tomatousb directly within xvort. To go back to netgear, you have to use the special version of netgear FW first, then upgrade to the latest netgear FW. The special back-to-stock FW is also a TRX file. You can not go back to dd-wrt directly as xvort does not take BIN files or CHK files. You have to go to either stock or tomatousb first.

    There is a custom CFE created by Xvort. you do NOT need to flash the custom CFE in order to use xvort. The custom CFE has advantages and disadvantages:

    Advantage: (by @XVortex )
    1) reset nvram - press wps (right button) while powering up the router till power led start rapidly flashing.
    2) push reset button while powering up till power led start slowly flashing to enter emergency web recovery mode.

    (It behaves like an Asus router, but it is not. It does not take native auswrt FW, just like it does not take native merlin FW)

    Disadvantages:
    You will not be able to run native netgear FW anymore. The FW will have to be patched in order to run on the custom CFE flashed routers. HOWEVER, @XVortex have just done that, he created a version of netgear FW that can run on the custom CFE routers. If you ever want to go back to stock, you do not have to re-flash the stock CFE, just flash the patched version and it is fairly current.

    please comment @XVortex I will try to correct after.
     
    Last edited: Jun 1, 2015
  58. cybrnook

    cybrnook Addicted to LI Member

    Delete
     
    Last edited: Jun 1, 2015
  59. TC777

    TC777 Networkin' Nut Member

    This firmware appears to be working better with the 3 Xbox Ones we have in our house playing the Destiny game. Unless Bungie changed something, which I doubt, we haven't been getting booted to orbit many times per night doing Strikes, like we used to before using this firmware.

    (I should add that the reason we have 3 Xbox Ones is just due to having another family living in the same house)
     
  60. Frank2

    Frank2 Networkin' Nut Member

    Myersw, I used to love my DD-WRT WAN traffic graph until I found out it ate up all my NVRAM. I now use my ISP traffic graph (for WAN traffic). On Time Warner and Cox you can see what you use on a daily/monthly basis. I only mention this because regardless of what your router tells you, you are capped/billed by what your ISP sees (vice your router). Just my $.02.
     
  61. FallOut

    FallOut Connected Client Member

    Thanks @tigs and @cybrnook, I appreciate both your replies.

    To be honest, the reason I wanted pure Asuswrt was to avoid having to wait sometimes for the modded version to be released, right now it goes through several people (RMerlin and XVortex). It would just be easier to download and flash, but it's true I might end up running the RMerlin version anyway.

    Since my last post, when I just wanted an easy way to download Asuswrt directly and flash it, I have been thinking a lot about it and now my curiosity is piqued, not because I need either the brick proofing or any of the other features, it's just more of a challenge now to see if I can actually do it. I don't mind losing the official Netgear firmware support, I checked the hardware and besides a different PCB most parts are identical between R7OOO and AC-68-P, so it seems feasible unless there is something about the CFE I don't get?

    So I'd like to ask @XVortex another question then, how did you make the custom CFE? Would you mind telling me here or on PM? I'd love to have a go myself and see how far I can get :)
     
    uridium64 likes this.
  62. myersw

    myersw Network Guru Member

    @Frank2
    So far my ISP, ATT Uverse, is not capping nor are they providing a way to see how much traffic you are using. I was pointing the traffic monitor stuff out to say this does not look right and could throw someone off who was depending on it for ISP caps. Since all of the traffic I was seeing at the time was between Ethernet port and wireless port it should be handled by the switching hardware/firmware and not seen by the WAN interface.
    I off load the traffic info onto a flash drive for storage so not worried about running out of NVRAM.
    --bill
     
  63. uridium64

    uridium64 Connected Client Member

    I've seen the idea with the custom CFE first in tigs post in this thread. TBH, I'm really interested in a custom CFE, since I have purchased an used Netgear EX7000 by an auction, which is quite similar to the R7000. I'd like to have a custom CFE on it first, so I can easily play around with the (smaller VPN-)images for the R7000. No need to hurry though, I'll receive the EX7000 not until the next weekend.

    I have mostly Asus routers around, which have all already a CFE. It's very comfortable and bricking a router is much harder than usually. I'm flashing the routers often within the CFE.
     
  64. tigs

    tigs Network Guru Member

    For those who would like to venture the custom CFE route, these are some cautionary points/steps:

    1. the router has to be accessible via SSH/telnet, meaning it can not be running the stock FW.

    2. Carefully study @jernau post #57

    3. make a backup of your stock CFE

    4. Modify the custom CFE provided by @XVortex to reflect your router's MAC addresses. The native netgear CFE uses a unified MAC address, which really has no use in this process. Find out your LAN address through your current GUI (either ddwrt, tomatousb, stock or xvrt). Ignore all wireless adapters' MAC addresses. All it matters is the LAN address. The firmware will calculate MAC addresses for the wifi based on the LAN address.

    I copied all the three different addresses shown on the DD-WRT status page to the respective fields in the custom CFE. You can also follow @XVortex's formula:

    et0macaddr is LAN
    pci/1/1 is lan mac+1
    pci/2/1 is lan mac+2

    @jernau followed this:

    ETH0 mac as et0macaddr & pci/1/1/macaddr and eth2 as pci/2/1/macaddr


    The following are the schemes how netgear and asus FW calculate wifi mac adddresses based on et0macaddr set in the CFE:

    1) Netgear:
    et0macaddr=LAN_MAC_Address
    pci/1/1/macaddr=et0macaddr
    pci/2/1/macaddr=et0macaddr-1

    2) Asus:
    et0macaddr=LAN_MAC_Address
    pci/1/1/macaddr=et0macaddr
    pci/2/1/macaddr=et0macaddr+4


    Regardless how you set your mac addresses in the custom CFE, the xvrt will calculate based on the et0macaddr address. The LAN address will be the et0macaddr, the 2.4GHz is the same as LAN, and the 5GHz will be LAN address + 4.

    I would recommend using different mac addresses for the three interfaces, either copy what is there in the DD-WRT or follow @XVortex formula.

    The rest are fairly straight forward: pick up your screte_code, the serial_number (optional), country code (optional) etc.

    Follow the instruction to flash the CFE.

    I used WinSCP to move the "custom CFE, flash-cfe.sh and mtd-write" to "/tmp/home/root". upon loging in, you will be in this directory. The flash-cfe.sh is a script. take a look at its content making sure the name of your custom CFE is the same as the one used in this script. Or do it manually in two steps:

    chmod +x ./mtd-write
    ./mtd-write -i new-cfe.bin -d boot

    new-cfe.bin is the name of your custom CFE.

    Pick a good time of the day when power disruption is less likely. Factory reset afterwards.

    Correct me anyone if any errors, I will update it afterwards.
     
    rotorbudd, blaedd, cybrnook and 7 others like this.
  65. Xephor

    Xephor New Member Member

    Hey tigs, great job on the how-to, I was able to flash the custom CFE successfully!

    I did use different commands to make this process easier for me:
    (these were taken from the T-Mobile Cellspot Router slickdeals page)

    Backing up CFE directly to USB command:
    cat /dev/mtd0 > /tmp/mnt/USB_NAME/original_cfe.bin

    To find USB name (if it isn't labeled, like mine):

    cd /tmp/mnt/
    ls

    then

    cd USBNAME

    I flashed the modified CFE off my USB w/o copying anything to router, which I did by cd'ing to my USB first before entering the write command you posted: cd /tmp/mnt/USB_NAME/
     
    myersw likes this.
  66. Frank2

    Frank2 Networkin' Nut Member

    I know you don't have an exact date, but is Merlin scheduled to put out a new release in the next few months, weeks?
     
  67. slidermike

    slidermike Addicted to LI Member

    That's a Merlin question really, not an VXortex question.
     
  68. Frank2

    Frank2 Networkin' Nut Member

    Absolutely. Just wondering if anyone in the forum knew the answer.
     
  69. Super_Mario

    Super_Mario Serious Server Member

    Dear VXortex & Merlin,
    I´m new here I has been using the R7000 since more than 1 year it is a nice device, but was missing something and that something is this Wonderful Firmware oh yeah!!! Thanks!!!

    Now I have a question, I´m trying to setup some Virtual Server / Port Forwarding ports for some specific Devices and Applications that I use mainly my Synology NAS and one IP camera, but when i add the the Rule to the Table List is added correctly and when I hit Apply it saves the data and then it refresh and it show: No data in table.

    Any ideas?

    Thanks
     
  70. RMerlin

    RMerlin Network Guru Member

    Probably weeks. Unsure yet, I'm currently evaluating the 378_6065 GPL code released only yesterday to determine if I want to delay release until I'm done merging + adapting it (a lot of changes in it versus 5123), or if I want to finalize the current 378.54 release and delay the merge until 378.55. It will also depend on how soon Asus will deliver the same GPL code for the MIPS-based models (as there's quite a few kernel changes in this release). I'll know more once I've spent more time studying the new code, so for now, I don't have any more precise ETA.
     
    cybrnook, William Clark and makpr like this.
  71. slidermike

    slidermike Addicted to LI Member

    I use virtual server/forwarding and it works well on my R7000.
    Maybe you should try rebooting the router or a reset to defaults and try again.
     
  72. harrykh

    harrykh Network Guru Member

    Hi, this fw sounds like it has everything I need. I flashed this way from the latest Netgear stock firmware:

    1. Restored defaults configuration using the stock GUI.
    2. Flashed merlin latest .chk file.
    3. Restored defaults using the new merlin GUI.
    4. Set both radio TX to 40%.

    Now everything seems to work but I get very very slow internet. Before I can do 50mbps/5mbps now download/upload are both...I kid you not, <1mbps.

    Also I notice my WAN IP is local 192.168.2.25 instead of my actual WAN.

    Is there anything I should do? I'm on Rogers Canada, Cable internet.

    Any help please, Thanks!
     
  73. slidermike

    slidermike Addicted to LI Member

    harry, I would reset to default again. Power cycle the router AND modem.
    I would not proceed with reconfiguring all the other stuff if your WAN interface is showing an invalid scheme.
    192.168.2.x is a private IP and should not be on the internet.
     
    harrykh likes this.
  74. Frank2

    Frank2 Networkin' Nut Member

    Got it. I didn't know you could off load the data graph to a flash drive. That said, I agree that it would be nice to get accurate router numbers for WAN-LAN/LAN-LAN/Hard Wired, etc.

    On a different note, I did find this little blurb from AT&T Uverse for your use;
    Our website, www.att.com/internet-usage, offers several resources to help you manage and monitor your usage. You can click onView my usage to view your personal usage from the January 2011 bill cycle to the most recent billing cycle. To protect confidential customer information, this site is password-protected. The login is your AT&T primary account email address (e.g., John_smith@att.net). The password is the same password used to access your att.net homepage and primary email account.

    AT&T initially will report usage data on a weekly basis. When a customer reaches 70% of their data plan, we will supplement their personal usage report on a daily basis. A customer's usage will be posted on the website within 1 - 4 days of use.
     
  75. harrykh

    harrykh Network Guru Member

    I saw it before when I switched from dd-wrt back to stock, but it was restored, by itself, after a while.

    Anyway, I tried using my phone to speed test. Like I said my official download/upload is 50mbps/5mbps, now my upload is faster than my download 500kbps/1mbps. :p I'll try later people are still using the internet, such as it is. Thanks!
     
  76. Super_Mario

    Super_Mario Serious Server Member

    Hello I try rebooting and it didn't works any hint to troubleshoot?
     
  77. harrykh

    harrykh Network Guru Member

    Hi, can someone please tell me how to reset. I think I forgot the password. Is it still pin in the hole, 5 to 7 seconds?
     
  78. mito

    mito Network Guru Member

    Yup.
    But this way you have to reconfigure all again by hand.
     
    harrykh likes this.
  79. Frank2

    Frank2 Networkin' Nut Member

    Cool. Thanks for the update. I'm just glad there's people like you that can do this stuff. If you need me to hammer a nail into a piece of wood for you, I can do that.
     
    Last edited: Jun 3, 2015
  80. slidermike

    slidermike Addicted to LI Member

    Try a different browser.
    Sometimes browser cache and other browser issues cause functions to not properly work when interacting with the gui.
     
  81. harrykh

    harrykh Network Guru Member

    I got everything working, thank you. Speed seems normal but range seems to be at the same level or maybe a bit better than dd-wrt. Stock can go a bit further. Any tweaks I should do? Right now I have TX at the default level of 50%.

    Thanks.
     
  82. myersw

    myersw Network Guru Member

    @Frank2
    Just checked that site again as it had been a long time since I last checked. Still does not give data usage only phone, which current period was 85 minutes usage. We use cell phones most of time not the landline. Last I knew they were not sure how to capture and display info. This site is giving you billing info and would not be of use to see how much data you have used currently to see that you are not going over. That is what they have not implemented yet which means they are not doing any capping at this time that I am aware of. I watch on dslreports and they have not reported any change to this.
    --bill
     
  83. Frank2

    Frank2 Networkin' Nut Member

    Interesting that AT&T doesn't offer the same info as COX/Time Warner. I guess they do so at their own peril. For what it's worth, both Time Warner and Cox have doubled their internet speeds for free i.e. if you were paying for 25Mbps, you now get 50Mbps at no additional cost. I asked the Time Warner rep why they are doing this and his response was "competition". So I guess there's something to be said for competition among cable providers.
     
  84. MrDoh

    MrDoh Addicted to LI Member

    Yes there is...I live in an area where Comcast has no competition and am still back at 25Mbps for their "Blast!" tier. And we pay the same as everyone else is paying for 50 or 105Mbps. Makes me just a little frustrated. Wouldn't take much for another ISP to come in here with 50Mbps broadband and blow Comcast away, sad commentary. Been this way here for several years now, and no reason why this shouldn't continue indefinitely.
     
    Last edited: Jun 3, 2015
  85. harrykh

    harrykh Network Guru Member

    Hi, loving the new firmware, putting TX to 35% seems to make the range better.

    In DDWRT Kong had suggestions like setting Channels to the higher values to get better power. It's there similar rules of thumb for this FW?

    Also I've reading up on custom CFE and that it is possible to brick without using it? Is the risk higher than flashing DDWRT?

    In the system info page I see my CFE as unknown is that normal?

    Thanks!
     
  86. slidermike

    slidermike Addicted to LI Member

    Yes "unknown is normal"
    Yes, the channels info Kong suggested is not specific to one OS over another. It is how countries regulate the wifi spectrum.
     
    harrykh likes this.
  87. XVortex

    XVortex Addicted to LI Member

    Yes.

    No. Risk is the same (or lower). Just do not forget to reset settings before and after the flashing.

    Yes. Asuswrt-Merlin firmware detects CFE version only in asus format.
     
    harrykh, cybrnook and William Clark like this.
  88. mito

    mito Network Guru Member

    If you want to se my settings go to the first post of this page. I checked 1% at a time always at same site with "Inssider", but remember that all houses/sites are different.
    & Thx alot;)
    Rgds.
     
    harrykh likes this.
  89. Super_Mario

    Super_Mario Serious Server Member

    Help guys I try different browser stills the same any hintnto make it works the virtual server / forwarding. I really need to make it works.
    Thanks
     
  90. slidermike

    slidermike Addicted to LI Member

    Did you reset the router to defaults, reboot and then configure the virtual server?
     
    cybrnook and Super_Mario like this.
  91. Super_Mario

    Super_Mario Serious Server Member

    Hi slidermike I reload the firmware again and then reboot and now it is working.
    Thanks for your hints.
     
  92. harrykh

    harrykh Network Guru Member

    Just making sure, the latest build sets the TX at 50% by default right? It was on mine and I reset like 3x or more.

    I just don't want to find out that for some reason 50% for me is 100% for other people. :p

    Also I have Roku2 that is connected via ethernet to a repeater (that I gave a 'manual' IP address to), for some reason the Roku is listed as having a static IP address and won't change. It's not a big deal. I'll just use that new IP for my purposes but I believe this is not normal?

    Also my Roku2 would not connect via wifi. I know the Roku2 is a bit picky when it comes to channels and I tried different combinations (Ch6, 20 width usually works) but nothing works. Again no big deal since I can use eth but if other devices wouldn't connect I'd like to know how to fix and maybe the reason why. :p

    Other than that all is good. Thank you!
     
  93. slidermike

    slidermike Addicted to LI Member

    harry,
    I have 1 roku 2 and 3 roku 3.
    Three of the 4 are wireless.
    Of those, the roku 2 is on the 2.4 (only radio they have) and it works just fine.
    I believe my radio is on channel 6/20 wide. WPA2 personal & AES.
    I can stream HD without any issue.
     
    harrykh likes this.
  94. myersw

    myersw Network Guru Member

    My Roku 2XS works fine without any issues. 2.4 channel, as it only supports that, and have wireless set to channel 6/20 wide. WPA2 personal & AES. Can stream HD without any issues.
     
  95. jsmiddleton4

    jsmiddleton4 Network Guru Member

    I've done CFE updates. As long as you follow a step by step set of instructions, don't get in a hurry, it isn't that complicated. However I've only done a CFE tweak and update when it made a positive difference, as examples made NVRAM/Flash RAM available or turned a T-Modile router into an Asus AC68. I see no positive difference at this juncture with messing with the R7000's CFE.
     
  96. MrDoh

    MrDoh Addicted to LI Member

    Yeah, does seem like more downside risk than upside potential for this one *smile*. I've done a CFE update as well, not motivated enough for this one.
     
  97. myersw

    myersw Network Guru Member

    Did a CFE back in the dark ages. See no reason to risk a brick for the little benefit you gain, plus having to load old if I want to go back to OEM version other then one XVortex has modified. If the CFE made it so I could load the RMerlin versions or Asus versions on the router then I would probably do it.
    --bill
     
  98. XVortex

    XVortex Addicted to LI Member

    Yes. Last XWRT build sets the TX at 50% by default. It is good point to start.
     
  99. mstombs

    mstombs Network Guru Member

    Asus 3.0.0.4.378.6065 for the MIPS RT-N66U released, only a 700MB zip file, but already a new beta firmware 6117 with release notes

    Beta Version ASUS RT-N66U Firmware version 3.0.0.4.378.6117

    Have Netgear given up supporting their hardware versions?
     
  100. FallOut

    FallOut Connected Client Member

    For me the positive would be what I learn from it, I haven't upgraded a CFE in ages and would like to find a JTAG port before doing so, but I find the idea fun and challenging, I'd like to learn. Besides if I succeed changing my R7OOO to AC-68-P then I'll try to opposite if I get the AC-68-P working again, I'll try to see if I can change it to a R7OOO. Would be cool to see how stock firmware works on another device.

    That's my plan eventually see if I can make it act like an original CFE and accept original firmwares, just for the fun of it. I haven't had the time to play around with either the CFE or the XWRT frimware so I don't currently know why flashing Asuswrt directly after installing @XVortex CFE won't work already, does anyone what ia atopping it from working?
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice