Audio streaming with WRT54GS

Discussion in 'Cisco/Linksys Wireless Routers' started by florent, Feb 24, 2005.

  1. florent

    florent Guest


    I've just got a WRT54GS v1.1; a dedicated music server is plugged on one of the 10/100 ports, 2 wireless connections are used by my main PC and a Squeezebox, both of them using Asus WL-330g in adaptor mode. When the server streams MP3 files to the Squeezebox everything seems good, but when I want to play some FLAC files, which are streamed in WAV format, I start to experience bad things : files doesn't stream at all, or with micro-dropouts, sometimes the Squeezebox itself seems to lost it connection to server for a few seconds.

    I hadn't got these problems with the router I used before, which was a Trust Speedshare Turbo Pro (802.11g). Both adapters are set to 802.11g / WPA, as is the router itself. Large files transfers between the PC and the server runs OK, with a speed of ~1,9 MBytes/s. Firmware has been updated to the last version of HyperWRT (I've also tried Linksys version, obviously with the same problems).

    I've tried to see via the web interface of the adapters if there was informations on signal strength, but it's basic, as it just list a RSSI without units : with the WRT54GS I've got something between 23 and 32 (it changes often), and with the Trust it's between 34 and 36. I suppose that it's some kind a percentage, when I put the adapter next to the WRT the value increases to 59.

    Has anybody experienced such problems when streaming via a WRT54GS ? A WAV streaming should consume something like ~1,2 Mbits/s, so I hadn't thought that it could pose a problem to the router. Maybe I've misconfigured something, but I can't find what ? I've already tried to change channel (no differences), but I don't think that's it (problems are still here with the channel previously used by the Trust).

    I've also started to take a look at value returned by wl on the router, but haven't understood all the options. Here's just an output that could be interesting :

    # wl rssi 00:E0:18:F8:3B:96
    rssi is -64
    # wl rssi 00:04:20:05:1C:38
    rssi is -62

    1st MAC address is from my main PC, 2nd one is from the Squeezebox (the adapters are set to clone these addresses). Does these values seem sufficient ? I would be interested by other commands to diagnose my problem.

    Thanks in advance for the suggestions,

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice