Azureus, Tomato 0.08, and UPnP

Discussion in 'Tomato Firmware' started by NateHoy, Nov 3, 2006.

  1. NateHoy

    NateHoy Network Guru Member

    I just wanted to see if I am alone in this, or if others are experiencing similar problems.

    I run Azureus 24/7 on my SuSE 10.1 Linux box. Occasionally, about once a day or so, I get an error that Azureus has lost contact with the UPnP server. Tomato's UPnP GUI still shows the ports as forwarded, but I start getting "firewalled" errors in Azureus.

    Going to the Tomato GUI and clearing out the port forward settings, then restarting Azureus, makes everything happy again. Until the next time.

    I'm going to go to manual port forwarding for the moment, and this isn't a really big deal (the speed of Tomato more than makes up for the inconvenience :thumbup: ).

    But I wanted to see if I was alone in this error.

    Me :hearts: Tomato. Tomato :cool: :cool: :cool:
  2. tstrike2000

    tstrike2000 Network Guru Member

    I'm assuming you left Multicast unchecked in the Firewall setting in .08 since I believe that caused a problem with UPNP and UDP.
  3. PsychoD

    PsychoD Network Guru Member

    Did you try upgrading to 0.9?
  4. NateHoy

    NateHoy Network Guru Member

    Multicast was unchecked. Saturday night, I upgraded to 0.09, and this morning I had the same error message (though my torrents were not affected, since I have the port forwarding set up manually now in addition to the UPnP setting)
  5. tstrike2000

    tstrike2000 Network Guru Member

    Nate, Since you've upgraded to the newest version and are still getting that UPnP message Azureus, it could a firewalling issue. I noticed Tomato only has Allow NAT Loopback, Allow Multicast, and Respond to Ping as Firewall options. It doesn't have the additional options that Thibor 15c has and I'm curious if not having the option to turn off those extra options in Tomato is an issue. Although I also could be totally offbase.
  6. NateHoy

    NateHoy Network Guru Member

    It could be. I'm not sure. The errors appear to be the PC losing contact with the UPnP server, which is inside the firewall, not outside. But, it is possible.

    I also run a ReplayTV and DVArchive, both of which use UPnP, and I see events from those IP addresses in my Azureus log as well. So maybe I'm just trying to do too much with UPnP on my LAN (though I've never had this problem with Tofu or Thibor builds).

    To be honest, Tomato is soooo much faster for me in web browsing and other interactive applications. I like it enough that I'd turn off UPnP entirely and go to manual port forwarding if I had to. :)

    I'm leaving UPnP up (backed up by manual port forwards) just in case I get some useful information on it.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice