Baffled NSLU2 Linux noob, startup script help please

Discussion in 'Cisco/Linksys Network Storage Devices' started by Sharp Rock, Aug 16, 2008.

  1. Sharp Rock

    Sharp Rock Addicted to LI Member


    I've been here a while, benifiting from all the GREAT info here. I've UNSLUNG my NSLU2 to 6.10. A few succeses with it:

    I have the ntpclient running, to fix the clock.

    Openssh installed, configured with public/private keys, password disabled. Using Putty on the PC

    Nano installed, works great!

    Lots of shares setup, and working great. Even have cifs shares working for my router.

    Now, I've been trying several ways to get a little daemon to run in the background ( (

    I have Perl, and all it's "depends" installed, and can run from a command line. I've tried a few different places to start it, but it will hang the bootup. Then I ssh in, and kill it's PID, and the boot up finishes. :confused: Then I added the & after one of script commands firing it off. That killed everything. Then I had to disconnect the drive to fix it. That failed, and I lost the root password, so reflashed, and reset everything up. Not wanting to repeat that exercise... Now I'm looking at adding a script in /opt/etc/init.d. Perhaps S80pixelserver with the line:

    /etc/ &

    Is this a good idea, or bad? I'm learning, but wallowing in the mud now! :frown:

    Any help or suggestions are appreciated!

  2. Sharp Rock

    Sharp Rock Addicted to LI Member

    Never mind...

    It worked!!! :thumbups::thumbups:
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice