BEFSR41 v.4 Firmware Question

Discussion in 'Cisco/Linksys Wireless Routers' started by AvatarCE, Jul 8, 2005.

  1. AvatarCE

    AvatarCE Network Guru Member

    I have a BEFSR41 v.4 Router that consistently drops my Internet connection, specifically when placed under a heavy load, ie multiple downloads or using BITorrent. Google searches suggest this is a well-known problem with this model, and that finding a firmware update is next to impossible. Several users state that they've contacted Linksys technical support, and have promised to have a firmware update emailed to them, only to never receive an email or hear from Linksys again. Is there anyone from Linksys who could possibly provide a bit of information on this problem, if there is actually a firmware upgrade for this model, and if not, when one might be available? I have several of these models out in the field, and I'd hate to have to replace them all with NetGears.....
  2. Jbob

    Jbob Network Guru Member

    BEFSR41 v4 firmware vs v3

    Good question. Does anybody now whether the V4 router is compatable with the v3 firmware?
  3. daggah

    daggah Guest

    Re: BEFSR41 v4 firmware vs v3

    It is NOT compatible. I just tried. :x
  4. Segmental

    Segmental Guest

    I just reported this to Cisco since they are the parent company, hopefully I get answers from them FAST.
  5. Neoforcer

    Neoforcer Network Guru Member

  6. AvatarCE

    AvatarCE Network Guru Member

    Testing it now... With any luck, this will fix the all-to-frequent drops.
  7. Glacialis

    Glacialis Network Guru Member

    Requesting update. I located and installed latest firmware moments ago to see if it will help my instance of this.
  8. w524e

    w524e Guest

    i am having the same problem here.
    and i've upgraded to the latest firmware(1.04.05).
    but it doesnt help. can't even play online game sometime.
    95% drops when Azureus runs.(BITorrent.)...
  9. AvatarCE

    AvatarCE Network Guru Member

    Follow Up...

    I've had the new firmware installed for about 2 months now, and haven't really had any more problems.... until today. I don't think I've really used my BitTorrent program since I installed the new firmware - as soon as I got 2 downloads going, my instant messenger started dropping roughly every 15 minutes. I let it run for about 2 hours this way. I then turned off my BitTorrent client, rebooted the router - and its been fine ever since. Back to the drawing board, Linksys engineers... Maybe we should all invest in some quality D-Link routers?
  10. LordMagnus

    LordMagnus Network Guru Member

    Same problem here. I had a BEFSR41 Ver. 4, that came originally with the firmware version 1.04.00. And on Linksys website there was an "update" to version 1.04.05. Since the router was brand new, I didn't even tested the "old" (But functional) firmware, I went ahead and made the mistake of updating it. And all hell broke lose:

    1- My connection will drop out every 45 to 60 seconds.
    2- My connection will drop out every single time I saved changes on my router setup.
    3- Only two of the 4 ports worked after the firmware "Upgrade"

    I chatted online with Linksys support, and after 6 VERY LONG hrs, of power cycleing and ALL the tests they make you do, the guy said "That's not a normal behavior of your router, I suggest you have your router replaced", So I did.

    I contacted the retailer, who gave me a 30 day return policy on deffective items and got the exact same router back, this time, with Firmware 1.04.02, Feb 18 2005.

    I went ahead, and updated to Firmware 1.04.05.... Have you ever had that feeling when you are 100% sure you're the stupidest person in the world ???... Yeah... that bad. :sad:

    All problems started again, so I contacted Linksys tech support, and there's no traces of the original firmware my router came with, there was a firmware request to the "Firmware department" and they promissed they'll e-mail me a compatible firmware, and I'm still waiting 3 weeks later, and find myself doing my router's job by switching cables around.

    Does anyone know, how can I fix this, or, if there's no sulution, who can I contact to complain about this ?

    Sorry for the long post. My simpathy to the ones with the same problem.

    This is how my desktop has looked for the past 3 weeks. :(
  11. LordMagnus

    LordMagnus Network Guru Member

    Ok, I just talked to Tech Support again.

    Aparently there is a beta version firmware for the BEFSR41 Ver 4 ONLY.

    It's version 1.04.03, with it isn't on the FTP, or their webpage.

    Once again, I've been promised a firmware that might fix my problem, She, the tech support, said it will be e-mailed to me withing a day. So once more, I'm trusting that "Withing a day".

    If I ever get such version, and If it fixes the constant drop outs problem, I'll make sure to post the file somewhere for more people to try.

    I'll report as soon as I get this file.

    Ps: Here I quote the complete chat session for the curious people:
  12. dogberttheory

    dogberttheory Network Guru Member

    So any word on if this mythical .03 firmware exist?
  13. LordMagnus

    LordMagnus Network Guru Member

    Just got it right now!!! I'm getting ready to flash it, and I'll make sure to report on this. If it works properly, I'll post if for anybody that wishes to try it out.

    Wish me luck !!
  14. LordMagnus

    LordMagnus Network Guru Member

    No love !

    Ok, Inside the zip file that support sent me, there was three files. befsx41_TFTP.exe, Rb41_boot.bin and RB41_v1.04.03_code.bin.

    Of course, using the flash tool they provided, this is what I did:

    1- Set factory default on router
    2- Set network card to 10Mb half duplex
    3- Flashed with RB41_boot.bin (after it said flash was successfull, inmediatly the power light started blinking, non-stop)
    4- Did a "Hard Reset" (Hold down reset 30 seconds, unplugged power cord from the back for 30 seconds, still holding down reset button, then plugged back on, and still holding down the reset for 30 seconds, released reset button. Even after the "Hard Reset" power button kept flashing constantly.
    5- Fhashed router using RB41_v1.04.03_code.bin (Automatically, after the flash successful message, the power light stopped blinking).
    6- Did another "Hard reset" and set up my router.

    It worked for 30 seconds and then, another one of those "A network cable has been disconnected" messages hit me. Not like it has anything to do, but I remembered I still haven't changed my network card back to 100 full duplex, so i went ahead and did that. But still, my router won't answer.

    I Hard Resetted infinite times, trying to get it to work, and most of the times, I coulnd't connect to it. I pinged and it timed out.

    So, I went ahead and reinstalled my old BEFSR41 Ver.2, wich has 2 burned ports due to a lightning storm, hence, the replacement, and I'm getting ready to return this BEFSR41 Ver.4, for wich I gave up any hopes.

    Unfortunately, Linksys warned me about posting this firmware since it is copywrighted.
    But even if I could post it for people to download, I don't recommend it.

    Next stop, for a Netgear quality router, any suggestions on either Netgear or D-Link ?? I'm not sure wich one should I get.

    Thanks to everybody for bearing with me through this frustrating proccess.
  15. dogberttheory

    dogberttheory Network Guru Member

    Ah, thanks for the information. And I prefer Netgear, but I really have not seen anything wrong with D-Link.

    So, has anyone found a way to fix this problem? Or did Linksys just completely bonk this version of the router and they are not fixing it?
  16. LordMagnus

    LordMagnus Network Guru Member

    I'm not sure. I do love Linksys, and like I said before, the other BEFSR41 ver. 2 worked wonders for me with a rock solid performance, until I made the mistake of leaving it plugged in during an electrical storm.

    I suppose that Linksys will take this issue seriously and come up with a fix, as they usually do. But I can't just afford the wait, nor the headache.

    I do, on the other hand, think this could possibly be a major hardware problem, and that they're trying to fix it with a firmware release... but I'm not an expert on the subject, so don't quote me on that.

    I'll be recieving a D-Link DI-624 tomorrow (hopefully). I'm planing on keeping the BEFSR41 Ver.2 and I'll try to find a good use for it. Suggestions are always welcome.

    Morale of this experience, Linksys BEFSR41 Ver.4 is the one Linksys router you need to stay away from, at least untill they clarify what the problem is, and if there's a definitive fix for it.

    - Lord Magnus.
  17. czak

    czak Guest

    I am having the exact same problems!

    I had an email conversation with linksys very similar to the one above. I have been promised a beta firmware but am yet to see it.
  18. TheTooleMan

    TheTooleMan Network Guru Member

    Firmware downgrade?

    I have the same v4 problems as everyone else described here, and am running the "upgraded" firmware. I had a v2 which worked great until something happened - not sure what, but the red light is solid, not blinking, and won't go out, and I was told by Linksys that this is fatal.

    a few questions:

    - can I downgrade the firmware in the v4 to an older version that actually works?

    - is the v2 really dead if the solid red light won't go out?

    - does anyone know if the WRT54G suffers the same problems with disconnects as v4?

    While I'm at it, was there never a v2 firmware upgrade? I've never seen it on the Linksys site. Perhaps it was perfect... :(
  19. TheTooleMan

    TheTooleMan Network Guru Member

    Answering my own questions...

    Today I replaced the malfunctioning piece of crap with a WRT54G that seems to work more smoothly. I never did get the old firmware to load onto the v4 router. Time will tell if this baby works right for me. Meanwhile, it's time to send in those Best Buy rebates! :D
  20. Darsarin

    Darsarin Guest

    I am having the same problems mainly when using bit torrent but not always. Has anyone heard anything on this?
  21. Dutchman01

    Dutchman01 LI Guru Member

    i did buy a linksys BEFSR41 V4 with original firmware 1.04.06 on it last week.

    Got the same problems with my internet connection too.

    I'm running on all my computers windows xp an what a get is this,

    Network cable not installed, i replaced my cat5 cables,
    I reboot the router and cable modem.
    I did try everything nothing works to solve this problem.
    Most of the time it happens with more than few connection open and azureus loading a few torrents.

    What is going on?????????????????????????????

    Did not have any of those problems ever with a cheap E-tech router.

    I just can't believe this is happening!!!!!!!!!!!!!!!!
  22. hasrin

    hasrin Guest

    It's been happening to me too. Each time I start up Azureus, Linksys does a reboot on its own.

    I managed to have a relatively stable connection by disabling the DHT (Distributed DB) on my Azureus. I suspect the router died caused by too many connections at the same time.

    I'm rather disappointed actually. My old Gigabyte router performed much better. Sadly there doesn't seem to be any 3rd party firmware that could possibly address this issue.
  23. sjones

    sjones Guest

    Befsr41 V4 - 1.04.06

    I recently acquired a linksys BEFSR41 V4 which came from the MFR flashed with 1.04.06. Latest Version on linksys download page is 1.04.05.

    1. Does anybody have any info on 1.04.06. What changes/fixes were implemented since the 1.04.05 release?

    2. Does anybody know where 1.04.06 can be obtained?
    I am having some issues with intermittent internet drop-outs and would like to try 1.04.05, but I have no way to get back to my current configuration.

    3. With regards to the intermittent WAN drop-outs. My internet connection will intermittently drop-out for several minutes and then automatically return. I do NOT have to reset the router or cycle router power. Does not appear to be related to WAN traffic load as most of the time I am browing the internet or retriving email. Has anyone made any progress on this issue?

    Chatted with Linksys support and they want me to try down-grading to 1.04.05 and re-establishing my Cable connection setup, including cloning my PC MAC address into the Linksys router.

    Not sure what good Cloning the PC MAC address into the router will do, I can successfully connect with my ISP (Charter Pipeline), except during the drop-outs. I'm afraid if I alter the MAC address registered with my ISP, that my connection my get shutdown, because it would look like I have 2 PCs using the same Dynamic IP address.

    I tried turning off the BEFSR41 logging feature - read somewhere that my be an issue. Still waiting to see if the intermittent drop-outs return.

    Any advise or assistance is welcome.
  24. luckycute

    luckycute Guest

    BEFSR41 v4 1.04.09

    BEFSR41 v4 1.04.09 is now available on
  25. Dutchman01

    Dutchman01 LI Guru Member

    I did install the latest firmware 1.04.09 after that i did make 3 hard reboot's of the router no problem's anny more for a view ours.

    After pc-2 game online it did start all over again Connections lost every time. Azureus running on pc-01

    went back to firmware 1.04.05 e vew flashes and hars reset router problems gone.

    I hate this BFSR41 V4 router.

    I think i i'm going to get a D-Link router or something.

    This is really horror.
  26. Guimmy

    Guimmy Guest

  27. rakeshjmd

    rakeshjmd LI Guru Member

    please update latest firmware from linksys/download
  28. Spooky_uk

    Spooky_uk LI Guru Member

    MY BEFSR81 died on me recently after many years of perfect and trouble free use so bought a replacement BEFSR41 in its place. Its version 4.1 of the router and came with firmware 1.4.09 (which is the latedt I believe)

    After setting up and using I am constantly getting dropouts not only on the internet connection but also on the lan ports between pc's on my network. tried reflashing the firmware to no avail. I emailed linksys with the problem - I received a reply informing it was not a problem they were aware of and went into detail on upgrading firmware and also setting MTU to different settings. Had already done this and it dis not resolve the issue. I have since sent 2 further emails to linksys and not received a reply.

    ANyone have a definitive resolution for this as of yet? Very close to binning it to be honest and I am of the mind to not purchase any more linksys products again ever due to the way that linksys have not offered support or explanation.
  29. ozone_stink

    ozone_stink Guest

    Same Problems.

    I've got the same thing going on with mine. (ver 4.1) I'm using Bell Canada HSE PPPoE.

    I've tried BEFSR41_v4_1.04.03 firmware and 1.4.09 with no joy. BEFSR41_v4_1.04.03 lasted a bit longer before reboot was necessary, but my VPN to work no longer could connect. 1.4.09 is installed now and my wife (who works at home) is offering to donate some of her jewellery to the cause, if necessary. -That's the carrot. You don't wanna see the stick!! :frown:

    I had an old v.2 BEFSR41 for years without any issue until an ADT home security install tech. drilled through our main electrical feed from the transformer on the street. -We lost more than the Linksys device that day!!

    Anyway, I WAS a happy customer and thought nothing of buying the exact same piece of kit twice from Linksys. I now loathe myself for this decision because I appear to be enmeshed in the same problem everybody else is having. Don't want wireless. I have made great pains to wire my house with cat5e everywhere. I just want something that works. -Apparently this is too much to ask for with this particular device. -Kinda reminds me of VLAN trunking on those old Cisco Catalyst 1924s. -Never worked, but held the promise of working. Wonder if the same guy wrote code for both devices? :wink:

    If somebody finds a fix, I'd be eternally grateful. However, for the moment, I'm seriously considering the $180.00 CAD for a D-Link gaming router. -I don't do online games, but the extra horsepower is supposed to handle multiple connections better.

    I'm a little mystified as to why my old version of Lynksys worked without issue and the new version does not. Either the firmware is not right or they've stripped some costs out of the hardware. Not sure which, but it's completely aggravating and certainly does not make me want to upgrade to another Lynksys. Of course, if somebody fixes this, I'll eat my words.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice