BEFSR41 V3 Troubles

Discussion in 'Cisco/Linksys Wireless Routers' started by Rabbler, Dec 10, 2005.

  1. Rabbler

    Rabbler Guest

    Are these things problematic? I just got the router from my father-in-Law. he was using it for his business IP phone but it was loosing it's settings and he is not very tech savy. Anyway the problem I'm having is occasionally this thing really slows down my d/l speeds by 80-90%. I have to unplug the power to it and reboot it. Then it's fine for a few days. I have tried every firmware I could get including some of the beta ones from linksys. (currently 1.06.05) Originally I had it set with local DHCP on but it would occasionally reassign a different Ip address to the 2 computers hooked up (this messes up the port forwarding of course) so I set it for static IP which seems to help a bit. any suggestions?
    It is also very slow for the config screens to load. sometime half the page is missing

    This is the first router I have ever had. I thought Linksys was supposed to be one of the best.

  2. Xenomorph

    Xenomorph Network Guru Member

    i have a Linksys BEFSR41 v3.

    its one of THE WORST routers i've ever used

    - the connection would drop all the time

    - the web interface was slow as hell. i'd click something and could go grab a soda before the page would load up. configuration was a NIGHTMARE.

    i tried official firmwares, older firmwares, and the beta firmware. there was no change in how it worked.

    im using a WRT54G now, and its been a great router.

    i still have all my routers: Netgear RT314 & RP614v2 and Linksys BEFSR41v3 & WRT54Gv3.

    The BEFSR41v3 is the only one of them i've wanted to smash into a million pieces. i didnt have it long before i got another router to use in its place.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice