BEFSR41 ver 3...Flashing power light

Discussion in 'Cisco/Linksys Wireless Routers' started by Airey, Jun 1, 2005.

  1. Airey

    Airey Guest

    My router has flashing power light, and cannot be hard reset.
    Went to the linksys support site, and it tells me to update firmware and hard reset, but neither of it works.

    I tried updating firmware but it wouldn't let me do it, says no connection to server. But when I connect using this router, it doesn't have internet connection, because it's not working in the first place. What am I doing wrong? Or is it just simply broken.

    Please help.
  2. jagboy

    jagboy Network Guru Member

  3. almond_23

    almond_23 Network Guru Member

    Do a hard reset first on the router. To do this, hold the reset button on the router for about 30 seconds, unplug/re-plug the power chord of the router but don't let go of the reset button after 10 seconds of plugging the power chord back in. Wait for 10 seconds then check the lights.

    If the power lights is still blinking, set a static ip address on your computer. Use, then try to ping the router. If you cannot ping it or even access the router setup page, then download the upgrade utility which is the tftp file on then look for something that says upgrade utility on one of the befsr41 products.

    Connect directly to your modem then download this file with the latest firmware of your router's version. Remember that when doing the firmware upgrade, make sure that the only thing that is connected to the router is the computer doing the firmware upgrade and that it is using a static ip because there are times when firmware upgrade stops halfway through because the computer is not getting an ip address from the dhcp server of the router. This is just for safe practice.

    After the firmware upgrade, do a hard reset again on the router and then check the lights....
    I hope this information is useful...:)
  4. fedup401

    fedup401 Addicted to LI Member

    ok i just figured out how to do this because this morning i had the same problem and linksys tech support was no help so i went online and started searching and this is what i found ...
    also if you do not know how to set up a static ip here are step by step directions..btw i do not want you to think i am talking down to you i just thought that since this morning i didn't even know what a static ip address was maybe i should include that.
    To set one:
    1. Go to your Control Panel within Windows.
    2. Go to Network Connections.
    3. Find a connection (usually called Local Area Connection).
    4. Right-click that connection, and left click properties.
    5. Click TCP/IP and Click the Properties button below it.
    6. Make sure to select the options to set addresses manually.

    The addresses that you need for this project depend on the router. Most likely an IP address of, subnet mask of, a default gateway of, and the same for Primary WINS server should work for you.
    So you have set a static IP address on the computer, e.g. with subnet mask

    If yes, then wire the computer to a numbered port of the router. Open a command prompt window and enter "ping -t". It will ping the router continuously. Leave it running. Now press the reset button on the router for 30 seconds. What the lights to verify that the router is really resetting. Then power down the router. Wait a moment and plug it back in.

    While doing this always check the ping output. Do you see any responses at any time?

    If you don't see any responses ever neither during or after reset nor during power up then the router is dead.

    If you see some responses during power up there is still a small chance. The blinking power light may be due to a bad firmware on the router. During booting the router before the router loads the actual firmware file it waits a few seconds and is responsive on During this time you may be able to start a tftp firmware upload to the router.

    Of course, timing is crucial here. It may now work the first time you try because you have missed the right moment. Keep the ping running. Prepare everything for the tftp upload so that you only to press the upload button to start the process. Power down the router. Then power it up. Watch the pings carefully. The moment you see a response, start the tftp upgrade process.

    Again, timing is crucial. You may have to try this a couple of times. If it works and you get the correct firmware file uploaded your router should boot the new firmware and work as usual.

    If you are not able to get the firmware uploaded with tftp then there is nothing you can do. Your router is bricked. Kudos! Thanks!
    it worked for me i hope you have the same luck
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice