BEFSR41 version 4.3 (power light blinking)

Discussion in 'Cisco/Linksys Wireless Routers' started by fedup401, Dec 12, 2008.

  1. fedup401

    fedup401 Addicted to LI Member

    ok here goes nothing I have tried to fix this power light problem since it started but to no victory. I have only had my router for 3 months so i would hate to have to replace it so soon after buying it. I went to the linksys tech support site and all it told me was that i had to update my firmware which in fact is what caused the problem in the first place. I went to update my firmware and it downloaded and installed fine but then all of a sudden my power light began blinking and i lost all internet connection through the router. I tried to reset the router over 100 times i am sure and it does nothing. (and yes before you ask i did hold it for the 30 seconds that tech support told me to also i tried the unplugging and leaving it unplugged method but that did nothing as well). I have tried everything i can think of except the one thing i can not do which is the site reset method but you have to have internet connection through the router to do that. I am open to suggestions if anyone knows of anything to fix this problem i would be eternally grateful. thanks in advance for any and all advise.
  2. fedup401

    fedup401 Addicted to LI Member

    i found the answer on my own so i will post it here in case anyone is having the same problem

    ok i just figured out how to do this because this morning i had the same problem and linksys tech support was no help so i went online and started searching and this is what i found ...
    also if you do not know how to set up a static ip here are step by step directions..btw i do not want you to think i am talking down to you i just thought that since this morning i didn't even know what a static ip address was maybe i should include that.
    To set one:
    1. Go to your Control Panel within Windows.
    2. Go to Network Connections.
    3. Find a connection (usually called Local Area Connection).
    4. Right-click that connection, and left click properties.
    5. Click TCP/IP and Click the Properties button below it.
    6. Make sure to select the options to set addresses manually.

    The addresses that you need for this project depend on the router. Most likely an IP address of, subnet mask of, a default gateway of, and the same for Primary WINS server should work for you.
    So you have set a static IP address on the computer, e.g. with subnet mask

    If yes, then wire the computer to a numbered port of the router. Open a command prompt window and enter "ping -t". It will ping the router continuously. Leave it running. Now press the reset button on the router for 30 seconds. What the lights to verify that the router is really resetting. Then power down the router. Wait a moment and plug it back in.

    While doing this always check the ping output. Do you see any responses at any time?

    If you don't see any responses ever neither during or after reset nor during power up then the router is dead.

    If you see some responses during power up there is still a small chance. The blinking power light may be due to a bad firmware on the router. During booting the router before the router loads the actual firmware file it waits a few seconds and is responsive on During this time you may be able to start a tftp firmware upload to the router.

    Of course, timing is crucial here. It may now work the first time you try because you have missed the right moment. Keep the ping running. Prepare everything for the tftp upload so that you only to press the upload button to start the process. Power down the router. Then power it up. Watch the pings carefully. The moment you see a response, start the tftp upgrade process.

    Again, timing is crucial. You may have to try this a couple of times. If it works and you get the correct firmware file uploaded your router should boot the new firmware and work as usual.

    If you are not able to get the firmware uploaded with tftp then there is nothing you can do. Your router is bricked. Kudos! Thanks!
    it worked for me i hope you have the same luck
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice