BEFSX41 firmware 1.52.9

Discussion in 'Cisco/Linksys Wireless Routers' started by HKphooey, Jan 25, 2006.

  1. HKphooey

    HKphooey Network Guru Member

    Anyone try this out yet? Released 1/11/2006

  2. dgvandal

    dgvandal Network Guru Member

  3. HKphooey

    HKphooey Network Guru Member

    Color me stupid, but how does one tell the difference between a BEFSX41 v1 and a v2 model?

    (Searched the forums for "BEFSX41 and version" and didn't find the answer...)
  4. jaydubb

    jaydubb Network Guru Member

    Look at the bottom of your router. Look for the model number. It will end with either V1 or V2.
  5. larrymcg

    larrymcg Network Guru Member

    I'm using the 1.52.9 firmware -- Is it the right version?

    I just purchased a BEFSX41 as a replacement for a very old BEFSR41 that was giving me problems. In any case the new router seems to be working so, not wanting to leave well enough alone, I decided to load up the latest firmware from th Linksys site which is version 1.52.9.

    Being extra cautious, I downloaded the new firmware from the BEFSX41 V1 place using the old router and then installed the new X41 (and it worked). When I tried to upgrade, using the router's firmware upgrade facility, I got an error like "Firmware file pattern error". I was thrilled that no changes were made to the router so it still worked. So, I downloaded the same file again using the new X41 router but the upgrade failed in the same way. The file name is BEFSX41_v1.52.9_code%2CO.bin

    So then I went to the BEFSX41 V2 downloads and saw that the same file was available there and the upgrade history listed it for the V1 and V2 routers. So I downloaded it. I didn't notice that the file name was slightly different: BEFSX41_v1.52.9_code.bin

    I upgraded using the new file and it worked. And the router still works. But the web app interface is TOTALLY different in all ways.

    The model number on the router does not say V1 or V2 so I'm assuming it's a V1.

    Is it possible I loaded a V2 firmware and got away with it?

    I'd like to tell Linksys that they have a bad firmware file on the V1 download place but I can't find a way to tell them.

  6. larrymcg

    larrymcg Network Guru Member

    Followup to firmware versions

    As has been posted in other places the V1.52.9 firmware works for both the V1 and V2 X41 routers. I contacted linksys support and got an answer the next day(!) that verified that.
    However, they ignored the part of my support request that claimed that something is wrong with the firmware file on the X41 V1 download page. It has a slightly different name and it fails to upgrade.

    So, my advice is to use the file from the X41 V2 download page.

  7. SupaDucta

    SupaDucta Network Guru Member

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice