BEFSX41 Firmware Update

Discussion in 'Cisco/Linksys Wireless Routers' started by EdwardBuchwalter, Sep 7, 2006.

  1. EdwardBuchwalter

    EdwardBuchwalter LI Guru Member

    I have been unable to upgrade my firmware - its at 1.50.18. I download the file, go to the web page, select the file and press download. Seems pretty easy - however it never works. The router disconnects from the session and when it has restarted its still the same old firmware. I have tried this from Safari (MAC OSX), IE (MAC OSX), Firefox (WIN32) and IE (WIN32). All platforms / combinations fail. Any ideas?

    Thanks for any help
  2. Guyfromhe

    Guyfromhe Network Guru Member

    whats the name of the bin file you have?
  3. EdwardBuchwalter

    EdwardBuchwalter LI Guru Member

    It is BEFSX41_v1.52.10_code.bin downloaded from the linksys site.
  4. Guyfromhe

    Guyfromhe Network Guru Member

    hm that looks right, I just put that firmware on 4 routers today, they all took it fine and I used firefox on a win2k machine directly connected to the router.
    very weird.
    are you sure you got the right ver #?
  5. EdwardBuchwalter

    EdwardBuchwalter LI Guru Member

    I checked it a few times and downloaded it a couple of times from linksys.

    I am not connected directly to router - rather through a wireless lan, hub, then the router. Maybe I should connect directly. Is this what you did?

  6. Guyfromhe

    Guyfromhe Network Guru Member

    connect directly it's a baaaaaaaaaaad idea to upgrade via wireless and even worse to try it though multiple devices and over a wireless link.
  7. EdwardBuchwalter

    EdwardBuchwalter LI Guru Member

    Sounds reasonable - I will give that a try!
  8. thormcse

    thormcse Guest

    Not over wireless

    You should always connect wired to the device you are upgrading. I hit that wall a few times myself.
  9. weeksben1

    weeksben1 Network Guru Member

    I'm running into the same problem, my BEFSR41, has 1.40.6. I downloaded BEFSR41_v1.04.09_code.bin. I then opened the router's web GUI, selected 'upgrade firmware' from the administration page. I browsed to the .bin file, clicked on upgrade, the progress bar moved along as if it were reflashing, the router then tried to get to the point that should tell a user if the upgrade failed or not, but it timed out. I restarted the router, and the old firmware was still in memory. Any one have any ideas how to solve this. BTW, this router is brand new just out of the box.
  10. d__l

    d__l Network Guru Member

    weeksben1, this might be a problem caused by your browser. The firmwares for SX41 do not seem to upgrade reliably with Mozilla-based browsers. They seem to hang midway through the process. I think this is something involving Javascript in the browser.

    On the SX41, you must use IE if you want a reliable, smooth upgrade using the GUI's internal flash page. Otherwise, you must use the TFTP program.

    If you are flashing with the correct firmware version for the version of SR41 you have, you may be seeing something similar. Another possibility is is to restore to factory defaults before flashing.
  11. jksponge

    jksponge Guest

    ever solve the firmware not taking prob?

    Same issues here with either browser not allowing FW update to the router. Any solution? Thanks!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice