BEFSX41 Speed Test Weirdnesses

Discussion in 'Cisco/Linksys Wireless Routers' started by larrymcg, Mar 5, 2006.

  1. larrymcg

    larrymcg Network Guru Member

    I recently replaced a BEFSR41 with a BEFSX41 upgraded to 1.59.2 firmware. I did some speed tests with Speakeasy (I'm in the SF Bay area so I use the SF site).

    With the R41 router I get a smooth rate that hovers in the 6-8Mbps range with a final rate between 6 and 7Mbps. That's good!

    With the X41 router I get a rate that is mostly in the 6-8Mbps range but with peaks as high as 13Mbps. The final rate is reported in the 6-7Mbps range. When the peaks occur the test's progress indicator stops(!) briefly and then starts moving again. Sometimes this happens more than once in a single test. Weird!?!?

    After seeing the X41 behavior I briefly tried the R41 but it's only the X41 that has the strange peaks.

    Is this OK?

  2. d__l

    d__l Network Guru Member

    After you flashed, did you clean out the old register settings to factory defaults with a long reset (30 secs. on the reset button)? Sometimes the SX41 will act quirky after a flash if it isn't long reset although this doesn't sound like the typical post-flash quirks.

    How is your throughput speed with SPI-off vs. with it turned on?
  3. larrymcg

    larrymcg Network Guru Member

    No clean out (long reset) was done. If I do one will I have to reestablish some settings via the web interface?

    If by SPI you mean the firewall, then I do not see any difference with it on or off. I'm running with it off all the time now due to the problems it gave me with streaming (see my other post done today).

  4. d__l

    d__l Network Guru Member

    Yes. If you clean it out, all your settings will be flushed too. You didn't know this, but on the SX41, it is a "best practice" to long reset automatically after the flash. It saves a lot of weirdness.
  5. larrymcg

    larrymcg Network Guru Member

    OK, I did the long reset and reentered the setup info.
    I found no difference in the way the router performs. So then I had to disable the firewall again (because of how it interferes with streaming).
    I guess I'll just proceed along being happy that the SX41 router is working and also solved the DHCP failures I was getting with the old SR41 router.
    Thanks for the help,
  6. d__l

    d__l Network Guru Member

    Sorry that didn't help you.

    I take it that you are on cable connection? Do you have your MTU set to Auto or Manual 1500? Often times these Linksys routers work best when they are set to Manual with the correct MTU setting rather than using the Auto setting, but I've never heard of an Auto setting causing speed fluctuations, only slowdowns.
  7. larrymcg

    larrymcg Network Guru Member

    Yes, a cable connection. The service claims to be 8Mbps so my end results on the speed tests are in line with that claim.

    With the 1.52.9 firmware the MTU options are Enable and Disable. With Disable selected the MTU size box is grayed out but says 1500.
    With Enable selected the MTU size box is enabled. So, my conclusion is that Enable == Manual. Weird terminology, confusing too!

    The default setting is Disable so I just changed it to Enable and left the size at 1500. The speed test still has the high peaks.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice